]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- update akode bcond description from changelog
[packages/amarok.git] / amarok.spec
1 # TODO
2 # warning: Installed (but unpackaged) file(s) found:
3 #   /usr/lib/kde3/libamarok_aKode-engine.la
4 #   /usr/lib/kde3/libamarok_aKode-engine.so
5 #   /usr/share/apps/konqsidebartng/entries/amarok.desktop
6 #   /usr/share/apps/konqsidebartng/kicker_entries/amarok.desktop
7 #   /usr/share/services/amarok_aKode-engine.desktop
8 # - aKode engine?
9 #
10 # Conditional builds:
11 %bcond_without  arts            # disable arts engine
12 %bcond_without  gstreamer       # disable gstreamer
13 %bcond_without  xine            # disable xine engine
14 %bcond_without  xmms            # disable xmms wrapping
15 %bcond_with     mysql                   # enable mysql support
16 %bcond_with     akode                   # enable aKode engine (too buggy/incomplete)
17 #
18 Summary:        A KDE audio player
19 Summary(pl):    Odtwarzacz audio dla KDE
20 Name:           amarok
21 Version:        1.2.4
22 Release:        1
23 License:        GPL
24 Group:          X11/Applications/Multimedia
25 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
26 # Source0-md5:  9a3bb2c043d1db169c6a370aff439e0f
27 URL:            http://amarok.kde.org/
28 BuildRequires:  SDL-devel
29 BuildRequires:  alsa-lib-devel
30 BuildRequires:  arts-qt-devel
31 BuildRequires:  automake
32 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
33 BuildRequires:  kdebase-devel
34 BuildRequires:  kdemultimedia-akode
35 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
36 BuildRequires:  libmusicbrainz-devel
37 BuildRequires:  libvisual-devel >= 0.2.0
38 BuildRequires:  pcre-devel
39 BuildRequires:  rpmbuild(macros) >= 1.129
40 BuildRequires:  sed >= 4.0
41 BuildRequires:  sqlite3-devel
42 BuildRequires:  taglib-devel >= 1.3.1
43 #BuildRequires: unsermake >= 040511
44 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
45 %{?with_xmms:BuildRequires:             xmms-devel}
46 %{?with_mysql:BuildRequires:            mysql-devel}
47 #BuildRequires: kdebindings-kjsembed-devel
48 Requires:       %{name}-plugin = %{version}-%{release}
49 Requires:       kdebase-core >= 9:3.1.93
50 Requires:       kdemultimedia-audiocd >= 9:3.1.93
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 A KDE audio player.
55
56 %description -l pl
57 Odtwarzacz audio dla KDE.
58
59 %package arts
60 Summary:        Plugin arts
61 Summary(pl):    Wtyczka arts
62 Group:          X11/Applications/Multimedia
63 Requires:       %{name} = %{version}-%{release}
64 Provides:       %{name}-plugin = %{version}-%{release}
65
66 %description arts
67 Plugin arts.
68
69 %description arts -l pl
70 Wtyczka arts.
71
72 %package gstreamer
73 Summary:        Plugin gstreamer
74 Summary(pl):    Wtyczka gstreamer
75 Group:          X11/Applications/Multimedia
76 # deps, to get it working:
77 # mp3 decoder: gstreamer-mad
78 # ogg decoder: gstreamer-vorbis
79 # audio output driver: gstreamer-audiosink-alsa
80 # from gstreamer-audio-effects to control volume, etc
81 # needed libs:
82 #  at least /usr/lib/gstreamer-0.8/libgstresample.so 
83 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
84 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
85 # gstreamer-musicbrainz for being able to edit id3 tags on files.
86 Requires:       gstreamer-audio-effects
87 Requires:       gstreamer-audiosink
88 Requires:       gstreamer-mad
89 Requires:       gstreamer-vorbis
90 Requires:       gstreamer-musicbrainz
91 Requires:       %{name} = %{version}-%{release}
92 Provides:       %{name}-plugin = %{version}-%{release}
93
94 %description gstreamer
95 Plugin gstreamer.
96
97 %description gstreamer -l pl
98 Wtyczka gstreamer.
99
100 %package xine
101 Summary:        Plugin xine
102 Summary(pl):    Wtyczka xine
103 Group:          X11/Applications/Multimedia
104 Requires:       %{name} = %{version}-%{release}
105 Requires:       xine-plugin-audio
106 Provides:       %{name}-plugin = %{version}-%{release}
107
108 %description xine
109 Plugin xine.
110
111 %description xine -l pl
112 Wtyczka xine.
113
114 %prep
115 %setup -q
116
117 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
118         amarok/src/amarok.desktop \
119
120 %build
121 cp -f /usr/share/automake/config.sub admin
122
123 #export UNSERMAKE=/usr/share/unsermake/unsermake
124
125 %{__make} -f admin/Makefile.common cvs
126
127 %configure \
128         --disable-rpath \
129         %{!?with_arts:--without-arts} \
130         %{!?with_xine:--without-xine} \
131         %{!?with_gstreamer:--without-gstreamer} \
132         %{?with_mysql:--with-mysql} \
133         --disable-final \
134         --with-qt-libraries=%{_libdir} \
135         --without-included-sqlite
136
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %{__make} install \
143         DESTDIR=$RPM_BUILD_ROOT \
144         kde_htmldir=%{_kdedocdir} \
145         kde_libs_htmldir=%{_kdedocdir}
146
147 # remove bogus dir
148 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
149
150 %find_lang amarok --all-name --with-kde
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post
156 echo "Remember to install libvisual-plugins-* packages if you"
157 echo "want to have a visualizations in amarok."
158
159 %files -f %{name}.lang
160 %defattr(644,root,root,755)
161 %doc AUTHORS ChangeLog README TODO
162 %attr(755,root,root) %{_bindir}/amarok
163 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
164 %attr(755,root,root) %{_bindir}/amarokapp
165 %attr(755,root,root) %{_bindir}/amarok_libvisual
166 #%attr(755,root,root) %{_bindir}/release_amarok
167 %{_libdir}/kde3/konqsidebar_universalamarok.la
168 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
169 %{_libdir}/kde3/libamarok_void-engine_plugin.la
170 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
171 %{_datadir}/apps/amarok
172 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
173 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
174 %{_datadir}/apps/profiles/amarok.profile.xml
175 %{_datadir}/config/amarokrc
176 %{_datadir}/config.kcfg/amarok.kcfg
177 %{_datadir}/services/amarok_void-engine_plugin.desktop
178 %{_datadir}/servicetypes/amarok_plugin.desktop
179 %{_desktopdir}/kde/amarok.desktop
180 %{_iconsdir}/*/*/apps/amarok.*
181
182 %if %{with arts}
183 %files arts
184 %defattr(644,root,root,755)
185 %{_libdir}/kde3/libamarok_artsengine_plugin.la
186 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
187 %{_libdir}/libamarokarts.la
188 %attr(755,root,root) %{_libdir}/libamarokarts.so
189 %{_libdir}/mcop/Amarok
190 %{_libdir}/mcop/amarokarts.mcopclass
191 %{_libdir}/mcop/amarokarts.mcoptype
192 %{_datadir}/services/amarok_artsengine_plugin.desktop
193 %endif
194
195 %if %{with gstreamer}
196 %files gstreamer
197 %defattr(644,root,root,755)
198 %{_libdir}/kde3/libamarok_gstengine_plugin.la
199 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
200 %{_datadir}/config.kcfg/gstconfig.kcfg
201 %{_datadir}/services/amarok_gstengine_plugin.desktop
202 %endif
203
204 %if %{with xine}
205 %files xine
206 %defattr(644,root,root,755)
207 %{_libdir}/kde3/libamarok_xine-engine.la
208 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
209 %{_datadir}/services/amarok_xine-engine.desktop
210 #%{_datadir}/services/amarok_xineengine_plugin.desktop
211 %endif
This page took 0.04317 seconds and 4 git commands to generate.