]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- merged some things from DEVEL (xine plugin and bcond)
[packages/amarok.git] / amarok.spec
1 #
2 # Conditional builds:
3 %bcond_without  gstreamer       # disable gstreamer
4 %bcond_without  xmms            # disable xmms wrapping
5 %bcond_without  xine            # disable xine engine
6 #
7 Summary:        A KDE audio player
8 Summary(pl):    Odtwarzacz audio dla KDE
9 Name:           amarok
10 Version:        1.1.1
11 Release:        1
12 License:        GPL
13 Group:          X11/Applications/Multimedia
14 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
15 # Source0-md5:  6c0cccd4c8b508a2e0c9b0f187a907cf
16 URL:            http://amarok.kde.org/
17 Buildrequires:  alsa-lib-devel
18 Buildrequires:  arts-qt-devel
19 Buildrequires:  automake
20 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.8.1}
21 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
22 BuildRequires:  rpmbuild(macros) >= 1.129
23 BuildRequires:  sed >= 4.0
24 BuildRequires:  sqlite-devel >= 2.8
25 BuildRequires:  taglib-devel >= 1.3
26 BuildRequires:  unsermake >= 040511
27 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.0-0.rc5.0}
28 %{?with_xmms:Buildrequires:     xmms-devel}
29 Buildrequires:  libmusicbrainz-devel
30 Buildrequires:  libvisual-devel >= 0.1.6-1
31 Buildrequires:  pcre-devel
32 #BuildRequires: kdebindings-kjsembed-devel 
33 Requires:       kdebase-core >= 9:3.1.93
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 A KDE audio player.
38
39 %description -l pl
40 Odtwarzacz audio dla KDE.
41
42 %package gstreamer
43 Summary:        Plugin gstreamer
44 Summary(pl):    Wtyczka gstreamer
45 Group:          X11/Applications/Multimedia
46 Requires:       %{name} = %{version}-%{release}
47
48 %description gstreamer
49 Plugin gstreamer.
50
51 %description gstreamer -l pl
52 Wtyczka gstreamer.
53
54 %package xine
55 Summary:        Plugin xine
56 Summary(pl):    Wtyczka xine
57 Group:          X11/Applications/Multimedia
58 Requires:       %{name} = %{version}-%{release}
59
60 %description xine
61 Plugin xine.
62
63 %description xine -l pl
64 Wtyczka xine.
65
66 %prep
67 %setup -q -n %{name}-%{version}
68
69 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
70         amarok/src/amarok.desktop \
71
72 %build
73 cp -f %{_datadir}/automake/config.sub admin
74
75 export UNSERMAKE=%{_datadir}/unsermake/unsermake
76
77 %{__make} -f admin/Makefile.common cvs
78
79 %configure \
80         --disable-rpath \
81         %{!?with_xine:--without-xine} \
82         %{!?with_gstreamer:--without-gstreamer} \
83         --with-qt-libraries=%{_libdir}
84
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT \
92         kde_htmldir=%{_kdedocdir} \
93         kde_libs_htmldir=%{_kdedocdir}
94
95 %find_lang amarok --all-name --with-kde
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %files -f %{name}.lang
101 %defattr(644,root,root,755)
102 %doc AUTHORS ChangeLog README TODO
103 %attr(755,root,root) %{_bindir}/amarok
104 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
105 %attr(755,root,root) %{_bindir}/amarokapp
106 %attr(755,root,root) %{_bindir}/amarok_libvisual
107 %attr(755,root,root) %{_bindir}/release_amarok
108 %{_libdir}/kde3/libamarok_artsengine_plugin.la
109 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
110 %{_libdir}/kde3/libamarok_void-engine_plugin.la
111 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
112 %{_libdir}/libamarokarts.la
113 %attr(755,root,root) %{_libdir}/libamarokarts.so
114 %{_libdir}/mcop/Amarok
115 %{_libdir}/mcop/amarokarts.mcopclass
116 %{_libdir}/mcop/amarokarts.mcoptype
117 %{_datadir}/apps/amarok
118 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
119 %{_datadir}/config.kcfg/amarok.kcfg
120 %{_datadir}/services/amarok_artsengine_plugin.desktop
121 %{_datadir}/services/amarok_void-engine_plugin.desktop
122 %{_datadir}/servicetypes/amarok_plugin.desktop
123 %{_desktopdir}/kde/amarok.desktop
124 %{_iconsdir}/*/*/apps/amarok.png
125 %{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
126 %{_datadir}/config/*
127
128 %if %{with gstreamer}
129 %files gstreamer
130 %defattr(644,root,root,755)
131 %{_libdir}/kde3/libamarok_gstengine_plugin.la
132 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
133 %{_datadir}/config.kcfg/gstconfig.kcfg
134 %{_datadir}/services/amarok_gstengine_plugin.desktop
135 %endif
136
137 %if %{with xine}
138 %files xine
139 %defattr(644,root,root,755)
140 %{_libdir}/kde3/libamarok_xine-engine.la
141 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
142 %{_datadir}/services/amarok_xine-engine.desktop
143 %{_datadir}/services/amarok_xineengine_plugin.desktop
144 %endif
This page took 0.034743 seconds and 4 git commands to generate.