]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- release 11
[packages/amarok.git] / amarok.spec
1 # TODO:
2 # - postgresql support alongside mysql
3 # - NMM audio backend support (fix build - propably some BRs)
4 # - make descriptions less useless
5 # - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 # - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 # - main package pulls /usr/bin/ruby
8 # - monitor http://bugs.kde.org/show_bug.cgi?id=137390 to remove the temporary fix
9 # - ProjectM (see README)
10 # - karma & MFS (see README)
11 #
12 # Conditional builds:
13 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
14 %bcond_without  mas             # disable MAS audio backend
15 %bcond_without  xine            # disable xine engine
16 %bcond_without  zeroconf        # disable support for zeroconf
17 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
18 %bcond_without  helix           # disable HelixPlayer engine
19 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
20 %bcond_with     nmm             # enable NMM audio backend
21 %bcond_with     mysql           # enable MySQL support
22 %bcond_with     pgsql           # enable PostgreSQL support
23 #
24 %ifarch i386
25 %undefine       with_helix
26 %endif
27
28 Summary:        A KDE audio player
29 Summary(pl.UTF-8):      Odtwarzacz audio dla KDE
30 Name:           amarok
31 Version:        1.4.9.1
32 Release:        11
33 License:        GPL
34 Group:          X11/Applications/Multimedia
35 Source0:        ftp://ftp.kde.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
36 # Source0-md5:  aa588778379a391ad3f4b3fc770217e4
37 Patch0:         %{name}-helixplayer-morearchs.patch
38 Patch1:         %{name}-libnjb.patch
39 Patch2:         %{name}-smp.patch
40 Patch3:         %{name}-sparc.patch
41 Patch4:         kde-ac260-lt.patch
42 Patch5:         kde-common-PLD.patch
43 Patch6:         %{name}-gcc4.patch
44 Patch7:         %{name}-titleorder.patch
45 Patch8:         %{name}-mongrel.patch
46 URL:            http://amarok.kde.org/
47 BuildRequires:  SDL-devel
48 BuildRequires:  alsa-lib-devel
49 BuildRequires:  autoconf
50 BuildRequires:  automake
51 BuildRequires:  dbus-glib-devel
52 BuildRequires:  gettext-devel
53 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
54 BuildRequires:  kdebase-devel
55 %{?with_akode:BuildRequires:    kdemultimedia-akode}
56 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
57 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.6.0}
58 %{?with_mp3players:BuildRequires:       libifp-devel >= 1.0.0.2}
59 BuildRequires:  libltdl-devel
60 %{?with_mp3players:BuildRequires:       libmtp-devel >= 0.1.1}
61 %{?with_mp3players:BuildRequires:       libnjb-devel >= 2.2.4}
62 %{?with_pgsql:BuildRequires:            libpqxx-devel}
63 BuildRequires:  libtunepimp-devel >= 0.5.1-6
64 BuildRequires:  libvisual-devel >= 0.4.0
65 BuildRequires:  mpeg4ip-devel >= 1:1.6
66 %{?with_mysql:BuildRequires:            mysql-devel}
67 BuildRequires:  pcre-devel
68 BuildRequires:  pkgconfig
69 BuildRequires:  rpm-pythonprov
70 BuildRequires:  rpmbuild(macros) >= 1.129
71 BuildRequires:  ruby-devel >= 1.8
72 BuildRequires:  sed >= 4.0
73 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
74 BuildRequires:  taglib-devel >= 1.4
75 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
76 Requires(post): /sbin/ldconfig
77 Requires:       %{name}-plugin = %{version}-%{release}
78 Requires:       kdebase-core >= 9:3.1.93
79 Requires:       kdelibs-libs >= 9:3.5.9
80 Requires:       kdemultimedia-audiocd >= 9:3.1.93
81 Requires:       ruby-mongrel
82 Suggests:       libvisual-plugin-actor-JESS
83 Suggests:       libvisual-plugin-actor-bumpscope
84 Suggests:       libvisual-plugin-actor-corona
85 Suggests:       libvisual-plugin-actor-flower
86 Suggests:       libvisual-plugin-actor-gdkpixbuf
87 Suggests:       libvisual-plugin-actor-gforce
88 Suggests:       libvisual-plugin-actor-gstreamer
89 Suggests:       libvisual-plugin-actor-infinite
90 Suggests:       libvisual-plugin-actor-jakdaw
91 Suggests:       libvisual-plugin-actor-lv_analyzer
92 Suggests:       libvisual-plugin-actor-lv_gltest
93 Suggests:       libvisual-plugin-actor-lv_scope
94 Suggests:       libvisual-plugin-actor-madspin
95 Suggests:       libvisual-plugin-actor-nastyfft
96 Suggests:       libvisual-plugin-actor-oinksie
97 Suggests:       libvisual-plugin-input-alsa
98 Suggests:       libvisual-plugin-input-esd
99 Suggests:       libvisual-plugin-input-jack
100 Suggests:       libvisual-plugin-input-mplayer
101 Suggests:       libvisual-plugin-morph-alphablend
102 Suggests:       libvisual-plugin-morph-flash
103 Suggests:       libvisual-plugin-morph-slide
104 Suggests:       libvisual-plugin-morph-tentacle
105 Obsoletes:      amarok-arts
106 Obsoletes:      amarok-xmms
107 # sr@Latn vs. sr@latin
108 Conflicts:      glibc-misc < 6:2.7
109 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111 # temporary hack for proper libgpod::itdb_get_mountpoint() detection.
112 %define         filterout_ld    -Wl,--as-needed
113
114 %description
115 A KDE audio player.
116
117 %description -l pl.UTF-8
118 Odtwarzacz audio dla KDE.
119
120 %package akode
121 Summary:        Plugin akode
122 Summary(pl.UTF-8):      Wtyczka akode
123 Group:          X11/Applications/Multimedia
124 Requires:       %{name} = %{version}-%{release}
125 Provides:       %{name}-plugin = %{version}-%{release}
126
127 %description akode
128 Plugin akode.
129
130 %description akode -l pl.UTF-8
131 Wtyczka akode.
132
133 %package helix
134 Summary:        Helix/Realplayer playback support for amarok
135 Summary(pl.UTF-8):      Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
136 Group:          X11/Applications/Multimedia
137 Requires:       %{name} = %{version}-%{release}
138 Requires:       helix-core
139 Provides:       %{name}-plugin = %{version}-%{release}
140
141 %description helix
142 Helix/Realplayer playback support for amarok.
143
144 %description helix -l pl.UTF-8
145 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
146
147 %package gstreamer
148 Summary:        Plugin gstreamer
149 Summary(pl.UTF-8):      Wtyczka gstreamer
150 Group:          X11/Applications/Multimedia
151 # deps, to get it working:
152 # mp3 decoder:  gstreamer-mad
153 # ogg decoder:  gstreamer-vorbis
154 # audio output driver:  gstreamer-audiosink-alsa
155 # from gstreamer-audio-effects to control volume, etc
156 # needed libs:
157 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
158 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
159 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
160 # gstreamer-musicbrainz for being able to edit id3 tags on files.
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       gstreamer-audio-effects
163 Requires:       gstreamer-audiosink
164 Requires:       gstreamer-mad
165 Requires:       gstreamer-musicbrainz
166 Requires:       gstreamer-vorbis
167 Provides:       %{name}-plugin = %{version}-%{release}
168
169 %description gstreamer
170 Plugin gstreamer.
171
172 %description gstreamer -l pl.UTF-8
173 Wtyczka gstreamer.
174
175 %package xine
176 Summary:        Plugin xine
177 Summary(pl.UTF-8):      Wtyczka xine
178 Group:          X11/Applications/Multimedia
179 Requires:       %{name} = %{version}-%{release}
180 Requires:       xine-plugin-audio
181 Provides:       %{name}-plugin = %{version}-%{release}
182
183 %description xine
184 Plugin xine.
185
186 %description xine -l pl.UTF-8
187 Wtyczka xine.
188
189 %package zeroconf
190 Summary:        Zeroconf data
191 Summary(pl.UTF-8):      Dane dla zeroconf
192 Group:          X11/Applications/Multimedia
193 Requires:       %{name} = %{version}-%{release}
194 Requires:       kdenetwork-kdnssd
195 Provides:       %{name}-plugin = %{version}-%{release}
196
197 %description zeroconf
198 Zeroconf data.
199
200 %description zeroconf -l pl.UTF-8
201 Dane dla zeroconf.
202
203 %package scripts
204 Summary:        amaroK scripts
205 Summary(pl.UTF-8):      Skrypty amaroKa
206 Group:          X11/Applications/Multimedia
207 Requires:       %{name} = %{version}-%{release}
208 Requires:       kdebase-kdialog
209 Requires:       python-PyQt
210 Requires:       ruby-modules
211
212 %description scripts
213 amaroK scripts allow you extend amaroK functionality.
214
215 You can learn more about scripts in amaroK from here:
216 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
217
218 %description scripts -l pl.UTF-8
219 Skrypty amaroKa pozwalające rozszerzać jego funkcjonalność.
220
221 Więcej o skryptach w amaroKu można dowiedzieć się stąd:
222 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
223
224 %prep
225 %setup -q
226 %patch0 -p1
227 %patch1 -p1
228 %patch2 -p1
229 %patch3 -p1
230 %patch4 -p1
231 %patch5 -p1
232 %patch6 -p1
233 %patch7 -p1
234 %patch8 -p1
235
236 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
237         amarok/src/amarok.desktop \
238
239 # see kde bug #110909
240 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
241
242 # kill env, call interpreter directly, so rpm automatics could rule
243 %{__sed} -i -e '
244         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
245         1s,#!.*bin/env.*python,#!%{__python},
246 ' amarok/src/scripts/*/*.{py,rb} amarok/src/amarok_proxy.rb
247
248 %build
249 cp -f /usr/share/automake/config.sub admin
250 %{__make} -f admin/Makefile.common cvs
251
252 # hack: passing something other than "no" or "yes" to --with-helix allows
253 # us to pass HELIX_LIBS
254 %configure \
255         HELIX_LIBS=%{_libdir}/helixplayer \
256         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
257         --disable-rpath \
258         --with%{!?with_mas:out}-mas \
259         --with%{!?with_xine:out}-xine \
260         --with%{!?with_gstreamer:out}-gstreamer10 \
261         --with%{!?with_akode:out}-akode \
262         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
263         --with%{!?with_nmm:out}-nmm \
264         --with%{!?with_mp3players:out}-libgpod \
265         --with%{!?with_mp3players:out}-libnjb \
266         --with%{!?with_mp3players:out}-libmtp \
267         --with%{!?with_mp3players:out}-ifp \
268         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
269         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
270         --disable-final \
271         --with-mp4v2 \
272         --with-qt-libraries=%{_libdir} \
273         --with%{!?with_included_sqlite:out}-included-sqlite
274
275 %{__make}
276
277 %install
278 rm -rf $RPM_BUILD_ROOT
279
280 %{__make} install \
281         DESTDIR=$RPM_BUILD_ROOT \
282         ruby_rubylibdir=%{ruby_rubylibdir} \
283         kde_htmldir=%{_kdedocdir} \
284         kde_libs_htmldir=%{_kdedocdir}
285
286 # remove bogus dir
287 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
288
289 rm $RPM_BUILD_ROOT%{_libdir}/kde3/*.la
290 rm $RPM_BUILD_ROOT%{_libdir}/libamarok.{so,la}
291
292 [ -d $RPM_BUILD_ROOT%{_datadir}/locale/sr@latin ] || \
293         mv -f $RPM_BUILD_ROOT%{_datadir}/locale/sr@{Latn,latin}
294 %find_lang amarok --all-name --with-kde
295
296 %clean
297 rm -rf $RPM_BUILD_ROOT
298
299 %post -p /sbin/ldconfig
300
301 %postun -p /sbin/ldconfig
302
303 %files -f amarok.lang
304 %defattr(644,root,root,755)
305 %doc AUTHORS ChangeLog README
306 %attr(755,root,root) %{_bindir}/amarok
307 %attr(755,root,root) %{_bindir}/amarokapp
308 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
309 %attr(755,root,root) %{_bindir}/amarok_libvisual
310 # used by last.fm and daap
311 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
312 # used by daap
313 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
314 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
315 %attr(755,root,root) %ghost %{_libdir}/libamarok.so.0
316 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
317 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
318 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
319 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
320 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
321 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
322 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
323 %dir %{_datadir}/apps/amarok
324 %dir %{_datadir}/apps/amarok/scripts
325 %{_datadir}/apps/amarok/*.rc
326 %{_datadir}/apps/amarok/data
327 %{_datadir}/apps/amarok/icons
328 %{_datadir}/apps/amarok/images
329 %{_datadir}/apps/amarok/themes
330 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
331 %{_datadir}/apps/konqueror/servicemenus/amarok_addaspodcast.desktop
332 %{_datadir}/apps/konqueror/servicemenus/amarok_play_audiocd.desktop
333 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
334 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
335 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
336 %{_datadir}/apps/profiles/amarok.profile.xml
337 %{_datadir}/config/amarokrc
338 %{_datadir}/config.kcfg/amarok.kcfg
339 %{_datadir}/services/amarok_generic-mediadevice.desktop
340 %{_datadir}/services/amarok_void-engine_plugin.desktop
341 %{_datadir}/services/amarok_daap-mediadevice.desktop
342 %{_datadir}/services/amarok_massstorage-device.desktop
343 %{_datadir}/services/amarok_nfs-device.desktop
344 %{_datadir}/services/amarok_smb-device.desktop
345 %{_datadir}/services/amaroklastfm.protocol
346 %{_datadir}/services/amarokitpc.protocol
347 %{_datadir}/services/amarokpcast.protocol
348 %{_datadir}/servicetypes/amarok_codecinstall.desktop
349 %{_datadir}/servicetypes/amarok_plugin.desktop
350 %{_desktopdir}/kde/amarok.desktop
351 %{_iconsdir}/*/*/apps/amarok.*
352
353 # TODO: move to subpackage
354 %dir %{ruby_rubylibdir}/amarok
355 # used by daap
356 %{ruby_rubylibdir}/amarok/codes.rb
357 # used by daap and lyrics_lyrc
358 %{ruby_rubylibdir}/amarok/debug.rb
359
360 # TODO: move to subpackage
361 %if %{with mp3players}
362 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
363 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
364 %attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
365 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
366 %{_datadir}/services/amarok_ifp-mediadevice.desktop
367 %{_datadir}/services/amarok_ipod-mediadevice.desktop
368 %{_datadir}/services/amarok_mtp-mediadevice.desktop
369 %{_datadir}/services/amarok_njb-mediadevice.desktop
370 %endif
371
372 %if %{with akode}
373 %files akode
374 %defattr(644,root,root,755)
375 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
376 %{_datadir}/services/amarok_aKode-engine.desktop
377 %endif
378
379 %if %{with gstreamer}
380 %files gstreamer
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
383 %{_datadir}/config.kcfg/gstconfig.kcfg
384 %{_datadir}/services/amarok_gst10engine_plugin.desktop
385 %endif
386
387 %if %{with helix}
388 %files helix
389 %defattr(644,root,root,755)
390 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
391 %{_datadir}/config.kcfg/helixconfig.kcfg
392 %{_datadir}/services/amarok_helixengine_plugin.desktop
393 %endif
394
395 %if %{with xine}
396 %files xine
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
399 %{_datadir}/config.kcfg/xinecfg.kcfg
400 %{_datadir}/services/amarok_xine-engine.desktop
401 %endif
402
403 %if 0
404 %if %{with zeroconf}
405 %files zeroconf
406 %defattr(644,root,root,755)
407 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
408 %endif
409 %endif
410
411 %files scripts
412 %defattr(644,root,root,755)
413 %dir %{_datadir}/apps/amarok/scripts/common
414 %{_datadir}/apps/amarok/scripts/common/Publisher.py
415 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
416
417 %dir %{_datadir}/apps/amarok/scripts/templates
418 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
419 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
420 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
421
422 # amarok searches for executable programs for scripts
423 # to figure out which files need to have execute permission, use this
424 # find command:
425 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
426
427 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
428 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
429 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
430
431 %dir %{_datadir}/apps/amarok/scripts/playlist2html
432 %{_datadir}/apps/amarok/scripts/playlist2html/README
433 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
434 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
435 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
436 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.spec
437 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.spec
438
439
440 %dir %{_datadir}/apps/amarok/scripts/webcontrol
441 %{_datadir}/apps/amarok/scripts/webcontrol/README
442 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
443 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
444 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
445 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
446 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
447 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
448 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
449 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
450 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
451 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
452 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
453 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
454 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
455 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
456 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
457 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
458 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
459 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
460 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
461
462 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
463 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
464 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
465 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
466 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
467
468 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
469 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
470 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
471 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
472 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
473
474 %dir %{_datadir}/apps/amarok/scripts/score_default
475 %{_datadir}/apps/amarok/scripts/score_default/COPYING
476 %{_datadir}/apps/amarok/scripts/score_default/README
477 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
478 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
479 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
480 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
481 %{_datadir}/apps/amarok/scripts/score_impulsive/README
482 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
483 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
484
485 %if 0
486 %dir %{_datadir}/apps/amarok/scripts/amarok_live
487 %{_datadir}/apps/amarok/scripts/amarok_live/README
488 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
489 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
490 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
491 %endif
This page took 0.0895550000000001 seconds and 4 git commands to generate.