]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- pl fix
[packages/amarok.git] / amarok.spec
1 #
2 # TODO:
3 #       * postgresql support alongside mysql
4 #       * NMM audio backend support (fix build - propably some BRs)
5 #       * make descriptions less useless
6 #       * HelixPlayer engine (fix build - propably some BRs)
7 #
8 # Conditional builds:
9 %bcond_without  arts            # disable arts engine
10 %bcond_without  gstreamer       # disable gstreamer
11 %bcond_without  mas             # disable MAS audio backend
12 %bcond_without  xine            # disable xine engine
13 %bcond_without  xmms            # disable xmms wrapping
14 %bcond_without  zeroconf        # disable suport for zeroconf
15 %bcond_with     helix           # enable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
19 Summary:        A KDE audio player
20 Summary(pl):    Odtwarzacz audio dla KDE
21 Name:           amarok
22 Version:        1.3
23 Release:        1
24 License:        GPL
25 Group:          X11/Applications/Multimedia
26 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
27 # Source0-md5:  2dd100584795fb20c621fdbc96cbee1e
28 Patch0:         kde-common-gcc4.patch
29 URL:            http://amarok.kde.org/
30 BuildRequires:  SDL-devel
31 BuildRequires:  alsa-lib-devel
32 BuildRequires:  arts-qt-devel
33 BuildRequires:  automake
34 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
35 BuildRequires:  kdebase-devel
36 %{?with_akode:BuildRequires:    kdemultimedia-akode}
37 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
38 BuildRequires:  libltdl-devel
39 BuildRequires:  libmusicbrainz-devel
40 BuildRequires:  libvisual-devel >= 0.2.0
41 BuildRequires:  pcre-devel
42 BuildRequires:  rpmbuild(macros) >= 1.129
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  sed >= 4.0
45 BuildRequires:  sqlite3-devel
46 BuildRequires:  taglib-devel >= 1.4
47 #BuildRequires: unsermake >= 040511
48 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
49 %{?with_xmms:BuildRequires:             xmms-devel}
50 %{?with_mysql:BuildRequires:            mysql-devel}
51 #BuildRequires: kdebindings-kjsembed-devel
52 Requires:       %{name}-plugin = %{version}-%{release}
53 Requires:       kdebase-core >= 9:3.1.93
54 Requires:       kdemultimedia-audiocd >= 9:3.1.93
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 A KDE audio player.
59
60 %description -l pl
61 Odtwarzacz audio dla KDE.
62
63 %package arts
64 Summary:        Plugin arts
65 Summary(pl):    Wtyczka arts
66 Group:          X11/Applications/Multimedia
67 Requires:       %{name} = %{version}-%{release}
68 Provides:       %{name}-plugin = %{version}-%{release}
69
70 %description arts
71 Plugin arts.
72
73 %description arts -l pl
74 Wtyczka arts.
75
76 %package akode
77 Summary:        Plugin akode
78 Summary(pl):    Wtyczka akode
79 Group:          X11/Applications/Multimedia
80 Requires:       %{name} = %{version}-%{release}
81 Provides:       %{name}-plugin = %{version}-%{release}
82
83 %description akode
84 Plugin akode.
85
86 %description akode -l pl
87 Wtyczka akode.
88
89 %package gstreamer
90 Summary:        Plugin gstreamer
91 Summary(pl):    Wtyczka gstreamer
92 Group:          X11/Applications/Multimedia
93 # deps, to get it working:
94 # mp3 decoder: gstreamer-mad
95 # ogg decoder: gstreamer-vorbis
96 # audio output driver: gstreamer-audiosink-alsa
97 # from gstreamer-audio-effects to control volume, etc
98 # needed libs:
99 #  at least /usr/lib/gstreamer-0.8/libgstresample.so 
100 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
101 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
102 # gstreamer-musicbrainz for being able to edit id3 tags on files.
103 Requires:       gstreamer-audio-effects
104 Requires:       gstreamer-audiosink
105 Requires:       gstreamer-mad
106 Requires:       gstreamer-vorbis
107 Requires:       gstreamer-musicbrainz
108 Requires:       %{name} = %{version}-%{release}
109 Provides:       %{name}-plugin = %{version}-%{release}
110
111 %description gstreamer
112 Plugin gstreamer.
113
114 %description gstreamer -l pl
115 Wtyczka gstreamer.
116
117 %package xine
118 Summary:        Plugin xine
119 Summary(pl):    Wtyczka xine
120 Group:          X11/Applications/Multimedia
121 Requires:       %{name} = %{version}-%{release}
122 Requires:       xine-plugin-audio
123 Provides:       %{name}-plugin = %{version}-%{release}
124
125 %description xine
126 Plugin xine.
127
128 %description xine -l pl
129 Wtyczka xine.
130
131 %package zeroconf
132 Summary:        Zeroconf data
133 Summary(pl):    Dane dla zeroconf
134 Group:          X11/Applications/Multimedia
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       kdenetwork-kdnssd
137 Provides:       %{name}-plugin = %{version}-%{release}
138
139 %description zeroconf
140 Zeroconf data.
141
142 %description zeroconf -l pl
143 Dane dla zeroconf.
144
145 %prep
146 %setup -q
147 %patch0 -p1
148 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
149         amarok/src/amarok.desktop \
150
151 %build
152 cp -f /usr/share/automake/config.sub admin
153
154 #export UNSERMAKE=/usr/share/unsermake/unsermake
155
156 %{__make} -f admin/Makefile.common cvs
157
158 %configure \
159         --disable-rpath \
160         %{!?with_arts:--without-arts} \
161         %{?with_mas:--with-mas} \
162         %{!?with_xine:--without-xine} \
163         %{!?with_gstreamer:--without-gstreamer} \
164         %{!?with_akode:--without-akode} \
165         %{?with_helix:--with-helix} \
166         %{?with_nmm:--with-nmm} \
167         %{?with_mysql:--with-mysql} \
168         --disable-final \
169         --with-qt-libraries=%{_libdir} \
170         --without-included-sqlite
171
172 %{__make}
173
174 %install
175 rm -rf $RPM_BUILD_ROOT
176
177 %{__make} install \
178         DESTDIR=$RPM_BUILD_ROOT \
179         kde_htmldir=%{_kdedocdir} \
180         kde_libs_htmldir=%{_kdedocdir}
181
182 # remove bogus dir
183 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
184
185 %find_lang amarok --all-name --with-kde
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %post
191 echo "Remember to install libvisual-plugins-* packages if you"
192 echo "want to have a visualizations in amarok."
193
194 %files -f %{name}.lang
195 %defattr(644,root,root,755)
196 %doc AUTHORS ChangeLog README TODO
197 %attr(755,root,root) %{_bindir}/amarok
198 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
199 %attr(755,root,root) %{_bindir}/amarokapp
200 %attr(755,root,root) %{_bindir}/amarok_libvisual
201 #%attr(755,root,root) %{_bindir}/release_amarok
202 %{_libdir}/kde3/konqsidebar_universalamarok.la
203 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
204 %{_libdir}/kde3/libamarok_void-engine_plugin.la
205 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
206 %{_datadir}/apps/amarok
207 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
208 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
209 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
210 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
211 %{_datadir}/apps/profiles/amarok.profile.xml
212 %{_datadir}/config/amarokrc
213 %{_datadir}/config.kcfg/amarok.kcfg
214 %{_datadir}/services/amarok_void-engine_plugin.desktop
215 %{_datadir}/servicetypes/amarok_plugin.desktop
216 %{_desktopdir}/kde/amarok.desktop
217 %{_iconsdir}/*/*/apps/amarok.*
218
219 %if %{with arts}
220 %files arts
221 %defattr(644,root,root,755)
222 %{_libdir}/kde3/libamarok_artsengine_plugin.la
223 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
224 %{_libdir}/libamarokarts.la
225 %attr(755,root,root) %{_libdir}/libamarokarts.so
226 %{_libdir}/mcop/Amarok
227 %{_libdir}/mcop/amarokarts.mcopclass
228 %{_libdir}/mcop/amarokarts.mcoptype
229 %{_datadir}/services/amarok_artsengine_plugin.desktop
230 %endif
231
232 %if %{with akode}
233 %files akode
234 %defattr(644,root,root,755)
235 %{_libdir}/kde3/libamarok_aKode-engine.la
236 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
237 %{_datadir}/services/amarok_aKode-engine.desktop
238 %endif
239
240 %if %{with gstreamer}
241 %files gstreamer
242 %defattr(644,root,root,755)
243 %{_libdir}/kde3/libamarok_gstengine_plugin.la
244 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
245 %{_datadir}/config.kcfg/gstconfig.kcfg
246 %{_datadir}/services/amarok_gstengine_plugin.desktop
247 %endif
248
249 %if %{with xine}
250 %files xine
251 %defattr(644,root,root,755)
252 %{_libdir}/kde3/libamarok_xine-engine.la
253 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
254 %{_datadir}/config.kcfg/xinecfg.kcfg
255 %{_datadir}/services/amarok_xine-engine.desktop
256 #%{_datadir}/services/amarok_xineengine_plugin.desktop
257 %endif
258
259 %if %{with zeroconf}
260 %files zeroconf
261 %defattr(644,root,root,755)
262 %{_datadir}/apps/zeroconf/_shoutcast._tcp
263 %endif
This page took 0.054728 seconds and 4 git commands to generate.