]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- updated to 1.2beta3
[packages/amarok.git] / amarok.spec
1 #
2 # Conditional builds:
3 %bcond_without  arts            # disable arts engine
4 %bcond_without  gstreamer       # disable gstreamer
5 %bcond_without  xine            # disable xine engine
6 %bcond_without  xmms            # disable xmms wrapping
7 %bcond_with     mysql           # enable mysql support
8 #
9
10 %define         _beta   beta3
11 Summary:        A KDE audio player
12 Summary(pl):    Odtwarzacz audio dla KDE
13 Name:           amarok
14 Version:        1.2.%{_beta}
15 Release:        0.1
16 License:        GPL
17 Group:          X11/Applications/Multimedia
18 Source0:        http://dl.sourceforge.net/amarok/%{name}-1.2-%{_beta}.tar.bz2
19 # Source0-md5:  e6379b144cdec4eca0556619a03f294c
20 URL:            http://amarok.kde.org/
21 Buildrequires:  alsa-lib-devel
22 Buildrequires:  arts-qt-devel
23 Buildrequires:  automake
24 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
25 BuildRequires:  kdebase-devel
26 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
27 Buildrequires:  libmusicbrainz-devel
28 Buildrequires:  libvisual-devel >= 0.2.0
29 Buildrequires:  pcre-devel
30 BuildRequires:  rpmbuild(macros) >= 1.129
31 BuildRequires:  sed >= 4.0
32 BuildRequires:  sqlite3-devel
33 BuildRequires:  taglib-devel >= 1.3.1
34 BuildRequires:  unsermake >= 040511
35 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
36 %{?with_xmms:BuildRequires:             xmms-devel}
37 %{?with_mysql:BuildRequires:            mysql-devel}
38 #BuildRequires: kdebindings-kjsembed-devel 
39 Requires:       %{name}-plugin = %{version}-%{release}
40 Requires:       kdebase-core >= 9:3.1.93
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 A KDE audio player.
45
46 %description -l pl
47 Odtwarzacz audio dla KDE.
48
49 %package arts
50 Summary:        Plugin arts
51 Summary(pl):    Wtyczka arts
52 Group:          X11/Applications/Multimedia
53 Requires:       %{name} = %{version}-%{release}
54 Provides:       %{name}-plugin = %{version}-%{release}
55
56 %description arts
57 Plugin arts.
58
59 %description arts -l pl
60 Wtyczka arts.
61
62 %package gstreamer
63 Summary:        Plugin gstreamer
64 Summary(pl):    Wtyczka gstreamer
65 Group:          X11/Applications/Multimedia
66 Requires:       %{name} = %{version}-%{release}
67 Provides:       %{name}-plugin = %{version}-%{release}
68
69 %description gstreamer
70 Plugin gstreamer.
71
72 %description gstreamer -l pl
73 Wtyczka gstreamer.
74
75 %package xine
76 Summary:        Plugin xine
77 Summary(pl):    Wtyczka xine
78 Group:          X11/Applications/Multimedia
79 Requires:       %{name} = %{version}-%{release}
80 Provides:       %{name}-plugin = %{version}-%{release}
81
82 %description xine
83 Plugin xine.
84
85 %description xine -l pl
86 Wtyczka xine.
87
88 %prep
89 %setup -q -n %{name}-1.2-%{_beta}
90
91 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
92         amarok/src/amarok.desktop \
93
94 %build
95 cp -f %{_datadir}/automake/config.sub admin
96
97 export UNSERMAKE=%{_datadir}/unsermake/unsermake
98
99 %{__make} -f admin/Makefile.common cvs
100
101 %configure \
102         --disable-rpath \
103         %{!?with_arts:--without-arts} \
104         %{!?with_xine:--without-xine} \
105         %{!?with_gstreamer:--without-gstreamer} \
106         %{?with_mysql:--with-mysql} \
107         --disable-final \
108         --with-qt-libraries=%{_libdir} \
109         --without-included-sqlite
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT \
118         kde_htmldir=%{_kdedocdir} \
119         kde_libs_htmldir=%{_kdedocdir}
120
121 # remove bogus dir
122 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
123
124 %find_lang amarok --all-name --with-kde
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %files -f %{name}.lang
130 %defattr(644,root,root,755)
131 %doc AUTHORS ChangeLog README TODO
132 %attr(755,root,root) %{_bindir}/amarok
133 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
134 %attr(755,root,root) %{_bindir}/amarokapp
135 %attr(755,root,root) %{_bindir}/amarok_libvisual
136 %attr(755,root,root) %{_bindir}/release_amarok
137 %{_libdir}/kde3/libamarok_void-engine_plugin.la
138 %{_libdir}/kde3/konqsidebar_universalamarok.la
139 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
140 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
141 %{_datadir}/apps/amarok
142 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
143 %{_datadir}/config.kcfg/amarok.kcfg
144 %{_datadir}/services/amarok_void-engine_plugin.desktop
145 %{_datadir}/servicetypes/amarok_plugin.desktop
146 %{_desktopdir}/kde/amarok.desktop
147 %{_iconsdir}/*/*/apps/amarok.png
148 %{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
149 %{_datadir}/config/*
150
151 %if %{with arts}
152 %files arts
153 %defattr(644,root,root,755)
154 %{_libdir}/kde3/libamarok_artsengine_plugin.la
155 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
156 %{_libdir}/libamarokarts.la
157 %attr(755,root,root) %{_libdir}/libamarokarts.so
158 %{_libdir}/mcop/Amarok
159 %{_libdir}/mcop/amarokarts.mcopclass
160 %{_libdir}/mcop/amarokarts.mcoptype
161 %{_datadir}/services/amarok_artsengine_plugin.desktop
162 %endif
163
164 %if %{with gstreamer}
165 %files gstreamer
166 %defattr(644,root,root,755)
167 %{_libdir}/kde3/libamarok_gstengine_plugin.la
168 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
169 %{_datadir}/config.kcfg/gstconfig.kcfg
170 %{_datadir}/services/amarok_gstengine_plugin.desktop
171 %endif
172
173 %if %{with xine}
174 %files xine
175 %defattr(644,root,root,755)
176 %{_libdir}/kde3/libamarok_xine-engine.la
177 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
178 %{_datadir}/services/amarok_xine-engine.desktop
179 %{_datadir}/services/amarok_xineengine_plugin.desktop
180 %endif
This page took 0.041408 seconds and 4 git commands to generate.