]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- added R: kdemultimedia-audiocd (for support AudioCD in amarok)
[packages/amarok.git] / amarok.spec
1 #
2 # Conditional builds:
3 %bcond_without  arts            # disable arts engine
4 %bcond_without  gstreamer       # disable gstreamer
5 %bcond_without  xine            # disable xine engine
6 %bcond_without  xmms            # disable xmms wrapping
7 %bcond_with     mysql           # enable mysql support
8 #
9
10 %define         _beta   beta3
11 Summary:        A KDE audio player
12 Summary(pl):    Odtwarzacz audio dla KDE
13 Name:           amarok
14 Version:        1.2.%{_beta}
15 Release:        0.1
16 License:        GPL
17 Group:          X11/Applications/Multimedia
18 Source0:        http://dl.sourceforge.net/amarok/%{name}-1.2-%{_beta}.tar.bz2
19 # Source0-md5:  e6379b144cdec4eca0556619a03f294c
20 URL:            http://amarok.kde.org/
21 Buildrequires:  alsa-lib-devel
22 Buildrequires:  arts-qt-devel
23 Buildrequires:  automake
24 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
25 BuildRequires:  kdebase-devel
26 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
27 Buildrequires:  libmusicbrainz-devel
28 Buildrequires:  libvisual-devel >= 0.2.0
29 Buildrequires:  pcre-devel
30 BuildRequires:  rpmbuild(macros) >= 1.129
31 BuildRequires:  sed >= 4.0
32 BuildRequires:  sqlite3-devel
33 BuildRequires:  taglib-devel >= 1.3.1
34 BuildRequires:  unsermake >= 040511
35 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
36 %{?with_xmms:BuildRequires:             xmms-devel}
37 %{?with_mysql:BuildRequires:            mysql-devel}
38 #BuildRequires: kdebindings-kjsembed-devel 
39 Requires:       %{name}-plugin = %{version}-%{release}
40 Requires:       kdebase-core >= 9:3.1.93
41 Requires:       kdemultimedia-audiocd >= 9:3.1.93
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 A KDE audio player.
46
47 %description -l pl
48 Odtwarzacz audio dla KDE.
49
50 %package arts
51 Summary:        Plugin arts
52 Summary(pl):    Wtyczka arts
53 Group:          X11/Applications/Multimedia
54 Requires:       %{name} = %{version}-%{release}
55 Provides:       %{name}-plugin = %{version}-%{release}
56
57 %description arts
58 Plugin arts.
59
60 %description arts -l pl
61 Wtyczka arts.
62
63 %package gstreamer
64 Summary:        Plugin gstreamer
65 Summary(pl):    Wtyczka gstreamer
66 Group:          X11/Applications/Multimedia
67 Requires:       %{name} = %{version}-%{release}
68 Provides:       %{name}-plugin = %{version}-%{release}
69
70 %description gstreamer
71 Plugin gstreamer.
72
73 %description gstreamer -l pl
74 Wtyczka gstreamer.
75
76 %package xine
77 Summary:        Plugin xine
78 Summary(pl):    Wtyczka xine
79 Group:          X11/Applications/Multimedia
80 Requires:       %{name} = %{version}-%{release}
81 Provides:       %{name}-plugin = %{version}-%{release}
82
83 %description xine
84 Plugin xine.
85
86 %description xine -l pl
87 Wtyczka xine.
88
89 %prep
90 %setup -q -n %{name}-1.2-%{_beta}
91
92 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
93         amarok/src/amarok.desktop \
94
95 %build
96 cp -f %{_datadir}/automake/config.sub admin
97
98 export UNSERMAKE=%{_datadir}/unsermake/unsermake
99
100 %{__make} -f admin/Makefile.common cvs
101
102 %configure \
103         --disable-rpath \
104         %{!?with_arts:--without-arts} \
105         %{!?with_xine:--without-xine} \
106         %{!?with_gstreamer:--without-gstreamer} \
107         %{?with_mysql:--with-mysql} \
108         --disable-final \
109         --with-qt-libraries=%{_libdir} \
110         --without-included-sqlite
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT \
119         kde_htmldir=%{_kdedocdir} \
120         kde_libs_htmldir=%{_kdedocdir}
121
122 # remove bogus dir
123 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
124
125 %find_lang amarok --all-name --with-kde
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files -f %{name}.lang
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog README TODO
133 %attr(755,root,root) %{_bindir}/amarok
134 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
135 %attr(755,root,root) %{_bindir}/amarokapp
136 %attr(755,root,root) %{_bindir}/amarok_libvisual
137 %attr(755,root,root) %{_bindir}/release_amarok
138 %{_libdir}/kde3/libamarok_void-engine_plugin.la
139 %{_libdir}/kde3/konqsidebar_universalamarok.la
140 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
141 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
142 %{_datadir}/apps/amarok
143 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
144 %{_datadir}/config.kcfg/amarok.kcfg
145 %{_datadir}/services/amarok_void-engine_plugin.desktop
146 %{_datadir}/servicetypes/amarok_plugin.desktop
147 %{_desktopdir}/kde/amarok.desktop
148 %{_iconsdir}/*/*/apps/amarok.png
149 %{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
150 %{_datadir}/config/*
151
152 %if %{with arts}
153 %files arts
154 %defattr(644,root,root,755)
155 %{_libdir}/kde3/libamarok_artsengine_plugin.la
156 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
157 %{_libdir}/libamarokarts.la
158 %attr(755,root,root) %{_libdir}/libamarokarts.so
159 %{_libdir}/mcop/Amarok
160 %{_libdir}/mcop/amarokarts.mcopclass
161 %{_libdir}/mcop/amarokarts.mcoptype
162 %{_datadir}/services/amarok_artsengine_plugin.desktop
163 %endif
164
165 %if %{with gstreamer}
166 %files gstreamer
167 %defattr(644,root,root,755)
168 %{_libdir}/kde3/libamarok_gstengine_plugin.la
169 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
170 %{_datadir}/config.kcfg/gstconfig.kcfg
171 %{_datadir}/services/amarok_gstengine_plugin.desktop
172 %endif
173
174 %if %{with xine}
175 %files xine
176 %defattr(644,root,root,755)
177 %{_libdir}/kde3/libamarok_xine-engine.la
178 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
179 %{_datadir}/services/amarok_xine-engine.desktop
180 %{_datadir}/services/amarok_xineengine_plugin.desktop
181 %endif
This page took 0.041809 seconds and 4 git commands to generate.