]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- remove seocnd ac/am regenration, makefile.cvs is enough
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
15 %bcond_with     helix           # enable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     pgsql           # enables postgresql support
19 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
20 %bcond_with     altlyrics       # use alternative lyrics provider
21 Summary:        A KDE audio player
22 Summary(pl):    Odtwarzacz audio dla KDE
23 Name:           amarok
24 Version:        1.3.5
25 Release:        3
26 License:        GPL
27 Group:          X11/Applications/Multimedia
28 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
29 # Source0-md5:  faac790ea432a784fa7d1ac6a34ee410
30 Patch0:         kde-common-gcc4.patch
31 Patch1:         %{name}-lyricsurl.patch
32 Patch2:         %{name}-desktop.patch
33 URL:            http://amarok.kde.org/
34 #BuildRequires: kdebindings-kjsembed-devel
35 #BuildRequires: unsermake >= 040511
36 BuildRequires:  SDL-devel
37 BuildRequires:  alsa-lib-devel
38 BuildRequires:  arts-qt-devel
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.6}
42 BuildRequires:  kdebase-devel
43 %{?with_akode:BuildRequires:    kdemultimedia-akode}
44 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
45 BuildRequires:  libltdl-devel
46 BuildRequires:  libmusicbrainz-devel
47 BuildRequires:  libvisual-devel >= 0.2.0
48 %{?with_mysql:BuildRequires:            mysql-devel}
49 %{?with_pgsql:BuildRequires:            libpqxx-devel}
50 BuildRequires:  pcre-devel
51 BuildRequires:  rpm-pythonprov
52 BuildRequires:  rpmbuild(macros) >= 1.129
53 BuildRequires:  sed >= 4.0
54 %{?with_helix:BuildRequires:helix-core}
55 %{?!with_included_sqlite:BuildRequires: sqlite3-devel}
56 BuildRequires:  taglib-devel >= 1.4
57 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
58 %{?with_xmms:BuildRequires:             xmms-devel}
59 Requires:       %{name}-plugin = %{version}-%{release}
60 Requires:       kdebase-core >= 9:3.1.93
61 Requires:       kdemultimedia-audiocd >= 9:3.1.93
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 A KDE audio player.
66
67 %description -l pl
68 Odtwarzacz audio dla KDE.
69
70 %package arts
71 Summary:        Plugin arts
72 Summary(pl):    Wtyczka arts
73 Group:          X11/Applications/Multimedia
74 Requires:       %{name} = %{version}-%{release}
75 Provides:       %{name}-plugin = %{version}-%{release}
76
77 %description arts
78 Plugin arts.
79
80 %description arts -l pl
81 Wtyczka arts.
82
83 %package akode
84 Summary:        Plugin akode
85 Summary(pl):    Wtyczka akode
86 Group:          X11/Applications/Multimedia
87 Requires:       %{name} = %{version}-%{release}
88 Provides:       %{name}-plugin = %{version}-%{release}
89
90 %description akode
91 Plugin akode.
92
93 %description akode -l pl
94 Wtyczka akode.
95
96 %package gstreamer
97 Summary:        Plugin gstreamer
98 Summary(pl):    Wtyczka gstreamer
99 Group:          X11/Applications/Multimedia
100 # deps, to get it working:
101 # mp3 decoder: gstreamer-mad
102 # ogg decoder: gstreamer-vorbis
103 # audio output driver: gstreamer-audiosink-alsa
104 # from gstreamer-audio-effects to control volume, etc
105 # needed libs:
106 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
107 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
108 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
109 # gstreamer-musicbrainz for being able to edit id3 tags on files.
110 Requires:       %{name} = %{version}-%{release}
111 Requires:       gstreamer-audio-effects
112 Requires:       gstreamer-audiosink
113 Requires:       gstreamer-mad
114 Requires:       gstreamer-musicbrainz
115 Requires:       gstreamer-vorbis
116 Provides:       %{name}-plugin = %{version}-%{release}
117
118 %description gstreamer
119 Plugin gstreamer.
120
121 %description gstreamer -l pl
122 Wtyczka gstreamer.
123
124 %package xine
125 Summary:        Plugin xine
126 Summary(pl):    Wtyczka xine
127 Group:          X11/Applications/Multimedia
128 Requires:       %{name} = %{version}-%{release}
129 Requires:       xine-plugin-audio
130 Provides:       %{name}-plugin = %{version}-%{release}
131
132 %description xine
133 Plugin xine.
134
135 %description xine -l pl
136 Wtyczka xine.
137
138 %package zeroconf
139 Summary:        Zeroconf data
140 Summary(pl):    Dane dla zeroconf
141 Group:          X11/Applications/Multimedia
142 Requires:       %{name} = %{version}-%{release}
143 Requires:       kdenetwork-kdnssd
144 Provides:       %{name}-plugin = %{version}-%{release}
145
146 %description zeroconf
147 Zeroconf data.
148
149 %description zeroconf -l pl
150 Dane dla zeroconf.
151
152 %package scripts
153 Summary:        amaroK scripts
154 Summary(pl):    Skrypty amaroKa
155 Group:          X11/Applications/Multimedia
156 Requires:       %{name} = %{version}-%{release}
157 Requires:       kdebase-kdialog
158 Requires:       python-PyQt
159
160 %description scripts
161 amaroK scripts allow you extend amaroK functionality.
162
163 You can learn more about scripts in amaroK from here:
164 <http://amarok.kde.org/wiki/index.php/Scripts>.
165
166 %description scripts -l pl
167 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
168
169 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
170 <http://amarok.kde.org/wiki/index.php/Scripts>.
171
172 %prep
173 %setup -q
174 %patch0 -p1
175 %{?with_altlyrics:%patch1 -p1}
176 %patch2 -p1
177 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
178         amarok/src/amarok.desktop \
179
180 # see kde bug #110909
181 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
182
183 %build
184 cp -f /usr/share/automake/config.sub admin
185
186 #export UNSERMAKE=/usr/share/unsermake/unsermake
187
188 %{__make} -f admin/Makefile.common cvs
189
190 %configure \
191         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
192         --disable-rpath \
193         --with%{!?with_arts:out}-arts \
194         --with%{!?with_mas:out}-mas \
195         --with%{!?with_xine:out}-xine \
196         --with%{!?with_gstreamer:out}-gstreamer \
197         --with%{!?with_akode:out}-akode \
198         --with%{!?with_helix:out}-helix \
199         --with%{!?with_nmm:out}-nmm \
200         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
201         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
202         --disable-final \
203         --with-qt-libraries=%{_libdir} \
204         --with%{!?with_included_sqlite:out}-included-sqlite
205
206 %{__make}
207
208 %install
209 rm -rf $RPM_BUILD_ROOT
210
211 %{__make} install \
212         DESTDIR=$RPM_BUILD_ROOT \
213         kde_htmldir=%{_kdedocdir} \
214         kde_libs_htmldir=%{_kdedocdir}
215
216 # remove bogus dir
217 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
218
219 %find_lang amarok --all-name --with-kde
220
221 %clean
222 rm -rf $RPM_BUILD_ROOT
223
224 %post
225 if [ "$1" = 1 ]; then
226         echo "Remember to install libvisual-plugins-* packages if you"
227         echo "want to have a visualizations in amaroK."
228 fi
229
230 %files -f %{name}.lang
231 %defattr(644,root,root,755)
232 %doc AUTHORS ChangeLog README
233 %attr(755,root,root) %{_bindir}/amarok
234 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
235 %attr(755,root,root) %{_bindir}/amarokapp
236 %attr(755,root,root) %{_bindir}/amarok_libvisual
237 #%attr(755,root,root) %{_bindir}/release_amarok
238 %{_libdir}/kde3/konqsidebar_universalamarok.la
239 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
240 %{_libdir}/kde3/libamarok_void-engine_plugin.la
241 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
242 %dir %{_datadir}/apps/amarok
243 %dir %{_datadir}/apps/amarok/scripts
244 %{_datadir}/apps/amarok/*.rc
245 %{_datadir}/apps/amarok/data
246 %{_datadir}/apps/amarok/icons
247 %{_datadir}/apps/amarok/images
248 %{_datadir}/apps/amarok/themes
249 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
250 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
251 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
252 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
253 %{_datadir}/apps/profiles/amarok.profile.xml
254 %{_datadir}/config/amarokrc
255 %{_datadir}/config.kcfg/amarok.kcfg
256 %{_datadir}/services/amarok_void-engine_plugin.desktop
257 %{_datadir}/servicetypes/amarok_plugin.desktop
258 %{_desktopdir}/kde/amarok.desktop
259 %{_iconsdir}/*/*/apps/amarok.*
260
261 %if %{with arts}
262 %files arts
263 %defattr(644,root,root,755)
264 %{_libdir}/kde3/libamarok_artsengine_plugin.la
265 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
266 %{_libdir}/libamarokarts.la
267 %attr(755,root,root) %{_libdir}/libamarokarts.so
268 %{_libdir}/mcop/Amarok
269 %{_libdir}/mcop/amarokarts.mcopclass
270 %{_libdir}/mcop/amarokarts.mcoptype
271 %{_datadir}/services/amarok_artsengine_plugin.desktop
272 %endif
273
274 %if %{with akode}
275 %files akode
276 %defattr(644,root,root,755)
277 %{_libdir}/kde3/libamarok_aKode-engine.la
278 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
279 %{_datadir}/services/amarok_aKode-engine.desktop
280 %endif
281
282 %if %{with gstreamer}
283 %files gstreamer
284 %defattr(644,root,root,755)
285 %{_libdir}/kde3/libamarok_gstengine_plugin.la
286 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
287 %{_datadir}/config.kcfg/gstconfig.kcfg
288 %{_datadir}/services/amarok_gstengine_plugin.desktop
289 %endif
290
291 %if %{with xine}
292 %files xine
293 %defattr(644,root,root,755)
294 %{_libdir}/kde3/libamarok_xine-engine.la
295 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
296 %{_datadir}/config.kcfg/xinecfg.kcfg
297 %{_datadir}/services/amarok_xine-engine.desktop
298 #%{_datadir}/services/amarok_xineengine_plugin.desktop
299 %endif
300
301 %if %{with zeroconf}
302 %files zeroconf
303 %defattr(644,root,root,755)
304 %{_datadir}/apps/zeroconf/_shoutcast._tcp
305 %endif
306
307 %files scripts
308 %defattr(644,root,root,755)
309
310 %dir %{_datadir}/apps/amarok/scripts/alarm
311 %{_datadir}/apps/amarok/scripts/alarm/README
312 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
313
314 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
315 %{_datadir}/apps/amarok/scripts/graphequalizer/README
316 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
317
318 %dir %{_datadir}/apps/amarok/scripts/playlist2html
319 %{_datadir}/apps/amarok/scripts/playlist2html/README
320 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
321 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
322 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
323
324 %dir %{_datadir}/apps/amarok/scripts/templates
325 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
326 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
327 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
328
329 %dir %{_datadir}/apps/amarok/scripts/webcontrol
330 %{_datadir}/apps/amarok/scripts/webcontrol/README
331 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
332 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
333 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
334 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
335 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
336 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
337 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
338 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
339 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
340 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
341 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
342 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
343 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
344 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
345 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
346 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
347
348 %dir %{_datadir}/apps/amarok/scripts/common
349 %{_datadir}/apps/amarok/scripts/common/Publisher.py
350 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
351
352 %dir %{_datadir}/apps/amarok/scripts/shouter
353 %{_datadir}/apps/amarok/scripts/shouter/README
354 %{_datadir}/apps/amarok/scripts/shouter/ChangeLog
355 %{_datadir}/apps/amarok/scripts/shouter/Amarok.py
356 %{_datadir}/apps/amarok/scripts/shouter/Globals.py
357 %{_datadir}/apps/amarok/scripts/shouter/Playlist.py
358 %{_datadir}/apps/amarok/scripts/shouter/Services.py
359 %{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
360 %{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
361 %{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
362 %{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
363 %{_datadir}/apps/amarok/scripts/shouter/StreamController.py
364 %{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
365 %{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
366 %{_datadir}/apps/amarok/scripts/shouter/debug.py
367 %{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
368 %dir %{_datadir}/apps/amarok/scripts/shouter/silence
369 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
370 %dir %{_datadir}/apps/amarok/scripts/shouter/test
371 %{_datadir}/apps/amarok/scripts/shouter/test/client.py
372 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
373
374 %if 0
375 %dir %{_datadir}/apps/amarok/scripts/amarok_live
376 %{_datadir}/apps/amarok/scripts/amarok_live/README
377 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
378 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
379 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
380 %endif
This page took 0.056136 seconds and 4 git commands to generate.