]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- updated to 1.3.8
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
15 %bcond_without  helix           # enable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     pgsql           # enables postgresql support
19 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
20 %bcond_with     altlyrics       # use alternative lyrics provider
21 #
22 %ifarch i386
23 %undefine       with_helix
24 %endif
25 Summary:        A KDE audio player
26 Summary(pl):    Odtwarzacz audio dla KDE
27 Name:           amarok
28 Version:        1.3.8
29 Release:        0.1
30 License:        GPL
31 Group:          X11/Applications/Multimedia
32 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
33 # Source0-md5:  fd1ee0509568e5f9f7d0aeb9af094786
34 Patch0:         kde-common-gcc4.patch
35 Patch1:         %{name}-lyricsurl.patch
36 Patch2:         %{name}-libtunepimp-0.4.0.patch
37 Patch3:         %{name}-helixplayer-morearchs.patch
38 URL:            http://amarok.kde.org/
39 #BuildRequires: kdebindings-kjsembed-devel
40 #BuildRequires: unsermake >= 040511
41 BuildRequires:  SDL-devel
42 BuildRequires:  alsa-lib-devel
43 BuildRequires:  arts-qt-devel
44 BuildRequires:  autoconf
45 BuildRequires:  automake
46 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.6}
47 BuildRequires:  kdebase-devel
48 %{?with_akode:BuildRequires:    kdemultimedia-akode}
49 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
50 BuildRequires:  libltdl-devel
51 BuildRequires:  libtunepimp-devel >= 0.4.0
52 BuildRequires:  libvisual-devel >= 0.2.0
53 %{?with_mysql:BuildRequires:            mysql-devel}
54 %{?with_pgsql:BuildRequires:            libpqxx-devel}
55 BuildRequires:  pcre-devel
56 BuildRequires:  rpm-pythonprov
57 BuildRequires:  rpmbuild(macros) >= 1.129
58 BuildRequires:  sed >= 4.0
59 %{!?with_included_sqlite:BuildRequires: sqlite3-devel}
60 BuildRequires:  taglib-devel >= 1.4
61 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
62 %{?with_xmms:BuildRequires:             xmms-devel}
63 Requires:       %{name}-plugin = %{version}-%{release}
64 Requires:       kdebase-core >= 9:3.1.93
65 Requires:       kdemultimedia-audiocd >= 9:3.1.93
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 A KDE audio player.
70
71 %description -l pl
72 Odtwarzacz audio dla KDE.
73
74 %package arts
75 Summary:        Plugin arts
76 Summary(pl):    Wtyczka arts
77 Group:          X11/Applications/Multimedia
78 Requires:       %{name} = %{version}-%{release}
79 Provides:       %{name}-plugin = %{version}-%{release}
80
81 %description arts
82 Plugin arts.
83
84 %description arts -l pl
85 Wtyczka arts.
86
87 %package akode
88 Summary:        Plugin akode
89 Summary(pl):    Wtyczka akode
90 Group:          X11/Applications/Multimedia
91 Requires:       %{name} = %{version}-%{release}
92 Provides:       %{name}-plugin = %{version}-%{release}
93
94 %description akode
95 Plugin akode.
96
97 %description akode -l pl
98 Wtyczka akode.
99
100 %package helix
101 Summary:        Helix/Realplayer playback support for amarok
102 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
103 Group:          X11/Applications/Multimedia
104 Requires:       %{name} = %{version}-%{release}
105 Requires:       helix-core
106 Provides:       %{name}-plugin = %{version}-%{release}
107
108 %description helix
109 Helix/Realplayer playback support for amarok.
110
111 %description helix -l pl
112 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
113
114
115 %package gstreamer
116 Summary:        Plugin gstreamer
117 Summary(pl):    Wtyczka gstreamer
118 Group:          X11/Applications/Multimedia
119 # deps, to get it working:
120 # mp3 decoder: gstreamer-mad
121 # ogg decoder: gstreamer-vorbis
122 # audio output driver: gstreamer-audiosink-alsa
123 # from gstreamer-audio-effects to control volume, etc
124 # needed libs:
125 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
126 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
127 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
128 # gstreamer-musicbrainz for being able to edit id3 tags on files.
129 Requires:       %{name} = %{version}-%{release}
130 Requires:       gstreamer-audio-effects
131 Requires:       gstreamer-audiosink
132 Requires:       gstreamer-mad
133 Requires:       gstreamer-musicbrainz
134 Requires:       gstreamer-vorbis
135 Provides:       %{name}-plugin = %{version}-%{release}
136
137 %description gstreamer
138 Plugin gstreamer.
139
140 %description gstreamer -l pl
141 Wtyczka gstreamer.
142
143 %package xine
144 Summary:        Plugin xine
145 Summary(pl):    Wtyczka xine
146 Group:          X11/Applications/Multimedia
147 Requires:       %{name} = %{version}-%{release}
148 Requires:       xine-plugin-audio
149 Provides:       %{name}-plugin = %{version}-%{release}
150
151 %description xine
152 Plugin xine.
153
154 %description xine -l pl
155 Wtyczka xine.
156
157 %package zeroconf
158 Summary:        Zeroconf data
159 Summary(pl):    Dane dla zeroconf
160 Group:          X11/Applications/Multimedia
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       kdenetwork-kdnssd
163 Provides:       %{name}-plugin = %{version}-%{release}
164
165 %description zeroconf
166 Zeroconf data.
167
168 %description zeroconf -l pl
169 Dane dla zeroconf.
170
171 %package scripts
172 Summary:        amaroK scripts
173 Summary(pl):    Skrypty amaroKa
174 Group:          X11/Applications/Multimedia
175 Requires:       %{name} = %{version}-%{release}
176 Requires:       kdebase-kdialog
177 Requires:       python-PyQt
178
179 %description scripts
180 amaroK scripts allow you extend amaroK functionality.
181
182 You can learn more about scripts in amaroK from here:
183 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
184
185 %description scripts -l pl
186 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
187
188 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
189 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
190
191 %prep
192 %setup -q
193 %patch0 -p1
194 %{?with_altlyrics:%patch1 -p1}
195 %patch2 -p1
196 %patch3 -p1
197 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
198         amarok/src/amarok.desktop \
199
200 # see kde bug #110909
201 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
202
203 %build
204 cp -f /usr/share/automake/config.sub admin
205
206 #export UNSERMAKE=/usr/share/unsermake/unsermake
207
208 %{__make} -f admin/Makefile.common cvs
209
210 # hack: passing something other than "no" or "yes" to --with-helix allows
211 # us to pass HELIX_LIBS
212 %configure \
213         HELIX_LIBS=%{_libdir}/helixplayer \
214         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
215         --disable-rpath \
216         --with%{!?with_arts:out}-arts \
217         --with%{!?with_mas:out}-mas \
218         --with%{!?with_xine:out}-xine \
219         --with%{!?with_gstreamer:out}-gstreamer \
220         --with%{!?with_akode:out}-akode \
221         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
222         --with%{!?with_nmm:out}-nmm \
223         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
224         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
225         --disable-final \
226         --with-qt-libraries=%{_libdir} \
227         --with%{!?with_included_sqlite:out}-included-sqlite
228
229 %{__make}
230
231 %install
232 rm -rf $RPM_BUILD_ROOT
233
234 %{__make} install \
235         DESTDIR=$RPM_BUILD_ROOT \
236         kde_htmldir=%{_kdedocdir} \
237         kde_libs_htmldir=%{_kdedocdir}
238
239 # remove bogus dir
240 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
241
242 %find_lang amarok --all-name --with-kde
243
244 %clean
245 rm -rf $RPM_BUILD_ROOT
246
247 %post
248 if [ "$1" = 1 ]; then
249         echo "Remember to install libvisual-plugins-* packages if you"
250         echo "want to have a visualizations in amaroK."
251 fi
252
253 %files -f %{name}.lang
254 %defattr(644,root,root,755)
255 %doc AUTHORS ChangeLog README
256 %attr(755,root,root) %{_bindir}/amarok
257 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
258 %attr(755,root,root) %{_bindir}/amarokapp
259 %attr(755,root,root) %{_bindir}/amarok_libvisual
260 #%attr(755,root,root) %{_bindir}/release_amarok
261 %{_libdir}/kde3/konqsidebar_universalamarok.la
262 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
263 %{_libdir}/kde3/libamarok_void-engine_plugin.la
264 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
265 %dir %{_datadir}/apps/amarok
266 %dir %{_datadir}/apps/amarok/scripts
267 %{_datadir}/apps/amarok/*.rc
268 %{_datadir}/apps/amarok/data
269 %{_datadir}/apps/amarok/icons
270 %{_datadir}/apps/amarok/images
271 %{_datadir}/apps/amarok/themes
272 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
273 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
274 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
275 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
276 %{_datadir}/apps/profiles/amarok.profile.xml
277 %{_datadir}/config/amarokrc
278 %{_datadir}/config.kcfg/amarok.kcfg
279 %{_datadir}/services/amarok_void-engine_plugin.desktop
280 %{_datadir}/servicetypes/amarok_plugin.desktop
281 %{_desktopdir}/kde/amarok.desktop
282 %{_iconsdir}/*/*/apps/amarok.*
283
284 %if %{with arts}
285 %files arts
286 %defattr(644,root,root,755)
287 %{_libdir}/kde3/libamarok_artsengine_plugin.la
288 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
289 %{_libdir}/libamarokarts.la
290 %attr(755,root,root) %{_libdir}/libamarokarts.so
291 %{_libdir}/mcop/Amarok
292 %{_libdir}/mcop/amarokarts.mcopclass
293 %{_libdir}/mcop/amarokarts.mcoptype
294 %{_datadir}/services/amarok_artsengine_plugin.desktop
295 %endif
296
297 %if %{with akode}
298 %files akode
299 %defattr(644,root,root,755)
300 %{_libdir}/kde3/libamarok_aKode-engine.la
301 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
302 %{_datadir}/services/amarok_aKode-engine.desktop
303 %endif
304
305 %if %{with gstreamer}
306 %files gstreamer
307 %defattr(644,root,root,755)
308 %{_libdir}/kde3/libamarok_gstengine_plugin.la
309 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
310 %{_datadir}/config.kcfg/gstconfig.kcfg
311 %{_datadir}/services/amarok_gstengine_plugin.desktop
312 %endif
313
314 %if %{with helix}
315 %files helix
316 %defattr(644,root,root,755)
317 %{_libdir}/kde3/libamarok_helixengine_plugin.la
318 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
319 %{_datadir}/config.kcfg/helixconfig.kcfg
320 %{_datadir}/services/amarok_helixengine_plugin.desktop
321 %endif
322
323 %if %{with xine}
324 %files xine
325 %defattr(644,root,root,755)
326 %{_libdir}/kde3/libamarok_xine-engine.la
327 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
328 %{_datadir}/config.kcfg/xinecfg.kcfg
329 %{_datadir}/services/amarok_xine-engine.desktop
330 #%{_datadir}/services/amarok_xineengine_plugin.desktop
331 %endif
332
333 %if 0
334 %if %{with zeroconf}
335 %files zeroconf
336 %defattr(644,root,root,755)
337 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
338 %endif
339 %endif
340
341 %files scripts
342 %defattr(644,root,root,755)
343
344 %dir %{_datadir}/apps/amarok/scripts/alarm
345 %{_datadir}/apps/amarok/scripts/alarm/README
346 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
347
348 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
349 %{_datadir}/apps/amarok/scripts/graphequalizer/README
350 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
351
352 %dir %{_datadir}/apps/amarok/scripts/playlist2html
353 %{_datadir}/apps/amarok/scripts/playlist2html/README
354 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
355 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
356 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
357
358 %dir %{_datadir}/apps/amarok/scripts/templates
359 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
360 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
361 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
362
363 %dir %{_datadir}/apps/amarok/scripts/webcontrol
364 %{_datadir}/apps/amarok/scripts/webcontrol/README
365 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
366 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
367 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
368 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
369 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
370 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
371 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
372 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
373 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
374 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
375 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
376 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
377 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
378 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
379 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
380 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
381
382 %dir %{_datadir}/apps/amarok/scripts/common
383 %{_datadir}/apps/amarok/scripts/common/Publisher.py
384 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
385
386 #%dir %{_datadir}/apps/amarok/scripts/shouter
387 #%{_datadir}/apps/amarok/scripts/shouter/README
388 #%{_datadir}/apps/amarok/scripts/shouter/ChangeLog
389 #%{_datadir}/apps/amarok/scripts/shouter/Amarok.py
390 #%{_datadir}/apps/amarok/scripts/shouter/Globals.py
391 #%{_datadir}/apps/amarok/scripts/shouter/Playlist.py
392 #%{_datadir}/apps/amarok/scripts/shouter/Services.py
393 #%{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
394 #%{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
395 #%{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
396 #%{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
397 #%{_datadir}/apps/amarok/scripts/shouter/StreamController.py
398 #%{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
399 #%{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
400 #%{_datadir}/apps/amarok/scripts/shouter/debug.py
401 #%{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
402 #%dir %{_datadir}/apps/amarok/scripts/shouter/silence
403 #%{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
404 #%dir %{_datadir}/apps/amarok/scripts/shouter/test
405 #%{_datadir}/apps/amarok/scripts/shouter/test/client.py
406 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
407
408 %if 0
409 %dir %{_datadir}/apps/amarok/scripts/amarok_live
410 %{_datadir}/apps/amarok/scripts/amarok_live/README
411 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
412 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
413 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
414 %endif
This page took 0.069223 seconds and 4 git commands to generate.