]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- FUCK!. merge akode bcond from HEAD
[packages/amarok.git] / amarok.spec
1 #
2 # TODO:
3 #       * postgresql support alongside mysql
4 #       * NMM, MAS audio backend support
5 #       * make descriptions less useless
6 #       * HelixPlayer engine?
7 #
8 # Conditional builds:
9 %bcond_without  arts            # disable arts engine
10 %bcond_without  gstreamer       # disable gstreamer
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable suport for zeroconf
14 %bcond_with     mysql           # enable mysql support
15 %bcond_with     akode                   # enable aKode engine (too buggy/incomplete)
16 #
17 %define _beta   beta3
18 Summary:        A KDE audio player
19 Summary(pl):    Odtwarzacz audio dla KDE
20 Name:           amarok
21 Version:        1.3
22 Release:        0.%{_beta}.1
23 License:        GPL
24 Group:          X11/Applications/Multimedia
25 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}-%{_beta}.tar.bz2
26 # Source0-md5:  e6587bcdd3dc9a811d40d00b89e13ceb
27 Patch0:         kde-common-gcc4.patch
28 URL:            http://amarok.kde.org/
29 BuildRequires:  SDL-devel
30 BuildRequires:  alsa-lib-devel
31 BuildRequires:  arts-qt-devel
32 BuildRequires:  automake
33 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
34 BuildRequires:  kdebase-devel
35 %{?with_akode:BuildRequires:    kdemultimedia-akode}
36 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
37 BuildRequires:  libltdl-devel
38 BuildRequires:  libmusicbrainz-devel
39 BuildRequires:  libvisual-devel >= 0.2.0
40 BuildRequires:  pcre-devel
41 BuildRequires:  rpmbuild(macros) >= 1.129
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  sqlite3-devel
44 BuildRequires:  taglib-devel >= 1.4
45 #BuildRequires: unsermake >= 040511
46 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
47 %{?with_xmms:BuildRequires:             xmms-devel}
48 %{?with_mysql:BuildRequires:            mysql-devel}
49 #BuildRequires: kdebindings-kjsembed-devel
50 Requires:       %{name}-plugin = %{version}-%{release}
51 Requires:       kdebase-core >= 9:3.1.93
52 Requires:       kdemultimedia-audiocd >= 9:3.1.93
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 A KDE audio player.
57
58 %description -l pl
59 Odtwarzacz audio dla KDE.
60
61 %package arts
62 Summary:        Plugin arts
63 Summary(pl):    Wtyczka arts
64 Group:          X11/Applications/Multimedia
65 PreReq:         %{name} = %{version}-%{release}
66 Provides:       %{name}-plugin = %{version}-%{release}
67
68 %description arts
69 Plugin arts.
70
71 %description arts -l pl
72 Wtyczka arts.
73
74 %package akode
75 Summary:        Plugin akode
76 Summary(pl):    Wtyczka akode
77 Group:          X11/Applications/Multimedia
78 PreReq:         %{name} = %{version}-%{release}
79 Provides:       %{name}-plugin = %{version}-%{release}
80
81 %description akode
82 Plugin akode.
83
84 %description akode -l pl
85 Wtyczka akode.
86
87 %package gstreamer
88 Summary:        Plugin gstreamer
89 Summary(pl):    Wtyczka gstreamer
90 Group:          X11/Applications/Multimedia
91 PreReq:         %{name} = %{version}-%{release}
92 # needed libs
93 # at least /usr/lib/gstreamer-0.8/libgstresample.so
94 # probably /usr/lib/gstreamer-0.8/libgstadder.so
95 # and probably /usr/lib/gstreamer-0.8/libgstvolume.so
96 Requires:       gstreamer-audio-effects
97 Provides:       %{name}-plugin = %{version}-%{release}
98
99 %description gstreamer
100 Plugin gstreamer.
101
102 %description gstreamer -l pl
103 Wtyczka gstreamer.
104
105 %package xine
106 Summary:        Plugin xine
107 Summary(pl):    Wtyczka xine
108 Group:          X11/Applications/Multimedia
109 PreReq:         %{name} = %{version}-%{release}
110 Provides:       %{name}-plugin = %{version}-%{release}
111
112 %description xine
113 Plugin xine.
114
115 %description xine -l pl
116 Wtyczka xine.
117
118 %package zeroconf
119 Summary:        Zeroconf data
120 Summary(pl):    Dane dla zeroconf
121 Group:          X11/Applications/Multimedia
122 PreReq:         %{name} = %{version}-%{release}
123 Requires:       kdenetwork-kdnssd
124 Provides:       %{name}-plugin = %{version}-%{release}
125
126 %description zeroconf
127 Zeroconf data.
128
129 %description zeroconf -l pl
130 Zeroconf data.
131
132 %prep
133 %setup -q -n %{name}-%{version}-%{_beta}
134 %patch0 -p1
135 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
136         amarok/src/amarok.desktop \
137
138 %build
139 cp -f /usr/share/automake/config.sub admin
140
141 #export UNSERMAKE=/usr/share/unsermake/unsermake
142
143 %{__make} -f admin/Makefile.common cvs
144
145 %configure \
146         --disable-rpath \
147         %{!?with_arts:--without-arts} \
148         %{!?with_xine:--without-xine} \
149         %{!?with_gstreamer:--without-gstreamer} \
150         %{!?with_akode:--without-akode} \
151         %{?with_mysql:--with-mysql} \
152         --disable-final \
153         --with-qt-libraries=%{_libdir} \
154         --without-included-sqlite
155
156 %{__make}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT \
163         kde_htmldir=%{_kdedocdir} \
164         kde_libs_htmldir=%{_kdedocdir}
165
166 # remove bogus dir
167 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
168
169 %find_lang amarok --all-name --with-kde
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post
175 echo "Remember to install libvisual-plugins-* packages if you"
176 echo "want to have a visualizations in amarok."
177
178 %files -f %{name}.lang
179 %defattr(644,root,root,755)
180 %doc AUTHORS ChangeLog README TODO
181 %attr(755,root,root) %{_bindir}/amarok
182 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
183 %attr(755,root,root) %{_bindir}/amarokapp
184 %attr(755,root,root) %{_bindir}/amarok_libvisual
185 #%attr(755,root,root) %{_bindir}/release_amarok
186 %{_libdir}/kde3/konqsidebar_universalamarok.la
187 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
188 %{_libdir}/kde3/libamarok_void-engine_plugin.la
189 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
190 %{_datadir}/apps/amarok
191 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
192 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
193 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
194 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
195 %{_datadir}/apps/profiles/amarok.profile.xml
196 %{_datadir}/config/amarokrc
197 %{_datadir}/config.kcfg/amarok.kcfg
198 %{_datadir}/services/amarok_void-engine_plugin.desktop
199 %{_datadir}/servicetypes/amarok_plugin.desktop
200 %{_desktopdir}/kde/amarok.desktop
201 %{_iconsdir}/*/*/apps/amarok.*
202
203 %if %{with arts}
204 %files arts
205 %defattr(644,root,root,755)
206 %{_libdir}/kde3/libamarok_artsengine_plugin.la
207 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
208 %{_libdir}/libamarokarts.la
209 %attr(755,root,root) %{_libdir}/libamarokarts.so
210 %{_libdir}/mcop/Amarok
211 %{_libdir}/mcop/amarokarts.mcopclass
212 %{_libdir}/mcop/amarokarts.mcoptype
213 %{_datadir}/services/amarok_artsengine_plugin.desktop
214 %endif
215
216 %if %{with akode}
217 %files akode
218 %defattr(644,root,root,755)
219 %{_libdir}/kde3/libamarok_aKode-engine.la
220 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
221 %{_datadir}/services/amarok_aKode-engine.desktop
222 %endif
223
224 %if %{with gstreamer}
225 %files gstreamer
226 %defattr(644,root,root,755)
227 %{_libdir}/kde3/libamarok_gstengine_plugin.la
228 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
229 %{_datadir}/config.kcfg/gstconfig.kcfg
230 %{_datadir}/services/amarok_gstengine_plugin.desktop
231 %endif
232
233 %if %{with xine}
234 %files xine
235 %defattr(644,root,root,755)
236 %{_libdir}/kde3/libamarok_xine-engine.la
237 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
238 %{_datadir}/services/amarok_xine-engine.desktop
239 #%{_datadir}/services/amarok_xineengine_plugin.desktop
240 %endif
241
242 %if %{with zeroconf}
243 %files zeroconf
244 %defattr(644,root,root,755)
245 %{_datadir}/apps/zeroconf/_shoutcast._tcp
246 %endif
This page took 0.037245 seconds and 4 git commands to generate.