]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- add R: gstreamer-audio-effects on -gstreamer
[packages/amarok.git] / amarok.spec
1 #
2 # Conditional builds:
3 %bcond_without  arts            # disable arts engine
4 %bcond_without  gstreamer       # disable gstreamer
5 %bcond_without  xine            # disable xine engine
6 %bcond_without  xmms            # disable xmms wrapping
7 %bcond_with     mysql           # enable mysql support
8 #
9
10 Summary:        A KDE audio player
11 Summary(pl):    Odtwarzacz audio dla KDE
12 Name:           amarok
13 Version:        1.2.3
14 Release:        1
15 License:        GPL
16 Group:          X11/Applications/Multimedia
17 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
18 # Source0-md5:  0082f47cb4503afc7d8e671cfd5cb983
19 URL:            http://amarok.kde.org/
20 BuildRequires:  SDL-devel
21 BuildRequires:  alsa-lib-devel
22 BuildRequires:  arts-qt-devel
23 BuildRequires:  automake
24 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
25 BuildRequires:  kdebase-devel
26 BuildRequires:  kdemultimedia-akode
27 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
28 BuildRequires:  libmusicbrainz-devel
29 BuildRequires:  libvisual-devel >= 0.2.0
30 BuildRequires:  pcre-devel
31 BuildRequires:  rpmbuild(macros) >= 1.129
32 BuildRequires:  sed >= 4.0
33 BuildRequires:  sqlite3-devel
34 BuildRequires:  taglib-devel >= 1.3.1
35 #BuildRequires: unsermake >= 040511
36 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
37 %{?with_xmms:BuildRequires:             xmms-devel}
38 %{?with_mysql:BuildRequires:            mysql-devel}
39 #BuildRequires: kdebindings-kjsembed-devel
40 Requires:       %{name}-plugin = %{version}-%{release}
41 Requires:       kdebase-core >= 9:3.1.93
42 Requires:       kdemultimedia-audiocd >= 9:3.1.93
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 A KDE audio player.
47
48 %description -l pl
49 Odtwarzacz audio dla KDE.
50
51 %package arts
52 Summary:        Plugin arts
53 Summary(pl):    Wtyczka arts
54 Group:          X11/Applications/Multimedia
55 Requires:       %{name} = %{version}-%{release}
56 Provides:       %{name}-plugin = %{version}-%{release}
57
58 %description arts
59 Plugin arts.
60
61 %description arts -l pl
62 Wtyczka arts.
63
64 %package gstreamer
65 Summary:        Plugin gstreamer
66 Summary(pl):    Wtyczka gstreamer
67 Group:          X11/Applications/Multimedia
68 Requires:       gstreamer-audio-effects
69 Requires:       %{name} = %{version}-%{release}
70 Provides:       %{name}-plugin = %{version}-%{release}
71
72 %description gstreamer
73 Plugin gstreamer.
74
75 %description gstreamer -l pl
76 Wtyczka gstreamer.
77
78 %package xine
79 Summary:        Plugin xine
80 Summary(pl):    Wtyczka xine
81 Group:          X11/Applications/Multimedia
82 Requires:       %{name} = %{version}-%{release}
83 Provides:       %{name}-plugin = %{version}-%{release}
84
85 %description xine
86 Plugin xine.
87
88 %description xine -l pl
89 Wtyczka xine.
90
91 %prep
92 %setup -q
93
94 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
95         amarok/src/amarok.desktop \
96
97 %build
98 cp -f /usr/share/automake/config.sub admin
99
100 #export UNSERMAKE=/usr/share/unsermake/unsermake
101
102 %{__make} -f admin/Makefile.common cvs
103
104 %configure \
105         --disable-rpath \
106         %{!?with_arts:--without-arts} \
107         %{!?with_xine:--without-xine} \
108         %{!?with_gstreamer:--without-gstreamer} \
109         %{?with_mysql:--with-mysql} \
110         --disable-final \
111         --with-qt-libraries=%{_libdir} \
112         --without-included-sqlite
113
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT \
121         kde_htmldir=%{_kdedocdir} \
122         kde_libs_htmldir=%{_kdedocdir}
123
124 # remove bogus dir
125 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
126
127 %find_lang amarok --all-name --with-kde
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post
133 echo "Remember to install libvisual-plugins-* packages if you"
134 echo "want to have a visualizations in amarok."
135
136 %files -f %{name}.lang
137 %defattr(644,root,root,755)
138 %doc AUTHORS ChangeLog README TODO
139 %attr(755,root,root) %{_bindir}/amarok
140 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
141 %attr(755,root,root) %{_bindir}/amarokapp
142 %attr(755,root,root) %{_bindir}/amarok_libvisual
143 #%attr(755,root,root) %{_bindir}/release_amarok
144 %{_libdir}/kde3/konqsidebar_universalamarok.la
145 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
146 %{_libdir}/kde3/libamarok_void-engine_plugin.la
147 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
148 %{_datadir}/apps/amarok
149 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
150 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
151 %{_datadir}/apps/profiles/amarok.profile.xml
152 %{_datadir}/config/amarokrc
153 %{_datadir}/config.kcfg/amarok.kcfg
154 %{_datadir}/services/amarok_void-engine_plugin.desktop
155 %{_datadir}/servicetypes/amarok_plugin.desktop
156 %{_desktopdir}/kde/amarok.desktop
157 %{_iconsdir}/*/*/apps/amarok.*
158
159 %if %{with arts}
160 %files arts
161 %defattr(644,root,root,755)
162 %{_libdir}/kde3/libamarok_artsengine_plugin.la
163 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
164 %{_libdir}/libamarokarts.la
165 %attr(755,root,root) %{_libdir}/libamarokarts.so
166 %{_libdir}/mcop/Amarok
167 %{_libdir}/mcop/amarokarts.mcopclass
168 %{_libdir}/mcop/amarokarts.mcoptype
169 %{_datadir}/services/amarok_artsengine_plugin.desktop
170 %endif
171
172 %if %{with gstreamer}
173 %files gstreamer
174 %defattr(644,root,root,755)
175 %{_libdir}/kde3/libamarok_gstengine_plugin.la
176 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
177 %{_datadir}/config.kcfg/gstconfig.kcfg
178 %{_datadir}/services/amarok_gstengine_plugin.desktop
179 %endif
180
181 %if %{with xine}
182 %files xine
183 %defattr(644,root,root,755)
184 %{_libdir}/kde3/libamarok_xine-engine.la
185 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
186 %{_datadir}/services/amarok_xine-engine.desktop
187 #%{_datadir}/services/amarok_xineengine_plugin.desktop
188 %endif
This page took 0.046856 seconds and 4 git commands to generate.