]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- rel +0.1 for new bcond
[packages/amarok.git] / amarok.spec
1 # This file does not like to be adapterized!
2 # - or at least rpm is broken, as it doesn't build without rpm-pythonprov
3 #
4 # TODO:
5 #       * postgresql support alongside mysql
6 #       * NMM audio backend support (fix build - propably some BRs)
7 #       * make descriptions less useless
8 #       * HelixPlayer engine (fix build - propably some BRs)
9 #
10 # Conditional builds:
11 %bcond_without  arts            # disable arts engine
12 %bcond_without  gstreamer       # disable gstreamer
13 %bcond_without  mas             # disable MAS audio backend
14 %bcond_without  xine            # disable xine engine
15 %bcond_without  xmms            # disable xmms wrapping
16 %bcond_without  zeroconf        # disable support for zeroconf
17 %bcond_with     helix           # enable HelixPlayer engine
18 %bcond_with     nmm             # enable NMM audio backend
19 %bcond_with     mysql           # enable mysql support
20 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
21 %bcond_with     altlyrics       # use alternative lyrics provider
22 Summary:        A KDE audio player
23 Summary(pl):    Odtwarzacz audio dla KDE
24 Name:           amarok
25 Version:        1.3
26 Release:        1.4
27 License:        GPL
28 Group:          X11/Applications/Multimedia
29 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
30 # Source0-md5:  2dd100584795fb20c621fdbc96cbee1e
31 Patch0:         kde-common-gcc4.patch
32 Patch1:         http://websvn.kde.org/trunk/extragear/multimedia/amarok/src/playlistbrowseritem.h?rev=449581&r1=449054&r2=449581&makepatch=1&diff_format=u
33 Patch2:         %{name}-lyricsurl.patch
34 URL:            http://amarok.kde.org/
35 BuildRequires:  SDL-devel
36 BuildRequires:  alsa-lib-devel
37 BuildRequires:  arts-qt-devel
38 BuildRequires:  automake
39 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
40 BuildRequires:  kdebase-devel
41 %{?with_akode:BuildRequires:    kdemultimedia-akode}
42 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
43 BuildRequires:  libltdl-devel
44 BuildRequires:  libmusicbrainz-devel
45 BuildRequires:  libvisual-devel >= 0.2.0
46 BuildRequires:  pcre-devel
47 BuildRequires:  rpmbuild(macros) >= 1.129
48 BuildRequires:  rpm-pythonprov
49 BuildRequires:  sed >= 4.0
50 BuildRequires:  sqlite3-devel
51 BuildRequires:  taglib-devel >= 1.4
52 #BuildRequires: unsermake >= 040511
53 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
54 %{?with_xmms:BuildRequires:             xmms-devel}
55 %{?with_mysql:BuildRequires:            mysql-devel}
56 #BuildRequires: kdebindings-kjsembed-devel
57 Requires:       %{name}-plugin = %{version}-%{release}
58 Requires:       kdebase-core >= 9:3.1.93
59 Requires:       kdemultimedia-audiocd >= 9:3.1.93
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 A KDE audio player.
64
65 %description -l pl
66 Odtwarzacz audio dla KDE.
67
68 %package arts
69 Summary:        Plugin arts
70 Summary(pl):    Wtyczka arts
71 Group:          X11/Applications/Multimedia
72 Requires:       %{name} = %{version}-%{release}
73 Provides:       %{name}-plugin = %{version}-%{release}
74
75 %description arts
76 Plugin arts.
77
78 %description arts -l pl
79 Wtyczka arts.
80
81 %package akode
82 Summary:        Plugin akode
83 Summary(pl):    Wtyczka akode
84 Group:          X11/Applications/Multimedia
85 Requires:       %{name} = %{version}-%{release}
86 Provides:       %{name}-plugin = %{version}-%{release}
87
88 %description akode
89 Plugin akode.
90
91 %description akode -l pl
92 Wtyczka akode.
93
94 %package gstreamer
95 Summary:        Plugin gstreamer
96 Summary(pl):    Wtyczka gstreamer
97 Group:          X11/Applications/Multimedia
98 # deps, to get it working:
99 # mp3 decoder: gstreamer-mad
100 # ogg decoder: gstreamer-vorbis
101 # audio output driver: gstreamer-audiosink-alsa
102 # from gstreamer-audio-effects to control volume, etc
103 # needed libs:
104 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
105 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
106 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
107 # gstreamer-musicbrainz for being able to edit id3 tags on files.
108 Requires:       gstreamer-audio-effects
109 Requires:       gstreamer-audiosink
110 Requires:       gstreamer-mad
111 Requires:       gstreamer-vorbis
112 Requires:       gstreamer-musicbrainz
113 Requires:       %{name} = %{version}-%{release}
114 Provides:       %{name}-plugin = %{version}-%{release}
115
116 %description gstreamer
117 Plugin gstreamer.
118
119 %description gstreamer -l pl
120 Wtyczka gstreamer.
121
122 %package xine
123 Summary:        Plugin xine
124 Summary(pl):    Wtyczka xine
125 Group:          X11/Applications/Multimedia
126 Requires:       %{name} = %{version}-%{release}
127 Requires:       xine-plugin-audio
128 Provides:       %{name}-plugin = %{version}-%{release}
129
130 %description xine
131 Plugin xine.
132
133 %description xine -l pl
134 Wtyczka xine.
135
136 %package zeroconf
137 Summary:        Zeroconf data
138 Summary(pl):    Dane dla zeroconf
139 Group:          X11/Applications/Multimedia
140 Requires:       %{name} = %{version}-%{release}
141 Requires:       kdenetwork-kdnssd
142 Provides:       %{name}-plugin = %{version}-%{release}
143
144 %description zeroconf
145 Zeroconf data.
146
147 %description zeroconf -l pl
148 Dane dla zeroconf.
149
150 %package scripts
151 Summary:        amaroK scripts
152 Group:          X11/Applications/Multimedia
153 Requires:       %{name} = %{version}-%{release}
154 Requires:       kdebase-kdialog
155 Requires:       python-PyQt
156
157 %description scripts
158 amaroK scripts allow you extend amaroK functionality.
159
160 You can learn more about scripts in amaroK from here:
161 <http://amarok.kde.org/wiki/index.php/Scripts>.
162
163 %prep
164 %setup -q
165 %patch0 -p1
166 %patch1 -p3
167 %{?with_altlyrics:%patch2 -p1}
168 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
169         amarok/src/amarok.desktop \
170
171 %build
172 cp -f /usr/share/automake/config.sub admin
173
174 #export UNSERMAKE=/usr/share/unsermake/unsermake
175
176 %{__make} -f admin/Makefile.common cvs
177
178 %configure \
179         --disable-rpath \
180         %{!?with_arts:--without-arts} \
181         %{?with_mas:--with-mas} \
182         %{!?with_xine:--without-xine} \
183         %{!?with_gstreamer:--without-gstreamer} \
184         %{!?with_akode:--without-akode} \
185         %{?with_helix:--with-helix} \
186         %{?with_nmm:--with-nmm} \
187         %{?with_mysql:--with-mysql} \
188         --disable-final \
189         --with-qt-libraries=%{_libdir} \
190         --without-included-sqlite
191
192 %{__make}
193
194 %install
195 rm -rf $RPM_BUILD_ROOT
196
197 %{__make} install \
198         DESTDIR=$RPM_BUILD_ROOT \
199         kde_htmldir=%{_kdedocdir} \
200         kde_libs_htmldir=%{_kdedocdir}
201
202 # remove bogus dir
203 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
204
205 %find_lang amarok --all-name --with-kde
206
207 %clean
208 rm -rf $RPM_BUILD_ROOT
209
210 %post
211 if [ "$1" = 1 ]; then
212         echo "Remember to install libvisual-plugins-* packages if you"
213         echo "want to have a visualizations in amaroK."
214 fi
215
216 %files -f %{name}.lang
217 %defattr(644,root,root,755)
218 %doc AUTHORS ChangeLog README TODO
219 %attr(755,root,root) %{_bindir}/amarok
220 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
221 %attr(755,root,root) %{_bindir}/amarokapp
222 %attr(755,root,root) %{_bindir}/amarok_libvisual
223 #%attr(755,root,root) %{_bindir}/release_amarok
224 %{_libdir}/kde3/konqsidebar_universalamarok.la
225 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
226 %{_libdir}/kde3/libamarok_void-engine_plugin.la
227 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
228 %dir %{_datadir}/apps/amarok
229 %dir %{_datadir}/apps/amarok/scripts
230 %{_datadir}/apps/amarok/*.rc
231 %{_datadir}/apps/amarok/data
232 %{_datadir}/apps/amarok/icons
233 %{_datadir}/apps/amarok/images
234 %{_datadir}/apps/amarok/themes
235 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
236 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
237 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
238 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
239 %{_datadir}/apps/profiles/amarok.profile.xml
240 %{_datadir}/config/amarokrc
241 %{_datadir}/config.kcfg/amarok.kcfg
242 %{_datadir}/services/amarok_void-engine_plugin.desktop
243 %{_datadir}/servicetypes/amarok_plugin.desktop
244 %{_desktopdir}/kde/amarok.desktop
245 %{_iconsdir}/*/*/apps/amarok.*
246
247 %if %{with arts}
248 %files arts
249 %defattr(644,root,root,755)
250 %{_libdir}/kde3/libamarok_artsengine_plugin.la
251 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
252 %{_libdir}/libamarokarts.la
253 %attr(755,root,root) %{_libdir}/libamarokarts.so
254 %{_libdir}/mcop/Amarok
255 %{_libdir}/mcop/amarokarts.mcopclass
256 %{_libdir}/mcop/amarokarts.mcoptype
257 %{_datadir}/services/amarok_artsengine_plugin.desktop
258 %endif
259
260 %if %{with akode}
261 %files akode
262 %defattr(644,root,root,755)
263 %{_libdir}/kde3/libamarok_aKode-engine.la
264 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
265 %{_datadir}/services/amarok_aKode-engine.desktop
266 %endif
267
268 %if %{with gstreamer}
269 %files gstreamer
270 %defattr(644,root,root,755)
271 %{_libdir}/kde3/libamarok_gstengine_plugin.la
272 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
273 %{_datadir}/config.kcfg/gstconfig.kcfg
274 %{_datadir}/services/amarok_gstengine_plugin.desktop
275 %endif
276
277 %if %{with xine}
278 %files xine
279 %defattr(644,root,root,755)
280 %{_libdir}/kde3/libamarok_xine-engine.la
281 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
282 %{_datadir}/config.kcfg/xinecfg.kcfg
283 %{_datadir}/services/amarok_xine-engine.desktop
284 #%{_datadir}/services/amarok_xineengine_plugin.desktop
285 %endif
286
287 %if %{with zeroconf}
288 %files zeroconf
289 %defattr(644,root,root,755)
290 %{_datadir}/apps/zeroconf/_shoutcast._tcp
291 %endif
292
293 %files scripts
294 %defattr(644,root,root,755)
295
296 %dir %{_datadir}/apps/amarok/scripts/alarm
297 %{_datadir}/apps/amarok/scripts/alarm/README
298 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
299
300 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
301 %{_datadir}/apps/amarok/scripts/graphequalizer/README
302 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
303
304 %dir %{_datadir}/apps/amarok/scripts/playlist2html
305 %{_datadir}/apps/amarok/scripts/playlist2html/README
306 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
307 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
308 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
309
310 %dir %{_datadir}/apps/amarok/scripts/templates
311 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
312 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
313 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
314
315 %dir %{_datadir}/apps/amarok/scripts/webcontrol
316 %{_datadir}/apps/amarok/scripts/webcontrol/README
317 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
318 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
319 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
320 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
321 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
322 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
323 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
324 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
325 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
326 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
327 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
328 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
329 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
330 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
331 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
332 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
333
334 %dir %{_datadir}/apps/amarok/scripts/common
335 %{_datadir}/apps/amarok/scripts/common/Publisher.py
336 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
337
338 %dir %{_datadir}/apps/amarok/scripts/shouter
339 %{_datadir}/apps/amarok/scripts/shouter/README
340 %{_datadir}/apps/amarok/scripts/shouter/ChangeLog
341 %{_datadir}/apps/amarok/scripts/shouter/Amarok.py
342 %{_datadir}/apps/amarok/scripts/shouter/Globals.py
343 %{_datadir}/apps/amarok/scripts/shouter/Playlist.py
344 %{_datadir}/apps/amarok/scripts/shouter/Services.py
345 %{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
346 %{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
347 %{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
348 %{_datadir}/apps/amarok/scripts/shouter/StreamController.py
349 %{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
350 %{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
351 %{_datadir}/apps/amarok/scripts/shouter/debug.py
352 %{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
353 %dir %{_datadir}/apps/amarok/scripts/shouter/silence
354 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-128.mp3
355 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-160.mp3
356 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-192.mp3
357 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-224.mp3
358 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-256.mp3
359 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-320.mp3
360 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
361 %dir %{_datadir}/apps/amarok/scripts/shouter/test
362 %{_datadir}/apps/amarok/scripts/shouter/test/client.py
363 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
364
365 %dir %{_datadir}/apps/amarok/scripts/amarok_live
366 %{_datadir}/apps/amarok/scripts/amarok_live/README
367 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
368 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
369 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
This page took 0.054872 seconds and 4 git commands to generate.