]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- simplified prep, sorted BRs
[packages/amarok.git] / amarok.spec
1 #
2 # Conditional builds:
3 %bcond_without  arts            # disable arts engine
4 %bcond_without  gstreamer       # disable gstreamer
5 %bcond_without  xine            # disable xine engine
6 %bcond_without  xmms            # disable xmms wrapping
7 #
8 Summary:        A KDE audio player
9 Summary(pl):    Odtwarzacz audio dla KDE
10 Name:           amarok
11 Version:        1.1.1
12 Release:        2
13 License:        GPL
14 Group:          X11/Applications/Multimedia
15 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
16 # Source0-md5:  6c0cccd4c8b508a2e0c9b0f187a907cf
17 Patch0:         %{name}-sqlite3.patch
18 URL:            http://amarok.kde.org/
19 Buildrequires:  alsa-lib-devel
20 Buildrequires:  arts-qt-devel
21 Buildrequires:  automake
22 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.8.1}
23 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
24 Buildrequires:  libmusicbrainz-devel
25 Buildrequires:  libvisual-devel >= 0.1.6-1
26 Buildrequires:  pcre-devel
27 BuildRequires:  rpmbuild(macros) >= 1.129
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  sqlite3-devel
30 BuildRequires:  taglib-devel >= 1.3
31 BuildRequires:  unsermake >= 040511
32 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.0-0.rc5.0}
33 %{?with_xmms:Buildrequires:     xmms-devel}
34 #BuildRequires: kdebindings-kjsembed-devel 
35 Requires:       %{name}-plugin = %{version}-%{release}
36 Requires:       kdebase-core >= 9:3.1.93
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 A KDE audio player.
41
42 %description -l pl
43 Odtwarzacz audio dla KDE.
44
45 %package arts
46 Summary:        Plugin arts
47 Summary(pl):    Wtyczka arts
48 Group:          X11/Applications/Multimedia
49 Requires:       %{name} = %{version}-%{release}
50 Provides:       %{name}-plugin = %{version}-%{release}
51
52 %description arts
53 Plugin arts.
54
55 %description arts -l pl
56 Wtyczka arts.
57
58 %package gstreamer
59 Summary:        Plugin gstreamer
60 Summary(pl):    Wtyczka gstreamer
61 Group:          X11/Applications/Multimedia
62 Requires:       %{name} = %{version}-%{release}
63 Provides:       %{name}-plugin = %{version}-%{release}
64
65 %description gstreamer
66 Plugin gstreamer.
67
68 %description gstreamer -l pl
69 Wtyczka gstreamer.
70
71 %package xine
72 Summary:        Plugin xine
73 Summary(pl):    Wtyczka xine
74 Group:          X11/Applications/Multimedia
75 Requires:       %{name} = %{version}-%{release}
76 Provides:       %{name}-plugin = %{version}-%{release}
77
78 %description xine
79 Plugin xine.
80
81 %description xine -l pl
82 Wtyczka xine.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87
88 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
89         amarok/src/amarok.desktop \
90
91 %build
92 cp -f %{_datadir}/automake/config.sub admin
93
94 export UNSERMAKE=%{_datadir}/unsermake/unsermake
95
96 %{__make} -f admin/Makefile.common cvs
97
98 %configure \
99         --disable-rpath \
100         %{!?with_arts:--without-arts} \
101         %{!?with_xine:--without-xine} \
102         %{!?with_gstreamer:--without-gstreamer} \
103         --with-qt-libraries=%{_libdir} \
104         --without-included-sqlite
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT \
113         kde_htmldir=%{_kdedocdir} \
114         kde_libs_htmldir=%{_kdedocdir}
115
116 %find_lang amarok --all-name --with-kde
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files -f %{name}.lang
122 %defattr(644,root,root,755)
123 %doc AUTHORS ChangeLog README TODO
124 %attr(755,root,root) %{_bindir}/amarok
125 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
126 %attr(755,root,root) %{_bindir}/amarokapp
127 %attr(755,root,root) %{_bindir}/amarok_libvisual
128 %attr(755,root,root) %{_bindir}/release_amarok
129 %{_libdir}/kde3/libamarok_void-engine_plugin.la
130 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
131 %{_datadir}/apps/amarok
132 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
133 %{_datadir}/config.kcfg/amarok.kcfg
134 %{_datadir}/services/amarok_void-engine_plugin.desktop
135 %{_datadir}/servicetypes/amarok_plugin.desktop
136 %{_desktopdir}/kde/amarok.desktop
137 %{_iconsdir}/*/*/apps/amarok.png
138 %{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
139 %{_datadir}/config/*
140
141 %if %{with arts}
142 %files arts
143 %defattr(644,root,root,755)
144 %{_libdir}/kde3/libamarok_artsengine_plugin.la
145 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
146 %{_libdir}/libamarokarts.la
147 %attr(755,root,root) %{_libdir}/libamarokarts.so
148 %{_libdir}/mcop/Amarok
149 %{_libdir}/mcop/amarokarts.mcopclass
150 %{_libdir}/mcop/amarokarts.mcoptype
151 %{_datadir}/services/amarok_artsengine_plugin.desktop
152 %endif
153
154 %if %{with gstreamer}
155 %files gstreamer
156 %defattr(644,root,root,755)
157 %{_libdir}/kde3/libamarok_gstengine_plugin.la
158 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
159 %{_datadir}/config.kcfg/gstconfig.kcfg
160 %{_datadir}/services/amarok_gstengine_plugin.desktop
161 %endif
162
163 %if %{with xine}
164 %files xine
165 %defattr(644,root,root,755)
166 %{_libdir}/kde3/libamarok_xine-engine.la
167 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
168 %{_datadir}/services/amarok_xine-engine.desktop
169 %{_datadir}/services/amarok_xineengine_plugin.desktop
170 %endif
This page took 0.078326 seconds and 4 git commands to generate.