]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- lang files back (why these were disabled?)
[packages/amarok.git] / amarok.spec
1 #
2 # TODO:
3 #       * postgresql support alongside mysql
4 #       * NMM, MAS audio backend support
5 #       * make descriptions less useless
6 #       * HelixPlayer engine?
7 #
8 # Conditional builds:
9 %bcond_without  arts            # disable arts engine
10 %bcond_without  gstreamer       # disable gstreamer
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disbale suport for zeroconf
14 %bcond_with     mysql           # enable mysql support
15 #
16 %define _beta   beta2
17 Summary:        A KDE audio player
18 Summary(pl):    Odtwarzacz audio dla KDE
19 Name:           amarok
20 Version:        1.3
21 Release:        0.%{_beta}.4
22 License:        GPL
23 Group:          X11/Applications/Multimedia
24 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}-%{_beta}.tar.bz2
25 # Source0-md5:  ca7b22074dab6107c61b3b92dadbe26e
26 Patch0:         kde-common-gcc4.patch
27 URL:            http://amarok.kde.org/
28 BuildRequires:  SDL-devel
29 BuildRequires:  alsa-lib-devel
30 BuildRequires:  arts-qt-devel
31 BuildRequires:  automake
32 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
33 BuildRequires:  kdebase-devel
34 BuildRequires:  kdemultimedia-akode
35 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
36 BuildRequires:  libltdl-devel
37 BuildRequires:  libmusicbrainz-devel
38 BuildRequires:  libvisual-devel >= 0.2.0
39 BuildRequires:  pcre-devel
40 BuildRequires:  rpmbuild(macros) >= 1.129
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  sqlite3-devel
44 BuildRequires:  taglib-devel >= 1.3.1
45 #BuildRequires: unsermake >= 040511
46 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
47 %{?with_xmms:BuildRequires:             xmms-devel}
48 %{?with_mysql:BuildRequires:            mysql-devel}
49 #BuildRequires: kdebindings-kjsembed-devel
50 Requires:       %{name}-plugin = %{version}-%{release}
51 Requires:       kdebase-core >= 9:3.1.93
52 Requires:       kdemultimedia-audiocd >= 9:3.1.93
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 A KDE audio player.
57
58 %description -l pl
59 Odtwarzacz audio dla KDE.
60
61 %package arts
62 Summary:        Plugin arts
63 Summary(pl):    Wtyczka arts
64 Group:          X11/Applications/Multimedia
65 PreReq:         %{name} = %{version}-%{release}
66 Provides:       %{name}-plugin = %{version}-%{release}
67
68 %description arts
69 Plugin arts.
70
71 %description arts -l pl
72 Wtyczka arts.
73
74
75 %package akode
76 Summary:        Plugin akode
77 Summary(pl):    Wtyczka akode
78 Group:          X11/Applications/Multimedia
79 PreReq:         %{name} = %{version}-%{release}
80 Provides:       %{name}-plugin = %{version}-%{release}
81
82 %description akode
83 Plugin akode.
84
85 %description akode -l pl
86 Wtyczka akode.
87
88
89 %package gstreamer
90 Summary:        Plugin gstreamer
91 Summary(pl):    Wtyczka gstreamer
92 Group:          X11/Applications/Multimedia
93 PreReq:         %{name} = %{version}-%{release}
94 # needed libs
95 # at least /usr/lib/gstreamer-0.8/libgstresample.so
96 # probably /usr/lib/gstreamer-0.8/libgstadder.so
97 # and probably /usr/lib/gstreamer-0.8/libgstvolume.so
98 Requires:       gstreamer-audio-effects
99 Provides:       %{name}-plugin = %{version}-%{release}
100
101 %description gstreamer
102 Plugin gstreamer.
103
104 %description gstreamer -l pl
105 Wtyczka gstreamer.
106
107 %package xine
108 Summary:        Plugin xine
109 Summary(pl):    Wtyczka xine
110 Group:          X11/Applications/Multimedia
111 PreReq:         %{name} = %{version}-%{release}
112 Provides:       %{name}-plugin = %{version}-%{release}
113
114 %description xine
115 Plugin xine.
116
117 %description xine -l pl
118 Wtyczka xine.
119
120 %package zeroconf
121 Summary:        Zeroconf data
122 Summary(pl):    Dane dla zeroconf
123 Group:          X11/Applications/Multimedia
124 PreReq:         %{name} = %{version}-%{release}
125 Requires:       kdenetwork-kdnssd
126 Provides:       %{name}-plugin = %{version}-%{release}
127
128 %description zeroconf
129 Zeroconf data.
130
131 %description zeroconf -l pl
132 Zeroconf data.
133
134
135 %prep
136 %setup -q -n %{name}-%{version}-%{_beta}
137 %patch0 -p1
138 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
139         amarok/src/amarok.desktop \
140
141 %build
142 cp -f /usr/share/automake/config.sub admin
143
144 #export UNSERMAKE=/usr/share/unsermake/unsermake
145
146 %{__make} -f admin/Makefile.common cvs
147
148 %configure \
149         --disable-rpath \
150         %{!?with_arts:--without-arts} \
151         %{!?with_xine:--without-xine} \
152         %{!?with_gstreamer:--without-gstreamer} \
153         %{?with_mysql:--with-mysql} \
154         --disable-final \
155         --with-qt-libraries=%{_libdir} \
156         --without-included-sqlite
157
158 %{__make}
159
160 %install
161 rm -rf $RPM_BUILD_ROOT
162
163 %{__make} install \
164         DESTDIR=$RPM_BUILD_ROOT \
165         kde_htmldir=%{_kdedocdir} \
166         kde_libs_htmldir=%{_kdedocdir}
167
168 # remove bogus dir
169 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
170
171 %find_lang amarok --all-name --with-kde
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post
177 echo "Remember to install libvisual-plugins-* packages if you"
178 echo "want to have a visualizations in amarok."
179
180 %files -f %{name}.lang
181 %defattr(644,root,root,755)
182 %doc AUTHORS ChangeLog README TODO
183 %attr(755,root,root) %{_bindir}/amarok
184 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
185 %attr(755,root,root) %{_bindir}/amarokapp
186 %attr(755,root,root) %{_bindir}/amarok_libvisual
187 #%attr(755,root,root) %{_bindir}/release_amarok
188 %{_libdir}/kde3/konqsidebar_universalamarok.la
189 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
190 %{_libdir}/kde3/libamarok_void-engine_plugin.la
191 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
192 %{_datadir}/apps/amarok
193 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
194 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
195 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
196 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
197 %{_datadir}/apps/profiles/amarok.profile.xml
198 %{_datadir}/config/amarokrc
199 %{_datadir}/config.kcfg/amarok.kcfg
200 %{_datadir}/services/amarok_void-engine_plugin.desktop
201 %{_datadir}/servicetypes/amarok_plugin.desktop
202 %{_desktopdir}/kde/amarok.desktop
203 %{_iconsdir}/*/*/apps/amarok.*
204
205 %if %{with arts}
206 %files arts
207 %defattr(644,root,root,755)
208 %{_libdir}/kde3/libamarok_artsengine_plugin.la
209 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
210 %{_libdir}/libamarokarts.la
211 %attr(755,root,root) %{_libdir}/libamarokarts.so
212 %{_libdir}/mcop/Amarok
213 %{_libdir}/mcop/amarokarts.mcopclass
214 %{_libdir}/mcop/amarokarts.mcoptype
215 %{_datadir}/services/amarok_artsengine_plugin.desktop
216 %endif
217
218 %files akode
219 %defattr(644,root,root,755)
220 %{_libdir}/kde3/libamarok_aKode-engine.la
221 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
222 %{_datadir}/services/amarok_aKode-engine.desktop
223
224 %if %{with gstreamer}
225 %files gstreamer
226 %defattr(644,root,root,755)
227 %{_libdir}/kde3/libamarok_gstengine_plugin.la
228 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
229 %{_datadir}/config.kcfg/gstconfig.kcfg
230 %{_datadir}/services/amarok_gstengine_plugin.desktop
231 %endif
232
233 %if %{with xine}
234 %files xine
235 %defattr(644,root,root,755)
236 %{_libdir}/kde3/libamarok_xine-engine.la
237 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
238 %{_datadir}/services/amarok_xine-engine.desktop
239 #%{_datadir}/services/amarok_xineengine_plugin.desktop
240 %endif
241
242 %if %{with zeroconf}
243 %files zeroconf
244 %defattr(644,root,root,755)
245 %{_datadir}/apps/zeroconf/_shoutcast._tcp
246 %endif
This page took 0.044839 seconds and 4 git commands to generate.