]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- disable system sqlite by default as
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_without  arts            # disable arts engine
9 %bcond_without  gstreamer       # disable gstreamer
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
15 %bcond_with     helix           # enable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     pgsql           # enables postgresql support
19 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
20 %bcond_with     altlyrics       # use alternative lyrics provider
21 Summary:        A KDE audio player
22 Summary(pl):    Odtwarzacz audio dla KDE
23 Name:           amarok
24 Version:        1.3.3
25 Release:        2.1
26 License:        GPL
27 Group:          X11/Applications/Multimedia
28 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
29 # Source0-md5:  13f02c3cce06d9c1d0511171d736efa3
30 Patch0:         kde-common-gcc4.patch
31 Patch1:         %{name}-lyricsurl.patch
32 URL:            http://amarok.kde.org/
33 #BuildRequires: kdebindings-kjsembed-devel
34 #BuildRequires: unsermake >= 040511
35 BuildRequires:  SDL-devel
36 BuildRequires:  alsa-lib-devel
37 BuildRequires:  arts-qt-devel
38 BuildRequires:  autoconf
39 BuildRequires:  automake
40 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.6}
41 BuildRequires:  kdebase-devel
42 %{?with_akode:BuildRequires:    kdemultimedia-akode}
43 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
44 BuildRequires:  libltdl-devel
45 BuildRequires:  libmusicbrainz-devel
46 BuildRequires:  libvisual-devel >= 0.2.0
47 %{?with_mysql:BuildRequires:            mysql-devel}
48 %{?with_pgsql:BuildRequires:            libpqxx-devel}
49 BuildRequires:  pcre-devel
50 BuildRequires:  rpm-pythonprov
51 BuildRequires:  rpmbuild(macros) >= 1.129
52 BuildRequires:  sed >= 4.0
53 %{?with_helix:BuildRequires:helix-core}
54 %{?!with_included_sqlite:BuildRequires: sqlite3-devel}
55 BuildRequires:  taglib-devel >= 1.4
56 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
57 %{?with_xmms:BuildRequires:             xmms-devel}
58 Requires:       %{name}-plugin = %{version}-%{release}
59 Requires:       kdebase-core >= 9:3.1.93
60 Requires:       kdemultimedia-audiocd >= 9:3.1.93
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 A KDE audio player.
65
66 %description -l pl
67 Odtwarzacz audio dla KDE.
68
69 %package arts
70 Summary:        Plugin arts
71 Summary(pl):    Wtyczka arts
72 Group:          X11/Applications/Multimedia
73 Requires:       %{name} = %{version}-%{release}
74 Provides:       %{name}-plugin = %{version}-%{release}
75
76 %description arts
77 Plugin arts.
78
79 %description arts -l pl
80 Wtyczka arts.
81
82 %package akode
83 Summary:        Plugin akode
84 Summary(pl):    Wtyczka akode
85 Group:          X11/Applications/Multimedia
86 Requires:       %{name} = %{version}-%{release}
87 Provides:       %{name}-plugin = %{version}-%{release}
88
89 %description akode
90 Plugin akode.
91
92 %description akode -l pl
93 Wtyczka akode.
94
95 %package gstreamer
96 Summary:        Plugin gstreamer
97 Summary(pl):    Wtyczka gstreamer
98 Group:          X11/Applications/Multimedia
99 # deps, to get it working:
100 # mp3 decoder: gstreamer-mad
101 # ogg decoder: gstreamer-vorbis
102 # audio output driver: gstreamer-audiosink-alsa
103 # from gstreamer-audio-effects to control volume, etc
104 # needed libs:
105 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
106 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
107 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
108 # gstreamer-musicbrainz for being able to edit id3 tags on files.
109 Requires:       %{name} = %{version}-%{release}
110 Requires:       gstreamer-audio-effects
111 Requires:       gstreamer-audiosink
112 Requires:       gstreamer-mad
113 Requires:       gstreamer-musicbrainz
114 Requires:       gstreamer-vorbis
115 Provides:       %{name}-plugin = %{version}-%{release}
116
117 %description gstreamer
118 Plugin gstreamer.
119
120 %description gstreamer -l pl
121 Wtyczka gstreamer.
122
123 %package xine
124 Summary:        Plugin xine
125 Summary(pl):    Wtyczka xine
126 Group:          X11/Applications/Multimedia
127 Requires:       %{name} = %{version}-%{release}
128 Requires:       xine-plugin-audio
129 Provides:       %{name}-plugin = %{version}-%{release}
130
131 %description xine
132 Plugin xine.
133
134 %description xine -l pl
135 Wtyczka xine.
136
137 %package zeroconf
138 Summary:        Zeroconf data
139 Summary(pl):    Dane dla zeroconf
140 Group:          X11/Applications/Multimedia
141 Requires:       %{name} = %{version}-%{release}
142 Requires:       kdenetwork-kdnssd
143 Provides:       %{name}-plugin = %{version}-%{release}
144
145 %description zeroconf
146 Zeroconf data.
147
148 %description zeroconf -l pl
149 Dane dla zeroconf.
150
151 %package scripts
152 Summary:        amaroK scripts
153 Summary(pl):    Skrypty amaroKa
154 Group:          X11/Applications/Multimedia
155 Requires:       %{name} = %{version}-%{release}
156 Requires:       kdebase-kdialog
157 Requires:       python-PyQt
158
159 %description scripts
160 amaroK scripts allow you extend amaroK functionality.
161
162 You can learn more about scripts in amaroK from here:
163 <http://amarok.kde.org/wiki/index.php/Scripts>.
164
165 %description scripts -l pl
166 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
167
168 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
169 <http://amarok.kde.org/wiki/index.php/Scripts>.
170
171 %prep
172 %setup -q
173 %patch0 -p1
174 %{?with_altlyrics:%patch1 -p1}
175 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
176         amarok/src/amarok.desktop \
177
178 # see kde bug #110909
179 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
180
181 %build
182 %{__aclocal}
183 %{__autoconf}
184 %{__autoheader}
185 %{__automake}
186
187 cp -f /usr/share/automake/config.sub admin
188
189 #export UNSERMAKE=/usr/share/unsermake/unsermake
190
191 %{__make} -f admin/Makefile.common cvs
192
193 %configure \
194         --disable-rpath \
195         --with%{!?with_arts:out}-arts \
196         --with%{!?with_mas:out}-mas \
197         --with%{!?with_xine:out}-xine \
198         --with%{!?with_gstreamer:out}-gstreamer \
199         --with%{!?with_akode:out}-akode \
200         --with%{!?with_helix:out}-helix \
201         --with%{!?with_nmm:out}-nmm \
202         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
203         --%{?with_mysql:en}%{!?with_mysql:dis}nable-postgresql \
204         --disable-final \
205         --with-qt-libraries=%{_libdir} \
206         --with%{!?with_included_sqlite:out}-included-sqlite
207
208 %{__make}
209
210 %install
211 rm -rf $RPM_BUILD_ROOT
212
213 %{__make} install \
214         DESTDIR=$RPM_BUILD_ROOT \
215         kde_htmldir=%{_kdedocdir} \
216         kde_libs_htmldir=%{_kdedocdir}
217
218 # remove bogus dir
219 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
220
221 %find_lang amarok --all-name --with-kde
222
223 %clean
224 rm -rf $RPM_BUILD_ROOT
225
226 %post
227 if [ "$1" = 1 ]; then
228         echo "Remember to install libvisual-plugins-* packages if you"
229         echo "want to have a visualizations in amaroK."
230 fi
231
232 %files -f %{name}.lang
233 %defattr(644,root,root,755)
234 %doc AUTHORS ChangeLog README TODO
235 %attr(755,root,root) %{_bindir}/amarok
236 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
237 %attr(755,root,root) %{_bindir}/amarokapp
238 %attr(755,root,root) %{_bindir}/amarok_libvisual
239 #%attr(755,root,root) %{_bindir}/release_amarok
240 %{_libdir}/kde3/konqsidebar_universalamarok.la
241 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
242 %{_libdir}/kde3/libamarok_void-engine_plugin.la
243 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
244 %dir %{_datadir}/apps/amarok
245 %dir %{_datadir}/apps/amarok/scripts
246 %{_datadir}/apps/amarok/*.rc
247 %{_datadir}/apps/amarok/data
248 %{_datadir}/apps/amarok/icons
249 %{_datadir}/apps/amarok/images
250 %{_datadir}/apps/amarok/themes
251 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
252 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
253 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
254 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
255 %{_datadir}/apps/profiles/amarok.profile.xml
256 %{_datadir}/config/amarokrc
257 %{_datadir}/config.kcfg/amarok.kcfg
258 %{_datadir}/services/amarok_void-engine_plugin.desktop
259 %{_datadir}/servicetypes/amarok_plugin.desktop
260 %{_desktopdir}/kde/amarok.desktop
261 %{_iconsdir}/*/*/apps/amarok.*
262
263 %if %{with arts}
264 %files arts
265 %defattr(644,root,root,755)
266 %{_libdir}/kde3/libamarok_artsengine_plugin.la
267 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
268 %{_libdir}/libamarokarts.la
269 %attr(755,root,root) %{_libdir}/libamarokarts.so
270 %{_libdir}/mcop/Amarok
271 %{_libdir}/mcop/amarokarts.mcopclass
272 %{_libdir}/mcop/amarokarts.mcoptype
273 %{_datadir}/services/amarok_artsengine_plugin.desktop
274 %endif
275
276 %if %{with akode}
277 %files akode
278 %defattr(644,root,root,755)
279 %{_libdir}/kde3/libamarok_aKode-engine.la
280 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
281 %{_datadir}/services/amarok_aKode-engine.desktop
282 %endif
283
284 %if %{with gstreamer}
285 %files gstreamer
286 %defattr(644,root,root,755)
287 %{_libdir}/kde3/libamarok_gstengine_plugin.la
288 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
289 %{_datadir}/config.kcfg/gstconfig.kcfg
290 %{_datadir}/services/amarok_gstengine_plugin.desktop
291 %endif
292
293 %if %{with xine}
294 %files xine
295 %defattr(644,root,root,755)
296 %{_libdir}/kde3/libamarok_xine-engine.la
297 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
298 %{_datadir}/config.kcfg/xinecfg.kcfg
299 %{_datadir}/services/amarok_xine-engine.desktop
300 #%{_datadir}/services/amarok_xineengine_plugin.desktop
301 %endif
302
303 %if %{with zeroconf}
304 %files zeroconf
305 %defattr(644,root,root,755)
306 %{_datadir}/apps/zeroconf/_shoutcast._tcp
307 %endif
308
309 %files scripts
310 %defattr(644,root,root,755)
311
312 %dir %{_datadir}/apps/amarok/scripts/alarm
313 %{_datadir}/apps/amarok/scripts/alarm/README
314 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
315
316 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
317 %{_datadir}/apps/amarok/scripts/graphequalizer/README
318 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
319
320 %dir %{_datadir}/apps/amarok/scripts/playlist2html
321 %{_datadir}/apps/amarok/scripts/playlist2html/README
322 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
323 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
324 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
325
326 %dir %{_datadir}/apps/amarok/scripts/templates
327 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
328 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
329 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
330
331 %dir %{_datadir}/apps/amarok/scripts/webcontrol
332 %{_datadir}/apps/amarok/scripts/webcontrol/README
333 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
334 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
335 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
336 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
337 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
338 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
339 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
340 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
341 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
342 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
343 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
344 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
345 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
346 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
347 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
348 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
349
350 %dir %{_datadir}/apps/amarok/scripts/common
351 %{_datadir}/apps/amarok/scripts/common/Publisher.py
352 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
353
354 %dir %{_datadir}/apps/amarok/scripts/shouter
355 %{_datadir}/apps/amarok/scripts/shouter/README
356 %{_datadir}/apps/amarok/scripts/shouter/ChangeLog
357 %{_datadir}/apps/amarok/scripts/shouter/Amarok.py
358 %{_datadir}/apps/amarok/scripts/shouter/Globals.py
359 %{_datadir}/apps/amarok/scripts/shouter/Playlist.py
360 %{_datadir}/apps/amarok/scripts/shouter/Services.py
361 %{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
362 %{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
363 %{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
364 %{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
365 %{_datadir}/apps/amarok/scripts/shouter/StreamController.py
366 %{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
367 %{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
368 %{_datadir}/apps/amarok/scripts/shouter/debug.py
369 %{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
370 %dir %{_datadir}/apps/amarok/scripts/shouter/silence
371 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
372 %dir %{_datadir}/apps/amarok/scripts/shouter/test
373 %{_datadir}/apps/amarok/scripts/shouter/test/client.py
374 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
375
376 %if 0
377 %dir %{_datadir}/apps/amarok/scripts/amarok_live
378 %{_datadir}/apps/amarok/scripts/amarok_live/README
379 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
380 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
381 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
382 %endif
This page took 0.09831 seconds and 4 git commands to generate.