]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- more todo.
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * HelixPlayer engine (fix build - propably some BRs)
6 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
7 #
8 # Conditional builds:
9 %bcond_without  arts            # disable arts engine
10 %bcond_without  gstreamer       # disable gstreamer
11 %bcond_without  mas             # disable MAS audio backend
12 %bcond_without  xine            # disable xine engine
13 %bcond_without  xmms            # disable xmms wrapping
14 %bcond_without  zeroconf        # disable support for zeroconf
15 %bcond_with     helix           # enable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
19 %bcond_with     altlyrics       # use alternative lyrics provider
20 Summary:        A KDE audio player
21 Summary(pl):    Odtwarzacz audio dla KDE
22 Name:           amarok
23 Version:        1.3.3
24 Release:        1
25 License:        GPL
26 Group:          X11/Applications/Multimedia
27 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
28 # Source0-md5:  13f02c3cce06d9c1d0511171d736efa3
29 Patch0:         kde-common-gcc4.patch
30 Patch1:         %{name}-lyricsurl.patch
31 URL:            http://amarok.kde.org/
32 #BuildRequires: kdebindings-kjsembed-devel
33 #BuildRequires: unsermake >= 040511
34 BuildRequires:  SDL-devel
35 BuildRequires:  alsa-lib-devel
36 BuildRequires:  arts-qt-devel
37 BuildRequires:  autoconf
38 BuildRequires:  automake
39 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
40 BuildRequires:  kdebase-devel
41 %{?with_akode:BuildRequires:    kdemultimedia-akode}
42 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
43 BuildRequires:  libltdl-devel
44 BuildRequires:  libmusicbrainz-devel
45 BuildRequires:  libvisual-devel >= 0.2.0
46 %{?with_mysql:BuildRequires:            mysql-devel}
47 BuildRequires:  pcre-devel
48 BuildRequires:  rpm-pythonprov
49 BuildRequires:  rpmbuild(macros) >= 1.129
50 BuildRequires:  sed >= 4.0
51 BuildRequires:  sqlite3-devel
52 BuildRequires:  taglib-devel >= 1.4
53 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
54 %{?with_xmms:BuildRequires:             xmms-devel}
55 Requires:       %{name}-plugin = %{version}-%{release}
56 Requires:       kdebase-core >= 9:3.1.93
57 Requires:       kdemultimedia-audiocd >= 9:3.1.93
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 A KDE audio player.
62
63 %description -l pl
64 Odtwarzacz audio dla KDE.
65
66 %package arts
67 Summary:        Plugin arts
68 Summary(pl):    Wtyczka arts
69 Group:          X11/Applications/Multimedia
70 Requires:       %{name} = %{version}-%{release}
71 Provides:       %{name}-plugin = %{version}-%{release}
72
73 %description arts
74 Plugin arts.
75
76 %description arts -l pl
77 Wtyczka arts.
78
79 %package akode
80 Summary:        Plugin akode
81 Summary(pl):    Wtyczka akode
82 Group:          X11/Applications/Multimedia
83 Requires:       %{name} = %{version}-%{release}
84 Provides:       %{name}-plugin = %{version}-%{release}
85
86 %description akode
87 Plugin akode.
88
89 %description akode -l pl
90 Wtyczka akode.
91
92 %package gstreamer
93 Summary:        Plugin gstreamer
94 Summary(pl):    Wtyczka gstreamer
95 Group:          X11/Applications/Multimedia
96 # deps, to get it working:
97 # mp3 decoder: gstreamer-mad
98 # ogg decoder: gstreamer-vorbis
99 # audio output driver: gstreamer-audiosink-alsa
100 # from gstreamer-audio-effects to control volume, etc
101 # needed libs:
102 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
103 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
104 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
105 # gstreamer-musicbrainz for being able to edit id3 tags on files.
106 Requires:       %{name} = %{version}-%{release}
107 Requires:       gstreamer-audio-effects
108 Requires:       gstreamer-audiosink
109 Requires:       gstreamer-mad
110 Requires:       gstreamer-musicbrainz
111 Requires:       gstreamer-vorbis
112 Provides:       %{name}-plugin = %{version}-%{release}
113
114 %description gstreamer
115 Plugin gstreamer.
116
117 %description gstreamer -l pl
118 Wtyczka gstreamer.
119
120 %package xine
121 Summary:        Plugin xine
122 Summary(pl):    Wtyczka xine
123 Group:          X11/Applications/Multimedia
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       xine-plugin-audio
126 Provides:       %{name}-plugin = %{version}-%{release}
127
128 %description xine
129 Plugin xine.
130
131 %description xine -l pl
132 Wtyczka xine.
133
134 %package zeroconf
135 Summary:        Zeroconf data
136 Summary(pl):    Dane dla zeroconf
137 Group:          X11/Applications/Multimedia
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       kdenetwork-kdnssd
140 Provides:       %{name}-plugin = %{version}-%{release}
141
142 %description zeroconf
143 Zeroconf data.
144
145 %description zeroconf -l pl
146 Dane dla zeroconf.
147
148 %package scripts
149 Summary:        amaroK scripts
150 Summary(pl):    Skrypty amaroKa
151 Group:          X11/Applications/Multimedia
152 Requires:       %{name} = %{version}-%{release}
153 Requires:       kdebase-kdialog
154 Requires:       python-PyQt
155
156 %description scripts
157 amaroK scripts allow you extend amaroK functionality.
158
159 You can learn more about scripts in amaroK from here:
160 <http://amarok.kde.org/wiki/index.php/Scripts>.
161
162 %description scripts -l pl
163 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
164
165 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
166 <http://amarok.kde.org/wiki/index.php/Scripts>.
167
168 %prep
169 %setup -q
170 %patch0 -p1
171 %{?with_altlyrics:%patch1 -p1}
172 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
173         amarok/src/amarok.desktop \
174
175 # see kde bug #110909
176 sed -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
177
178 %build
179 %{__aclocal}
180 %{__autoconf}
181 %{__autoheader}
182 %{__automake}
183
184 cp -f /usr/share/automake/config.sub admin
185
186 #export UNSERMAKE=/usr/share/unsermake/unsermake
187
188 %{__make} -f admin/Makefile.common cvs
189
190 %configure \
191         --disable-rpath \
192         %{!?with_arts:--without-arts} \
193         %{?with_mas:--with-mas} \
194         %{!?with_xine:--without-xine} \
195         %{!?with_gstreamer:--without-gstreamer} \
196         %{!?with_akode:--without-akode} \
197         %{?with_helix:--with-helix} \
198         %{?with_nmm:--with-nmm} \
199         %{?with_mysql:--with-mysql} \
200         --disable-final \
201         --with-qt-libraries=%{_libdir} \
202         --without-included-sqlite
203
204 %{__make}
205
206 %install
207 rm -rf $RPM_BUILD_ROOT
208
209 %{__make} install \
210         DESTDIR=$RPM_BUILD_ROOT \
211         kde_htmldir=%{_kdedocdir} \
212         kde_libs_htmldir=%{_kdedocdir}
213
214 # remove bogus dir
215 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
216
217 %find_lang amarok --all-name --with-kde
218
219 %clean
220 rm -rf $RPM_BUILD_ROOT
221
222 %post
223 if [ "$1" = 1 ]; then
224         echo "Remember to install libvisual-plugins-* packages if you"
225         echo "want to have a visualizations in amaroK."
226 fi
227
228 %files -f %{name}.lang
229 %defattr(644,root,root,755)
230 %doc AUTHORS ChangeLog README TODO
231 %attr(755,root,root) %{_bindir}/amarok
232 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
233 %attr(755,root,root) %{_bindir}/amarokapp
234 %attr(755,root,root) %{_bindir}/amarok_libvisual
235 #%attr(755,root,root) %{_bindir}/release_amarok
236 %{_libdir}/kde3/konqsidebar_universalamarok.la
237 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
238 %{_libdir}/kde3/libamarok_void-engine_plugin.la
239 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
240 %dir %{_datadir}/apps/amarok
241 %dir %{_datadir}/apps/amarok/scripts
242 %{_datadir}/apps/amarok/*.rc
243 %{_datadir}/apps/amarok/data
244 %{_datadir}/apps/amarok/icons
245 %{_datadir}/apps/amarok/images
246 %{_datadir}/apps/amarok/themes
247 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
248 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
249 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
250 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
251 %{_datadir}/apps/profiles/amarok.profile.xml
252 %{_datadir}/config/amarokrc
253 %{_datadir}/config.kcfg/amarok.kcfg
254 %{_datadir}/services/amarok_void-engine_plugin.desktop
255 %{_datadir}/servicetypes/amarok_plugin.desktop
256 %{_desktopdir}/kde/amarok.desktop
257 %{_iconsdir}/*/*/apps/amarok.*
258
259 %if %{with arts}
260 %files arts
261 %defattr(644,root,root,755)
262 %{_libdir}/kde3/libamarok_artsengine_plugin.la
263 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
264 %{_libdir}/libamarokarts.la
265 %attr(755,root,root) %{_libdir}/libamarokarts.so
266 %{_libdir}/mcop/Amarok
267 %{_libdir}/mcop/amarokarts.mcopclass
268 %{_libdir}/mcop/amarokarts.mcoptype
269 %{_datadir}/services/amarok_artsengine_plugin.desktop
270 %endif
271
272 %if %{with akode}
273 %files akode
274 %defattr(644,root,root,755)
275 %{_libdir}/kde3/libamarok_aKode-engine.la
276 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
277 %{_datadir}/services/amarok_aKode-engine.desktop
278 %endif
279
280 %if %{with gstreamer}
281 %files gstreamer
282 %defattr(644,root,root,755)
283 %{_libdir}/kde3/libamarok_gstengine_plugin.la
284 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
285 %{_datadir}/config.kcfg/gstconfig.kcfg
286 %{_datadir}/services/amarok_gstengine_plugin.desktop
287 %endif
288
289 %if %{with xine}
290 %files xine
291 %defattr(644,root,root,755)
292 %{_libdir}/kde3/libamarok_xine-engine.la
293 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
294 %{_datadir}/config.kcfg/xinecfg.kcfg
295 %{_datadir}/services/amarok_xine-engine.desktop
296 #%{_datadir}/services/amarok_xineengine_plugin.desktop
297 %endif
298
299 %if %{with zeroconf}
300 %files zeroconf
301 %defattr(644,root,root,755)
302 %{_datadir}/apps/zeroconf/_shoutcast._tcp
303 %endif
304
305 %files scripts
306 %defattr(644,root,root,755)
307
308 %dir %{_datadir}/apps/amarok/scripts/alarm
309 %{_datadir}/apps/amarok/scripts/alarm/README
310 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
311
312 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
313 %{_datadir}/apps/amarok/scripts/graphequalizer/README
314 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
315
316 %dir %{_datadir}/apps/amarok/scripts/playlist2html
317 %{_datadir}/apps/amarok/scripts/playlist2html/README
318 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
319 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
320 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
321
322 %dir %{_datadir}/apps/amarok/scripts/templates
323 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
324 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
325 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
326
327 %dir %{_datadir}/apps/amarok/scripts/webcontrol
328 %{_datadir}/apps/amarok/scripts/webcontrol/README
329 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
330 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
331 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
332 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
333 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
334 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
335 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
336 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
337 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
338 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
339 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
340 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
341 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
342 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
343 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
344 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
345
346 %dir %{_datadir}/apps/amarok/scripts/common
347 %{_datadir}/apps/amarok/scripts/common/Publisher.py
348 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
349
350 %dir %{_datadir}/apps/amarok/scripts/shouter
351 %{_datadir}/apps/amarok/scripts/shouter/README
352 %{_datadir}/apps/amarok/scripts/shouter/ChangeLog
353 %{_datadir}/apps/amarok/scripts/shouter/Amarok.py
354 %{_datadir}/apps/amarok/scripts/shouter/Globals.py
355 %{_datadir}/apps/amarok/scripts/shouter/Playlist.py
356 %{_datadir}/apps/amarok/scripts/shouter/Services.py
357 %{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
358 %{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
359 %{_datadir}/apps/amarok/scripts/shouter/SocketErrors.py
360 %{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
361 %{_datadir}/apps/amarok/scripts/shouter/StreamController.py
362 %{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
363 %{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
364 %{_datadir}/apps/amarok/scripts/shouter/debug.py
365 %{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
366 %dir %{_datadir}/apps/amarok/scripts/shouter/silence
367 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
368 %dir %{_datadir}/apps/amarok/scripts/shouter/test
369 %{_datadir}/apps/amarok/scripts/shouter/test/client.py
370 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
371
372 %if 0
373 %dir %{_datadir}/apps/amarok/scripts/amarok_live
374 %{_datadir}/apps/amarok/scripts/amarok_live/README
375 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
376 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
377 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
378 %endif
This page took 0.077379 seconds and 4 git commands to generate.