]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
d258fabe1337352990415194ff4b4cef6f85564b
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
9 %bcond_without  mas             # disable MAS audio backend
10 %bcond_without  xine            # disable xine engine
11 %bcond_without  xmms            # disable xmms wrapping
12 %bcond_without  zeroconf        # disable support for zeroconf
13 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
14 %bcond_without  helix           # disable HelixPlayer engine
15 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable MySQL support
18 %bcond_with     pgsql           # enable PostgreSQL support
19 #
20 %ifarch i386
21 %undefine       with_helix
22 %endif
23
24 Summary:        A KDE audio player
25 Summary(pl):    Odtwarzacz audio dla KDE
26 Name:           amarok
27 %define         _ver 1.4.1
28 %define         _rel beta1
29 Version:        %{_ver}
30 Release:        0.%{_rel}.1
31 License:        GPL
32 Group:          X11/Applications/Multimedia
33 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{_ver}-%{_rel}.tar.bz2
34 # Source0-md5:  ee043cf6efa3f2ac7b470eb6c050c0f7
35 Patch0:         %{name}-helixplayer-morearchs.patch
36 URL:            http://amarok.kde.org/
37 BuildRequires:  SDL-devel
38 BuildRequires:  alsa-lib-devel
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 BuildRequires:  dbus-glib-devel
42 BuildRequires:  gettext-devel
43 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
44 BuildRequires:  kdebase-devel
45 %{?with_akode:BuildRequires:    kdemultimedia-akode}
46 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
47 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
48 %{?with_mp3players:BuildRequires:       libifp-devel}
49 BuildRequires:  libltdl-devel
50 %{?with_pgsql:BuildRequires:            libpqxx-devel}
51 BuildRequires:  libtunepimp-devel >= 0.4.0
52 BuildRequires:  libvisual-devel >= 0.4.0
53 BuildRequires:  mpeg4ip-devel
54 %{?with_mysql:BuildRequires:            mysql-devel}
55 BuildRequires:  pcre-devel
56 BuildRequires:  pkgconfig
57 BuildRequires:  rpm-pythonprov
58 BuildRequires:  rpmbuild(macros) >= 1.129
59 BuildRequires:  sed >= 4.0
60 %{!?with_included_sqlite:BuildRequires: sqlite3-devel}
61 BuildRequires:  taglib-devel >= 1.4
62 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
63 %{?with_xmms:BuildRequires:     xmms-devel}
64 Requires:       %{name}-plugin = %{version}-%{release}
65 Requires:       kdebase-core >= 9:3.1.93
66 Requires:       kdemultimedia-audiocd >= 9:3.1.93
67 Obsoletes:      amarok-arts
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 A KDE audio player.
72
73 %description -l pl
74 Odtwarzacz audio dla KDE.
75
76 %package akode
77 Summary:        Plugin akode
78 Summary(pl):    Wtyczka akode
79 Group:          X11/Applications/Multimedia
80 Requires:       %{name} = %{version}-%{release}
81 Provides:       %{name}-plugin = %{version}-%{release}
82
83 %description akode
84 Plugin akode.
85
86 %description akode -l pl
87 Wtyczka akode.
88
89 %package helix
90 Summary:        Helix/Realplayer playback support for amarok
91 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
92 Group:          X11/Applications/Multimedia
93 Requires:       %{name} = %{version}-%{release}
94 Requires:       helix-core
95 Provides:       %{name}-plugin = %{version}-%{release}
96
97 %description helix
98 Helix/Realplayer playback support for amarok.
99
100 %description helix -l pl
101 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
102
103 %package gstreamer
104 Summary:        Plugin gstreamer
105 Summary(pl):    Wtyczka gstreamer
106 Group:          X11/Applications/Multimedia
107 # deps, to get it working:
108 # mp3 decoder:  gstreamer-mad
109 # ogg decoder:  gstreamer-vorbis
110 # audio output driver:  gstreamer-audiosink-alsa
111 # from gstreamer-audio-effects to control volume, etc
112 # needed libs:
113 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
114 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
115 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
116 # gstreamer-musicbrainz for being able to edit id3 tags on files.
117 Requires:       %{name} = %{version}-%{release}
118 Requires:       gstreamer-audio-effects
119 Requires:       gstreamer-audiosink
120 Requires:       gstreamer-mad
121 Requires:       gstreamer-musicbrainz
122 Requires:       gstreamer-vorbis
123 Provides:       %{name}-plugin = %{version}-%{release}
124
125 %description gstreamer
126 Plugin gstreamer.
127
128 %description gstreamer -l pl
129 Wtyczka gstreamer.
130
131 %package xine
132 Summary:        Plugin xine
133 Summary(pl):    Wtyczka xine
134 Group:          X11/Applications/Multimedia
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       xine-plugin-audio
137 Provides:       %{name}-plugin = %{version}-%{release}
138
139 %description xine
140 Plugin xine.
141
142 %description xine -l pl
143 Wtyczka xine.
144
145 %package xmms
146 Summary:        Xmms wrapper
147 Summary(pl):    Wrapper xmms
148 Group:          X11/Applications/Multimedia
149 Requires:       %{name} = %{version}-%{release}
150
151 %description xmms
152 Xmms wrapper.
153
154 %description xmms -l pl
155 Wrapper xmms.
156
157 %package zeroconf
158 Summary:        Zeroconf data
159 Summary(pl):    Dane dla zeroconf
160 Group:          X11/Applications/Multimedia
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       kdenetwork-kdnssd
163 Provides:       %{name}-plugin = %{version}-%{release}
164
165 %description zeroconf
166 Zeroconf data.
167
168 %description zeroconf -l pl
169 Dane dla zeroconf.
170
171 %package scripts
172 Summary:        amaroK scripts
173 Summary(pl):    Skrypty amaroKa
174 Group:          X11/Applications/Multimedia
175 Requires:       %{name} = %{version}-%{release}
176 Requires:       kdebase-kdialog
177 Requires:       python-PyQt
178 Requires:       ruby-modules
179
180 %description scripts
181 amaroK scripts allow you extend amaroK functionality.
182
183 You can learn more about scripts in amaroK from here:
184 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
185
186 %description scripts -l pl
187 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
188
189 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
190 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
191
192 %prep
193 %setup -q -n %{name}-%{_ver}-%{_rel}
194 %patch0 -p1
195 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
196         amarok/src/amarok.desktop \
197
198 # see kde bug #110909
199 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
200
201 # kill env, call interpreter directly, so rpm automatics could rule
202 %{__sed} -i -e '
203         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
204         1s,#!.*bin/env.*python,#!%{_bindir}/python,
205         1s,#!.*bin/env.*bash,#!/bin/bash,
206 ' amarok/src/scripts/*/*.{py,rb,sh}
207
208 %build
209 cp -f /usr/share/automake/config.sub admin
210 %{__make} -f admin/Makefile.common cvs
211
212 # hack: passing something other than "no" or "yes" to --with-helix allows
213 # us to pass HELIX_LIBS
214 %configure \
215         HELIX_LIBS=%{_libdir}/helixplayer \
216         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
217         --disable-rpath \
218         --with%{!?with_mas:out}-mas \
219         --with%{!?with_xine:out}-xine \
220         --with%{!?with_gstreamer:out}-gstreamer10 \
221         --with%{!?with_akode:out}-akode \
222         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
223         --with%{!?with_nmm:out}-nmm \
224         --with%{!?with_mp3players:out}-libgpod \
225         --with%{!?with_mp3players:out}-ifp \
226         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
227         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
228         --disable-final \
229         --with-mp4v2 \
230         --with-qt-libraries=%{_libdir} \
231         --with%{!?with_included_sqlite:out}-included-sqlite
232
233 %{__make}
234
235 %install
236 rm -rf $RPM_BUILD_ROOT
237
238 %{__make} install \
239         DESTDIR=$RPM_BUILD_ROOT \
240         kde_htmldir=%{_kdedocdir} \
241         kde_libs_htmldir=%{_kdedocdir}
242
243 # remove bogus dir
244 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
245
246 %find_lang amarok --all-name --with-kde
247
248 %clean
249 rm -rf $RPM_BUILD_ROOT
250
251 if [ "$1" = 1 ]; then
252         echo "Remember to install libvisual-plugins-* packages if you"
253         echo "want to have a visualizations in amaroK."
254 fi
255
256 %post   -p /sbin/ldconfig
257 %postun -p /sbin/ldconfig
258
259 %files -f %{name}.lang
260 %defattr(644,root,root,755)
261 %doc AUTHORS ChangeLog README
262 %attr(755,root,root) %{_bindir}/amarok
263 %attr(755,root,root) %{_bindir}/amarokapp
264 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
265 %attr(755,root,root) %{_bindir}/amarok_libvisual
266 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
267 %{_libdir}/kde3/konqsidebar_universalamarok.la
268 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
269 %{_libdir}/kde3/libamarok_generic-mediadevice.la
270 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
271 %{_libdir}/kde3/libamarok_void-engine_plugin.la
272 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
273 %{_libdir}/libamarok.la
274 %dir %{_datadir}/apps/amarok
275 %dir %{_datadir}/apps/amarok/scripts
276 %{_datadir}/apps/amarok/*.rc
277 %{_datadir}/apps/amarok/data
278 %{_datadir}/apps/amarok/icons
279 %{_datadir}/apps/amarok/images
280 %{_datadir}/apps/amarok/themes
281 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
282 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
283 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
284 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
285 %{_datadir}/apps/profiles/amarok.profile.xml
286 %{_datadir}/config/amarokrc
287 %{_datadir}/config.kcfg/amarok.kcfg
288 %{_datadir}/services/amarok_generic-mediadevice.desktop
289 %{_datadir}/services/amarok_void-engine_plugin.desktop
290 %{_datadir}/servicetypes/amarok_plugin.desktop
291 %{_desktopdir}/kde/amarok.desktop
292 %{_iconsdir}/*/*/apps/amarok.*
293 # TODO: move to subpackage
294 %if %{with mp3players}
295 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
296 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
297 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
298 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
299 %{_datadir}/services/amarok_ipod-mediadevice.desktop
300 %{_datadir}/services/amarok_ifp-mediadevice.desktop
301 %endif
302
303 %if %{with akode}
304 %files akode
305 %defattr(644,root,root,755)
306 %{_libdir}/kde3/libamarok_aKode-engine.la
307 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
308 %{_datadir}/services/amarok_aKode-engine.desktop
309 %endif
310
311 %if %{with gstreamer}
312 %files gstreamer
313 %defattr(644,root,root,755)
314 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
315 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
316 %{_datadir}/config.kcfg/gstconfig.kcfg
317 %{_datadir}/services/amarok_gst10engine_plugin.desktop
318 %endif
319
320 %if %{with helix}
321 %files helix
322 %defattr(644,root,root,755)
323 %{_libdir}/kde3/libamarok_helixengine_plugin.la
324 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
325 %{_datadir}/config.kcfg/helixconfig.kcfg
326 %{_datadir}/services/amarok_helixengine_plugin.desktop
327 %endif
328
329 %if %{with xine}
330 %files xine
331 %defattr(644,root,root,755)
332 %{_libdir}/kde3/libamarok_xine-engine.la
333 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
334 %{_datadir}/config.kcfg/xinecfg.kcfg
335 %{_datadir}/services/amarok_xine-engine.desktop
336 #%{_datadir}/services/amarok_xineengine_plugin.desktop
337 %endif
338
339 %if %{with xmms}
340 %files xmms
341 %defattr(644,root,root,755)
342 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
343 %endif
344
345 %if 0
346 %if %{with zeroconf}
347 %files zeroconf
348 %defattr(644,root,root,755)
349 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
350 %endif
351 %endif
352
353 %files scripts
354 %defattr(644,root,root,755)
355 %dir %{_datadir}/apps/amarok/scripts/common
356 %{_datadir}/apps/amarok/scripts/common/Publisher.py
357 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
358
359 %dir %{_datadir}/apps/amarok/scripts/templates
360 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
361 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
362 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
363
364 # amarok searches for executable programs for scripts
365 # to figure out which files need to have execute permission, use this
366 # find command:
367 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
368
369 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
370 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
371 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
372
373 %dir %{_datadir}/apps/amarok/scripts/playlist2html
374 %{_datadir}/apps/amarok/scripts/playlist2html/README
375 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
376 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
377 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
378
379 %dir %{_datadir}/apps/amarok/scripts/webcontrol
380 %{_datadir}/apps/amarok/scripts/webcontrol/README
381 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
382 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
383 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
384 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
385 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
386 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
387 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
388 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
389 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
390 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
391 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
392 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
393 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
394 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
395 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
396 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
397 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
398 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
399 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
400
401 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
402 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
403 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
404 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
405 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
406
407 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
408 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
409 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
410 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
411 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
412
413 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
414 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
415
416 %if 0
417 %dir %{_datadir}/apps/amarok/scripts/amarok_live
418 %{_datadir}/apps/amarok/scripts/amarok_live/README
419 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
420 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
421 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
422 %endif
This page took 0.058024 seconds and 3 git commands to generate.