]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- python-PyQt for -scripts
[packages/amarok.git] / amarok.spec
1 # This file does not like to be adapterized!
2 # - or at least rpm is broken, as it doesn't build without rpm-pythonprov
3 #
4 # TODO:
5 #       * postgresql support alongside mysql
6 #       * NMM audio backend support (fix build - propably some BRs)
7 #       * make descriptions less useless
8 #       * HelixPlayer engine (fix build - propably some BRs)
9 #
10 # Conditional builds:
11 %bcond_without  arts            # disable arts engine
12 %bcond_without  gstreamer       # disable gstreamer
13 %bcond_without  mas             # disable MAS audio backend
14 %bcond_without  xine            # disable xine engine
15 %bcond_without  xmms            # disable xmms wrapping
16 %bcond_without  zeroconf        # disable support for zeroconf
17 %bcond_with     helix           # enable HelixPlayer engine
18 %bcond_with     nmm             # enable NMM audio backend
19 %bcond_with     mysql           # enable mysql support
20 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
21 Summary:        A KDE audio player
22 Summary(pl):    Odtwarzacz audio dla KDE
23 Name:           amarok
24 Version:        1.3
25 Release:        1.2
26 License:        GPL
27 Group:          X11/Applications/Multimedia
28 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
29 # Source0-md5:  2dd100584795fb20c621fdbc96cbee1e
30 Patch0:         kde-common-gcc4.patch
31 Patch1:         http://websvn.kde.org/trunk/extragear/multimedia/amarok/src/playlistbrowseritem.h?rev=449581&r1=449054&r2=449581&makepatch=1&diff_format=u
32 URL:            http://amarok.kde.org/
33 BuildRequires:  SDL-devel
34 BuildRequires:  alsa-lib-devel
35 BuildRequires:  arts-qt-devel
36 BuildRequires:  automake
37 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
38 BuildRequires:  kdebase-devel
39 %{?with_akode:BuildRequires:    kdemultimedia-akode}
40 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
41 BuildRequires:  libltdl-devel
42 BuildRequires:  libmusicbrainz-devel
43 BuildRequires:  libvisual-devel >= 0.2.0
44 BuildRequires:  pcre-devel
45 BuildRequires:  rpmbuild(macros) >= 1.129
46 BuildRequires:  rpm-pythonprov
47 BuildRequires:  sed >= 4.0
48 BuildRequires:  sqlite3-devel
49 BuildRequires:  taglib-devel >= 1.4
50 #BuildRequires: unsermake >= 040511
51 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
52 %{?with_xmms:BuildRequires:             xmms-devel}
53 %{?with_mysql:BuildRequires:            mysql-devel}
54 #BuildRequires: kdebindings-kjsembed-devel
55 Requires:       %{name}-plugin = %{version}-%{release}
56 Requires:       kdebase-core >= 9:3.1.93
57 Requires:       kdemultimedia-audiocd >= 9:3.1.93
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 A KDE audio player.
62
63 %description -l pl
64 Odtwarzacz audio dla KDE.
65
66 %package arts
67 Summary:        Plugin arts
68 Summary(pl):    Wtyczka arts
69 Group:          X11/Applications/Multimedia
70 Requires:       %{name} = %{version}-%{release}
71 Provides:       %{name}-plugin = %{version}-%{release}
72
73 %description arts
74 Plugin arts.
75
76 %description arts -l pl
77 Wtyczka arts.
78
79 %package akode
80 Summary:        Plugin akode
81 Summary(pl):    Wtyczka akode
82 Group:          X11/Applications/Multimedia
83 Requires:       %{name} = %{version}-%{release}
84 Provides:       %{name}-plugin = %{version}-%{release}
85
86 %description akode
87 Plugin akode.
88
89 %description akode -l pl
90 Wtyczka akode.
91
92 %package gstreamer
93 Summary:        Plugin gstreamer
94 Summary(pl):    Wtyczka gstreamer
95 Group:          X11/Applications/Multimedia
96 # deps, to get it working:
97 # mp3 decoder: gstreamer-mad
98 # ogg decoder: gstreamer-vorbis
99 # audio output driver: gstreamer-audiosink-alsa
100 # from gstreamer-audio-effects to control volume, etc
101 # needed libs:
102 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
103 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
104 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
105 # gstreamer-musicbrainz for being able to edit id3 tags on files.
106 Requires:       gstreamer-audio-effects
107 Requires:       gstreamer-audiosink
108 Requires:       gstreamer-mad
109 Requires:       gstreamer-vorbis
110 Requires:       gstreamer-musicbrainz
111 Requires:       %{name} = %{version}-%{release}
112 Provides:       %{name}-plugin = %{version}-%{release}
113
114 %description gstreamer
115 Plugin gstreamer.
116
117 %description gstreamer -l pl
118 Wtyczka gstreamer.
119
120 %package xine
121 Summary:        Plugin xine
122 Summary(pl):    Wtyczka xine
123 Group:          X11/Applications/Multimedia
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       xine-plugin-audio
126 Provides:       %{name}-plugin = %{version}-%{release}
127
128 %description xine
129 Plugin xine.
130
131 %description xine -l pl
132 Wtyczka xine.
133
134 %package zeroconf
135 Summary:        Zeroconf data
136 Summary(pl):    Dane dla zeroconf
137 Group:          X11/Applications/Multimedia
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       kdenetwork-kdnssd
140 Provides:       %{name}-plugin = %{version}-%{release}
141
142 %description zeroconf
143 Zeroconf data.
144
145 %description zeroconf -l pl
146 Dane dla zeroconf.
147
148 %package scripts
149 Summary:        amaroK scripts
150 Group:          X11/Applications/Multimedia
151 Requires:       %{name} = %{version}-%{release}
152 Requires:       kdebase-kdialog
153 Requires:       python-PyQt
154
155 %description scripts
156 amaroK scripts allow you extend amaroK functionality.
157
158 You can learn more about scripts in amaroK from here:
159 <http://amarok.kde.org/wiki/index.php/Scripts>.
160
161 %prep
162 %setup -q
163 %patch0 -p1
164 %patch1 -p3
165 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
166         amarok/src/amarok.desktop \
167
168 %build
169 cp -f /usr/share/automake/config.sub admin
170
171 #export UNSERMAKE=/usr/share/unsermake/unsermake
172
173 %{__make} -f admin/Makefile.common cvs
174
175 %configure \
176         --disable-rpath \
177         %{!?with_arts:--without-arts} \
178         %{?with_mas:--with-mas} \
179         %{!?with_xine:--without-xine} \
180         %{!?with_gstreamer:--without-gstreamer} \
181         %{!?with_akode:--without-akode} \
182         %{?with_helix:--with-helix} \
183         %{?with_nmm:--with-nmm} \
184         %{?with_mysql:--with-mysql} \
185         --disable-final \
186         --with-qt-libraries=%{_libdir} \
187         --without-included-sqlite
188
189 %{__make}
190
191 %install
192 rm -rf $RPM_BUILD_ROOT
193
194 %{__make} install \
195         DESTDIR=$RPM_BUILD_ROOT \
196         kde_htmldir=%{_kdedocdir} \
197         kde_libs_htmldir=%{_kdedocdir}
198
199 # remove bogus dir
200 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
201
202 %find_lang amarok --all-name --with-kde
203
204 %clean
205 rm -rf $RPM_BUILD_ROOT
206
207 %post
208 if [ "$1" = 1 ]; then
209         echo "Remember to install libvisual-plugins-* packages if you"
210         echo "want to have a visualizations in amaroK."
211 fi
212
213 %files -f %{name}.lang
214 %defattr(644,root,root,755)
215 %doc AUTHORS ChangeLog README TODO
216 %attr(755,root,root) %{_bindir}/amarok
217 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
218 %attr(755,root,root) %{_bindir}/amarokapp
219 %attr(755,root,root) %{_bindir}/amarok_libvisual
220 #%attr(755,root,root) %{_bindir}/release_amarok
221 %{_libdir}/kde3/konqsidebar_universalamarok.la
222 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
223 %{_libdir}/kde3/libamarok_void-engine_plugin.la
224 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
225 %dir %{_datadir}/apps/amarok
226 %dir %{_datadir}/apps/amarok/scripts
227 %{_datadir}/apps/amarok/*.rc
228 %{_datadir}/apps/amarok/data
229 %{_datadir}/apps/amarok/icons
230 %{_datadir}/apps/amarok/images
231 %{_datadir}/apps/amarok/themes
232 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
233 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
234 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
235 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
236 %{_datadir}/apps/profiles/amarok.profile.xml
237 %{_datadir}/config/amarokrc
238 %{_datadir}/config.kcfg/amarok.kcfg
239 %{_datadir}/services/amarok_void-engine_plugin.desktop
240 %{_datadir}/servicetypes/amarok_plugin.desktop
241 %{_desktopdir}/kde/amarok.desktop
242 %{_iconsdir}/*/*/apps/amarok.*
243
244 %if %{with arts}
245 %files arts
246 %defattr(644,root,root,755)
247 %{_libdir}/kde3/libamarok_artsengine_plugin.la
248 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
249 %{_libdir}/libamarokarts.la
250 %attr(755,root,root) %{_libdir}/libamarokarts.so
251 %{_libdir}/mcop/Amarok
252 %{_libdir}/mcop/amarokarts.mcopclass
253 %{_libdir}/mcop/amarokarts.mcoptype
254 %{_datadir}/services/amarok_artsengine_plugin.desktop
255 %endif
256
257 %if %{with akode}
258 %files akode
259 %defattr(644,root,root,755)
260 %{_libdir}/kde3/libamarok_aKode-engine.la
261 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
262 %{_datadir}/services/amarok_aKode-engine.desktop
263 %endif
264
265 %if %{with gstreamer}
266 %files gstreamer
267 %defattr(644,root,root,755)
268 %{_libdir}/kde3/libamarok_gstengine_plugin.la
269 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
270 %{_datadir}/config.kcfg/gstconfig.kcfg
271 %{_datadir}/services/amarok_gstengine_plugin.desktop
272 %endif
273
274 %if %{with xine}
275 %files xine
276 %defattr(644,root,root,755)
277 %{_libdir}/kde3/libamarok_xine-engine.la
278 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
279 %{_datadir}/config.kcfg/xinecfg.kcfg
280 %{_datadir}/services/amarok_xine-engine.desktop
281 #%{_datadir}/services/amarok_xineengine_plugin.desktop
282 %endif
283
284 %if %{with zeroconf}
285 %files zeroconf
286 %defattr(644,root,root,755)
287 %{_datadir}/apps/zeroconf/_shoutcast._tcp
288 %endif
289
290 %files scripts
291 %defattr(644,root,root,755)
292
293 %dir %{_datadir}/apps/amarok/scripts/alarm
294 %{_datadir}/apps/amarok/scripts/alarm/README
295 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/alarm/alarm.py
296
297 %dir %{_datadir}/apps/amarok/scripts/graphequalizer
298 %{_datadir}/apps/amarok/scripts/graphequalizer/README
299 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
300
301 %dir %{_datadir}/apps/amarok/scripts/playlist2html
302 %{_datadir}/apps/amarok/scripts/playlist2html/README
303 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
304 %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
305 %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
306
307 %dir %{_datadir}/apps/amarok/scripts/templates
308 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
309 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
310 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
311
312 %dir %{_datadir}/apps/amarok/scripts/webcontrol
313 %{_datadir}/apps/amarok/scripts/webcontrol/README
314 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
315 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
316 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
317 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
318 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
319 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
320 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
321 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
322 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
323 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
324 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
325 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
326 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
327 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
328 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
329 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
330
331 %dir %{_datadir}/apps/amarok/scripts/common
332 %{_datadir}/apps/amarok/scripts/common/Publisher.py
333 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
334
335 %dir %{_datadir}/apps/amarok/scripts/shouter
336 %{_datadir}/apps/amarok/scripts/shouter/README
337 %{_datadir}/apps/amarok/scripts/shouter/ChangeLog
338 %{_datadir}/apps/amarok/scripts/shouter/Amarok.py
339 %{_datadir}/apps/amarok/scripts/shouter/Globals.py
340 %{_datadir}/apps/amarok/scripts/shouter/Playlist.py
341 %{_datadir}/apps/amarok/scripts/shouter/Services.py
342 %{_datadir}/apps/amarok/scripts/shouter/ShouterConfig.py
343 %{_datadir}/apps/amarok/scripts/shouter/ShouterExceptions.py
344 %{_datadir}/apps/amarok/scripts/shouter/StreamConfig.py
345 %{_datadir}/apps/amarok/scripts/shouter/StreamController.py
346 %{_datadir}/apps/amarok/scripts/shouter/StreamPublisher.py
347 %{_datadir}/apps/amarok/scripts/shouter/binfuncs.py
348 %{_datadir}/apps/amarok/scripts/shouter/debug.py
349 %{_datadir}/apps/amarok/scripts/shouter/propfind-req.xml
350 %dir %{_datadir}/apps/amarok/scripts/shouter/silence
351 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-128.mp3
352 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-160.mp3
353 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-192.mp3
354 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-224.mp3
355 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-256.mp3
356 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-320.mp3
357 %{_datadir}/apps/amarok/scripts/shouter/silence/silence-48.mp3
358 %dir %{_datadir}/apps/amarok/scripts/shouter/test
359 %{_datadir}/apps/amarok/scripts/shouter/test/client.py
360 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/shouter/Shouter.py
361
362 %dir %{_datadir}/apps/amarok/scripts/amarok_live
363 %{_datadir}/apps/amarok/scripts/amarok_live/README
364 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
365 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
366 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
This page took 0.044742 seconds and 3 git commands to generate.