]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- merged from DEVEL
[packages/amarok.git] / amarok.spec
1 #
2 # TODO:
3 #       * postgresql support alongside mysql
4 #       * NMM audio backend support (fix build - propably some BRs)
5 #       * make descriptions less useless
6 #       * HelixPlayer engine (fix build - propably some BRs)
7 #
8 # Conditional builds:
9 %bcond_without  arts            # disable arts engine
10 %bcond_without  gstreamer       # disable gstreamer
11 %bcond_without  mas             # disable MAS audio backend
12 %bcond_without  xine            # disable xine engine
13 %bcond_without  xmms            # disable xmms wrapping
14 %bcond_without  zeroconf        # disable suport for zeroconf
15 %bcond_with     helix           # enable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
19 Summary:        A KDE audio player
20 Summary(pl):    Odtwarzacz audio dla KDE
21 Name:           amarok
22 Version:        1.3
23 Release:        1
24 License:        GPL
25 Group:          X11/Applications/Multimedia
26 Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
27 # Source0-md5:  2dd100584795fb20c621fdbc96cbee1e
28 Patch0:         kde-common-gcc4.patch
29 URL:            http://amarok.kde.org/
30 BuildRequires:  SDL-devel
31 BuildRequires:  alsa-lib-devel
32 BuildRequires:  arts-qt-devel
33 BuildRequires:  automake
34 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
35 BuildRequires:  kdebase-devel
36 %{?with_akode:BuildRequires:    kdemultimedia-akode}
37 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
38 BuildRequires:  libltdl-devel
39 BuildRequires:  libmusicbrainz-devel
40 BuildRequires:  libvisual-devel >= 0.2.0
41 BuildRequires:  pcre-devel
42 BuildRequires:  rpmbuild(macros) >= 1.129
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  sqlite3-devel
45 BuildRequires:  taglib-devel >= 1.4
46 #BuildRequires: unsermake >= 040511
47 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
48 %{?with_xmms:BuildRequires:             xmms-devel}
49 %{?with_mysql:BuildRequires:            mysql-devel}
50 #BuildRequires: kdebindings-kjsembed-devel
51 Requires:       %{name}-plugin = %{version}-%{release}
52 Requires:       kdebase-core >= 9:3.1.93
53 Requires:       kdemultimedia-audiocd >= 9:3.1.93
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 A KDE audio player.
58
59 %description -l pl
60 Odtwarzacz audio dla KDE.
61
62 %package arts
63 Summary:        Plugin arts
64 Summary(pl):    Wtyczka arts
65 Group:          X11/Applications/Multimedia
66 PreReq:         %{name} = %{version}-%{release}
67 Provides:       %{name}-plugin = %{version}-%{release}
68
69 %description arts
70 Plugin arts.
71
72 %description arts -l pl
73 Wtyczka arts.
74
75 %package akode
76 Summary:        Plugin akode
77 Summary(pl):    Wtyczka akode
78 Group:          X11/Applications/Multimedia
79 PreReq:         %{name} = %{version}-%{release}
80 Provides:       %{name}-plugin = %{version}-%{release}
81
82 %description akode
83 Plugin akode.
84
85 %description akode -l pl
86 Wtyczka akode.
87
88 %package gstreamer
89 Summary:        Plugin gstreamer
90 Summary(pl):    Wtyczka gstreamer
91 Group:          X11/Applications/Multimedia
92 # deps, to get it working:
93 # mp3 decoder: gstreamer-mad
94 # ogg decoder: gstreamer-vorbis
95 # audio output driver: gstreamer-audiosink-alsa
96 # from gstreamer-audio-effects to control volume, etc
97 # needed libs:
98 #  at least /usr/lib/gstreamer-0.8/libgstresample.so 
99 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
100 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
101 # gstreamer-musicbrainz for being able to edit id3 tags on files.
102 Requires:       gstreamer-audio-effects
103 Requires:       gstreamer-audiosink
104 Requires:       gstreamer-mad
105 Requires:       gstreamer-vorbis
106 Requires:       gstreamer-musicbrainz
107 Requires:       %{name} = %{version}-%{release}
108 Provides:       %{name}-plugin = %{version}-%{release}
109
110 %description gstreamer
111 Plugin gstreamer.
112
113 %description gstreamer -l pl
114 Wtyczka gstreamer.
115
116 %package xine
117 Summary:        Plugin xine
118 Summary(pl):    Wtyczka xine
119 Group:          X11/Applications/Multimedia
120 Requires:       %{name} = %{version}-%{release}
121 Requires:       xine-plugin-audio
122 Provides:       %{name}-plugin = %{version}-%{release}
123
124 %description xine
125 Plugin xine.
126
127 %description xine -l pl
128 Wtyczka xine.
129
130 %package zeroconf
131 Summary:        Zeroconf data
132 Summary(pl):    Dane dla zeroconf
133 Group:          X11/Applications/Multimedia
134 PreReq:         %{name} = %{version}-%{release}
135 Requires:       kdenetwork-kdnssd
136 Provides:       %{name}-plugin = %{version}-%{release}
137
138 %description zeroconf
139 Zeroconf data.
140
141 %description zeroconf -l pl
142 Zeroconf data.
143
144 %prep
145 %setup -q
146 %patch0 -p1
147 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
148         amarok/src/amarok.desktop \
149
150 %build
151 cp -f /usr/share/automake/config.sub admin
152
153 #export UNSERMAKE=/usr/share/unsermake/unsermake
154
155 %{__make} -f admin/Makefile.common cvs
156
157 %configure \
158         --disable-rpath \
159         %{!?with_arts:--without-arts} \
160         %{?with_mas:--with-mas} \
161         %{!?with_xine:--without-xine} \
162         %{!?with_gstreamer:--without-gstreamer} \
163         %{!?with_akode:--without-akode} \
164         %{?with_helix:--with-helix} \
165         %{?with_nmm:--with-nmm} \
166         %{?with_mysql:--with-mysql} \
167         --disable-final \
168         --with-qt-libraries=%{_libdir} \
169         --without-included-sqlite
170
171 %{__make}
172
173 %install
174 rm -rf $RPM_BUILD_ROOT
175
176 %{__make} install \
177         DESTDIR=$RPM_BUILD_ROOT \
178         kde_htmldir=%{_kdedocdir} \
179         kde_libs_htmldir=%{_kdedocdir}
180
181 # remove bogus dir
182 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
183
184 %find_lang amarok --all-name --with-kde
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %post
190 echo "Remember to install libvisual-plugins-* packages if you"
191 echo "want to have a visualizations in amarok."
192
193 %files -f %{name}.lang
194 %defattr(644,root,root,755)
195 %doc AUTHORS ChangeLog README TODO
196 %attr(755,root,root) %{_bindir}/amarok
197 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
198 %attr(755,root,root) %{_bindir}/amarokapp
199 %attr(755,root,root) %{_bindir}/amarok_libvisual
200 #%attr(755,root,root) %{_bindir}/release_amarok
201 %{_libdir}/kde3/konqsidebar_universalamarok.la
202 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
203 %{_libdir}/kde3/libamarok_void-engine_plugin.la
204 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
205 %{_datadir}/apps/amarok
206 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
207 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
208 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
209 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
210 %{_datadir}/apps/profiles/amarok.profile.xml
211 %{_datadir}/config/amarokrc
212 %{_datadir}/config.kcfg/amarok.kcfg
213 %{_datadir}/services/amarok_void-engine_plugin.desktop
214 %{_datadir}/servicetypes/amarok_plugin.desktop
215 %{_desktopdir}/kde/amarok.desktop
216 %{_iconsdir}/*/*/apps/amarok.*
217
218 %if %{with arts}
219 %files arts
220 %defattr(644,root,root,755)
221 %{_libdir}/kde3/libamarok_artsengine_plugin.la
222 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
223 %{_libdir}/libamarokarts.la
224 %attr(755,root,root) %{_libdir}/libamarokarts.so
225 %{_libdir}/mcop/Amarok
226 %{_libdir}/mcop/amarokarts.mcopclass
227 %{_libdir}/mcop/amarokarts.mcoptype
228 %{_datadir}/services/amarok_artsengine_plugin.desktop
229 %endif
230
231 %if %{with akode}
232 %files akode
233 %defattr(644,root,root,755)
234 %{_libdir}/kde3/libamarok_aKode-engine.la
235 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
236 %{_datadir}/services/amarok_aKode-engine.desktop
237 %endif
238
239 %if %{with gstreamer}
240 %files gstreamer
241 %defattr(644,root,root,755)
242 %{_libdir}/kde3/libamarok_gstengine_plugin.la
243 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
244 %{_datadir}/config.kcfg/gstconfig.kcfg
245 %{_datadir}/services/amarok_gstengine_plugin.desktop
246 %endif
247
248 %if %{with xine}
249 %files xine
250 %defattr(644,root,root,755)
251 %{_libdir}/kde3/libamarok_xine-engine.la
252 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
253 %{_datadir}/config.kcfg/xinecfg.kcfg
254 %{_datadir}/services/amarok_xine-engine.desktop
255 #%{_datadir}/services/amarok_xineengine_plugin.desktop
256 %endif
257
258 %if %{with zeroconf}
259 %files zeroconf
260 %defattr(644,root,root,755)
261 %{_datadir}/apps/zeroconf/_shoutcast._tcp
262 %endif
This page took 0.041829 seconds and 3 git commands to generate.