]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- TODO added
[packages/amarok.git] / amarok.spec
1 #
2 # TODO: separate arts plugin
3 #
4 # Conditional builds:
5 %bcond_without  gstreamer       # disable gstreamer
6 %bcond_without  xmms            # disable xmms wrapping
7 %bcond_without  xine            # disable xine engine
8 #
9 Summary:        A KDE audio player
10 Summary(pl):    Odtwarzacz audio dla KDE
11 Name:           amarok
12 Version:        1.1.1
13 Release:        1
14 License:        GPL
15 Group:          X11/Applications/Multimedia
16 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
17 # Source0-md5:  6c0cccd4c8b508a2e0c9b0f187a907cf
18 URL:            http://amarok.kde.org/
19 Buildrequires:  alsa-lib-devel
20 Buildrequires:  arts-qt-devel
21 Buildrequires:  automake
22 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.8.1}
23 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
24 BuildRequires:  rpmbuild(macros) >= 1.129
25 BuildRequires:  sed >= 4.0
26 BuildRequires:  sqlite-devel >= 2.8
27 BuildRequires:  taglib-devel >= 1.3
28 BuildRequires:  unsermake >= 040511
29 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.0-0.rc5.0}
30 %{?with_xmms:Buildrequires:     xmms-devel}
31 Buildrequires:  libmusicbrainz-devel
32 Buildrequires:  libvisual-devel >= 0.1.6-1
33 Buildrequires:  pcre-devel
34 #BuildRequires: kdebindings-kjsembed-devel 
35 Requires:       kdebase-core >= 9:3.1.93
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 A KDE audio player.
40
41 %description -l pl
42 Odtwarzacz audio dla KDE.
43
44 %package gstreamer
45 Summary:        Plugin gstreamer
46 Summary(pl):    Wtyczka gstreamer
47 Group:          X11/Applications/Multimedia
48 Requires:       %{name} = %{version}-%{release}
49
50 %description gstreamer
51 Plugin gstreamer.
52
53 %description gstreamer -l pl
54 Wtyczka gstreamer.
55
56 %package xine
57 Summary:        Plugin xine
58 Summary(pl):    Wtyczka xine
59 Group:          X11/Applications/Multimedia
60 Requires:       %{name} = %{version}-%{release}
61
62 %description xine
63 Plugin xine.
64
65 %description xine -l pl
66 Wtyczka xine.
67
68 %prep
69 %setup -q -n %{name}-%{version}
70
71 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
72         amarok/src/amarok.desktop \
73
74 %build
75 cp -f %{_datadir}/automake/config.sub admin
76
77 export UNSERMAKE=%{_datadir}/unsermake/unsermake
78
79 %{__make} -f admin/Makefile.common cvs
80
81 %configure \
82         --disable-rpath \
83         %{!?with_xine:--without-xine} \
84         %{!?with_gstreamer:--without-gstreamer} \
85         --with-qt-libraries=%{_libdir} \
86         --without-included-sqlite
87
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT \
95         kde_htmldir=%{_kdedocdir} \
96         kde_libs_htmldir=%{_kdedocdir}
97
98 %find_lang amarok --all-name --with-kde
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files -f %{name}.lang
104 %defattr(644,root,root,755)
105 %doc AUTHORS ChangeLog README TODO
106 %attr(755,root,root) %{_bindir}/amarok
107 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
108 %attr(755,root,root) %{_bindir}/amarokapp
109 %attr(755,root,root) %{_bindir}/amarok_libvisual
110 %attr(755,root,root) %{_bindir}/release_amarok
111 %{_libdir}/kde3/libamarok_artsengine_plugin.la
112 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
113 %{_libdir}/kde3/libamarok_void-engine_plugin.la
114 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
115 %{_libdir}/libamarokarts.la
116 %attr(755,root,root) %{_libdir}/libamarokarts.so
117 %{_libdir}/mcop/Amarok
118 %{_libdir}/mcop/amarokarts.mcopclass
119 %{_libdir}/mcop/amarokarts.mcoptype
120 %{_datadir}/apps/amarok
121 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
122 %{_datadir}/config.kcfg/amarok.kcfg
123 %{_datadir}/services/amarok_artsengine_plugin.desktop
124 %{_datadir}/services/amarok_void-engine_plugin.desktop
125 %{_datadir}/servicetypes/amarok_plugin.desktop
126 %{_desktopdir}/kde/amarok.desktop
127 %{_iconsdir}/*/*/apps/amarok.png
128 %{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
129 %{_datadir}/config/*
130
131 %if %{with gstreamer}
132 %files gstreamer
133 %defattr(644,root,root,755)
134 %{_libdir}/kde3/libamarok_gstengine_plugin.la
135 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
136 %{_datadir}/config.kcfg/gstconfig.kcfg
137 %{_datadir}/services/amarok_gstengine_plugin.desktop
138 %endif
139
140 %if %{with xine}
141 %files xine
142 %defattr(644,root,root,755)
143 %{_libdir}/kde3/libamarok_xine-engine.la
144 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
145 %{_datadir}/services/amarok_xine-engine.desktop
146 %{_datadir}/services/amarok_xineengine_plugin.desktop
147 %endif
This page took 0.0778990000000001 seconds and 3 git commands to generate.