]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- added --with-nmm to configure
[packages/amarok.git] / amarok.spec
1 #
2 # TODO:
3 #       * postgresql support alongside mysql
4 #       * NMM audio backend support (fix build - propably some BRs)
5 #       * make descriptions less useless
6 #       * HelixPlayer engine (fix build - propably some BRs)
7 #
8 # Conditional builds:
9 %bcond_without  arts            # disable arts engine
10 %bcond_without  gstreamer       # disable gstreamer
11 %bcond_without  mas             # disable MAS audio backend
12 %bcond_without  xine            # disable xine engine
13 %bcond_without  xmms            # disable xmms wrapping
14 %bcond_without  zeroconf        # disable suport for zeroconf
15 %bcond_with     helix           # enable HelixPlayer engine
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable mysql support
18 %bcond_with     akode           # enable aKode engine (too buggy/incomplete)
19 #
20 #%define        _beta   beta3
21 Summary:        A KDE audio player
22 Summary(pl):    Odtwarzacz audio dla KDE
23 Name:           amarok
24 Version:        1.3
25 #Release:       0.%{_beta}.2
26 Release:        1
27 License:        GPL
28 Group:          X11/Applications/Multimedia
29 #Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}-%{_beta}.tar.bz2
30 Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
31 # Source0-md5:  2dd100584795fb20c621fdbc96cbee1e
32 Patch0:         kde-common-gcc4.patch
33 URL:            http://amarok.kde.org/
34 BuildRequires:  SDL-devel
35 BuildRequires:  alsa-lib-devel
36 BuildRequires:  arts-qt-devel
37 BuildRequires:  automake
38 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.1}
39 BuildRequires:  kdebase-devel
40 %{?with_akode:BuildRequires:    kdemultimedia-akode}
41 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
42 BuildRequires:  libltdl-devel
43 BuildRequires:  libmusicbrainz-devel
44 BuildRequires:  libvisual-devel >= 0.2.0
45 BuildRequires:  pcre-devel
46 BuildRequires:  rpmbuild(macros) >= 1.129
47 BuildRequires:  sed >= 4.0
48 BuildRequires:  sqlite3-devel
49 BuildRequires:  taglib-devel >= 1.4
50 #BuildRequires: unsermake >= 040511
51 %{?with_xine:BuildRequires:             xine-lib-devel >= 2:1.0-0.rc5.0}
52 %{?with_xmms:BuildRequires:             xmms-devel}
53 %{?with_mysql:BuildRequires:            mysql-devel}
54 #BuildRequires: kdebindings-kjsembed-devel
55 Requires:       %{name}-plugin = %{version}-%{release}
56 Requires:       kdebase-core >= 9:3.1.93
57 Requires:       kdemultimedia-audiocd >= 9:3.1.93
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 A KDE audio player.
62
63 %description -l pl
64 Odtwarzacz audio dla KDE.
65
66 %package arts
67 Summary:        Plugin arts
68 Summary(pl):    Wtyczka arts
69 Group:          X11/Applications/Multimedia
70 PreReq:         %{name} = %{version}-%{release}
71 Provides:       %{name}-plugin = %{version}-%{release}
72
73 %description arts
74 Plugin arts.
75
76 %description arts -l pl
77 Wtyczka arts.
78
79 %package akode
80 Summary:        Plugin akode
81 Summary(pl):    Wtyczka akode
82 Group:          X11/Applications/Multimedia
83 PreReq:         %{name} = %{version}-%{release}
84 Provides:       %{name}-plugin = %{version}-%{release}
85
86 %description akode
87 Plugin akode.
88
89 %description akode -l pl
90 Wtyczka akode.
91
92 %package gstreamer
93 Summary:        Plugin gstreamer
94 Summary(pl):    Wtyczka gstreamer
95 Group:          X11/Applications/Multimedia
96 PreReq:         %{name} = %{version}-%{release}
97 # needed libs
98 # at least /usr/lib/gstreamer-0.8/libgstresample.so
99 # probably /usr/lib/gstreamer-0.8/libgstadder.so
100 # and probably /usr/lib/gstreamer-0.8/libgstvolume.so
101 Requires:       gstreamer-audio-effects
102 Provides:       %{name}-plugin = %{version}-%{release}
103
104 %description gstreamer
105 Plugin gstreamer.
106
107 %description gstreamer -l pl
108 Wtyczka gstreamer.
109
110 %package xine
111 Summary:        Plugin xine
112 Summary(pl):    Wtyczka xine
113 Group:          X11/Applications/Multimedia
114 PreReq:         %{name} = %{version}-%{release}
115 Provides:       %{name}-plugin = %{version}-%{release}
116
117 %description xine
118 Plugin xine.
119
120 %description xine -l pl
121 Wtyczka xine.
122
123 %package zeroconf
124 Summary:        Zeroconf data
125 Summary(pl):    Dane dla zeroconf
126 Group:          X11/Applications/Multimedia
127 PreReq:         %{name} = %{version}-%{release}
128 Requires:       kdenetwork-kdnssd
129 Provides:       %{name}-plugin = %{version}-%{release}
130
131 %description zeroconf
132 Zeroconf data.
133
134 %description zeroconf -l pl
135 Zeroconf data.
136
137 %prep
138 #%setup -q -n %{name}-%{version}-%{_beta}
139 %setup -q
140 %patch0 -p1
141 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
142         amarok/src/amarok.desktop \
143
144 %build
145 cp -f /usr/share/automake/config.sub admin
146
147 #export UNSERMAKE=/usr/share/unsermake/unsermake
148
149 %{__make} -f admin/Makefile.common cvs
150
151 %configure \
152         --disable-rpath \
153         %{!?with_arts:--without-arts} \
154         %{?with_mas:--with-mas} \
155         %{!?with_xine:--without-xine} \
156         %{!?with_gstreamer:--without-gstreamer} \
157         %{!?with_akode:--without-akode} \
158         %{?with_helix:--with-helix} \
159         %{?with_nmm:--with-nmm} \
160         %{?with_mysql:--with-mysql} \
161         --disable-final \
162         --with-qt-libraries=%{_libdir} \
163         --without-included-sqlite
164
165 %{__make}
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169
170 %{__make} install \
171         DESTDIR=$RPM_BUILD_ROOT \
172         kde_htmldir=%{_kdedocdir} \
173         kde_libs_htmldir=%{_kdedocdir}
174
175 # remove bogus dir
176 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
177
178 %find_lang amarok --all-name --with-kde
179
180 %clean
181 rm -rf $RPM_BUILD_ROOT
182
183 %post
184 echo "Remember to install libvisual-plugins-* packages if you"
185 echo "want to have a visualizations in amarok."
186
187 %files -f %{name}.lang
188 %defattr(644,root,root,755)
189 %doc AUTHORS ChangeLog README TODO
190 %attr(755,root,root) %{_bindir}/amarok
191 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
192 %attr(755,root,root) %{_bindir}/amarokapp
193 %attr(755,root,root) %{_bindir}/amarok_libvisual
194 #%attr(755,root,root) %{_bindir}/release_amarok
195 %{_libdir}/kde3/konqsidebar_universalamarok.la
196 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
197 %{_libdir}/kde3/libamarok_void-engine_plugin.la
198 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
199 %{_datadir}/apps/amarok
200 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
201 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
202 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
203 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
204 %{_datadir}/apps/profiles/amarok.profile.xml
205 %{_datadir}/config/amarokrc
206 %{_datadir}/config.kcfg/amarok.kcfg
207 %{_datadir}/services/amarok_void-engine_plugin.desktop
208 %{_datadir}/servicetypes/amarok_plugin.desktop
209 %{_desktopdir}/kde/amarok.desktop
210 %{_iconsdir}/*/*/apps/amarok.*
211
212 %if %{with arts}
213 %files arts
214 %defattr(644,root,root,755)
215 %{_libdir}/kde3/libamarok_artsengine_plugin.la
216 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
217 %{_libdir}/libamarokarts.la
218 %attr(755,root,root) %{_libdir}/libamarokarts.so
219 %{_libdir}/mcop/Amarok
220 %{_libdir}/mcop/amarokarts.mcopclass
221 %{_libdir}/mcop/amarokarts.mcoptype
222 %{_datadir}/services/amarok_artsengine_plugin.desktop
223 %endif
224
225 %if %{with akode}
226 %files akode
227 %defattr(644,root,root,755)
228 %{_libdir}/kde3/libamarok_aKode-engine.la
229 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
230 %{_datadir}/services/amarok_aKode-engine.desktop
231 %endif
232
233 %if %{with gstreamer}
234 %files gstreamer
235 %defattr(644,root,root,755)
236 %{_libdir}/kde3/libamarok_gstengine_plugin.la
237 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
238 %{_datadir}/config.kcfg/gstconfig.kcfg
239 %{_datadir}/services/amarok_gstengine_plugin.desktop
240 %endif
241
242 %if %{with xine}
243 %files xine
244 %defattr(644,root,root,755)
245 %{_libdir}/kde3/libamarok_xine-engine.la
246 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
247 %{_datadir}/config.kcfg/xinecfg.kcfg
248 %{_datadir}/services/amarok_xine-engine.desktop
249 #%{_datadir}/services/amarok_xineengine_plugin.desktop
250 %endif
251
252 %if %{with zeroconf}
253 %files zeroconf
254 %defattr(644,root,root,755)
255 %{_datadir}/apps/zeroconf/_shoutcast._tcp
256 %endif
This page took 0.045164 seconds and 3 git commands to generate.