]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- fix problems with autoconf 2.60 which creates configure that runs in POSIX mode
[packages/amarok.git] / amarok.spec
1 # TODO:
2 # - postgresql support alongside mysql
3 # - NMM audio backend support (fix build - propably some BRs)
4 # - make descriptions less useless
5 # - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 # - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 # - main package pulls /usr/bin/ruby
8 #
9 # Conditional builds:
10 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
11 %bcond_without  mas             # disable MAS audio backend
12 %bcond_without  xine            # disable xine engine
13 %bcond_without  xmms            # disable xmms wrapping
14 %bcond_without  zeroconf        # disable support for zeroconf
15 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
16 %bcond_without  helix           # disable HelixPlayer engine
17 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
18 %bcond_with     nmm             # enable NMM audio backend
19 %bcond_with     mysql           # enable MySQL support
20 %bcond_with     pgsql           # enable PostgreSQL support
21 #
22 %ifarch i386
23 %undefine       with_helix
24 %endif
25
26 Summary:        A KDE audio player
27 Summary(pl):    Odtwarzacz audio dla KDE
28 Name:           amarok
29 Version:        1.4.3
30 Release:        1
31 License:        GPL
32 Group:          X11/Applications/Multimedia
33 #Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
34 Source0:        http://mirrors.isc.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
35 # Source0-md5:  b0b4f8952ad23705c70815d50fd0af52
36 Patch0:         %{name}-helixplayer-morearchs.patch
37 Patch1:         %{name}-libnjb.patch
38 URL:            http://amarok.kde.org/
39 BuildRequires:  SDL-devel
40 BuildRequires:  alsa-lib-devel
41 BuildRequires:  autoconf
42 BuildRequires:  automake
43 BuildRequires:  dbus-glib-devel
44 BuildRequires:  gettext-devel
45 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
46 BuildRequires:  kdebase-devel
47 %{?with_akode:BuildRequires:    kdemultimedia-akode}
48 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
49 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
50 %{?with_mp3players:BuildRequires:       libifp-devel}
51 %{?with_mp3players:BuildRequires:       libmtp-devel}
52 %{?with_mp3players:BuildRequires:       libnjb-devel}
53 BuildRequires:  libltdl-devel
54 %{?with_pgsql:BuildRequires:            libpqxx-devel}
55 BuildRequires:  libtunepimp-devel >= 0.4.0
56 BuildRequires:  libvisual-devel >= 0.4.0
57 BuildRequires:  mpeg4ip-devel
58 %{?with_mysql:BuildRequires:            mysql-devel}
59 BuildRequires:  pcre-devel
60 BuildRequires:  pkgconfig
61 BuildRequires:  rpm-pythonprov
62 BuildRequires:  rpmbuild(macros) >= 1.129
63 BuildRequires:  ruby-devel >= 1.8
64 BuildRequires:  sed >= 4.0
65 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
66 BuildRequires:  taglib-devel >= 1.4
67 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
68 %{?with_xmms:BuildRequires:     xmms-devel}
69 Requires(post): /sbin/ldconfig
70 Requires:       %{name}-plugin = %{version}-%{release}
71 Requires:       kdebase-core >= 9:3.1.93
72 Requires:       kdemultimedia-audiocd >= 9:3.1.93
73 Obsoletes:      amarok-arts
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 A KDE audio player.
78
79 %description -l pl
80 Odtwarzacz audio dla KDE.
81
82 %package akode
83 Summary:        Plugin akode
84 Summary(pl):    Wtyczka akode
85 Group:          X11/Applications/Multimedia
86 Requires:       %{name} = %{version}-%{release}
87 Provides:       %{name}-plugin = %{version}-%{release}
88
89 %description akode
90 Plugin akode.
91
92 %description akode -l pl
93 Wtyczka akode.
94
95 %package helix
96 Summary:        Helix/Realplayer playback support for amarok
97 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
98 Group:          X11/Applications/Multimedia
99 Requires:       %{name} = %{version}-%{release}
100 Requires:       helix-core
101 Provides:       %{name}-plugin = %{version}-%{release}
102
103 %description helix
104 Helix/Realplayer playback support for amarok.
105
106 %description helix -l pl
107 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
108
109 %package gstreamer
110 Summary:        Plugin gstreamer
111 Summary(pl):    Wtyczka gstreamer
112 Group:          X11/Applications/Multimedia
113 # deps, to get it working:
114 # mp3 decoder:  gstreamer-mad
115 # ogg decoder:  gstreamer-vorbis
116 # audio output driver:  gstreamer-audiosink-alsa
117 # from gstreamer-audio-effects to control volume, etc
118 # needed libs:
119 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
120 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
121 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
122 # gstreamer-musicbrainz for being able to edit id3 tags on files.
123 Requires:       %{name} = %{version}-%{release}
124 Requires:       gstreamer-audio-effects
125 Requires:       gstreamer-audiosink
126 Requires:       gstreamer-mad
127 Requires:       gstreamer-musicbrainz
128 Requires:       gstreamer-vorbis
129 Provides:       %{name}-plugin = %{version}-%{release}
130
131 %description gstreamer
132 Plugin gstreamer.
133
134 %description gstreamer -l pl
135 Wtyczka gstreamer.
136
137 %package xine
138 Summary:        Plugin xine
139 Summary(pl):    Wtyczka xine
140 Group:          X11/Applications/Multimedia
141 Requires:       %{name} = %{version}-%{release}
142 Requires:       xine-plugin-audio
143 Provides:       %{name}-plugin = %{version}-%{release}
144
145 %description xine
146 Plugin xine.
147
148 %description xine -l pl
149 Wtyczka xine.
150
151 %package xmms
152 Summary:        Xmms wrapper
153 Summary(pl):    Wrapper xmms
154 Group:          X11/Applications/Multimedia
155 Requires:       %{name} = %{version}-%{release}
156
157 %description xmms
158 Xmms wrapper.
159
160 %description xmms -l pl
161 Wrapper xmms.
162
163 %package zeroconf
164 Summary:        Zeroconf data
165 Summary(pl):    Dane dla zeroconf
166 Group:          X11/Applications/Multimedia
167 Requires:       %{name} = %{version}-%{release}
168 Requires:       kdenetwork-kdnssd
169 Provides:       %{name}-plugin = %{version}-%{release}
170
171 %description zeroconf
172 Zeroconf data.
173
174 %description zeroconf -l pl
175 Dane dla zeroconf.
176
177 %package scripts
178 Summary:        amaroK scripts
179 Summary(pl):    Skrypty amaroKa
180 Group:          X11/Applications/Multimedia
181 Requires:       %{name} = %{version}-%{release}
182 Requires:       kdebase-kdialog
183 Requires:       python-PyQt
184 Requires:       ruby-modules
185
186 %description scripts
187 amaroK scripts allow you extend amaroK functionality.
188
189 You can learn more about scripts in amaroK from here:
190 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
191
192 %description scripts -l pl
193 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
194
195 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
196 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
197
198 %prep
199 %setup -q
200 %patch0 -p1
201 %patch1 -p1
202 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
203         amarok/src/amarok.desktop \
204
205 # see kde bug #110909
206 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
207
208 # kill env, call interpreter directly, so rpm automatics could rule
209 %{__sed} -i -e '
210         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
211         1s,#!.*bin/env.*python,#!%{_bindir}/python,
212         1s,#!.*bin/env.*bash,#!/bin/bash,
213 ' amarok/src/scripts/*/*.{py,rb,sh} amarok/src/amarok_proxy.rb
214
215 %build
216 cp -f /usr/share/automake/config.sub admin
217 %{__make} -f admin/Makefile.common cvs
218
219 # hack: passing something other than "no" or "yes" to --with-helix allows
220 # us to pass HELIX_LIBS
221 %configure \
222         HELIX_LIBS=%{_libdir}/helixplayer \
223         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
224         --disable-rpath \
225         --with%{!?with_mas:out}-mas \
226         --with%{!?with_xine:out}-xine \
227         --with%{!?with_gstreamer:out}-gstreamer10 \
228         --with%{!?with_akode:out}-akode \
229         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
230         --with%{!?with_nmm:out}-nmm \
231         --with%{!?with_xmms:out}-xmms \
232         --with%{!?with_mp3players:out}-libgpod \
233         --with%{!?with_mp3players:out}-libnjb \
234         --with%{!?with_mp3players:out}-libmtp \
235         --with%{!?with_mp3players:out}-ifp \
236         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
237         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
238         --disable-final \
239         --with-mp4v2 \
240         --with-qt-libraries=%{_libdir} \
241         --with%{!?with_included_sqlite:out}-included-sqlite
242
243 %{__make}
244
245 %install
246 rm -rf $RPM_BUILD_ROOT
247
248 %{__make} install \
249         DESTDIR=$RPM_BUILD_ROOT \
250         kde_htmldir=%{_kdedocdir} \
251         kde_libs_htmldir=%{_kdedocdir}
252
253 # remove bogus dir
254 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
255
256 %find_lang amarok --all-name --with-kde
257
258 %clean
259 rm -rf $RPM_BUILD_ROOT
260
261 %post
262 /sbin/ldconfig
263 if [ "$1" = 1 ]; then
264         echo "Remember to install libvisual-plugins-* packages if you"
265         echo "want to have a visualizations in amaroK."
266 fi
267
268 %postun -p /sbin/ldconfig
269
270 %files -f %{name}.lang
271 %defattr(644,root,root,755)
272 %doc AUTHORS ChangeLog README
273 %attr(755,root,root) %{_bindir}/amarok
274 %attr(755,root,root) %{_bindir}/amarokapp
275 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
276 %attr(755,root,root) %{_bindir}/amarok_libvisual
277 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
278 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
279 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
280 %{_libdir}/kde3/konqsidebar_universalamarok.la
281 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
282 %{_libdir}/kde3/libamarok_generic-mediadevice.la
283 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
284 %{_libdir}/kde3/libamarok_void-engine_plugin.la
285 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
286 %{_libdir}/libamarok.la
287 %{_libdir}/kde3/libamarok_daap-mediadevice.la
288 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
289 %{_libdir}/kde3/libamarok_massstorage-device.la
290 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
291 %{_libdir}/kde3/libamarok_nfs-device.la
292 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
293 %{_libdir}/kde3/libamarok_smb-device.la
294 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
295 %dir %{_datadir}/apps/amarok
296 %dir %{_datadir}/apps/amarok/scripts
297 %{_datadir}/apps/amarok/ruby_lib
298 %{_datadir}/apps/amarok/*.rc
299 %{_datadir}/apps/amarok/data
300 %{_datadir}/apps/amarok/icons
301 %{_datadir}/apps/amarok/images
302 %{_datadir}/apps/amarok/themes
303 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
304 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
305 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
306 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
307 %{_datadir}/apps/profiles/amarok.profile.xml
308 %{_datadir}/config/amarokrc
309 %{_datadir}/config.kcfg/amarok.kcfg
310 %{_datadir}/services/amarok_generic-mediadevice.desktop
311 %{_datadir}/services/amarok_void-engine_plugin.desktop
312 %{_datadir}/services/amarok_daap-mediadevice.desktop
313 %{_datadir}/services/amarok_massstorage-device.desktop
314 %{_datadir}/services/amarok_nfs-device.desktop
315 %{_datadir}/services/amarok_smb-device.desktop
316 %{_datadir}/services/amaroklastfm.protocol
317 %{_datadir}/services/amarokitpc.protocol
318 %{_datadir}/services/amarokpcast.protocol
319 %{_datadir}/servicetypes/amarok_codecinstall.desktop
320 %{_datadir}/servicetypes/amarok_plugin.desktop
321 %{_desktopdir}/kde/amarok.desktop
322 %{_iconsdir}/*/*/apps/amarok.*
323 # TODO: move to subpackage
324 %if %{with mp3players}
325 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
326 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
327 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
328 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
329 %{_libdir}/kde3/libamarok_mtp-mediadevice.la
330 %attr(755,root,root) %{_libdir}/kde3/libamarok_mtp-mediadevice.so
331 %{_libdir}/kde3/libamarok_njb-mediadevice.la
332 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
333 %{_datadir}/services/amarok_ifp-mediadevice.desktop
334 %{_datadir}/services/amarok_ipod-mediadevice.desktop
335 %{_datadir}/services/amarok_mtp-mediadevice.desktop
336 %{_datadir}/services/amarok_njb-mediadevice.desktop
337 %endif
338
339 %if %{with akode}
340 %files akode
341 %defattr(644,root,root,755)
342 %{_libdir}/kde3/libamarok_aKode-engine.la
343 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
344 %{_datadir}/services/amarok_aKode-engine.desktop
345 %endif
346
347 %if %{with gstreamer}
348 %files gstreamer
349 %defattr(644,root,root,755)
350 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
351 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
352 %{_datadir}/config.kcfg/gstconfig.kcfg
353 %{_datadir}/services/amarok_gst10engine_plugin.desktop
354 %endif
355
356 %if %{with helix}
357 %files helix
358 %defattr(644,root,root,755)
359 %{_libdir}/kde3/libamarok_helixengine_plugin.la
360 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
361 %{_datadir}/config.kcfg/helixconfig.kcfg
362 %{_datadir}/services/amarok_helixengine_plugin.desktop
363 %endif
364
365 %if %{with xine}
366 %files xine
367 %defattr(644,root,root,755)
368 %{_libdir}/kde3/libamarok_xine-engine.la
369 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
370 %{_datadir}/config.kcfg/xinecfg.kcfg
371 %{_datadir}/services/amarok_xine-engine.desktop
372 %endif
373
374 %if %{with xmms}
375 %files xmms
376 %defattr(644,root,root,755)
377 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
378 %endif
379
380 %if 0
381 %if %{with zeroconf}
382 %files zeroconf
383 %defattr(644,root,root,755)
384 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
385 %endif
386 %endif
387
388 %files scripts
389 %defattr(644,root,root,755)
390 %dir %{_datadir}/apps/amarok/scripts/common
391 %{_datadir}/apps/amarok/scripts/common/Publisher.py
392 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
393
394 %dir %{_datadir}/apps/amarok/scripts/templates
395 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
396 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
397 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
398
399 # amarok searches for executable programs for scripts
400 # to figure out which files need to have execute permission, use this
401 # find command:
402 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
403
404 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
405 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
406 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
407
408 %dir %{_datadir}/apps/amarok/scripts/playlist2html
409 %{_datadir}/apps/amarok/scripts/playlist2html/README
410 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
411 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
412 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
413
414 %dir %{_datadir}/apps/amarok/scripts/webcontrol
415 %{_datadir}/apps/amarok/scripts/webcontrol/README
416 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
417 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
418 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
419 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
420 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
421 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
422 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
423 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
424 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
425 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
426 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
427 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
428 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
429 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
430 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
431 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
432 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
433 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
434 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
435
436 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
437 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
438 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
439 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
440 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
441
442 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
443 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
444 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
445 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
446 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
447
448 %dir %{_datadir}/apps/amarok/scripts/score_default
449 %{_datadir}/apps/amarok/scripts/score_default/COPYING
450 %{_datadir}/apps/amarok/scripts/score_default/README
451 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
452 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
453 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
454 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
455 %{_datadir}/apps/amarok/scripts/score_impulsive/README
456 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
457 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
458
459 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
460 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
461
462 %if 0
463 %dir %{_datadir}/apps/amarok/scripts/amarok_live
464 %{_datadir}/apps/amarok/scripts/amarok_live/README
465 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
466 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
467 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
468 %endif
This page took 0.077113 seconds and 3 git commands to generate.