]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- up to 1.4.1 stable
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       * postgresql support alongside mysql
3 #       * NMM audio backend support (fix build - propably some BRs)
4 #       * make descriptions less useless
5 #       * track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #
7 # Conditional builds:
8 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
9 %bcond_without  mas             # disable MAS audio backend
10 %bcond_without  xine            # disable xine engine
11 %bcond_without  xmms            # disable xmms wrapping
12 %bcond_without  zeroconf        # disable support for zeroconf
13 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA)
14 %bcond_without  helix           # disable HelixPlayer engine
15 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
16 %bcond_with     nmm             # enable NMM audio backend
17 %bcond_with     mysql           # enable MySQL support
18 %bcond_with     pgsql           # enable PostgreSQL support
19 #
20 %ifarch i386
21 %undefine       with_helix
22 %endif
23
24 Summary:        A KDE audio player
25 Summary(pl):    Odtwarzacz audio dla KDE
26 Name:           amarok
27 Version:        1.4.1
28 Release:        1
29 License:        GPL
30 Group:          X11/Applications/Multimedia
31 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
32 # Source0-md5:  4ed6e766541c4227d1d8c8eb93d0b891
33 Patch0:         %{name}-helixplayer-morearchs.patch
34 Patch1:         %{name}-libnjb.patch
35 URL:            http://amarok.kde.org/
36 BuildRequires:  SDL-devel
37 BuildRequires:  alsa-lib-devel
38 BuildRequires:  autoconf
39 BuildRequires:  automake
40 BuildRequires:  dbus-glib-devel
41 BuildRequires:  gettext-devel
42 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
43 BuildRequires:  kdebase-devel
44 %{?with_akode:BuildRequires:    kdemultimedia-akode}
45 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
46 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
47 %{?with_mp3players:BuildRequires:       libifp-devel}
48 BuildRequires:  libltdl-devel
49 %{?with_mp3players:BuildRequires:       libnjb-devel}
50 %{?with_pgsql:BuildRequires:            libpqxx-devel}
51 BuildRequires:  libtunepimp-devel >= 0.4.0
52 BuildRequires:  libvisual-devel >= 0.4.0
53 BuildRequires:  mpeg4ip-devel
54 %{?with_mysql:BuildRequires:            mysql-devel}
55 BuildRequires:  pcre-devel
56 BuildRequires:  pkgconfig
57 BuildRequires:  rpm-pythonprov
58 BuildRequires:  rpmbuild(macros) >= 1.129
59 BuildRequires:  ruby-devel >= 1.8
60 BuildRequires:  sed >= 4.0
61 %{!?with_included_sqlite:BuildRequires: sqlite3-devel}
62 BuildRequires:  taglib-devel >= 1.4
63 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
64 %{?with_xmms:BuildRequires:     xmms-devel}
65 Requires:       %{name}-plugin = %{version}-%{release}
66 Requires:       kdebase-core >= 9:3.1.93
67 Requires:       kdemultimedia-audiocd >= 9:3.1.93
68 Obsoletes:      amarok-arts
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %description
72 A KDE audio player.
73
74 %description -l pl
75 Odtwarzacz audio dla KDE.
76
77 %package akode
78 Summary:        Plugin akode
79 Summary(pl):    Wtyczka akode
80 Group:          X11/Applications/Multimedia
81 Requires:       %{name} = %{version}-%{release}
82 Provides:       %{name}-plugin = %{version}-%{release}
83
84 %description akode
85 Plugin akode.
86
87 %description akode -l pl
88 Wtyczka akode.
89
90 %package helix
91 Summary:        Helix/Realplayer playback support for amarok
92 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
93 Group:          X11/Applications/Multimedia
94 Requires:       %{name} = %{version}-%{release}
95 Requires:       helix-core
96 Provides:       %{name}-plugin = %{version}-%{release}
97
98 %description helix
99 Helix/Realplayer playback support for amarok.
100
101 %description helix -l pl
102 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
103
104 %package gstreamer
105 Summary:        Plugin gstreamer
106 Summary(pl):    Wtyczka gstreamer
107 Group:          X11/Applications/Multimedia
108 # deps, to get it working:
109 # mp3 decoder:  gstreamer-mad
110 # ogg decoder:  gstreamer-vorbis
111 # audio output driver:  gstreamer-audiosink-alsa
112 # from gstreamer-audio-effects to control volume, etc
113 # needed libs:
114 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
115 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
116 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
117 # gstreamer-musicbrainz for being able to edit id3 tags on files.
118 Requires:       %{name} = %{version}-%{release}
119 Requires:       gstreamer-audio-effects
120 Requires:       gstreamer-audiosink
121 Requires:       gstreamer-mad
122 Requires:       gstreamer-musicbrainz
123 Requires:       gstreamer-vorbis
124 Provides:       %{name}-plugin = %{version}-%{release}
125
126 %description gstreamer
127 Plugin gstreamer.
128
129 %description gstreamer -l pl
130 Wtyczka gstreamer.
131
132 %package xine
133 Summary:        Plugin xine
134 Summary(pl):    Wtyczka xine
135 Group:          X11/Applications/Multimedia
136 Requires:       %{name} = %{version}-%{release}
137 Requires:       xine-plugin-audio
138 Provides:       %{name}-plugin = %{version}-%{release}
139
140 %description xine
141 Plugin xine.
142
143 %description xine -l pl
144 Wtyczka xine.
145
146 %package xmms
147 Summary:        Xmms wrapper
148 Summary(pl):    Wrapper xmms
149 Group:          X11/Applications/Multimedia
150 Requires:       %{name} = %{version}-%{release}
151
152 %description xmms
153 Xmms wrapper.
154
155 %description xmms -l pl
156 Wrapper xmms.
157
158 %package zeroconf
159 Summary:        Zeroconf data
160 Summary(pl):    Dane dla zeroconf
161 Group:          X11/Applications/Multimedia
162 Requires:       %{name} = %{version}-%{release}
163 Requires:       kdenetwork-kdnssd
164 Provides:       %{name}-plugin = %{version}-%{release}
165
166 %description zeroconf
167 Zeroconf data.
168
169 %description zeroconf -l pl
170 Dane dla zeroconf.
171
172 %package scripts
173 Summary:        amaroK scripts
174 Summary(pl):    Skrypty amaroKa
175 Group:          X11/Applications/Multimedia
176 Requires:       %{name} = %{version}-%{release}
177 Requires:       kdebase-kdialog
178 Requires:       python-PyQt
179 Requires:       ruby-modules
180
181 %description scripts
182 amaroK scripts allow you extend amaroK functionality.
183
184 You can learn more about scripts in amaroK from here:
185 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
186
187 %description scripts -l pl
188 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
189
190 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
191 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
192
193 %prep
194 %setup -q
195 %patch0 -p1
196 %patch1 -p1
197 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
198         amarok/src/amarok.desktop \
199
200 # see kde bug #110909
201 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
202
203 # kill env, call interpreter directly, so rpm automatics could rule
204 %{__sed} -i -e '
205         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
206         1s,#!.*bin/env.*python,#!%{_bindir}/python,
207         1s,#!.*bin/env.*bash,#!/bin/bash,
208 ' amarok/src/scripts/*/*.{py,rb,sh}
209
210 %build
211 cp -f /usr/share/automake/config.sub admin
212 %{__make} -f admin/Makefile.common cvs
213
214 # hack: passing something other than "no" or "yes" to --with-helix allows
215 # us to pass HELIX_LIBS
216 %configure \
217         HELIX_LIBS=%{_libdir}/helixplayer \
218         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
219         --disable-rpath \
220         --with%{!?with_mas:out}-mas \
221         --with%{!?with_xine:out}-xine \
222         --with%{!?with_gstreamer:out}-gstreamer10 \
223         --with%{!?with_akode:out}-akode \
224         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
225         --with%{!?with_nmm:out}-nmm \
226         --with%{!?with_mp3players:out}-libgpod \
227         --with%{!?with_mp3players:out}-libnjb \
228         --with%{!?with_mp3players:out}-ifp \
229         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
230         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
231         --disable-final \
232         --with-mp4v2 \
233         --with-qt-libraries=%{_libdir} \
234         --with%{!?with_included_sqlite:out}-included-sqlite
235
236 %{__make}
237
238 %install
239 rm -rf $RPM_BUILD_ROOT
240
241 %{__make} install \
242         DESTDIR=$RPM_BUILD_ROOT \
243         kde_htmldir=%{_kdedocdir} \
244         kde_libs_htmldir=%{_kdedocdir}
245
246 # remove bogus dir
247 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
248
249 %find_lang amarok --all-name --with-kde
250
251 %clean
252 rm -rf $RPM_BUILD_ROOT
253
254 if [ "$1" = 1 ]; then
255         echo "Remember to install libvisual-plugins-* packages if you"
256         echo "want to have a visualizations in amaroK."
257 fi
258
259 %post   -p /sbin/ldconfig
260 %postun -p /sbin/ldconfig
261
262 %files -f %{name}.lang
263 %defattr(644,root,root,755)
264 %doc AUTHORS ChangeLog README
265 %attr(755,root,root) %{_bindir}/amarok
266 %attr(755,root,root) %{_bindir}/amarokapp
267 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
268 %attr(755,root,root) %{_bindir}/amarok_libvisual
269 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
270 %{_libdir}/kde3/konqsidebar_universalamarok.la
271 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
272 %{_libdir}/kde3/libamarok_generic-mediadevice.la
273 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
274 %{_libdir}/kde3/libamarok_njb-mediadevice.la
275 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
276 %{_libdir}/kde3/libamarok_void-engine_plugin.la
277 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
278 %{_libdir}/libamarok.la
279 %dir %{_datadir}/apps/amarok
280 %dir %{_datadir}/apps/amarok/scripts
281 %{_datadir}/apps/amarok/*.rc
282 %{_datadir}/apps/amarok/data
283 %{_datadir}/apps/amarok/icons
284 %{_datadir}/apps/amarok/images
285 %{_datadir}/apps/amarok/themes
286 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
287 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
288 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
289 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
290 %{_datadir}/apps/profiles/amarok.profile.xml
291 %{_datadir}/config/amarokrc
292 %{_datadir}/config.kcfg/amarok.kcfg
293 %{_datadir}/services/amarok_generic-mediadevice.desktop
294 %{_datadir}/services/amarok_void-engine_plugin.desktop
295 %{_datadir}/servicetypes/amarok_plugin.desktop
296 %{_desktopdir}/kde/amarok.desktop
297 %{_iconsdir}/*/*/apps/amarok.*
298 # TODO: move to subpackage
299 %if %{with mp3players}
300 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
301 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
302 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
303 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
304 %{_datadir}/services/amarok_ipod-mediadevice.desktop
305 %{_datadir}/services/amarok_ifp-mediadevice.desktop
306 %{_datadir}/services/amarok_njb-mediadevice.desktop
307 %endif
308
309 %if %{with akode}
310 %files akode
311 %defattr(644,root,root,755)
312 %{_libdir}/kde3/libamarok_aKode-engine.la
313 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
314 %{_datadir}/services/amarok_aKode-engine.desktop
315 %endif
316
317 %if %{with gstreamer}
318 %files gstreamer
319 %defattr(644,root,root,755)
320 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
321 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
322 %{_datadir}/config.kcfg/gstconfig.kcfg
323 %{_datadir}/services/amarok_gst10engine_plugin.desktop
324 %endif
325
326 %if %{with helix}
327 %files helix
328 %defattr(644,root,root,755)
329 %{_libdir}/kde3/libamarok_helixengine_plugin.la
330 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
331 %{_datadir}/config.kcfg/helixconfig.kcfg
332 %{_datadir}/services/amarok_helixengine_plugin.desktop
333 %endif
334
335 %if %{with xine}
336 %files xine
337 %defattr(644,root,root,755)
338 %{_libdir}/kde3/libamarok_xine-engine.la
339 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
340 %{_datadir}/config.kcfg/xinecfg.kcfg
341 %{_datadir}/services/amarok_xine-engine.desktop
342 #%{_datadir}/services/amarok_xineengine_plugin.desktop
343 %endif
344
345 %if %{with xmms}
346 %files xmms
347 %defattr(644,root,root,755)
348 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
349 %endif
350
351 %if 0
352 %if %{with zeroconf}
353 %files zeroconf
354 %defattr(644,root,root,755)
355 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
356 %endif
357 %endif
358
359 %files scripts
360 %defattr(644,root,root,755)
361 %dir %{_datadir}/apps/amarok/scripts/common
362 %{_datadir}/apps/amarok/scripts/common/Publisher.py
363 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
364
365 %dir %{_datadir}/apps/amarok/scripts/templates
366 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
367 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
368 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
369
370 # amarok searches for executable programs for scripts
371 # to figure out which files need to have execute permission, use this
372 # find command:
373 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
374
375 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
376 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
377 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
378
379 %dir %{_datadir}/apps/amarok/scripts/playlist2html
380 %{_datadir}/apps/amarok/scripts/playlist2html/README
381 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
382 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
383 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
384
385 %dir %{_datadir}/apps/amarok/scripts/webcontrol
386 %{_datadir}/apps/amarok/scripts/webcontrol/README
387 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
388 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
389 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
390 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
391 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
392 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
393 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
394 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
395 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
396 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
397 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
398 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
399 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
400 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
401 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
402 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
403 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
404 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
405 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
406
407 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
408 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
409 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
410 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
411 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
412
413 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
414 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
415 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
416 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
417 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
418
419 %dir %{_datadir}/apps/amarok/scripts/score_default
420 %{_datadir}/apps/amarok/scripts/score_default/COPYING
421 %{_datadir}/apps/amarok/scripts/score_default/README
422 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
423 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
424 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
425 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
426 %{_datadir}/apps/amarok/scripts/score_impulsive/README
427 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
428 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
429
430 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
431 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
432
433 %if 0
434 %dir %{_datadir}/apps/amarok/scripts/amarok_live
435 %{_datadir}/apps/amarok/scripts/amarok_live/README
436 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
437 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
438 %attr(755,root,root)  %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
439 %endif
This page took 0.083398 seconds and 3 git commands to generate.