]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
2cd11a2593af529a7e3aa7d4567437701b62d901
[packages/amarok.git] / amarok.spec
1 # TODO:
2 #       - postgresql support alongside mysql
3 #       - NMM audio backend support (fix build - propably some BRs)
4 #       - make descriptions less useless
5 #       - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 #       - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 #
8 # Conditional builds:
9 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
10 %bcond_without  mas             # disable MAS audio backend
11 %bcond_without  xine            # disable xine engine
12 %bcond_without  xmms            # disable xmms wrapping
13 %bcond_without  zeroconf        # disable support for zeroconf
14 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
15 %bcond_without  helix           # disable HelixPlayer engine
16 %bcond_without  mp3players      # disable iPod and iRiver MP3 players support
17 %bcond_with     nmm             # enable NMM audio backend
18 %bcond_with     mysql           # enable MySQL support
19 %bcond_with     pgsql           # enable PostgreSQL support
20 #
21 %ifarch i386
22 %undefine       with_helix
23 %endif
24
25 Summary:        A KDE audio player
26 Summary(pl):    Odtwarzacz audio dla KDE
27 Name:           amarok
28 Version:        1.4.1
29 Release:        2
30 License:        GPL
31 Group:          X11/Applications/Multimedia
32 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
33 # Source0-md5:  4ed6e766541c4227d1d8c8eb93d0b891
34 Patch0:         %{name}-helixplayer-morearchs.patch
35 Patch1:         %{name}-libnjb.patch
36 URL:            http://amarok.kde.org/
37 BuildRequires:  SDL-devel
38 BuildRequires:  alsa-lib-devel
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 BuildRequires:  dbus-glib-devel
42 BuildRequires:  gettext-devel
43 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
44 BuildRequires:  kdebase-devel
45 %{?with_akode:BuildRequires:    kdemultimedia-akode}
46 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
47 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
48 %{?with_mp3players:BuildRequires:       libifp-devel}
49 BuildRequires:  libltdl-devel
50 %{?with_mp3players:BuildRequires:       libnjb-devel}
51 %{?with_pgsql:BuildRequires:            libpqxx-devel}
52 BuildRequires:  libtunepimp-devel >= 0.4.0
53 BuildRequires:  libvisual-devel >= 0.4.0
54 BuildRequires:  mpeg4ip-devel
55 %{?with_mysql:BuildRequires:            mysql-devel}
56 BuildRequires:  pcre-devel
57 BuildRequires:  pkgconfig
58 BuildRequires:  rpm-pythonprov
59 BuildRequires:  rpmbuild(macros) >= 1.129
60 BuildRequires:  ruby-devel >= 1.8
61 BuildRequires:  sed >= 4.0
62 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
63 BuildRequires:  taglib-devel >= 1.4
64 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
65 %{?with_xmms:BuildRequires:     xmms-devel}
66 Requires:       %{name}-plugin = %{version}-%{release}
67 Requires:       kdebase-core >= 9:3.1.93
68 Requires:       kdemultimedia-audiocd >= 9:3.1.93
69 Obsoletes:      amarok-arts
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %description
73 A KDE audio player.
74
75 %description -l pl
76 Odtwarzacz audio dla KDE.
77
78 %package akode
79 Summary:        Plugin akode
80 Summary(pl):    Wtyczka akode
81 Group:          X11/Applications/Multimedia
82 Requires:       %{name} = %{version}-%{release}
83 Provides:       %{name}-plugin = %{version}-%{release}
84
85 %description akode
86 Plugin akode.
87
88 %description akode -l pl
89 Wtyczka akode.
90
91 %package helix
92 Summary:        Helix/Realplayer playback support for amarok
93 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
94 Group:          X11/Applications/Multimedia
95 Requires:       %{name} = %{version}-%{release}
96 Requires:       helix-core
97 Provides:       %{name}-plugin = %{version}-%{release}
98
99 %description helix
100 Helix/Realplayer playback support for amarok.
101
102 %description helix -l pl
103 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
104
105 %package gstreamer
106 Summary:        Plugin gstreamer
107 Summary(pl):    Wtyczka gstreamer
108 Group:          X11/Applications/Multimedia
109 # deps, to get it working:
110 # mp3 decoder:  gstreamer-mad
111 # ogg decoder:  gstreamer-vorbis
112 # audio output driver:  gstreamer-audiosink-alsa
113 # from gstreamer-audio-effects to control volume, etc
114 # needed libs:
115 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
116 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
117 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
118 # gstreamer-musicbrainz for being able to edit id3 tags on files.
119 Requires:       %{name} = %{version}-%{release}
120 Requires:       gstreamer-audio-effects
121 Requires:       gstreamer-audiosink
122 Requires:       gstreamer-mad
123 Requires:       gstreamer-musicbrainz
124 Requires:       gstreamer-vorbis
125 Provides:       %{name}-plugin = %{version}-%{release}
126
127 %description gstreamer
128 Plugin gstreamer.
129
130 %description gstreamer -l pl
131 Wtyczka gstreamer.
132
133 %package xine
134 Summary:        Plugin xine
135 Summary(pl):    Wtyczka xine
136 Group:          X11/Applications/Multimedia
137 Requires:       %{name} = %{version}-%{release}
138 Requires:       xine-plugin-audio
139 Provides:       %{name}-plugin = %{version}-%{release}
140
141 %description xine
142 Plugin xine.
143
144 %description xine -l pl
145 Wtyczka xine.
146
147 %package xmms
148 Summary:        Xmms wrapper
149 Summary(pl):    Wrapper xmms
150 Group:          X11/Applications/Multimedia
151 Requires:       %{name} = %{version}-%{release}
152
153 %description xmms
154 Xmms wrapper.
155
156 %description xmms -l pl
157 Wrapper xmms.
158
159 %package zeroconf
160 Summary:        Zeroconf data
161 Summary(pl):    Dane dla zeroconf
162 Group:          X11/Applications/Multimedia
163 Requires:       %{name} = %{version}-%{release}
164 Requires:       kdenetwork-kdnssd
165 Provides:       %{name}-plugin = %{version}-%{release}
166
167 %description zeroconf
168 Zeroconf data.
169
170 %description zeroconf -l pl
171 Dane dla zeroconf.
172
173 %package scripts
174 Summary:        amaroK scripts
175 Summary(pl):    Skrypty amaroKa
176 Group:          X11/Applications/Multimedia
177 Requires:       %{name} = %{version}-%{release}
178 Requires:       kdebase-kdialog
179 Requires:       python-PyQt
180 Requires:       ruby-modules
181
182 %description scripts
183 amaroK scripts allow you extend amaroK functionality.
184
185 You can learn more about scripts in amaroK from here:
186 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
187
188 %description scripts -l pl
189 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
190
191 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
192 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
193
194 %prep
195 %setup -q
196 %patch0 -p1
197 %patch1 -p1
198 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
199         amarok/src/amarok.desktop \
200
201 # see kde bug #110909
202 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
203
204 # kill env, call interpreter directly, so rpm automatics could rule
205 %{__sed} -i -e '
206         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
207         1s,#!.*bin/env.*python,#!%{_bindir}/python,
208         1s,#!.*bin/env.*bash,#!/bin/bash,
209 ' amarok/src/scripts/*/*.{py,rb,sh} amarok/src/amarok_proxy.rb
210
211 %build
212 cp -f /usr/share/automake/config.sub admin
213 %{__make} -f admin/Makefile.common cvs
214
215 # hack: passing something other than "no" or "yes" to --with-helix allows
216 # us to pass HELIX_LIBS
217 %configure \
218         HELIX_LIBS=%{_libdir}/helixplayer \
219         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
220         --disable-rpath \
221         --with%{!?with_mas:out}-mas \
222         --with%{!?with_xine:out}-xine \
223         --with%{!?with_gstreamer:out}-gstreamer10 \
224         --with%{!?with_akode:out}-akode \
225         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
226         --with%{!?with_nmm:out}-nmm \
227         --with%{!?with_mp3players:out}-libgpod \
228         --with%{!?with_mp3players:out}-libnjb \
229         --with%{!?with_mp3players:out}-ifp \
230         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
231         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
232         --disable-final \
233         --with-mp4v2 \
234         --with-qt-libraries=%{_libdir} \
235         --with%{!?with_included_sqlite:out}-included-sqlite
236
237 %{__make}
238
239 %install
240 rm -rf $RPM_BUILD_ROOT
241
242 %{__make} install \
243         DESTDIR=$RPM_BUILD_ROOT \
244         kde_htmldir=%{_kdedocdir} \
245         kde_libs_htmldir=%{_kdedocdir}
246
247 # remove bogus dir
248 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
249
250 %find_lang amarok --all-name --with-kde
251
252 %clean
253 rm -rf $RPM_BUILD_ROOT
254
255 if [ "$1" = 1 ]; then
256         echo "Remember to install libvisual-plugins-* packages if you"
257         echo "want to have a visualizations in amaroK."
258 fi
259
260 %post   -p /sbin/ldconfig
261 %postun -p /sbin/ldconfig
262
263 %files -f %{name}.lang
264 %defattr(644,root,root,755)
265 %doc AUTHORS ChangeLog README
266 %attr(755,root,root) %{_bindir}/amarok
267 %attr(755,root,root) %{_bindir}/amarokapp
268 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
269 %attr(755,root,root) %{_bindir}/amarok_libvisual
270 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
271 %{_libdir}/kde3/konqsidebar_universalamarok.la
272 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
273 %{_libdir}/kde3/libamarok_generic-mediadevice.la
274 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
275 %{_libdir}/kde3/libamarok_void-engine_plugin.la
276 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
277 %{_libdir}/libamarok.la
278 %dir %{_datadir}/apps/amarok
279 %dir %{_datadir}/apps/amarok/scripts
280 %{_datadir}/apps/amarok/*.rc
281 %{_datadir}/apps/amarok/data
282 %{_datadir}/apps/amarok/icons
283 %{_datadir}/apps/amarok/images
284 %{_datadir}/apps/amarok/themes
285 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
286 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
287 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
288 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
289 %{_datadir}/apps/profiles/amarok.profile.xml
290 %{_datadir}/config/amarokrc
291 %{_datadir}/config.kcfg/amarok.kcfg
292 %{_datadir}/services/amarok_generic-mediadevice.desktop
293 %{_datadir}/services/amarok_void-engine_plugin.desktop
294 %{_datadir}/services/lastfm.protocol
295 %{_datadir}/servicetypes/amarok_codecinstall.desktop
296 %{_datadir}/servicetypes/amarok_plugin.desktop
297 %{_desktopdir}/kde/amarok.desktop
298 %{_iconsdir}/*/*/apps/amarok.*
299 # TODO: move to subpackage
300 %if %{with mp3players}
301 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
302 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
303 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
304 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
305 %{_libdir}/kde3/libamarok_njb-mediadevice.la
306 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
307 %{_datadir}/services/amarok_ifp-mediadevice.desktop
308 %{_datadir}/services/amarok_ipod-mediadevice.desktop
309 %{_datadir}/services/amarok_njb-mediadevice.desktop
310 %endif
311
312 %if %{with akode}
313 %files akode
314 %defattr(644,root,root,755)
315 %{_libdir}/kde3/libamarok_aKode-engine.la
316 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
317 %{_datadir}/services/amarok_aKode-engine.desktop
318 %endif
319
320 %if %{with gstreamer}
321 %files gstreamer
322 %defattr(644,root,root,755)
323 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
324 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
325 %{_datadir}/config.kcfg/gstconfig.kcfg
326 %{_datadir}/services/amarok_gst10engine_plugin.desktop
327 %endif
328
329 %if %{with helix}
330 %files helix
331 %defattr(644,root,root,755)
332 %{_libdir}/kde3/libamarok_helixengine_plugin.la
333 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
334 %{_datadir}/config.kcfg/helixconfig.kcfg
335 %{_datadir}/services/amarok_helixengine_plugin.desktop
336 %endif
337
338 %if %{with xine}
339 %files xine
340 %defattr(644,root,root,755)
341 %{_libdir}/kde3/libamarok_xine-engine.la
342 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
343 %{_datadir}/config.kcfg/xinecfg.kcfg
344 %{_datadir}/services/amarok_xine-engine.desktop
345 %endif
346
347 %if %{with xmms}
348 %files xmms
349 %defattr(644,root,root,755)
350 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
351 %endif
352
353 %if 0
354 %if %{with zeroconf}
355 %files zeroconf
356 %defattr(644,root,root,755)
357 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
358 %endif
359 %endif
360
361 %files scripts
362 %defattr(644,root,root,755)
363 %dir %{_datadir}/apps/amarok/scripts/common
364 %{_datadir}/apps/amarok/scripts/common/Publisher.py
365 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
366
367 %dir %{_datadir}/apps/amarok/scripts/templates
368 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
369 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
370 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
371
372 # amarok searches for executable programs for scripts
373 # to figure out which files need to have execute permission, use this
374 # find command:
375 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
376
377 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
378 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
379 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
380
381 %dir %{_datadir}/apps/amarok/scripts/playlist2html
382 %{_datadir}/apps/amarok/scripts/playlist2html/README
383 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
384 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
385 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
386
387 %dir %{_datadir}/apps/amarok/scripts/webcontrol
388 %{_datadir}/apps/amarok/scripts/webcontrol/README
389 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
390 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
391 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
392 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
393 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
394 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
395 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
396 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
397 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
398 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
399 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
400 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
401 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
402 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
403 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
404 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
405 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
406 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
407 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
408
409 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
410 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
411 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
412 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
413 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
414
415 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
416 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
417 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
418 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
419 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
420
421 %dir %{_datadir}/apps/amarok/scripts/score_default
422 %{_datadir}/apps/amarok/scripts/score_default/COPYING
423 %{_datadir}/apps/amarok/scripts/score_default/README
424 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
425 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
426 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
427 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
428 %{_datadir}/apps/amarok/scripts/score_impulsive/README
429 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
430 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
431
432 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
433 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
434
435 %if 0
436 %dir %{_datadir}/apps/amarok/scripts/amarok_live
437 %{_datadir}/apps/amarok/scripts/amarok_live/README
438 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
439 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
440 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
441 %endif
This page took 0.068001 seconds and 3 git commands to generate.