]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
0e8c719bba92889d6c5bd343640c418f3ff76848
[packages/amarok.git] / amarok.spec
1 #
2 # Conditional builds:
3 %bcond_without  arts            # disable arts engine
4 %bcond_without  gstreamer       # disable gstreamer
5 %bcond_without  xine            # disable xine engine
6 %bcond_without  xmms            # disable xmms wrapping
7 #
8 Summary:        A KDE audio player
9 Summary(pl):    Odtwarzacz audio dla KDE
10 Name:           amarok
11 Version:        1.1.1
12 Release:        3
13 License:        GPL
14 Group:          X11/Applications/Multimedia
15 Source0:        http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
16 # Source0-md5:  6c0cccd4c8b508a2e0c9b0f187a907cf
17 Patch0:         %{name}-sqlite3.patch
18 URL:            http://amarok.kde.org/
19 Buildrequires:  alsa-lib-devel
20 Buildrequires:  arts-qt-devel
21 Buildrequires:  automake
22 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.8.1}
23 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
24 Buildrequires:  libmusicbrainz-devel
25 Buildrequires:  libvisual-devel >= 0.1.6-1
26 Buildrequires:  pcre-devel
27 BuildRequires:  rpmbuild(macros) >= 1.129
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  sqlite3-devel
30 BuildRequires:  taglib-devel >= 1.3
31 BuildRequires:  unsermake >= 040511
32 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.0-0.rc5.0}
33 %{?with_xmms:Buildrequires:     xmms-devel}
34 #BuildRequires: kdebindings-kjsembed-devel 
35 Requires:       %{name}-plugin = %{version}-%{release}
36 Requires:       kdebase-core >= 9:3.1.93
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 A KDE audio player.
41
42 %description -l pl
43 Odtwarzacz audio dla KDE.
44
45 %package arts
46 Summary:        Plugin arts
47 Summary(pl):    Wtyczka arts
48 Group:          X11/Applications/Multimedia
49 Requires:       %{name} = %{version}-%{release}
50 Provides:       %{name}-plugin = %{version}-%{release}
51
52 %description arts
53 Plugin arts.
54
55 %description arts -l pl
56 Wtyczka arts.
57
58 %package gstreamer
59 Summary:        Plugin gstreamer
60 Summary(pl):    Wtyczka gstreamer
61 Group:          X11/Applications/Multimedia
62 Requires:       %{name} = %{version}-%{release}
63 Provides:       %{name}-plugin = %{version}-%{release}
64
65 %description gstreamer
66 Plugin gstreamer.
67
68 %description gstreamer -l pl
69 Wtyczka gstreamer.
70
71 %package xine
72 Summary:        Plugin xine
73 Summary(pl):    Wtyczka xine
74 Group:          X11/Applications/Multimedia
75 Requires:       %{name} = %{version}-%{release}
76 Provides:       %{name}-plugin = %{version}-%{release}
77
78 %description xine
79 Plugin xine.
80
81 %description xine -l pl
82 Wtyczka xine.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87
88 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
89         amarok/src/amarok.desktop \
90
91 %build
92 cp -f %{_datadir}/automake/config.sub admin
93
94 export UNSERMAKE=%{_datadir}/unsermake/unsermake
95
96 %{__make} -f admin/Makefile.common cvs
97
98 %configure \
99         --disable-rpath \
100         %{!?with_arts:--without-arts} \
101         %{!?with_xine:--without-xine} \
102         %{!?with_gstreamer:--without-gstreamer} \
103         --with-qt-libraries=%{_libdir} \
104         --without-included-sqlite
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT \
113         kde_htmldir=%{_kdedocdir} \
114         kde_libs_htmldir=%{_kdedocdir}
115
116 # remove bogus dir
117 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
118
119 %find_lang amarok --all-name --with-kde
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files -f %{name}.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog README TODO
127 %attr(755,root,root) %{_bindir}/amarok
128 %{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
129 %attr(755,root,root) %{_bindir}/amarokapp
130 %attr(755,root,root) %{_bindir}/amarok_libvisual
131 %attr(755,root,root) %{_bindir}/release_amarok
132 %{_libdir}/kde3/libamarok_void-engine_plugin.la
133 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
134 %{_datadir}/apps/amarok
135 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
136 %{_datadir}/config.kcfg/amarok.kcfg
137 %{_datadir}/services/amarok_void-engine_plugin.desktop
138 %{_datadir}/servicetypes/amarok_plugin.desktop
139 %{_desktopdir}/kde/amarok.desktop
140 %{_iconsdir}/*/*/apps/amarok.png
141 %{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
142 %{_datadir}/config/*
143
144 %if %{with arts}
145 %files arts
146 %defattr(644,root,root,755)
147 %{_libdir}/kde3/libamarok_artsengine_plugin.la
148 %attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
149 %{_libdir}/libamarokarts.la
150 %attr(755,root,root) %{_libdir}/libamarokarts.so
151 %{_libdir}/mcop/Amarok
152 %{_libdir}/mcop/amarokarts.mcopclass
153 %{_libdir}/mcop/amarokarts.mcoptype
154 %{_datadir}/services/amarok_artsengine_plugin.desktop
155 %endif
156
157 %if %{with gstreamer}
158 %files gstreamer
159 %defattr(644,root,root,755)
160 %{_libdir}/kde3/libamarok_gstengine_plugin.la
161 %attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
162 %{_datadir}/config.kcfg/gstconfig.kcfg
163 %{_datadir}/services/amarok_gstengine_plugin.desktop
164 %endif
165
166 %if %{with xine}
167 %files xine
168 %defattr(644,root,root,755)
169 %{_libdir}/kde3/libamarok_xine-engine.la
170 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
171 %{_datadir}/services/amarok_xine-engine.desktop
172 %{_datadir}/services/amarok_xineengine_plugin.desktop
173 %endif
This page took 0.030321 seconds and 2 git commands to generate.