]> git.pld-linux.org Git - packages/amarok.git/blob - amarok.spec
- 1.4.3
[packages/amarok.git] / amarok.spec
1 # TODO:
2 # - postgresql support alongside mysql
3 # - NMM audio backend support (fix build - propably some BRs)
4 # - make descriptions less useless
5 # - track http://websvn.kde.org/trunk/extragear/multimedia/amarok/TODO?rev=470324&r1=470292&r2=470324
6 # - include /usr/bin/amarok_proxy.rb (proxy server for last.fm, but req. ruby)
7 # - main package pulls /usr/bin/ruby
8 #
9 # Conditional builds:
10 %bcond_with     gstreamer       # enable gstreamer (gst10 not stable)
11 %bcond_without  mas             # disable MAS audio backend
12 %bcond_without  xine            # disable xine engine
13 %bcond_without  xmms            # disable xmms wrapping
14 %bcond_without  zeroconf        # disable support for zeroconf
15 %bcond_without  included_sqlite # don't use included sqlite (VERY BAD IDEA), needs sqlite >= 3.3 otherwise
16 %bcond_without  helix           # disable HelixPlayer engine
17 %bcond_with     mp3players      # disable iPod and iRiver MP3 players support
18 %bcond_with     nmm             # enable NMM audio backend
19 %bcond_with     mysql           # enable MySQL support
20 %bcond_with     pgsql           # enable PostgreSQL support
21 #
22 %ifarch i386
23 %undefine       with_helix
24 %endif
25
26 Summary:        A KDE audio player
27 Summary(pl):    Odtwarzacz audio dla KDE
28 Name:           amarok
29 Version:        1.4.3
30 Release:        1
31 License:        GPL
32 Group:          X11/Applications/Multimedia
33 #Source0:       http://dl.sourceforge.net/amarok/%{name}-%{version}.tar.bz2
34 Source0:        http://mirrors.isc.org/pub/kde/stable/amarok/%{version}/src/%{name}-%{version}.tar.bz2
35 # Source0-md5:  b0b4f8952ad23705c70815d50fd0af52
36 Patch0:         %{name}-helixplayer-morearchs.patch
37 Patch1:         %{name}-libnjb.patch
38 URL:            http://amarok.kde.org/
39 BuildRequires:  SDL-devel
40 BuildRequires:  alsa-lib-devel
41 BuildRequires:  autoconf
42 BuildRequires:  automake
43 BuildRequires:  dbus-glib-devel
44 BuildRequires:  gettext-devel
45 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 0.10.0}
46 BuildRequires:  kdebase-devel
47 %{?with_akode:BuildRequires:    kdemultimedia-akode}
48 BuildRequires:  kdemultimedia-devel >= 9:3.1.93
49 %{?with_mp3players:BuildRequires:       libgpod-devel >= 0.2.0}
50 %{?with_mp3players:BuildRequires:       libifp-devel}
51 %{?with_mp3players:BuildRequires:       libmtp-devel}
52 %{?with_mp3players:BuildRequires:       libnjb-devel}
53 BuildRequires:  libltdl-devel
54 %{?with_pgsql:BuildRequires:            libpqxx-devel}
55 BuildRequires:  libtunepimp-devel >= 0.4.0
56 BuildRequires:  libvisual-devel >= 0.4.0
57 BuildRequires:  mpeg4ip-devel
58 %{?with_mysql:BuildRequires:            mysql-devel}
59 BuildRequires:  pcre-devel
60 BuildRequires:  pkgconfig
61 BuildRequires:  rpm-pythonprov
62 BuildRequires:  rpmbuild(macros) >= 1.129
63 BuildRequires:  ruby-devel >= 1.8
64 BuildRequires:  sed >= 4.0
65 %{!?with_included_sqlite:BuildRequires: sqlite3-devel >= 3.3}
66 BuildRequires:  taglib-devel >= 1.4
67 %{?with_xine:BuildRequires:     xine-lib-devel >= 1.1.1}
68 %{?with_xmms:BuildRequires:     xmms-devel}
69 Requires(post): /sbin/ldconfig
70 Requires:       %{name}-plugin = %{version}-%{release}
71 Requires:       kdebase-core >= 9:3.1.93
72 Requires:       kdemultimedia-audiocd >= 9:3.1.93
73 Obsoletes:      amarok-arts
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 A KDE audio player.
78
79 %description -l pl
80 Odtwarzacz audio dla KDE.
81
82 %package akode
83 Summary:        Plugin akode
84 Summary(pl):    Wtyczka akode
85 Group:          X11/Applications/Multimedia
86 Requires:       %{name} = %{version}-%{release}
87 Provides:       %{name}-plugin = %{version}-%{release}
88
89 %description akode
90 Plugin akode.
91
92 %description akode -l pl
93 Wtyczka akode.
94
95 %package helix
96 Summary:        Helix/Realplayer playback support for amarok
97 Summary(pl):    Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka
98 Group:          X11/Applications/Multimedia
99 Requires:       %{name} = %{version}-%{release}
100 Requires:       helix-core
101 Provides:       %{name}-plugin = %{version}-%{release}
102
103 %description helix
104 Helix/Realplayer playback support for amarok.
105
106 %description helix -l pl
107 Wsparcie dla odtwarzania przez Helix/Realplayera dla amaroka.
108
109 %package gstreamer
110 Summary:        Plugin gstreamer
111 Summary(pl):    Wtyczka gstreamer
112 Group:          X11/Applications/Multimedia
113 # deps, to get it working:
114 # mp3 decoder:  gstreamer-mad
115 # ogg decoder:  gstreamer-vorbis
116 # audio output driver:  gstreamer-audiosink-alsa
117 # from gstreamer-audio-effects to control volume, etc
118 # needed libs:
119 #  at least /usr/lib/gstreamer-0.8/libgstresample.so
120 #  probably /usr/lib/gstreamer-0.8/libgstadder.so
121 #  and probably /usr/lib/gstreamer-0.8/libgstvolume.so
122 # gstreamer-musicbrainz for being able to edit id3 tags on files.
123 Requires:       %{name} = %{version}-%{release}
124 Requires:       gstreamer-audio-effects
125 Requires:       gstreamer-audiosink
126 Requires:       gstreamer-mad
127 Requires:       gstreamer-musicbrainz
128 Requires:       gstreamer-vorbis
129 Provides:       %{name}-plugin = %{version}-%{release}
130
131 %description gstreamer
132 Plugin gstreamer.
133
134 %description gstreamer -l pl
135 Wtyczka gstreamer.
136
137 %package xine
138 Summary:        Plugin xine
139 Summary(pl):    Wtyczka xine
140 Group:          X11/Applications/Multimedia
141 Requires:       %{name} = %{version}-%{release}
142 Requires:       xine-plugin-audio
143 Provides:       %{name}-plugin = %{version}-%{release}
144
145 %description xine
146 Plugin xine.
147
148 %description xine -l pl
149 Wtyczka xine.
150
151 %package xmms
152 Summary:        Xmms wrapper
153 Summary(pl):    Wrapper xmms
154 Group:          X11/Applications/Multimedia
155 Requires:       %{name} = %{version}-%{release}
156
157 %description xmms
158 Xmms wrapper.
159
160 %description xmms -l pl
161 Wrapper xmms.
162
163 %package zeroconf
164 Summary:        Zeroconf data
165 Summary(pl):    Dane dla zeroconf
166 Group:          X11/Applications/Multimedia
167 Requires:       %{name} = %{version}-%{release}
168 Requires:       kdenetwork-kdnssd
169 Provides:       %{name}-plugin = %{version}-%{release}
170
171 %description zeroconf
172 Zeroconf data.
173
174 %description zeroconf -l pl
175 Dane dla zeroconf.
176
177 %package scripts
178 Summary:        amaroK scripts
179 Summary(pl):    Skrypty amaroKa
180 Group:          X11/Applications/Multimedia
181 Requires:       %{name} = %{version}-%{release}
182 Requires:       kdebase-kdialog
183 Requires:       python-PyQt
184 Requires:       ruby-modules
185
186 %description scripts
187 amaroK scripts allow you extend amaroK functionality.
188
189 You can learn more about scripts in amaroK from here:
190 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
191
192 %description scripts -l pl
193 Skrypty amaroKa pozwalaj±ce rozszerzaæ jego funkcjonalno¶æ.
194
195 Wiêcej o skryptach w amaroKu mo¿na dowiedzieæ siê st±d:
196 <http://amarok.kde.org/amarokwiki/index.php/Script-Writing_HowTo>.
197
198 %prep
199 %setup -q
200 %patch0 -p1
201 %patch1 -p1
202 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
203         amarok/src/amarok.desktop \
204
205 # see kde bug #110909
206 %{__sed} -i -e 's/amarok_live//' amarok/src/scripts/Makefile.am
207
208 # kill env, call interpreter directly, so rpm automatics could rule
209 %{__sed} -i -e '
210         1s,#!.*bin/env.*ruby,#!%{_bindir}/ruby,
211         1s,#!.*bin/env.*python,#!%{_bindir}/python,
212         1s,#!.*bin/env.*bash,#!/bin/bash,
213 ' amarok/src/scripts/*/*.{py,rb,sh} amarok/src/amarok_proxy.rb
214
215 %build
216 cp -f /usr/share/automake/config.sub admin
217 %{__make} -f admin/Makefile.common cvs
218
219 # hack: passing something other than "no" or "yes" to --with-helix allows
220 # us to pass HELIX_LIBS
221 %configure \
222         HELIX_LIBS=%{_libdir}/helixplayer \
223         --%{?debug:en}%{!?debug:dis}able-debug%{?debug:=full} \
224         --disable-rpath \
225         --with%{!?with_mas:out}-mas \
226         --with%{!?with_xine:out}-xine \
227         --with%{!?with_gstreamer:out}-gstreamer10 \
228         --with%{!?with_akode:out}-akode \
229         --with%{!?with_helix:out}-helix%{?with_helix:=usegivenpath} \
230         --with%{!?with_nmm:out}-nmm \
231         --with%{!?with_mp3players:out}-libgpod \
232         --with%{!?with_mp3players:out}-libnjb \
233         --with%{!?with_mp3players:out}-libmtp \
234         --with%{!?with_mp3players:out}-ifp \
235         --%{?with_mysql:en}%{!?with_mysql:dis}able-mysql \
236         --%{?with_mysql:en}%{!?with_mysql:dis}able-postgresql \
237         --disable-final \
238         --with-mp4v2 \
239         --with-qt-libraries=%{_libdir} \
240         --with%{!?with_included_sqlite:out}-included-sqlite
241
242 %{__make}
243
244 %install
245 rm -rf $RPM_BUILD_ROOT
246
247 %{__make} install \
248         DESTDIR=$RPM_BUILD_ROOT \
249         kde_htmldir=%{_kdedocdir} \
250         kde_libs_htmldir=%{_kdedocdir}
251
252 # remove bogus dir
253 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
254
255 %find_lang amarok --all-name --with-kde
256
257 %clean
258 rm -rf $RPM_BUILD_ROOT
259
260 %post
261 /sbin/ldconfig
262 if [ "$1" = 1 ]; then
263         echo "Remember to install libvisual-plugins-* packages if you"
264         echo "want to have a visualizations in amaroK."
265 fi
266
267 %postun -p /sbin/ldconfig
268
269 %files -f %{name}.lang
270 %defattr(644,root,root,755)
271 %doc AUTHORS ChangeLog README
272 %attr(755,root,root) %{_bindir}/amarok
273 %attr(755,root,root) %{_bindir}/amarokapp
274 %attr(755,root,root) %{_bindir}/amarokcollectionscanner
275 %attr(755,root,root) %{_bindir}/amarok_libvisual
276 %attr(755,root,root) %{_bindir}/amarok_proxy.rb
277 %attr(755,root,root) %{_bindir}/amarok_daapserver.rb
278 %attr(755,root,root) %{_libdir}/libamarok.so.*.*.*
279 %{_libdir}/kde3/konqsidebar_universalamarok.la
280 %attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
281 %{_libdir}/kde3/libamarok_generic-mediadevice.la
282 %attr(755,root,root) %{_libdir}/kde3/libamarok_generic-mediadevice.so
283 %{_libdir}/kde3/libamarok_void-engine_plugin.la
284 %attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
285 %{_libdir}/libamarok.la
286 %{_libdir}/kde3/libamarok_daap-mediadevice.la
287 %attr(755,root,root) %{_libdir}/kde3/libamarok_daap-mediadevice.so
288 %{_libdir}/kde3/libamarok_massstorage-device.la
289 %attr(755,root,root) %{_libdir}/kde3/libamarok_massstorage-device.so
290 %{_libdir}/kde3/libamarok_nfs-device.la
291 %attr(755,root,root) %{_libdir}/kde3/libamarok_nfs-device.so
292 %{_libdir}/kde3/libamarok_smb-device.la
293 %attr(755,root,root) %{_libdir}/kde3/libamarok_smb-device.so
294 %dir %{_datadir}/apps/amarok
295 %dir %{_datadir}/apps/amarok/scripts
296 %{_datadir}/apps/amarok/ruby_lib
297 %{_datadir}/apps/amarok/*.rc
298 %{_datadir}/apps/amarok/data
299 %{_datadir}/apps/amarok/icons
300 %{_datadir}/apps/amarok/images
301 %{_datadir}/apps/amarok/themes
302 %{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
303 %{_datadir}/apps/konqsidebartng/add/amarok.desktop
304 %{_datadir}/apps/konqsidebartng/entries/amarok.desktop
305 %{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
306 %{_datadir}/apps/profiles/amarok.profile.xml
307 %{_datadir}/config/amarokrc
308 %{_datadir}/config.kcfg/amarok.kcfg
309 %{_datadir}/services/amarok_generic-mediadevice.desktop
310 %{_datadir}/services/amarok_void-engine_plugin.desktop
311 %{_datadir}/services/amarok_daap-mediadevice.desktop
312 %{_datadir}/services/amarok_massstorage-device.desktop
313 %{_datadir}/services/amarok_nfs-device.desktop
314 %{_datadir}/services/amarok_smb-device.desktop
315 %{_datadir}/services/amaroklastfm.protocol
316 %{_datadir}/services/amarokitpc.protocol
317 %{_datadir}/services/amarokpcast.protocol
318 %{_datadir}/servicetypes/amarok_codecinstall.desktop
319 %{_datadir}/servicetypes/amarok_plugin.desktop
320 %{_desktopdir}/kde/amarok.desktop
321 %{_iconsdir}/*/*/apps/amarok.*
322 # TODO: move to subpackage
323 %if %{with mp3players}
324 %{_libdir}/kde3/libamarok_ifp-mediadevice.la
325 %attr(755,root,root) %{_libdir}/kde3/libamarok_ifp-mediadevice.so
326 %{_libdir}/kde3/libamarok_ipod-mediadevice.la
327 %attr(755,root,root) %{_libdir}/kde3/libamarok_ipod-mediadevice.so
328 %{_libdir}/kde3/libamarok_njb-mediadevice.la
329 %attr(755,root,root) %{_libdir}/kde3/libamarok_njb-mediadevice.so
330 %{_datadir}/services/amarok_ifp-mediadevice.desktop
331 %{_datadir}/services/amarok_ipod-mediadevice.desktop
332 %{_datadir}/services/amarok_njb-mediadevice.desktop
333 %endif
334
335 %if %{with akode}
336 %files akode
337 %defattr(644,root,root,755)
338 %{_libdir}/kde3/libamarok_aKode-engine.la
339 %attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
340 %{_datadir}/services/amarok_aKode-engine.desktop
341 %endif
342
343 %if %{with gstreamer}
344 %files gstreamer
345 %defattr(644,root,root,755)
346 %{_libdir}/kde3/libamarok_gst10engine_plugin.la
347 %attr(755,root,root) %{_libdir}/kde3/libamarok_gst10engine_plugin.so
348 %{_datadir}/config.kcfg/gstconfig.kcfg
349 %{_datadir}/services/amarok_gst10engine_plugin.desktop
350 %endif
351
352 %if %{with helix}
353 %files helix
354 %defattr(644,root,root,755)
355 %{_libdir}/kde3/libamarok_helixengine_plugin.la
356 %attr(755,root,root) %{_libdir}/kde3/libamarok_helixengine_plugin.so
357 %{_datadir}/config.kcfg/helixconfig.kcfg
358 %{_datadir}/services/amarok_helixengine_plugin.desktop
359 %endif
360
361 %if %{with xine}
362 %files xine
363 %defattr(644,root,root,755)
364 %{_libdir}/kde3/libamarok_xine-engine.la
365 %attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
366 %{_datadir}/config.kcfg/xinecfg.kcfg
367 %{_datadir}/services/amarok_xine-engine.desktop
368 %endif
369
370 %if %{with xmms}
371 %files xmms
372 %defattr(644,root,root,755)
373 %attr(755,root,root) %{_bindir}/amarok_xmmswrapper2
374 %endif
375
376 %if 0
377 %if %{with zeroconf}
378 %files zeroconf
379 %defattr(644,root,root,755)
380 #%{_datadir}/apps/zeroconf/_shoutcast._tcp
381 %endif
382 %endif
383
384 %files scripts
385 %defattr(644,root,root,755)
386 %dir %{_datadir}/apps/amarok/scripts/common
387 %{_datadir}/apps/amarok/scripts/common/Publisher.py
388 %{_datadir}/apps/amarok/scripts/common/Zeroconf.py
389
390 %dir %{_datadir}/apps/amarok/scripts/templates
391 %{_datadir}/apps/amarok/scripts/templates/amarok.rb
392 %{_datadir}/apps/amarok/scripts/templates/python_qt_template.py
393 %{_datadir}/apps/amarok/scripts/templates/ruby_qt_template.rb
394
395 # amarok searches for executable programs for scripts
396 # to figure out which files need to have execute permission, use this
397 # find command:
398 # $ find $RPM_BUILD_ROOT/usr/share/apps/amarok/scripts -perm +1
399
400 #%dir %{_datadir}/apps/amarok/scripts/graphequalizer
401 #%{_datadir}/apps/amarok/scripts/graphequalizer/README
402 #%attr(755,root,root) %{_datadir}/apps/amarok/scripts/graphequalizer/graphequalizer
403
404 %dir %{_datadir}/apps/amarok/scripts/playlist2html
405 %{_datadir}/apps/amarok/scripts/playlist2html/README
406 %{_datadir}/apps/amarok/scripts/playlist2html/Playlist.py
407 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/PlaylistServer.py
408 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/playlist2html/playlist2html.py
409
410 %dir %{_datadir}/apps/amarok/scripts/webcontrol
411 %{_datadir}/apps/amarok/scripts/webcontrol/README
412 %{_datadir}/apps/amarok/scripts/webcontrol/Globals.py
413 %{_datadir}/apps/amarok/scripts/webcontrol/Playlist.py
414 %{_datadir}/apps/amarok/scripts/webcontrol/RequestHandler.py
415 %{_datadir}/apps/amarok/scripts/webcontrol/amarok_cut.png
416 %{_datadir}/apps/amarok/scripts/webcontrol/controlbackground.png
417 %{_datadir}/apps/amarok/scripts/webcontrol/main.css
418 %{_datadir}/apps/amarok/scripts/webcontrol/main.js
419 %{_datadir}/apps/amarok/scripts/webcontrol/player_end.png
420 %{_datadir}/apps/amarok/scripts/webcontrol/player_pause.png
421 %{_datadir}/apps/amarok/scripts/webcontrol/player_play.png
422 %{_datadir}/apps/amarok/scripts/webcontrol/player_start.png
423 %{_datadir}/apps/amarok/scripts/webcontrol/player_stop.png
424 %{_datadir}/apps/amarok/scripts/webcontrol/template.thtml
425 %{_datadir}/apps/amarok/scripts/webcontrol/vol_speaker.png
426 %{_datadir}/apps/amarok/scripts/webcontrol/WebPublisher.py
427 %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.spec
428 %{_datadir}/apps/amarok/scripts/webcontrol/smallstar.png
429 %{_datadir}/apps/amarok/scripts/webcontrol/star.png
430 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/webcontrol/WebControl.py
431
432 %dir %{_datadir}/apps/amarok/scripts/lyrics_astraweb
433 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/COPYING
434 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/README
435 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.rb
436 %{_datadir}/apps/amarok/scripts/lyrics_astraweb/lyrics_astraweb.spec
437
438 %dir %{_datadir}/apps/amarok/scripts/lyrics_lyrc
439 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/COPYING
440 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/README
441 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.rb
442 %{_datadir}/apps/amarok/scripts/lyrics_lyrc/lyrics_lyrc.spec
443
444 %dir %{_datadir}/apps/amarok/scripts/score_default
445 %{_datadir}/apps/amarok/scripts/score_default/COPYING
446 %{_datadir}/apps/amarok/scripts/score_default/README
447 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_default/score_default.rb
448 %{_datadir}/apps/amarok/scripts/score_default/score_default.spec
449 %dir %{_datadir}/apps/amarok/scripts/score_impulsive
450 %{_datadir}/apps/amarok/scripts/score_impulsive/COPYING
451 %{_datadir}/apps/amarok/scripts/score_impulsive/README
452 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.rb
453 %{_datadir}/apps/amarok/scripts/score_impulsive/score_impulsive.spec
454
455 %dir %{_datadir}/apps/amarok/scripts/ruby_debug
456 %{_datadir}/apps/amarok/scripts/ruby_debug/debug.rb
457
458 %if 0
459 %dir %{_datadir}/apps/amarok/scripts/amarok_live
460 %{_datadir}/apps/amarok/scripts/amarok_live/README
461 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part1.sh
462 %{_datadir}/apps/amarok/scripts/amarok_live/amarok.live.remaster.part2.sh
463 %attr(755,root,root) %{_datadir}/apps/amarok/scripts/amarok_live/amarok_live.py
464 %endif
This page took 0.100815 seconds and 3 git commands to generate.