]> git.pld-linux.org Git - packages/amarok-script-wiki_lyrics.git/blob - amarok-script-wiki_lyrics.spec
- darklyrics site now in utf8 encoding; rel 4
[packages/amarok-script-wiki_lyrics.git] / amarok-script-wiki_lyrics.spec
1 # NOTE
2 # - could use QtRuby, Ruby/GTK or Ruby/Tk, but as only -tk was available on AC,
3 #   used that dependency.
4 %define         scriptname      wiki_lyrics
5 Summary:        A collection of lyrics scripts for amaroK
6 Summary(pl.UTF-8):      Zestaw skryptów do tekstów utworów dla amaroKa
7 Name:           amarok-script-wiki_lyrics
8 Version:        0.12.4
9 Release:        3
10 License:        GPL v2
11 Group:          X11/Applications/Multimedia
12 Source0:        http://www.kde-apps.org/CONTENT/content-files/35151-wiki_lyrics-%{version}.amarokscript.tar.bz2
13 # Source0-md5:  b03c6dabdf87c1e2b0e4ae7e21144743
14 Patch0:         %{name}-charset.patch
15 URL:            http://www.lyriki.com/Help:Wiki-Lyrics_Script
16 BuildRequires:  sed >= 4.0
17 Requires:       amarok >= 1.4
18 Requires:       ruby-modules >= 1.8
19 Requires:       ruby-tk
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _scriptdir %{_datadir}/apps/amarok/scripts
24
25 %description
26 A collection of lyrics scripts to interface with various sites and,
27 optionally, submit content to Lyriki.com or LyricWiki.org (wikis for
28 lyrics). All of these scripts can query the other ones when they can't
29 provide the lyrics for a song.
30
31 Supported sites:
32 - Lyriki (www.lyriki.com)
33 - LyricWiki (www.lyricwiki.org)
34 - AZ Lyrics (www.azlyrics.com)
35 - Baidu MP3 (mp3.baidu.com)
36 - Dark Lyrics (www.darklyrics.com)
37 - Giitaayan (www.giitaayan.com)
38 - Jamendo (www.jamendo.com)
39 - Leos Lyrics (www.leoslyrics.com)
40 - Lyrc (lyrc.com.ar)
41 - Lyrics Download (www.lyricsdownload.com)
42 - Lyrics Mania (www.lyricsmania.com)
43 - Not Popular (www.notpopular.com)
44 - Seek Lyrics (www.seeklyrics.com)
45 - Sing365 (www.sing365.com)
46 - Terra Letras (letras.terra.com.br)
47
48 %description -l pl.UTF-8
49 Zestaw współpracujących z różnymi serwisami skryptów do pobierania
50 tekstów utworów i opcjonalnie umieszczania treści na Lyriki.com lub
51 LyricWiki.org (wiki dla tekstów utworów). Wszystkie te skrypty mogą
52 odpytywać inne jeśli nie znajdą tekstu piosenki.
53
54 Obsługiwane serwisy:
55 - Lyriki (www.lyriki.com)
56 - LyricWiki (www.lyricwiki.org)
57 - AZ Lyrics (www.azlyrics.com)
58 - Baidu MP3 (mp3.baidu.com)
59 - Dark Lyrics (www.darklyrics.com)
60 - Giitaayan (www.giitaayan.com)
61 - Jamendo (www.jamendo.com)
62 - Leos Lyrics (www.leoslyrics.com)
63 - Lyrc (lyrc.com.ar)
64 - Lyrics Download (www.lyricsdownload.com)
65 - Lyrics Mania (www.lyricsmania.com)
66 - Not Popular (www.notpopular.com)
67 - Seek Lyrics (www.seeklyrics.com)
68 - Sing365 (www.sing365.com)
69 - Terra Letras (letras.terra.com.br)
70
71 %prep
72 %setup -q -n %{scriptname}
73 %patch0 -p1
74 rm *.kdev*
75 rm -rf win tests
76 rm {docs,amarok}/COPYING # GPL v2
77 rm i18n/README # note about when editing files
78
79 %{__sed} -i -e '1s,#!/usr/bin/env ruby,#!%{_bindir}/ruby,' *.rb amarok/*.rb cli/*.rb
80
81 # ELF 32-bit LSB executable, Intel 80386
82 # TODO: package separately if it's really needed
83 rm -f itrans/itrans
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT%{_scriptdir}/%{scriptname}
88 cp -a . $RPM_BUILD_ROOT%{_scriptdir}/%{scriptname}
89 rm -rf $RPM_BUILD_ROOT%{_scriptdir}/%{scriptname}/docs
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %doc docs/ChangeLog docs/TODO docs/HOWTO.txt docs/README
97 %dir %{_scriptdir}/%{scriptname}
98
99 %attr(755,root,root) %{_scriptdir}/%{scriptname}/*.rb
100
101 %dir %{_scriptdir}/%{scriptname}/cli
102 %attr(755,root,root) %{_scriptdir}/%{scriptname}/cli/*.rb
103
104 %dir %{_scriptdir}/%{scriptname}/gui
105 %attr(755,root,root) %{_scriptdir}/%{scriptname}/gui/*.rb
106
107 %dir %{_scriptdir}/%{scriptname}/i18n
108 %attr(755,root,root) %{_scriptdir}/%{scriptname}/i18n/*.rb
109
110 %dir %{_scriptdir}/%{scriptname}/utils
111 %attr(755,root,root) %{_scriptdir}/%{scriptname}/utils/*.rb
112
113 %dir %{_scriptdir}/%{scriptname}/itrans
114 %attr(755,root,root) %{_scriptdir}/%{scriptname}/itrans/*
115
116 %dir %{_scriptdir}/%{scriptname}/amarok
117 # README must be here in %files, not in %doc
118 %{_scriptdir}/%{scriptname}/amarok/README
119 %attr(755,root,root) %{_scriptdir}/%{scriptname}/amarok/*.rb
120 %{_scriptdir}/%{scriptname}/amarok/*.spec
This page took 0.090536 seconds and 3 git commands to generate.