]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
613975abc8afac737c9163a5482b68c1157fdcbd
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - separate package with tcl web-frontend
4 # - fix as-needed
5 # - pico shouldn't link with kerberos, should it?
6 # - switch to http://re-alpine.sourceforge.net/ - RIP alpine
7 %define         ver             2.00
8 %define         patchlevel      84
9 Summary:        University of Washington Alpine mail user agent
10 Summary(pl.UTF-8):      Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
11 Name:           alpine
12 Version:        %{ver}.%{patchlevel}
13 Release:        6.1
14 Epoch:          1
15 License:        Apache v2.0
16 Group:          Applications/Mail
17 # Main site:
18 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
19 # Source with applied patches from http://staff.washington.edu/chappa/alpine/
20 Source0:        http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
21 # Source0-md5:  70ba4281354f1ba2d341038ec0e323c7
22 Source1:        pico.desktop
23 Source2:        %{name}.desktop
24 Source3:        %{name}.png
25 Patch0:         %{name}-index_display.patch
26 Patch1:         %{name}-doc.patch
27 Patch2:         %{name}-filter.patch
28 Patch3:         %{name}-fhs.patch
29 Patch4:         %{name}-libc-client.patch
30 Patch5:         %{name}-ssl.patch
31 Patch6:         %{name}-no_1777_warning.patch
32 Patch7:         %{name}-home_etc.patch
33 Patch8:         %{name}-RFC1522_MAXW.patch
34 Patch9:         mimedesc.patch
35 Patch10:        re-alpine-2.01.smime-signandencrypt.patch
36 URL:            http://www.washington.edu/alpine/
37 BuildRequires:  autoconf
38 BuildRequires:  automake
39 BuildRequires:  home-etc-devel
40 %if "%{pld_release}" != "ac"
41 BuildRequires:  heimdal-devel
42 %endif
43 BuildRequires:  libtool
44 BuildRequires:  ncurses-devel
45 BuildRequires:  openldap-devel
46 BuildRequires:  openssl-devel
47 BuildRequires:  pam-devel
48 # Only for web-frontend:
49 #BuildRequires: tcl-devel
50 Suggests:       aspell
51 Suggests:       ca-certificates
52 Conflicts:      ca-certificates < 20080809-4
53 Provides:       pine = 6.00
54 Obsoletes:      pine
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         alpineconfdir   %{_sysconfdir}/%{name}
58 %define         filterout_ld    -Wl,--as-needed
59
60 %description
61 Alpine -- an Alternatively Licensed Program for Internet News & Email
62 -- is a tool for reading, sending, and managing electronic messages.
63 Alpine is the successor to Pine and was developed by Computing &
64 Communications at the University of Washington. Though originally
65 designed for inexperienced email users, Alpine supports many advanced
66 features, and an ever-growing number of configuration and
67 personal-preference options.
68
69 %description -l pl.UTF-8
70 Alpine, czyli Alternatively Licensed Program for Internet News & Email
71 (alternatywnie licencjonowany program do newsów i poczty internetowej)
72 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
73 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
74 wydział Computing & Communications (Obliczeń i komunikacji) na
75 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
76 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
77 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
78 ciągle rośnie.
79
80 %package -n pico
81 Summary:        Simple text editor in the style of the Pine Composer
82 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
83 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
84 Group:          Applications/Editors
85 Provides:       pico = 6.00
86
87 %description -n pico
88 Pico is a simple, display-oriented text editor based on the Alpine
89 message system composer. As with Pine, commands are displayed at the
90 bottom of the screen, and context-sensitive help is provided. As
91 characters are typed they are immediately inserted into the text.
92
93 %description -n pico -l pl.UTF-8
94 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
95 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
96 dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
97 włączane do tekstu.
98
99 %description -n pico -l pt_BR.UTF-8
100 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
101 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
102 e ajuda de acordo com o contexto está disponível.
103
104 %package -n pilot
105 Summary:        Simple file system browser in the style of the Alpine Composer
106 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
107 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
108 Group:          Applications/Shells
109 Provides:       pilot = 6.00
110
111 %description -n pilot
112 Pilot is a simple, display-oriented file system browser based on the
113 Alpine message system composer. As with Alpine, commands are displayed
114 at the bottom of the screen, and context-sensitive help is provided.
115
116 %description -n pilot -l pl.UTF-8
117 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
118 stylu composera pine. Podobnie jak w alpine polecenia są wyświetlane
119 na dole ekranu oraz jest dostępna pomoc kontekstowa.
120
121 %description -n pilot -l pt_BR.UTF-8
122 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
123 como no Pine, comandos são apresentados na parte de baixo da tela, e
124 ajuda de acordo com o contexto está disponível.
125
126 %prep
127 %setup -q -n %{name}-%{ver}
128 %patch0 -p1
129 %patch1 -p1
130 %patch2 -p1
131 %patch3 -p1
132 %patch4 -p1
133 %patch5 -p1
134 %patch6 -p1
135 %patch7 -p1
136 %patch8 -p1
137 %patch9 -p1
138 %patch10 -p1
139
140 %build
141 rm -f libtool missing
142 %{__libtoolize}
143 %{__aclocal} -I m4
144 %{__autoconf}
145 %{__autoheader}
146 %{__automake}
147 %configure \
148         --%{?debug:en}%{!?debug:dis}able-debug \
149         --enable-quotas \
150         --without-tcl \
151         --with-smtp-msa=/usr/lib/sendmail \
152         --with-simple-spellcheck=aspell \
153         --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
154         --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
155         --with-krb5-dir=%{_prefix} \
156         --with-ldap-dir=%{_prefix} \
157         --with-system-mail-directory=/var/mail \
158         --with-c-client-target=slx \
159 %if "%{pld_release}" == "ti"
160         --with-ssl-dir=/var/lib/openssl/certs \
161         --with-ssl-certs-dir=/var/lib/openssl/certs \
162 %else
163         --with-ssl-dir=/etc/openssl/certs \
164         --with-ssl-certs-dir=/etc/certs \
165         --with-ssl-lib-dir=%{_libdir} \
166 %endif
167         --with-passfile=.pine.pwd
168
169 %{__make} \
170         GCCOPTLEVEL="%{rpmcflags}"
171
172 %install
173 rm -rf $RPM_BUILD_ROOT
174 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
175
176 %{__make} install \
177         DESTDIR=$RPM_BUILD_ROOT
178
179 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
180 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
181 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
182
183 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
184
185 $RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
186 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
187 #
188 # Alpine system-wide enforced configuration file - customize as needed
189 #
190 # This file holds the system-wide enforced values for alpine configuration
191 # settings. Any values set in it will override values set in the
192 # system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
193 # the user's own configuration file (~/.pinerc).
194 # For more information on the format of this file, read the
195 # comments at the top of %{_sysconfdir}/%{name}/alpine.conf
196
197 EOF
198
199 %clean
200 rm -rf $RPM_BUILD_ROOT
201
202 %files
203 %defattr(644,root,root,755)
204 %doc README doc/tech-notes.txt
205 %dir %{_sysconfdir}/%{name}
206 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
207 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
208 %attr(755,root,root) %{_bindir}/%{name}
209 %attr(755,root,root) %{_bindir}/pine
210 %attr(755,root,root) %{_bindir}/rpload
211 %attr(755,root,root) %{_bindir}/rpdump
212 %{_mandir}/man1/%{name}.1*
213 %{_mandir}/man1/rpload.1*
214 %{_mandir}/man1/rpdump.1*
215 %{_desktopdir}/%{name}.desktop
216 %{_pixmapsdir}/%{name}.png
217
218 %files -n pico
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_bindir}/pico
221 %{_desktopdir}/pico.desktop
222 %{_mandir}/man1/pico*
223
224 %files -n pilot
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_bindir}/pilot
227 %{_mandir}/man1/pilot*
This page took 0.064638 seconds and 3 git commands to generate.