]> git.pld-linux.org Git - packages/allegro5.git/blob - allegro5.spec
- release 3 (by relup.sh)
[packages/allegro5.git] / allegro5.spec
1 #
2 # TODO:
3 # - check if it's usable now
4 #
5 # Conditional build:
6 %bcond_without  alsa            # ALSA support in allegro_audio library
7 %bcond_with     curl            # cURL example
8 %bcond_without  doc             # rebuild HTML and texinfo documentation
9 %bcond_without  dumb            # MOD support in allegro_acodec library
10 %bcond_without  gtk             # (GTK+ 2.x based) native dialog library
11 %bcond_without  openal          # OpenAL support in allegro_audio library
12 %bcond_without  physfs          # PhysFS addon library
13 %bcond_without  pulseaudio      # PulseAudio support in allegro_audio library
14 %bcond_without  python          # Python wrapper
15 %bcond_with     sse             # SSE instructions usage
16 #
17 %ifarch pentium3 pentium4 %{x8664}
18 %define with_sse        1
19 %endif
20 Summary:        A game programming library
21 Summary(de.UTF-8):      Eine Bibliothek zur Programmierung von Spielen
22 Summary(es.UTF-8):      Una biblioteca de programación de juegos
23 Summary(fr.UTF-8):      Une librairie de programmation de jeux
24 Summary(it.UTF-8):      Una libreria per la programmazione di videogiochi
25 Summary(pl.UTF-8):      Biblioteka do programowania gier
26 Name:           allegro5
27 Version:        5.0.10
28 Release:        3
29 License:        Giftware
30 Group:          Libraries
31 Source0:        http://downloads.sourceforge.net/alleg/allegro-%{version}.tar.gz
32 # Source0-md5:  bf51a90e158ff8b1cec0514ef70195cf
33 Patch0:         %{name}-glx.patch
34 URL:            http://alleg.sourceforge.net/
35 %{?with_openal:BuildRequires:   OpenAL-devel}
36 BuildRequires:  OpenGL-GLU-devel
37 BuildRequires:  OpenGL-devel
38 %{?with_alsa:BuildRequires:     alsa-lib-devel}
39 BuildRequires:  cmake >= 2.6
40 %{?with_curl:BuildRequires:     curl-devel}
41 BuildRequires:  dumb-devel
42 BuildRequires:  flac-devel
43 BuildRequires:  freetype-devel >= 2
44 %{?with_gtk:BuildRequires:      glib2-devel >= 2.0}
45 %{?with_gtk:BuildRequires:      gtk+2-devel >= 2.0}
46 BuildRequires:  libjpeg-devel
47 BuildRequires:  libogg-devel
48 BuildRequires:  libpng-devel
49 BuildRequires:  libvorbis-devel
50 %{?with_physfs:BuildRequires:   physfs-devel}
51 BuildRequires:  pkgconfig
52 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9.15}
53 BuildRequires:  rpmbuild(macros) >= 1.605
54 BuildRequires:  xorg-lib-libX11-devel
55 BuildRequires:  xorg-lib-libXcursor-devel
56 BuildRequires:  xorg-lib-libXext-devel
57 BuildRequires:  xorg-lib-libXinerama-devel
58 BuildRequires:  xorg-lib-libXpm-devel
59 BuildRequires:  xorg-lib-libXrandr-devel
60 BuildRequires:  xorg-lib-libXxf86vm-devel
61 BuildRequires:  zlib-devel
62 %if %{with python}
63 BuildRequires:  python
64 BuildRequires:  python-modules
65 BuildRequires:  rpm-pythonprov
66 %endif
67 %if %{with doc}
68 BuildRequires:  ctags
69 BuildRequires:  pandoc >= 1.5
70 BuildRequires:  texinfo
71 BuildRequires:  texlive-latex
72 %endif
73 Obsoletes:      allegro5-tools
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 Allegro is a cross-platform library intended for use in computer games
78 and other types of multimedia programming.
79
80 %description -l de.UTF-8
81 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
82 Computerspielen und anderen Formen von Multinediaprogrammierung.
83
84 %description -l es.UTF-8
85 Allegro es una librería multi-plataforma creada para ser usada en la
86 programación de juegos u otro tipo de programación multimedia.
87
88 %description -l fr.UTF-8
89 Allegro est une librairie multi-plateforme destinée à être utilisée
90 dans les jeux vidéo ou d'autres types de programmation multimédia.
91
92 %description -l it.UTF-8
93 Allegro è una libreria multipiattaforma dedicata all'uso nei
94 videogiochi ed in altri tipi di programmazione multimediale.
95
96 %description -l pl.UTF-8
97 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
98 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
99
100 %package devel
101 Summary:        A game programming library - header files
102 Summary(es.UTF-8):      Archivos de inclusión
103 Summary(pl.UTF-8):      Biblioteka do programowania gier - pliki nagłówkowe
104 Group:          Development/Libraries
105 Requires:       %{name} = %{version}-%{release}
106
107 %description devel
108 Allegro is a cross-platform library intended for use in computer games
109 and other types of multimedia programming.
110
111 This package contains header files neccessary for compiling
112 applications using allegro library.
113
114 %description devel -l de.UTF-8
115 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
116 Computerspielen und anderen Formen von Multinediaprogrammierung.
117 Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
118 verwenden.
119
120 %description devel -l es.UTF-8
121 Allegro es una librería multi-plataforma creada para ser usada en la
122 programación de juegos u otro tipo de programación multimedia. Este
123 paquete es necesario para compilar los programas que usen Allegro.
124
125 %description devel -l fr.UTF-8
126 Allegro est une librairie multi-plateforme destinée à être utilisée
127 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
128 package est nécessaire pour compiler les programmes utilisant Allegro.
129
130 %description devel -l it.UTF-8
131 Allegro è una libreria multipiattaforma dedicata all'uso nei
132 videogiochi ed in altri tipi di programmazione multimediale. Questo
133 pacchetto è necessario per compilare programmi scritti con Allegro.
134
135 %description devel -l pl.UTF-8
136 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
137 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
138
139 Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
140 aplikacji wykorzystujących bibliotekę allegro.
141
142 %package acodec
143 Summary:        Allegro acodec addon library
144 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro acodec
145 Group:          Libraries
146 Requires:       %{name}-audio = %{version}-%{release}
147
148 %description acodec
149 Allegro acodec addon library.
150
151 %description acodec -l pl.UTF-8
152 Biblioteka dodatkowa Allegro acodec.
153
154 %package acodec-devel
155 Summary:        Header files for Allegro acodec addon library
156 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro acodec
157 Group:          Libraries
158 Requires:       %{name}-acodec = %{version}-%{release}
159 Requires:       %{name}-audio-devel = %{version}-%{release}
160
161 %description acodec-devel
162 Header files for Allegro acodec addon library.
163
164 %description acodec-devel -l pl.UTF-8
165 Pliki nagłówkowe biblioteki dodatkowej Allegro acodec.
166
167 %package audio
168 Summary:        Allegro audio addon library
169 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro audio
170 Group:          Libraries
171 Requires:       %{name} = %{version}-%{release}
172
173 %description audio
174 Allegro audio addon library.
175
176 %description audio -l pl.UTF-8
177 Biblioteka dodatkowa Allegro audio.
178
179 %package audio-devel
180 Summary:        Header files for Allegro audio addon library
181 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro audio
182 Group:          Libraries
183 Requires:       %{name}-audio = %{version}-%{release}
184 Requires:       %{name}-devel = %{version}-%{release}
185
186 %description audio-devel
187 Header files for Allegro audio addon library.
188
189 %description audio-devel -l pl.UTF-8
190 Pliki nagłówkowe biblioteki dodatkowej Allegro audio.
191
192 %package dialog
193 Summary:        Allegro dialog addon library
194 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro dialog
195 Group:          Libraries
196 Requires:       %{name} = %{version}-%{release}
197
198 %description dialog
199 Allegro dialog addon library.
200
201 %description dialog -l pl.UTF-8
202 Biblioteka dodatkowa Allegro dialog.
203
204 %package dialog-devel
205 Summary:        Header files for Allegro dialog addon library
206 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro dialog
207 Group:          Libraries
208 Requires:       %{name}-dialog = %{version}-%{release}
209 Requires:       %{name}-devel = %{version}-%{release}
210
211 %description dialog-devel
212 Header files for Allegro dialog addon library.
213
214 %description dialog-devel -l pl.UTF-8
215 Pliki nagłówkowe biblioteki dodatkowej Allegro dialog.
216
217 %package image
218 Summary:        Allegro image addon library
219 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro image
220 Group:          Libraries
221 Requires:       %{name} = %{version}-%{release}
222
223 %description image
224 Allegro image addon library.
225
226 %description image -l pl.UTF-8
227 Biblioteka dodatkowa Allegro image.
228
229 %package image-devel
230 Summary:        Header files for Allegro image addon library
231 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro image
232 Group:          Libraries
233 Requires:       %{name}-image = %{version}-%{release}
234 Requires:       %{name}-devel = %{version}-%{release}
235
236 %description image-devel
237 Header files for Allegro image addon library.
238
239 %description image-devel -l pl.UTF-8
240 Pliki nagłówkowe biblioteki dodatkowej Allegro image.
241
242 %package physfs
243 Summary:        Allegro physfs addon library
244 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro physfs
245 Group:          Libraries
246 Requires:       %{name} = %{version}-%{release}
247
248 %description physfs
249 Allegro physfs addon library.
250
251 %description physfs -l pl.UTF-8
252 Biblioteka dodatkowa Allegro physfs.
253
254 %package physfs-devel
255 Summary:        Header files for Allegro physfs addon library
256 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro physfs
257 Group:          Libraries
258 Requires:       %{name}-physfs = %{version}-%{release}
259 Requires:       %{name}-devel = %{version}-%{release}
260
261 %description physfs-devel
262 Header files for Allegro physfs addon library.
263
264 %description physfs-devel -l pl.UTF-8
265 Pliki nagłówkowe biblioteki dodatkowej Allegro physfs.
266
267 %package ttf
268 Summary:        Allegro ttf addon library
269 Summary(pl.UTF-8):      Biblioteka dodatkowa Allegro ttf
270 Group:          Libraries
271 Requires:       %{name} = %{version}-%{release}
272
273 %description ttf
274 Allegro ttf addon library.
275
276 %description ttf -l pl.UTF-8
277 Biblioteka dodatkowa Allegro ttf.
278
279 %package ttf-devel
280 Summary:        Header files for Allegro ttf addon library
281 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dodatkowej Allegro ttf
282 Group:          Libraries
283 Requires:       %{name}-ttf = %{version}-%{release}
284 Requires:       %{name}-devel = %{version}-%{release}
285
286 %description ttf-devel
287 Header files for Allegro ttf addon library.
288
289 %description ttf-devel -l pl.UTF-8
290 Pliki nagłówkowe biblioteki dodatkowej Allegro ttf.
291
292 %package examples
293 Summary:        A game programming library - examples
294 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy przykładowe
295 Group:          Development/Libraries
296 Requires:       %{name} = %{version}-%{release}
297
298 %description examples
299 This package contains example programs which demonstrate allegro
300 features.
301
302 %description examples -l pl.UTF-8
303 Pakiet zawiera programy przykładowe demonstrujące możliwości
304 biblioteki allegro.
305
306 %package -n python-%{name}
307 Summary:        Python wrapper for Allegro library
308 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki Allegro
309 Group:          Development/Languages/Python
310 Requires:       %{name} = %{version}-%{release}
311 Requires:       python-modules
312
313 %description -n python-%{name}
314 Python wrapper for Allegro library.
315
316 %description -n python-%{name} -l pl.UTF-8
317 Pythonowy interfejs do biblioteki Allegro.
318
319 %prep
320 %setup -q -n allegro-%{version}
321 %patch0 -p1
322
323 %build
324 install -d build
325 cd build
326 %cmake .. \
327         -DMANDIR=%{_mandir} \
328         -DINFODIR=%{_infodir} \
329         %{!?with_sse:-DWANT_ALLOW_SSE=OFF} \
330         %{!?with_alsa:-DWANT_ALSA=OFF} \
331         %{?with_curl:-DWANT_CURL_EXAMPLE=ON} \
332         %{!?with_dumb:-DWANT_MODAUDIO=OFF} \
333         %{!?with_gtk:-DWANT_NATIVE_DIALOG=OFF} \
334         %{!?with_openal:-DWANT_OPENAL=OFF} \
335         %{!?with_physfs:-DWANT_PHYSFS=OFF} \
336         %{!?with_pulseaudio:-DWANT_PULSEAUDIO=OFF} \
337         %{?with_python:-DWANT_PYTHON_WRAPPER=ON}
338
339 %{__make}
340
341 %install
342 rm -rf $RPM_BUILD_ROOT
343 install -d $RPM_BUILD_ROOT%{_bindir}
344
345 %{__make} install -C build \
346         DESTDIR=$RPM_BUILD_ROOT
347
348 %if %{with python}
349 install -d $RPM_BUILD_ROOT%{py_sitescriptdir}
350 install build/python/allegro.py $RPM_BUILD_ROOT%{py_sitescriptdir}
351 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
352 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
353 %py_postclean
354 %endif
355
356 install -d $RPM_BUILD_ROOT%{_mandir}/man3
357 cp -p docs/man/*.3 $RPM_BUILD_ROOT%{_mandir}/man3
358
359 # install examples
360 find build/examples -maxdepth 1 -perm 755 -name "ex*" -exec install {} $RPM_BUILD_ROOT%{_bindir} \;
361
362 %clean
363 rm -rf $RPM_BUILD_ROOT
364
365 %post   -p /sbin/ldconfig
366 %postun -p /sbin/ldconfig
367
368 %post   acodec -p /sbin/ldconfig
369 %postun acodec -p /sbin/ldconfig
370
371 %post   audio -p /sbin/ldconfig
372 %postun audio -p /sbin/ldconfig
373
374 %post   dialog -p /sbin/ldconfig
375 %postun dialog -p /sbin/ldconfig
376
377 %post   image -p /sbin/ldconfig
378 %postun image -p /sbin/ldconfig
379
380 %post   physfs -p /sbin/ldconfig
381 %postun physfs -p /sbin/ldconfig
382
383 %post   ttf -p /sbin/ldconfig
384 %postun ttf -p /sbin/ldconfig
385
386 %files
387 %defattr(644,root,root,755)
388 %doc CHANGES-5.0.txt README.txt docs/html/refman
389 %attr(755,root,root) %{_libdir}/liballegro.so.*.*.*
390 %attr(755,root,root) %ghost %{_libdir}/liballegro.so.5.0
391 %attr(755,root,root) %{_libdir}/liballegro_color.so.*.*.*
392 %attr(755,root,root) %ghost %{_libdir}/liballegro_color.so.5.0
393 %attr(755,root,root) %{_libdir}/liballegro_font.so.*.*.*
394 %attr(755,root,root) %ghost %{_libdir}/liballegro_font.so.5.0
395 %attr(755,root,root) %{_libdir}/liballegro_main.so.*.*.*
396 %attr(755,root,root) %ghost %{_libdir}/liballegro_main.so.5.0
397 %attr(755,root,root) %{_libdir}/liballegro_memfile.so.*.*.*
398 %attr(755,root,root) %ghost %{_libdir}/liballegro_memfile.so.5.0
399 %attr(755,root,root) %{_libdir}/liballegro_primitives.so.*.*.*
400 %attr(755,root,root) %ghost %{_libdir}/liballegro_primitives.so.5.0
401
402 %files devel
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{_libdir}/liballegro.so
405 %attr(755,root,root) %{_libdir}/liballegro_color.so
406 %attr(755,root,root) %{_libdir}/liballegro_font.so
407 %attr(755,root,root) %{_libdir}/liballegro_main.so
408 %attr(755,root,root) %{_libdir}/liballegro_memfile.so
409 %attr(755,root,root) %{_libdir}/liballegro_primitives.so
410 %{_includedir}/allegro5
411 %exclude %{_includedir}/allegro5/allegro_acodec.h
412 %exclude %{_includedir}/allegro5/allegro_audio.h
413 %exclude %{_includedir}/allegro5/allegro_image.h
414 %{?with_gtk:%exclude %{_includedir}/allegro5/allegro_native_dialog.h}
415 %{?with_physfs:%exclude %{_includedir}/allegro5/allegro_physfs.h}
416 %exclude %{_includedir}/allegro5/allegro_ttf.h
417 %{_pkgconfigdir}/allegro-5.0.pc
418 %{_pkgconfigdir}/allegro-5.pc
419 %{_pkgconfigdir}/allegro_color-5.0.pc
420 %{_pkgconfigdir}/allegro_color-5.pc
421 %{_pkgconfigdir}/allegro_font-5.0.pc
422 %{_pkgconfigdir}/allegro_font-5.pc
423 %{_pkgconfigdir}/allegro_main-5.0.pc
424 %{_pkgconfigdir}/allegro_main-5.pc
425 %{_pkgconfigdir}/allegro_memfile-5.0.pc
426 %{_pkgconfigdir}/allegro_memfile-5.pc
427 %{_pkgconfigdir}/allegro_primitives-5.0.pc
428 %{_pkgconfigdir}/allegro_primitives-5.pc
429 %{_mandir}/man3/ALLEGRO_*.3*
430 %{_mandir}/man3/al_*.3*
431
432 %files acodec
433 %defattr(644,root,root,755)
434 %attr(755,root,root) %{_libdir}/liballegro_acodec.so.*.*.*
435 %attr(755,root,root) %ghost %{_libdir}/liballegro_acodec.so.5.0
436
437 %files acodec-devel
438 %defattr(644,root,root,755)
439 %attr(755,root,root) %{_libdir}/liballegro_acodec.so
440 %{_includedir}/allegro5/allegro_acodec.h
441 %{_pkgconfigdir}/allegro_acodec-5.0.pc
442 %{_pkgconfigdir}/allegro_acodec-5.pc
443
444 %files audio
445 %defattr(644,root,root,755)
446 %attr(755,root,root) %{_libdir}/liballegro_audio.so.*.*.*
447 %attr(755,root,root) %ghost %{_libdir}/liballegro_audio.so.5.0
448
449 %files audio-devel
450 %defattr(644,root,root,755)
451 %attr(755,root,root) %{_libdir}/liballegro_audio.so
452 %{_includedir}/allegro5/allegro_audio.h
453 %{_pkgconfigdir}/allegro_audio-5.0.pc
454 %{_pkgconfigdir}/allegro_audio-5.pc
455
456 %if %{with gtk}
457 %files dialog
458 %defattr(644,root,root,755)
459 %attr(755,root,root) %{_libdir}/liballegro_dialog.so.*.*.*
460 %attr(755,root,root) %ghost %{_libdir}/liballegro_dialog.so.5.0
461
462 %files dialog-devel
463 %defattr(644,root,root,755)
464 %attr(755,root,root) %{_libdir}/liballegro_dialog.so
465 %{_includedir}/allegro5/allegro_native_dialog.h
466 %{_pkgconfigdir}/allegro_dialog-5.0.pc
467 %{_pkgconfigdir}/allegro_dialog-5.pc
468 %endif
469
470 %files image
471 %defattr(644,root,root,755)
472 %attr(755,root,root) %{_libdir}/liballegro_image.so.*.*.*
473 %attr(755,root,root) %ghost %{_libdir}/liballegro_image.so.5.0
474
475 %files image-devel
476 %defattr(644,root,root,755)
477 %attr(755,root,root) %{_libdir}/liballegro_image.so
478 %{_includedir}/allegro5/allegro_image.h
479 %{_pkgconfigdir}/allegro_image-5.0.pc
480 %{_pkgconfigdir}/allegro_image-5.pc
481
482 %if %{with physfs}
483 %files physfs
484 %defattr(644,root,root,755)
485 %attr(755,root,root) %{_libdir}/liballegro_physfs.so.*.*.*
486 %attr(755,root,root) %ghost %{_libdir}/liballegro_physfs.so.5.0
487
488 %files physfs-devel
489 %defattr(644,root,root,755)
490 %attr(755,root,root) %{_libdir}/liballegro_physfs.so
491 %{_includedir}/allegro5/allegro_physfs.h
492 %{_pkgconfigdir}/allegro_physfs-5.0.pc
493 %{_pkgconfigdir}/allegro_physfs-5.pc
494 %endif
495
496 %files ttf
497 %defattr(644,root,root,755)
498 %attr(755,root,root) %ghost %{_libdir}/liballegro_ttf.so.5.0
499 %attr(755,root,root) %{_libdir}/liballegro_ttf.so.*.*.*
500
501 %files ttf-devel
502 %defattr(644,root,root,755)
503 %attr(755,root,root) %{_libdir}/liballegro_ttf.so
504 %{_includedir}/allegro5/allegro_ttf.h
505 %{_pkgconfigdir}/allegro_ttf-5.0.pc
506 %{_pkgconfigdir}/allegro_ttf-5.pc
507
508 %files examples
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{_bindir}/ex_acodec
511 %attr(755,root,root) %{_bindir}/ex_acodec_multi
512 %attr(755,root,root) %{_bindir}/ex_audio_chain
513 %attr(755,root,root) %{_bindir}/ex_audio_props
514 %attr(755,root,root) %{_bindir}/ex_audio_simple
515 %attr(755,root,root) %{_bindir}/ex_audio_timer
516 %attr(755,root,root) %{_bindir}/ex_bitmap
517 %attr(755,root,root) %{_bindir}/ex_bitmap_flip
518 %attr(755,root,root) %{_bindir}/ex_bitmap_target
519 %attr(755,root,root) %{_bindir}/ex_blend
520 %attr(755,root,root) %{_bindir}/ex_blend2
521 %attr(755,root,root) %{_bindir}/ex_blend_bench
522 %attr(755,root,root) %{_bindir}/ex_blend_test
523 %attr(755,root,root) %{_bindir}/ex_blit
524 %attr(755,root,root) %{_bindir}/ex_clip
525 %attr(755,root,root) %{_bindir}/ex_color
526 %attr(755,root,root) %{_bindir}/ex_config
527 %attr(755,root,root) %{_bindir}/ex_convert
528 %{?with_curl:%attr(755,root,root) %{_bindir}/ex_curl}
529 %attr(755,root,root) %{_bindir}/ex_dir
530 %attr(755,root,root) %{_bindir}/ex_disable_screensaver
531 %attr(755,root,root) %{_bindir}/ex_display_events
532 %attr(755,root,root) %{_bindir}/ex_display_options
533 %attr(755,root,root) %{_bindir}/ex_draw
534 %attr(755,root,root) %{_bindir}/ex_draw_bitmap
535 %attr(755,root,root) %{_bindir}/ex_drawpixels
536 %attr(755,root,root) %{_bindir}/ex_dualies
537 %attr(755,root,root) %{_bindir}/ex_expose
538 %attr(755,root,root) %{_bindir}/ex_file_slice
539 %attr(755,root,root) %{_bindir}/ex_filter
540 %attr(755,root,root) %{_bindir}/ex_font
541 %attr(755,root,root) %{_bindir}/ex_fs_resize
542 %attr(755,root,root) %{_bindir}/ex_fs_window
543 %attr(755,root,root) %{_bindir}/ex_get_path
544 %attr(755,root,root) %{_bindir}/ex_gldepth
545 %attr(755,root,root) %{_bindir}/ex_glext
546 %attr(755,root,root) %{_bindir}/ex_haiku
547 %attr(755,root,root) %{_bindir}/ex_icon
548 %attr(755,root,root) %{_bindir}/ex_icon2
549 %attr(755,root,root) %{_bindir}/ex_joystick_events
550 %attr(755,root,root) %{_bindir}/ex_joystick_hotplugging
551 %attr(755,root,root) %{_bindir}/ex_font_justify
552 %attr(755,root,root) %{_bindir}/ex_kcm_direct
553 %attr(755,root,root) %{_bindir}/ex_keyboard_events
554 %attr(755,root,root) %{_bindir}/ex_keyboard_focus
555 %attr(755,root,root) %{_bindir}/ex_lines
556 %attr(755,root,root) %{_bindir}/ex_lockbitmap
557 %attr(755,root,root) %{_bindir}/ex_logo
558 %attr(755,root,root) %{_bindir}/ex_membmp
559 %attr(755,root,root) %{_bindir}/ex_memfile
560 %attr(755,root,root) %{_bindir}/ex_mixer_chain
561 %attr(755,root,root) %{_bindir}/ex_mixer_pp
562 %attr(755,root,root) %{_bindir}/ex_monitorinfo
563 %attr(755,root,root) %{_bindir}/ex_mouse
564 %attr(755,root,root) %{_bindir}/ex_mouse_cursor
565 %attr(755,root,root) %{_bindir}/ex_mouse_events
566 %attr(755,root,root) %{_bindir}/ex_mouse_focus
567 %attr(755,root,root) %{_bindir}/ex_multisample
568 %attr(755,root,root) %{_bindir}/ex_multiwin
569 %attr(755,root,root) %{_bindir}/ex_native_filechooser
570 %attr(755,root,root) %{_bindir}/ex_nodisplay
571 %attr(755,root,root) %{_bindir}/ex_noframe
572 %attr(755,root,root) %{_bindir}/ex_opengl
573 %attr(755,root,root) %{_bindir}/ex_opengl_pixel_shader
574 %attr(755,root,root) %{_bindir}/ex_path
575 %attr(755,root,root) %{_bindir}/ex_path_test
576 %{?with_physfs:%attr(755,root,root) %{_bindir}/ex_physfs}
577 %attr(755,root,root) %{_bindir}/ex_pixelformat
578 %attr(755,root,root) %{_bindir}/ex_premulalpha
579 %attr(755,root,root) %{_bindir}/ex_prim
580 %attr(755,root,root) %{_bindir}/ex_resample_test
581 %attr(755,root,root) %{_bindir}/ex_resize
582 %attr(755,root,root) %{_bindir}/ex_resize2
583 %attr(755,root,root) %{_bindir}/ex_rotate
584 %attr(755,root,root) %{_bindir}/ex_saw
585 %attr(755,root,root) %{_bindir}/ex_scale
586 %attr(755,root,root) %{_bindir}/ex_stream_file
587 %attr(755,root,root) %{_bindir}/ex_stream_seek
588 %attr(755,root,root) %{_bindir}/ex_subbitmap
589 %attr(755,root,root) %{_bindir}/ex_synth
590 %attr(755,root,root) %{_bindir}/ex_threads
591 %attr(755,root,root) %{_bindir}/ex_threads2
592 %attr(755,root,root) %{_bindir}/ex_timedwait
593 %attr(755,root,root) %{_bindir}/ex_timer
594 %attr(755,root,root) %{_bindir}/ex_transform
595 %attr(755,root,root) %{_bindir}/ex_ttf
596 %attr(755,root,root) %{_bindir}/ex_user_events
597 %attr(755,root,root) %{_bindir}/ex_utf8
598 %attr(755,root,root) %{_bindir}/ex_vsync
599 %attr(755,root,root) %{_bindir}/ex_warp_mouse
600 %attr(755,root,root) %{_bindir}/ex_windows
601 %attr(755,root,root) %{_bindir}/ex_winfull
602
603 %if %{with python}
604 %files -n python-%{name}
605 %defattr(644,root,root,755)
606 %{py_sitescriptdir}/allegro.py[co]
607 %endif
This page took 0.077552 seconds and 3 git commands to generate.