]> git.pld-linux.org Git - packages/allegro5.git/blob - allegro.spec
- fixed opt patch, updated frame-pointer patch, cleanups
[packages/allegro5.git] / allegro.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # without ALSA modules
4 %bcond_without  arts    # without aRts module
5 %bcond_without  dbglib  # don't build debug versions of library
6 %bcond_without  proflib # don't debug profiling versions of library
7 %bcond_without  svga    # without svgalib module
8 %bcond_without  sse     # build without sse (valgrind doesn't support it yet)
9 #
10 %ifnarch %{ix86} alpha
11 %undefine       with_svga
12 %endif
13 Summary:        A game programming library
14 Summary(de):    Eine Bibliothek zur Programmierung von Spielen
15 Summary(es):    Una libreria de programacion de juegos
16 Summary(fr):    Une librairie de programmation de jeux
17 Summary(it):    Una libreria per la programmazione di videogiochi
18 Summary(pl):    Biblioteka do programowania gier
19 Name:           allegro
20 Version:        4.1.12
21 Release:        2
22 License:        Giftware
23 Group:          Libraries
24 Source0:        http://dl.sourceforge.net/alleg/%{name}-%{version}.tar.gz
25 # Source0-md5:  93c215aab32b086dcfd8a74c1d383abc
26 Patch0:         %{name}-info.patch
27 Patch1:         %{name}-examples.patch
28 Patch2:         %{name}-opt.patch
29 Patch3:         %{name}-ldflags.patch
30 Patch4:         %{name}-frame-pointer.patch
31 URL:            http://alleg.sourceforge.net/
32 BuildRequires:  XFree86-devel
33 %{?with_alsa:BuildRequires:     alsa-lib-devel}
34 %{?with_arts:BuildRequires:     arts-devel}
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  esound-devel
38 %{?with_svga:BuildRequires:     svgalib-devel}
39 BuildRequires:  texinfo
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Allegro is a cross-platform library intended for use in computer games
44 and other types of multimedia programming.
45
46 %description -l de
47 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
48 Computerspielen und anderen Formen von Multinediaprogrammierung.
49
50 %description -l es
51 Allegro es una librería multi-plataforma creada para ser usada en la
52 programación de juegos u otro tipo de programación multimedia.
53
54 %description -l fr
55 Allegro est une librairie multi-plateforme destinée à être utilisée dans
56 les jeux vidéo ou d'autres types de programmation multimédia.
57
58 %description -l it
59 Allegro è una libreria multipiattaforma dedicata all'uso nei videogiochi
60 ed in altri tipi di programmazione multimediale.
61
62 %description -l pl
63 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
64 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
65
66 %package devel
67 Summary:        A game programming library - header files
68 Summary(pl):    Biblioteka do programowania gier - pliki nag³ówkowe
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}
71
72 %description devel
73 Allegro is a cross-platform library intended for use in computer games
74 and other types of multimedia programming.
75
76 This package contains header files neccessary for compiling
77 applications using allegro library.
78
79 %description devel -l de
80 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
81 Computerspielen und anderen Formen von Multinediaprogrammierung.
82 Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
83 verwenden.
84
85 %description devel -l es
86 Allegro es una librería multi-plataforma creada para ser usada en la
87 programación de juegos u otro tipo de programación multimedia. Este
88 paquete es necesario para compilar los programas que usen Allegro.
89
90 %description devel -l fr
91 Allegro est une librairie multi-plateforme destinée à être utilisée dans
92 les jeux vidéo ou d'autres types de programmation multimédia. Ce package
93 est nécessaire pour compiler les programmes utilisant Allegro.
94
95 %description devel -l it
96 Allegro è una libreria multipiattaforma dedicata all'uso nei videogiochi
97 ed in altri tipi di programmazione multimediale. Questo pacchetto è
98 necessario per compilare programmi scritti con Allegro.
99
100 %description devel -l pl
101 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
102 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
103
104 Ten pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania
105 aplikacji wykorzystuj±cych bibliotekê allegro.
106
107 %package static
108 Summary:        A game programming library - static libraries
109 Summary(pl):    Biblioteka do programowania gier - biblioteki statyczne
110 Group:          Development/Libraries
111 Requires:       %{name}-devel = %{version}
112
113 %description static
114 Allegro is a cross-platform library intended for use in computer games
115 and other types of multimedia programming.
116
117 This package contains static libraries for linking with allegro
118 applications.
119
120 %description static -l pl
121 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
122 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
123
124 Ten pakiet zawiera biblioteki statyczne do konsolidacji z aplikacjami
125 wykorzystuj±cymi allegro.
126
127 %package debug
128 Summary:        liballd - debug version of shared allegro library
129 Summary(pl):    liballd - wersja debug dzielonej biblioteki allegro
130 Group:          Development/Libraries
131 Requires:       %{name}-devel = %{version}
132
133 %description debug
134 liballd - debug version of shared allegro library (contains debugging
135 symbols and other information).
136
137 %description debug -l pl
138 liballd - wersja debug dzielonej biblioteki allegro (zawieraj±ca
139 symbole i inne informacje potrzebne przy odpluskwianiu).
140
141 %package debug-static
142 Summary:        liballd - debug version of static allegro library
143 Summary(pl):    liballd - wersja debug statycznej biblioteki allegro
144 Group:          Development/Libraries
145 Requires:       %{name}-devel = %{version}
146
147 %description debug-static
148 liballd - debug version of static allegro library (contains debugging
149 symbols and other information).
150
151 %description debug-static -l pl
152 liballd - wersja debug statycznej biblioteki allegro (zawieraj±ca
153 symbole i inne informacje potrzebne przy odpluskwianiu).
154
155 %package profile
156 Summary:        liballp - profiling version of shared allegro library
157 Summary(pl):    liballp - wersja dzielonej biblioteki allegro s³u¿±ca do profilowania
158 Group:          Development/Libraries
159 Requires:       %{name}-devel = %{version}
160
161 %description profile
162 liballp - profiling version of shared allegro library.
163
164 %description profile -l pl
165 liballp - wersja dzielonej biblioteki allegro s³u¿±ca do profilowania.
166
167 %package profile-static
168 Summary:        liballp - profiling version of static allegro library
169 Summary(pl):    liballp - wersja statycznej biblioteki allegro s³u¿±ca do profilowania
170 Group:          Development/Libraries
171 Requires:       %{name}-devel = %{version}
172
173 %description profile-static
174 liballp - profiling version of static allegro library.
175
176 %description debug-static -l pl
177 liballp - wersja statycznej biblioteki allegro s³u¿±ca do
178 profilowania.
179
180 %package svgalib
181 Summary:        A game programming library - svgalib module
182 Summary(pl):    Biblioteka do programowania gier - modu³ dla svgalib
183 Group:          Libraries
184 PreReq:         %{name} = %{version}
185
186 %description svgalib
187 Allegro is a cross-platform library intended for use in computer games
188 and other types of multimedia programming.
189
190 This package contains module for use with allegro and svgalib.
191
192 %description svgalib -l pl
193 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
194 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
195
196 Ten pakiet zawiera modu³ do wykorzystania allegro z svgalibem.
197
198 %package dga2
199 Summary:        A game programming library - DGA2 module
200 Summary(pl):    Biblioteka do programowania gier - modu³ dla DGA2
201 Group:          Libraries
202 PreReq:         %{name} = %{version}
203
204 %description dga2
205 Allegro is a cross-platform library intended for use in computer games
206 and other types of multimedia programming.
207
208 This package contains module for use with DGA.
209
210 %description dga2 -l pl
211 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
212 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
213
214 Ten pakiet zawiera modu³ do wykorzystania z DGA.
215
216 %package esd
217 Summary:        A game programming library - esound module
218 Summary(pl):    Biblioteka do programowania gier - modu³ dla esound
219 Group:          Libraries
220 PreReq:         %{name} = %{version}
221
222 %description esd
223 Allegro is a cross-platform library intended for use in computer games
224 and other types of multimedia programming.
225
226 This package contains a esound module for use with ESound daemon.
227
228 %description esd -l pl
229 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
230 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
231
232 Ten pakiet zawiera modu³ do wykorzystania z demonem ESound.
233
234 %package arts
235 Summary:        A game programming library - aRts module
236 Summary(pl):    Biblioteka do programowania gier - modu³ dla aRts
237 Group:          Libraries
238 PreReq:         %{name} = %{version}
239
240 %description arts
241 Allegro is a cross-platform library intended for use in computer games
242 and other types of multimedia programming.
243
244 This package contains a esound module for use with aRts.
245
246 %description arts -l pl
247 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
248 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
249
250 Ten pakiet zawiera modu³ do wykorzystania z aRts.
251
252 %package fbcon
253 Summary:        A game programming library - framebuffer module
254 Summary(pl):    Biblioteka do programowania gier - modu³ dla framebuffera
255 Group:          Libraries
256 PreReq:         %{name} = %{version}
257
258 %description fbcon
259 Allegro is a cross-platform library intended for use in computer games
260 and other types of multimedia programming.
261
262 This package contains a esound module for use with framebuffer.
263
264 %description fbcon -l pl
265 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
266 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
267
268 Ten pakiet zawiera modu³ do wykorzystania z framebufferem.
269
270 %package vga
271 Summary:        A game programming library - vga module
272 Summary(pl):    Biblioteka do programowania gier - modu³ dla vga
273 Group:          Libraries
274 PreReq:         %{name} = %{version}
275
276 %description vga
277 Allegro is a cross-platform library intended for use in computer games
278 and other types of multimedia programming.
279
280 This package contains a esound module for use with vga.
281
282 %description vga -l pl
283 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
284 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
285
286 Ten pakiet zawiera modu³ do wykorzystania z vga.
287
288 %package alsa
289 Summary:        A game programming library - ALSA modules
290 Summary(pl):    Biblioteka do programowania gier - modu³y dla ALSA
291 Group:          Libraries
292 PreReq:         %{name} = %{version}
293 Obsoletes:      allegro-alsa9
294
295 %description alsa
296 Allegro is a cross-platform library intended for use in computer games
297 and other types of multimedia programming.
298
299 This package contains modules for use with ALSA sound library.
300
301 %description alsa -l pl
302 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
303 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
304
305 Ten pakiet zawiera modu³y do wykorzystania z bibliotek± d¼wiêkow±
306 ALSA.
307
308 %package tools
309 Summary:        A game programming library - tools
310 Summary(de):    Zusätzliche Hilfprogramme für die Allegro Bibliothek
311 Summary(es):    Herramientas adicionales para la librería de programación Allegro
312 Summary(fr):    Outils supplémentaires pour la librairie de programmation Allegro
313 Summary(it):    Programmi di utilità aggiuntivi per la libreria Allegro
314 Summary(pl):    Biblioteka do programowania gier - narzêdzia
315 Group:          Libraries
316 PreReq:         %{name} = %{version}
317
318 %description tools
319 Allegro is a cross-platform library intended for use in computer games
320 and other types of multimedia programming.
321
322 This package contains tools.
323
324 %description tools -l de
325 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
326 Computerspielen und anderen Formen von Multinediaprogrammierung.
327 Dieses Paket enthält Programme, die für die Entwicklung von
328 Allegro Programmen hilfreich sind.
329
330 %description tools -l es
331 Allegro es una librería multi-plataforma creada para ser usada en la
332 programación de juegos u otro tipo de programación multimedia. Este
333 paquete contiene herramientas adicionales que son útiles para
334 desarrollar programas que usen Allegro.
335
336 %description tools -l fr
337 Allegro est une librairie multi-plateforme destinée à être utilisée dans
338 les jeux vidéo ou d'autres types de programmation multimédia. Ce package
339 contient des outils supplémentaires qui sont utiles pour le développement
340 de programmes avec Allegro.
341
342 %description tools -l it
343 Allegro è una libreria multipiattaforma dedicata all'uso nei videogiochi
344 ed in altri tipi di programmazione multimediale. Questo pacchetto
345 contiene programmi di utilità aggiuntivi utili allo sviluppo di programmi
346 con Allegro.
347
348 %description tools -l pl
349 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
350 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
351
352 Ten pakiet zawiera narzêdzia.
353
354 %package tests
355 Summary:        A game programming library - test programs
356 Summary(pl):    Biblioteka do programowania gier - programy testuj±ce
357 Group:          Development/Libraries
358 Requires:       %{name} = %{version}
359
360 %description tests
361 This package contains programs for testing allegro library.
362
363 %description tests -l pl
364 Pakiet zawiera programy testuj±ce bibliotekê allegro.
365
366 %package examples
367 Summary:        A game programming library - examples
368 Summary(pl):    Biblioteka do programowania gier - programy przyk³adowe
369 Group:          Development/Libraries
370 Requires:       %{name} = %{version}
371
372 %description examples
373 This package contains example programs which demonstrate allegro
374 features.
375
376 %description examples -l pl
377 Pakiet zawiera programy przyk³adowe demonstruj±ce mo¿liwo¶ci
378 biblioteki allegro.
379
380 %prep
381 %setup -q
382 %patch0 -p1
383 %patch1 -p1
384 %patch2 -p1
385 %patch3 -p1
386 %patch4 -p1
387
388 %build
389 %{__aclocal}
390 %{__autoheader} configure.in > include/allegro/platform/alunixac.hin
391 %{__autoconf}
392 TARGET_ARCH="%{rpmcflags}" export TARGET_ARCH
393 # dbglib & proflib are compiled besides normlib, so it's ok to have them here
394 %configure \
395         --enable-static \
396         %{!?with_svga:--disable-svgalib} \
397         %{?with_dbglib:--enable-dbglib} \
398         %{?with_proflib:--enable-proflib} \
399         %{!?with_arts:--disable-artsdigi} \
400         %{!?with_sse:--disable-sse} \
401         %{!?with_sse:--disable-asm} \
402 %ifnarch %{ix86}
403         --disable-asm \
404         --disable-mmx \
405         --disable-sse
406 %endif
407
408 %{__make} \
409         MAKEINFO=makeinfo
410
411 %install
412 rm -rf $RPM_BUILD_ROOT
413
414 %{__make} install install-man install-info install-lib \
415         DESTDIR=$RPM_BUILD_ROOT
416
417 install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/4.1
418
419 mv $RPM_BUILD_ROOT%{_bindir}/demo{,-allegro}
420 mv $RPM_BUILD_ROOT%{_bindir}/play{,-allegro}
421 mv $RPM_BUILD_ROOT%{_bindir}/setup{,-allegro}
422 mv $RPM_BUILD_ROOT%{_bindir}/test{,-allegro}
423
424 # help rpm to find reqs for ELF objects
425 chmod 755 $RPM_BUILD_ROOT%{_libdir}/{*.so,allegro/*/*.so}
426
427 %clean
428 rm -rf $RPM_BUILD_ROOT
429
430 %post   -p /sbin/ldconfig
431 %postun -p /sbin/ldconfig
432
433 %files
434 %defattr(644,root,root,755)
435 %doc AUTHORS CHANGES THANKS
436 %attr(755,root,root) %{_libdir}/liballeg-%{version}.so
437 %dir %{_libdir}/allegro
438 %dir %{_libdir}/allegro/4.1
439 %{_libdir}/allegro/4.1/modules.lst
440
441 %files devel
442 %defattr(644,root,root,755)
443 %attr(755,root,root) %{_bindir}/allegro-config
444 %{_libdir}/liballeg_unsharable.a
445 %{_includedir}/*
446 %{_mandir}/man3/*
447 %{_infodir}/*.info*
448
449 %files static
450 %defattr(644,root,root,755)
451 %{_libdir}/liballeg.a
452
453 %if %{with dbglib}
454 %files debug
455 %defattr(644,root,root,755)
456 %attr(755,root,root) %{_libdir}/liballd-%{version}.so
457 %{_libdir}/liballd_unsharable.a
458
459 %files debug-static
460 %defattr(644,root,root,755)
461 %{_libdir}/liballd.a
462 %endif
463
464 %if %{with proflib}
465 %files profile
466 %defattr(644,root,root,755)
467 %attr(755,root,root) %{_libdir}/liballp-%{version}.so
468 %{_libdir}/liballp_unsharable.a
469
470 %files profile-static
471 %defattr(644,root,root,755)
472 %{_libdir}/liballp.a
473 %endif
474
475 %if %{with svga}
476 %files svgalib
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-svgalib.so
479 %endif
480
481 %files dga2
482 %defattr(644,root,root,755)
483 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-dga2.so
484
485 %files esd
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-esddigi.so
488
489 %if %{with arts}
490 %files arts
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-artsdigi.so
493 %endif
494
495 %files fbcon
496 %defattr(644,root,root,755)
497 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-fbcon.so
498
499 %ifarch %{ix86}
500 %files vga
501 %defattr(644,root,root,755)
502 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-vga.so
503 %endif
504
505 %if %{with alsa}
506 %files alsa
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-alsadigi.so
509 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-alsamidi.so
510 %endif
511
512 %files tools
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_bindir}/colormap
515 %attr(755,root,root) %{_bindir}/exedat
516 %attr(755,root,root) %{_bindir}/pack
517 %attr(755,root,root) %{_bindir}/rgbmap
518 %attr(755,root,root) %{_bindir}/textconv
519 %attr(755,root,root) %{_bindir}/dat
520 %attr(755,root,root) %{_bindir}/dat2c
521 %attr(755,root,root) %{_bindir}/dat2s
522 %attr(755,root,root) %{_bindir}/grabber
523 %attr(755,root,root) %{_bindir}/pat2dat
524 %attr(755,root,root) %{_bindir}/setup-allegro
525 %attr(755,root,root) %{_bindir}/keyconf
526
527 %files tests
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_bindir}/afinfo
530 %attr(755,root,root) %{_bindir}/akaitest
531 %attr(755,root,root) %{_bindir}/demo-allegro
532 %attr(755,root,root) %{_bindir}/digitest
533 %attr(755,root,root) %{_bindir}/filetest
534 %attr(755,root,root) %{_bindir}/gfxinfo
535 %attr(755,root,root) %{_bindir}/mathtest
536 %attr(755,root,root) %{_bindir}/miditest
537 %attr(755,root,root) %{_bindir}/play-allegro
538 %attr(755,root,root) %{_bindir}/playfli
539 %attr(755,root,root) %{_bindir}/test-allegro
540 %attr(755,root,root) %{_bindir}/vesainfo
541
542 %files examples
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_bindir}/ex12bit
545 %attr(755,root,root) %{_bindir}/ex3buf
546 %attr(755,root,root) %{_bindir}/ex3d
547 %attr(755,root,root) %{_bindir}/exaccel
548 %attr(755,root,root) %{_bindir}/exalpha
549 %attr(755,root,root) %{_bindir}/exbitmap
550 %attr(755,root,root) %{_bindir}/exblend
551 %attr(755,root,root) %{_bindir}/excamera
552 %attr(755,root,root) %{_bindir}/excolmap
553 %attr(755,root,root) %{_bindir}/exconfig
554 %attr(755,root,root) %{_bindir}/excustom
555 %attr(755,root,root) %{_bindir}/exdata
556 %attr(755,root,root) %{_bindir}/exdbuf
557 %attr(755,root,root) %{_bindir}/exdodgy
558 %attr(755,root,root) %{_bindir}/exexedat
559 %attr(755,root,root) %{_bindir}/exfixed
560 %attr(755,root,root) %{_bindir}/exflame
561 %attr(755,root,root) %{_bindir}/exflip
562 %attr(755,root,root) %{_bindir}/exgui
563 %attr(755,root,root) %{_bindir}/exhello
564 %attr(755,root,root) %{_bindir}/exjoy
565 %attr(755,root,root) %{_bindir}/exkeys
566 %attr(755,root,root) %{_bindir}/exlights
567 %attr(755,root,root) %{_bindir}/exmem
568 %attr(755,root,root) %{_bindir}/exmidi
569 %attr(755,root,root) %{_bindir}/exmouse
570 %attr(755,root,root) %{_bindir}/expal
571 %attr(755,root,root) %{_bindir}/expat
572 %attr(755,root,root) %{_bindir}/exquat
573 %attr(755,root,root) %{_bindir}/exrgbhsv
574 %attr(755,root,root) %{_bindir}/exsample
575 %attr(755,root,root) %{_bindir}/exscale
576 %attr(755,root,root) %{_bindir}/exscn3d
577 %attr(755,root,root) %{_bindir}/exscroll
578 %attr(755,root,root) %{_bindir}/exshade
579 %attr(755,root,root) %{_bindir}/exspline
580 %attr(755,root,root) %{_bindir}/exsprite
581 %attr(755,root,root) %{_bindir}/exstars
582 %attr(755,root,root) %{_bindir}/exstream
583 %attr(755,root,root) %{_bindir}/exswitch
584 %attr(755,root,root) %{_bindir}/extimer
585 %attr(755,root,root) %{_bindir}/extrans
586 %attr(755,root,root) %{_bindir}/extruec
587 %attr(755,root,root) %{_bindir}/exunicod
588 %attr(755,root,root) %{_bindir}/exupdate
589 %attr(755,root,root) %{_bindir}/exxfade
590 %attr(755,root,root) %{_bindir}/exzbuf
This page took 0.677887 seconds and 4 git commands to generate.