]> git.pld-linux.org Git - packages/allegro.git/blob - allegro.spec
- up to 4.9.13
[packages/allegro.git] / allegro.spec
1 #
2 # TODO: - Handle situations when there are no modules (most bconds turned off)
3 #       - make bconds work again or remove
4 #
5 # Conditional build:
6 %bcond_without  alsa    # without ALSA modules
7 #%%bcond_without        arts    # without aRts module
8 #%%bcond_without        dga2    # without DGA2 module
9 #%%bcond_without        dbglib  # don't build debug versions of library
10 #%%bcond_without        esd     # without esound module
11 #%%bcond_without        fbcon   # without framebuffer module
12 #%%bcond_without        jack    # without JACK module
13 #%%bcond_without        proflib # don't debug profiling versions of library
14 #%%bcond_without        sse     # build without sse
15 %bcond_without  static  # don't build static versions of library
16 #%%bcond_without        svga    # without svgalib module
17 #%%bcond_without        vga     # without vga module
18 #
19 Summary:        A game programming library
20 Summary(de.UTF-8):      Eine Bibliothek zur Programmierung von Spielen
21 Summary(es.UTF-8):      Una biblioteca de programación de juegos
22 Summary(fr.UTF-8):      Une librairie de programmation de jeux
23 Summary(it.UTF-8):      Una libreria per la programmazione di videogiochi
24 Summary(pl.UTF-8):      Biblioteka do programowania gier
25 Name:           allegro
26 Version:        4.9.13
27 Release:        0.1
28 License:        Giftware
29 Group:          Libraries
30 Source0:        http://dl.sourceforge.net/alleg/%{name}-%{version}.tar.gz
31 # Source0-md5:  92c7aabac119abb5d1d566597e07607c
32 Patch0:         %{name}-info.patch
33 Patch1:         %{name}-examples.patch
34 Patch2:         %{name}-opt.patch
35 Patch3:         %{name}-ldflags.patch
36 Patch4:         %{name}-frame-pointer.patch
37 Patch5:         %{name}-config.patch
38 URL:            http://alleg.sourceforge.net/
39 %{?with_alsa:BuildRequires:     alsa-lib-devel}
40 #%%{?with_arts:BuildRequires:   artsc-devel}
41 BuildRequires:  cmake >= 2.6
42 #%%{?with_esd:BuildRequires:    esound-devel}
43 #%%if %{with jack}
44 #BuildRequires: jack-audio-connection-kit-devel
45 #BuildRequires: pkgconfig
46 #%%endif
47 #BuildRequires: sed >= 4.0
48 #%%{?with_svga:BuildRequires:   svgalib-devel}
49 #BuildRequires: texinfo
50 BuildRequires:  xorg-lib-libX11-devel
51 BuildRequires:  xorg-lib-libXcursor-devel
52 BuildRequires:  xorg-lib-libXext-devel
53 BuildRequires:  xorg-lib-libXpm-devel
54 #BuildRequires: xorg-lib-libXxf86dga-devel
55 BuildRequires:  xorg-lib-libXxf86vm-devel
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 Allegro is a cross-platform library intended for use in computer games
60 and other types of multimedia programming.
61
62 %description -l de.UTF-8
63 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
64 Computerspielen und anderen Formen von Multinediaprogrammierung.
65
66 %description -l es.UTF-8
67 Allegro es una librería multi-plataforma creada para ser usada en la
68 programación de juegos u otro tipo de programación multimedia.
69
70 %description -l fr.UTF-8
71 Allegro est une librairie multi-plateforme destinée à être utilisée
72 dans les jeux vidéo ou d'autres types de programmation multimédia.
73
74 %description -l it.UTF-8
75 Allegro è una libreria multipiattaforma dedicata all'uso nei
76 videogiochi ed in altri tipi di programmazione multimediale.
77
78 %description -l pl.UTF-8
79 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
80 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
81
82 %package devel
83 Summary:        A game programming library - header files
84 Summary(es.UTF-8):      Archivos de inclusión
85 Summary(pl.UTF-8):      Biblioteka do programowania gier - pliki nagłówkowe
86 Group:          Development/Libraries
87 Requires:       %{name} = %{version}-%{release}
88
89 %description devel
90 Allegro is a cross-platform library intended for use in computer games
91 and other types of multimedia programming.
92
93 This package contains header files neccessary for compiling
94 applications using allegro library.
95
96 %description devel -l de.UTF-8
97 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
98 Computerspielen und anderen Formen von Multinediaprogrammierung.
99 Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
100 verwenden.
101
102 %description devel -l es.UTF-8
103 Allegro es una librería multi-plataforma creada para ser usada en la
104 programación de juegos u otro tipo de programación multimedia. Este
105 paquete es necesario para compilar los programas que usen Allegro.
106
107 %description devel -l fr.UTF-8
108 Allegro est une librairie multi-plateforme destinée à être utilisée
109 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
110 package est nécessaire pour compiler les programmes utilisant Allegro.
111
112 %description devel -l it.UTF-8
113 Allegro è una libreria multipiattaforma dedicata all'uso nei
114 videogiochi ed in altri tipi di programmazione multimediale. Questo
115 pacchetto è necessario per compilare programmi scritti con Allegro.
116
117 %description devel -l pl.UTF-8
118 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
119 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
120
121 Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
122 aplikacji wykorzystujących bibliotekę allegro.
123
124 %package static
125 Summary:        A game programming library - static libraries
126 Summary(pl.UTF-8):      Biblioteka do programowania gier - biblioteki statyczne
127 Group:          Development/Libraries
128 Requires:       %{name}-devel = %{version}-%{release}
129 Requires:       xorg-lib-libX11-devel
130 Requires:       xorg-lib-libXcursor-devel
131 Requires:       xorg-lib-libXext-devel
132 Requires:       xorg-lib-libXpm-devel
133 Requires:       xorg-lib-libXxf86vm-devel
134
135 %description static
136 Allegro is a cross-platform library intended for use in computer games
137 and other types of multimedia programming.
138
139 This package contains static libraries for linking with allegro
140 applications.
141
142 %description static -l pl.UTF-8
143 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
144 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
145
146 Ten pakiet zawiera biblioteki statyczne do konsolidacji z aplikacjami
147 wykorzystującymi allegro.
148
149 %package debug
150 Summary:        liballd - debug version of shared allegro library
151 Summary(pl.UTF-8):      liballd - wersja debug dzielonej biblioteki allegro
152 Group:          Development/Libraries
153 Requires:       %{name}-devel = %{version}-%{release}
154
155 %description debug
156 liballd - debug version of shared allegro library (contains debugging
157 symbols and other information).
158
159 %description debug -l pl.UTF-8
160 liballd - wersja debug dzielonej biblioteki allegro (zawierająca
161 symbole i inne informacje potrzebne przy odpluskwianiu).
162
163 %package debug-static
164 Summary:        liballd - debug version of static allegro library
165 Summary(pl.UTF-8):      liballd - wersja debug statycznej biblioteki allegro
166 Group:          Development/Libraries
167 Requires:       %{name}-devel = %{version}-%{release}
168
169 %description debug-static
170 liballd - debug version of static allegro library (contains debugging
171 symbols and other information).
172
173 %description debug-static -l pl.UTF-8
174 liballd - wersja debug statycznej biblioteki allegro (zawierająca
175 symbole i inne informacje potrzebne przy odpluskwianiu).
176
177 %package profile
178 Summary:        liballp - profiling version of shared allegro library
179 Summary(pl.UTF-8):      liballp - wersja dzielonej biblioteki allegro służąca do profilowania
180 Group:          Development/Libraries
181 Requires:       %{name}-devel = %{version}-%{release}
182
183 %description profile
184 liballp - profiling version of shared allegro library.
185
186 %description profile -l pl.UTF-8
187 liballp - wersja dzielonej biblioteki allegro służąca do profilowania.
188
189 %package profile-static
190 Summary:        liballp - profiling version of static allegro library
191 Summary(pl.UTF-8):      liballp - wersja statycznej biblioteki allegro służąca do profilowania
192 Group:          Development/Libraries
193 Requires:       %{name}-devel = %{version}-%{release}
194
195 %description profile-static
196 liballp - profiling version of static allegro library.
197
198 %description profile-static -l pl.UTF-8
199 liballp - wersja statycznej biblioteki allegro służąca do
200 profilowania.
201
202 %package svgalib
203 Summary:        A game programming library - svgalib module
204 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla svgalib
205 Group:          Libraries
206 Requires:       %{name} = %{version}-%{release}
207
208 %description svgalib
209 Allegro is a cross-platform library intended for use in computer games
210 and other types of multimedia programming.
211
212 This package contains module for use with allegro and svgalib.
213
214 %description svgalib -l pl.UTF-8
215 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
216 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
217
218 Ten pakiet zawiera moduł do wykorzystania allegro z svgalibem.
219
220 %package dga2
221 Summary:        A game programming library - DGA2 module
222 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla DGA2
223 Group:          Libraries
224 Requires:       %{name} = %{version}-%{release}
225
226 %description dga2
227 Allegro is a cross-platform library intended for use in computer games
228 and other types of multimedia programming.
229
230 This package contains module for use with DGA.
231
232 %description dga2 -l pl.UTF-8
233 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
234 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
235
236 Ten pakiet zawiera moduł do wykorzystania z DGA.
237
238 %package esd
239 Summary:        A game programming library - esound module
240 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla esound
241 Group:          Libraries
242 Requires:       %{name} = %{version}-%{release}
243
244 %description esd
245 Allegro is a cross-platform library intended for use in computer games
246 and other types of multimedia programming.
247
248 This package contains a esound module for use with ESound daemon.
249
250 %description esd -l pl.UTF-8
251 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
252 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
253
254 Ten pakiet zawiera moduł do wykorzystania z demonem ESound.
255
256 %package arts
257 Summary:        A game programming library - aRts module
258 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla aRts
259 Group:          Libraries
260 Requires:       %{name} = %{version}-%{release}
261
262 %description arts
263 Allegro is a cross-platform library intended for use in computer games
264 and other types of multimedia programming.
265
266 This package contains a esound module for use with aRts.
267
268 %description arts -l pl.UTF-8
269 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
270 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
271
272 Ten pakiet zawiera moduł do wykorzystania z aRts.
273
274 %package fbcon
275 Summary:        A game programming library - framebuffer module
276 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla framebuffera
277 Group:          Libraries
278 Requires:       %{name} = %{version}-%{release}
279
280 %description fbcon
281 Allegro is a cross-platform library intended for use in computer games
282 and other types of multimedia programming.
283
284 This package contains a esound module for use with framebuffer.
285
286 %description fbcon -l pl.UTF-8
287 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
288 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
289
290 Ten pakiet zawiera moduł do wykorzystania z framebufferem.
291
292 %package vga
293 Summary:        A game programming library - vga module
294 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla vga
295 Group:          Libraries
296 Requires:       %{name} = %{version}-%{release}
297
298 %description vga
299 Allegro is a cross-platform library intended for use in computer games
300 and other types of multimedia programming.
301
302 This package contains a esound module for use with vga.
303
304 %description vga -l pl.UTF-8
305 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
306 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
307
308 Ten pakiet zawiera moduł do wykorzystania z vga.
309
310 %package alsa
311 Summary:        A game programming library - ALSA modules
312 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduły dla ALSA
313 Group:          Libraries
314 Requires:       %{name} = %{version}-%{release}
315 Obsoletes:      allegro-alsa9
316
317 %description alsa
318 Allegro is a cross-platform library intended for use in computer games
319 and other types of multimedia programming.
320
321 This package contains modules for use with ALSA sound library.
322
323 %description alsa -l pl.UTF-8
324 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
325 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
326
327 Ten pakiet zawiera moduły do wykorzystania z biblioteką dźwiękową
328 ALSA.
329
330 %package jack
331 Summary:        A game programming library - JACK module
332 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla JACK-a
333 Group:          Libraries
334 Requires:       %{name} = %{version}-%{release}
335
336 %description jack
337 Allegro is a cross-platform library intended for use in computer games
338 and other types of multimedia programming.
339
340 This package contains module for use with JACK sound library.
341
342 %description jack -l pl.UTF-8
343 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
344 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
345
346 Ten pakiet zawiera moduł do wykorzystania z biblioteką dźwiękową JACK.
347
348 %package tools
349 Summary:        A game programming library - tools
350 Summary(de.UTF-8):      Zusätzliche Hilfprogramme für die Allegro Bibliothek
351 Summary(es.UTF-8):      Herramientas adicionales para la librería de programación Allegro
352 Summary(fr.UTF-8):      Outils supplémentaires pour la librairie de programmation Allegro
353 Summary(it.UTF-8):      Programmi di utilità aggiuntivi per la libreria Allegro
354 Summary(pl.UTF-8):      Biblioteka do programowania gier - narzędzia
355 Group:          Libraries
356 Requires:       %{name} = %{version}-%{release}
357
358 %description tools
359 Allegro is a cross-platform library intended for use in computer games
360 and other types of multimedia programming.
361
362 This package contains tools.
363
364 %description tools -l de.UTF-8
365 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
366 Computerspielen und anderen Formen von Multinediaprogrammierung.
367 Dieses Paket enthält Programme, die für die Entwicklung von Allegro
368 Programmen hilfreich sind.
369
370 %description tools -l es.UTF-8
371 Allegro es una librería multi-plataforma creada para ser usada en la
372 programación de juegos u otro tipo de programación multimedia. Este
373 paquete contiene herramientas adicionales que son útiles para
374 desarrollar programas que usen Allegro.
375
376 %description tools -l fr.UTF-8
377 Allegro est une librairie multi-plateforme destinée à être utilisée
378 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
379 package contient des outils supplémentaires qui sont utiles pour le
380 développement de programmes avec Allegro.
381
382 %description tools -l it.UTF-8
383 Allegro è una libreria multipiattaforma dedicata all'uso nei
384 videogiochi ed in altri tipi di programmazione multimediale. Questo
385 pacchetto contiene programmi di utilità aggiuntivi utili allo sviluppo
386 di programmi con Allegro.
387
388 %description tools -l pl.UTF-8
389 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
390 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
391
392 Ten pakiet zawiera narzędzia.
393
394 %package tests
395 Summary:        A game programming library - test programs
396 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy testujące
397 Group:          Development/Libraries
398 Requires:       %{name} = %{version}-%{release}
399
400 %description tests
401 This package contains programs for testing allegro library.
402
403 %description tests -l pl.UTF-8
404 Pakiet zawiera programy testujące bibliotekę allegro.
405
406 %package examples
407 Summary:        A game programming library - examples
408 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy przykładowe
409 Group:          Development/Libraries
410 Requires:       %{name} = %{version}-%{release}
411
412 %description examples
413 This package contains example programs which demonstrate allegro
414 features.
415
416 %description examples -l pl.UTF-8
417 Pakiet zawiera programy przykładowe demonstrujące możliwości
418 biblioteki allegro.
419
420 %prep
421 %setup -q
422 #%%patch0 -p1
423 #%%patch1 -p1
424 #%%patch2 -p1
425 %patch3 -p1
426 #%%patch4 -p1
427 #%%patch5 -p1
428
429 #find include/allegro5 -name '*.h' -print0 | xargs -0 %{__sed} -i -e 's@allegro5/@%{_headers_dir}/include/allegro5@'
430 #%%{__sed} -i -e 's@allegro5/@../@' include/allegro5/internal/alconfig.h
431
432 %build
433 #TARGET_ARCH="%{rpmcflags}" export TARGET_ARCH
434 # dbglib & proflib are compiled besides normlib, so it's ok to have them here
435 #%%configure \
436 #%      %{?with_dbglib:--enable-dbglib} \
437 #%      %{?with_proflib:--enable-proflib} \
438 #%%endif
439 #%      %{!?with_arts:--disable-artsdigi} \
440 #%      %{!?with_dga2:--disable-xwin-dga2} \
441 #%      %{!?with_esd:--disable-esddigi} \
442 #%      %{!?with_fbcon:--disable-fbcon} \
443 #%      %{!?with_jack:--disable-jackdigi} \
444 #%      %{!?with_svga:--disable-svgalib} \
445 #%      %{!?with_vga:--disable-vga} \
446 #%%if !%{with sse}
447 #       --disable-sse \
448 #       --disable-asm \
449 #%%endif
450 #%%ifnarch %{ix86}
451 #       --disable-asm \
452 #       --disable-mmx \
453 #       --disable-sse
454 #%%endif
455 mkdir Build
456 cd Build
457 %cmake .. \
458         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
459         %{?with_static:-DSHARED="off"} \
460         %{!?with_alsa:-DWANT_ALSA="off"}
461
462 %{__make}
463 #%%{__make} \
464 #       MAKEINFO=makeinfo
465
466 %install
467 rm -rf $RPM_BUILD_ROOT
468
469 #%%{__make} install install-man install-info install-lib \
470 #       DESTDIR=$RPM_BUILD_ROOT
471 %{__make} install -C Build \
472         DESTDIR=$RPM_BUILD_ROOT
473
474 #install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/%{version}
475
476 #mv $RPM_BUILD_ROOT%{_bindir}/demo{,-allegro}
477 #mv $RPM_BUILD_ROOT%{_bindir}/play{,-allegro}
478 #mv $RPM_BUILD_ROOT%{_bindir}/setup{,-allegro}
479 #mv $RPM_BUILD_ROOT%{_bindir}/test{,-allegro}
480
481 # help rpm to find reqs for ELF objects
482 #chmod 755 $RPM_BUILD_ROOT%{_libdir}/{*.so,allegro/*/*.so}
483
484 %clean
485 rm -rf $RPM_BUILD_ROOT
486
487 #%%post -p /sbin/ldconfig
488 #%%postun       -p /sbin/ldconfig
489
490 #%%post devel   -p      /sbin/postshell
491 #-/usr/sbin/fix-info-dir -c %{_infodir}
492
493 #%%postun devel -p      /sbin/postshell
494 #-/usr/sbin/fix-info-dir -c %{_infodir}
495
496 %files
497 %defattr(644,root,root,755)
498 %doc CHANGES-4.9.txt docs/html/refman readme_a5.txt
499 #%%attr(755,root,root) %{_libdir}/liballeg-%{version}.so
500 #%%dir %{_libdir}/allegro
501 #%%dir %{_libdir}/allegro/%{version}
502 #%%{_libdir}/allegro/%{version}/modules.lst
503
504 %files devel
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{_bindir}/allegro5-config
507 #%%{_libdir}/liballeg_unsharable.a
508 %{_includedir}/*
509 #%%{_aclocaldir}/allegro.m4
510 #%%{_mandir}/man3/*
511 #%%{_infodir}/*.info*
512
513 #%%if %{with static}
514 #%%files static
515 #%%defattr(644,root,root,755)
516 #%%{_libdir}/liballeg.a
517 #%%endif
518
519 #%%if %{with dbglib}
520 #%%files debug
521 #%%defattr(644,root,root,755)
522 #%%attr(755,root,root) %{_libdir}/liballd-%{version}.so
523 #%%{_libdir}/liballd_unsharable.a
524
525 #%%if %{with static}
526 #%%files debug-static
527 #%%defattr(644,root,root,755)
528 #%%{_libdir}/liballd.a
529 #%%endif
530 #%%endif
531
532 #%%if %{with proflib}
533 #%%files profile
534 #%%defattr(644,root,root,755)
535 #%%attr(755,root,root) %{_libdir}/liballp-%{version}.so
536 #%%{_libdir}/liballp_unsharable.a
537
538 #%%if %{with static}
539 #%%files profile-static
540 #%%defattr(644,root,root,755)
541 #%%{_libdir}/liballp.a
542 #%%endif
543 #%%endif
544
545 #%%if %{with svga}
546 #%%files svgalib
547 #%%defattr(644,root,root,755)
548 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-svgalib.so
549 #%%endif
550
551 #%%if %{with dga2}
552 #%%files dga2
553 #%%defattr(644,root,root,755)
554 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-dga2.so
555 #%%endif
556
557 #%%if %{with esd}
558 #%%files esd
559 #%%defattr(644,root,root,755)
560 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-esddigi.so
561 #%%endif
562
563 #%%if %{with arts}
564 #%%files arts
565 #%%defattr(644,root,root,755)
566 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-artsdigi.so
567 #%%endif
568
569 #%%if %{with fbcon}
570 #%%files fbcon
571 #%%defattr(644,root,root,755)
572 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-fbcon.so
573 #%%endif
574
575 #%%ifarch %{ix86}
576 #%%if %{with vga}
577 #%%files vga
578 #%%defattr(644,root,root,755)
579 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-vga.so
580 #%%endif
581 #%%endif
582
583 #%%if %{with alsa}
584 #%%files alsa
585 #%%defattr(644,root,root,755)
586 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsadigi.so
587 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsamidi.so
588 #%%endif
589
590 #%%if %{with jack}
591 #%%files jack
592 #%%defattr(644,root,root,755)
593 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-jackdigi.so
594 #%%endif
595
596 #%%files tools
597 #%%defattr(644,root,root,755)
598 #%%attr(755,root,root) %{_bindir}/colormap
599 #%%attr(755,root,root) %{_bindir}/exedat
600 #%%attr(755,root,root) %{_bindir}/pack
601 #%%attr(755,root,root) %{_bindir}/rgbmap
602 #%%attr(755,root,root) %{_bindir}/textconv
603 #%attr(755,root,root) %{_bindir}/xkeymap
604 #%%attr(755,root,root) %{_bindir}/xf2pcx
605 #%%attr(755,root,root) %{_bindir}/dat
606 #%%attr(755,root,root) %{_bindir}/dat2c
607 #%%attr(755,root,root) %{_bindir}/dat2s
608 #%%attr(755,root,root) %{_bindir}/grabber
609 #%%attr(755,root,root) %{_bindir}/pat2dat
610 #%attr(755,root,root) %{_bindir}/setup-allegro
611
612 #%%files tests
613 #%%defattr(644,root,root,755)
614 #%%attr(755,root,root) %{_bindir}/afinfo
615 #%%attr(755,root,root) %{_bindir}/akaitest
616 #%%attr(755,root,root) %{_bindir}/cpptest
617 #%%attr(755,root,root) %{_bindir}/demo-allegro
618 #%%attr(755,root,root) %{_bindir}/digitest
619 #%%attr(755,root,root) %{_bindir}/filetest
620 #%%attr(755,root,root) %{_bindir}/gfxinfo
621 #%%attr(755,root,root) %{_bindir}/mathtest
622 #%%attr(755,root,root) %{_bindir}/miditest
623 #%%attr(755,root,root) %{_bindir}/play-allegro
624 #%%attr(755,root,root) %{_bindir}/playfli
625 #%%attr(755,root,root) %{_bindir}/test-allegro
626 #%%attr(755,root,root) %{_bindir}/vesainfo
627
628 #%%files examples
629 #%%defattr(644,root,root,755)
630 #%%attr(755,root,root) %{_bindir}/ex12bit
631 #%%attr(755,root,root) %{_bindir}/ex3buf
632 #%%attr(755,root,root) %{_bindir}/ex3d
633 #%%attr(755,root,root) %{_bindir}/exaccel
634 #%%attr(755,root,root) %{_bindir}/exalpha
635 #%%attr(755,root,root) %{_bindir}/exbitmap
636 #%%attr(755,root,root) %{_bindir}/exblend
637 #%%attr(755,root,root) %{_bindir}/excamera
638 #%%attr(755,root,root) %{_bindir}/excolmap
639 #%%attr(755,root,root) %{_bindir}/exconfig
640 #%%attr(755,root,root) %{_bindir}/excustom
641 #%%attr(755,root,root) %{_bindir}/exdata
642 #%%attr(755,root,root) %{_bindir}/exdbuf
643 #%%attr(755,root,root) %{_bindir}/exexedat
644 #%%attr(755,root,root) %{_bindir}/exfixed
645 #%%attr(755,root,root) %{_bindir}/exflame
646 #%%attr(755,root,root) %{_bindir}/exflip
647 #%%attr(755,root,root) %{_bindir}/exfont
648 #%%attr(755,root,root) %{_bindir}/exgui
649 #%%attr(755,root,root) %{_bindir}/exhello
650 #%%attr(755,root,root) %{_bindir}/exjoy
651 #%%attr(755,root,root) %{_bindir}/exkeys
652 #%%attr(755,root,root) %{_bindir}/exlights
653 #%%attr(755,root,root) %{_bindir}/exmem
654 #%%attr(755,root,root) %{_bindir}/exmidi
655 #%%attr(755,root,root) %{_bindir}/exmouse
656 #%%attr(755,root,root) %{_bindir}/expackf
657 #%%attr(755,root,root) %{_bindir}/expal
658 #%%attr(755,root,root) %{_bindir}/expat
659 #%%attr(755,root,root) %{_bindir}/exquat
660 #%%attr(755,root,root) %{_bindir}/exrgbhsv
661 #%%attr(755,root,root) %{_bindir}/exsample
662 #%%attr(755,root,root) %{_bindir}/exsyscur
663 #%%attr(755,root,root) %{_bindir}/exscale
664 #%%attr(755,root,root) %{_bindir}/exscn3d
665 #%%attr(755,root,root) %{_bindir}/exscroll
666 #%%attr(755,root,root) %{_bindir}/exshade
667 #%%attr(755,root,root) %{_bindir}/exspline
668 #%%attr(755,root,root) %{_bindir}/exsprite
669 #%%attr(755,root,root) %{_bindir}/exstars
670 #%%attr(755,root,root) %{_bindir}/exstream
671 #%%attr(755,root,root) %{_bindir}/exswitch
672 #%%attr(755,root,root) %{_bindir}/extimer
673 #%%attr(755,root,root) %{_bindir}/extrans
674 #%%attr(755,root,root) %{_bindir}/extruec
675 #%%attr(755,root,root) %{_bindir}/exunicod
676 #%%attr(755,root,root) %{_bindir}/exupdate
677 #%%attr(755,root,root) %{_bindir}/exxfade
678 #%%attr(755,root,root) %{_bindir}/exzbuf
679 #%%attr(755,root,root) %{_bindir}/exnew_events
This page took 0.077815 seconds and 3 git commands to generate.