]> git.pld-linux.org Git - packages/allegro.git/blob - allegro.spec
b41726564ccd654b00c8c19ce059a1cbc50d6d28
[packages/allegro.git] / allegro.spec
1 #
2 # TODO: Handle situations when there are no modules (most bconds turned off)
3 #
4 # Conditional build:
5 %bcond_without  alsa    # without ALSA modules
6 %bcond_without  arts    # without aRts module
7 %bcond_without  dga2    # without DGA2 module
8 %bcond_without  dbglib  # don't build debug versions of library
9 %bcond_without  esd     # without esound module
10 %bcond_without  fbcon   # without framebuffer module
11 %bcond_without  jack    # without JACK module
12 %bcond_without  proflib # don't debug profiling versions of library
13 %bcond_without  sse     # build without sse
14 %bcond_without  static  # don't build static versions of library
15 %bcond_without  svga    # without svgalib module
16 %bcond_without  vga     # without vga module
17 #
18 Summary:        A game programming library
19 Summary(de.UTF-8):      Eine Bibliothek zur Programmierung von Spielen
20 Summary(es.UTF-8):      Una biblioteca de programación de juegos
21 Summary(fr.UTF-8):      Une librairie de programmation de jeux
22 Summary(it.UTF-8):      Una libreria per la programmazione di videogiochi
23 Summary(pl.UTF-8):      Biblioteka do programowania gier
24 Name:           allegro
25 Version:        4.9.8
26 Release:        0.1
27 License:        Giftware
28 Group:          Libraries
29 Source0:        http://dl.sourceforge.net/alleg/%{name}-%{version}.tar.gz
30 # Source0-md5:  98c4102dc5f5195576d9817d8ea00811
31 Patch0:         %{name}-info.patch
32 Patch1:         %{name}-examples.patch
33 Patch2:         %{name}-opt.patch
34 Patch3:         %{name}-ldflags.patch
35 Patch4:         %{name}-frame-pointer.patch
36 Patch5:         %{name}-config.patch
37 Patch6:         %{name}-headers.patch
38 URL:            http://alleg.sourceforge.net/
39 #%%{?with_alsa:BuildRequires:   alsa-lib-devel}
40 #%%{?with_arts:BuildRequires:   artsc-devel}
41 BuildRequires:  cmake >= 2.6
42 #%%{?with_esd:BuildRequires:    esound-devel}
43 #%%if %{with jack}
44 #BuildRequires: jack-audio-connection-kit-devel
45 #BuildRequires: pkgconfig
46 #%%endif
47 #BuildRequires: sed >= 4.0
48 #%%{?with_svga:BuildRequires:   svgalib-devel}
49 #BuildRequires: texinfo
50 #BuildRequires: xorg-lib-libX11-devel
51 #BuildRequires: xorg-lib-libXcursor-devel
52 #BuildRequires: xorg-lib-libXext-devel
53 #BuildRequires: xorg-lib-libXpm-devel
54 #BuildRequires: xorg-lib-libXxf86dga-devel
55 #BuildRequires: xorg-lib-libXxf86vm-devel
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 Allegro is a cross-platform library intended for use in computer games
60 and other types of multimedia programming.
61
62 %description -l de.UTF-8
63 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
64 Computerspielen und anderen Formen von Multinediaprogrammierung.
65
66 %description -l es.UTF-8
67 Allegro es una librería multi-plataforma creada para ser usada en la
68 programación de juegos u otro tipo de programación multimedia.
69
70 %description -l fr.UTF-8
71 Allegro est une librairie multi-plateforme destinée à être utilisée
72 dans les jeux vidéo ou d'autres types de programmation multimédia.
73
74 %description -l it.UTF-8
75 Allegro è una libreria multipiattaforma dedicata all'uso nei
76 videogiochi ed in altri tipi di programmazione multimediale.
77
78 %description -l pl.UTF-8
79 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
80 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
81
82 %package devel
83 Summary:        A game programming library - header files
84 Summary(es.UTF-8):      Archivos de inclusión
85 Summary(pl.UTF-8):      Biblioteka do programowania gier - pliki nagłówkowe
86 Group:          Development/Libraries
87 Requires:       %{name} = %{version}-%{release}
88
89 %description devel
90 Allegro is a cross-platform library intended for use in computer games
91 and other types of multimedia programming.
92
93 This package contains header files neccessary for compiling
94 applications using allegro library.
95
96 %description devel -l de.UTF-8
97 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
98 Computerspielen und anderen Formen von Multinediaprogrammierung.
99 Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
100 verwenden.
101
102 %description devel -l es.UTF-8
103 Allegro es una librería multi-plataforma creada para ser usada en la
104 programación de juegos u otro tipo de programación multimedia. Este
105 paquete es necesario para compilar los programas que usen Allegro.
106
107 %description devel -l fr.UTF-8
108 Allegro est une librairie multi-plateforme destinée à être utilisée
109 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
110 package est nécessaire pour compiler les programmes utilisant Allegro.
111
112 %description devel -l it.UTF-8
113 Allegro è una libreria multipiattaforma dedicata all'uso nei
114 videogiochi ed in altri tipi di programmazione multimediale. Questo
115 pacchetto è necessario per compilare programmi scritti con Allegro.
116
117 %description devel -l pl.UTF-8
118 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
119 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
120
121 Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
122 aplikacji wykorzystujących bibliotekę allegro.
123
124 %package static
125 Summary:        A game programming library - static libraries
126 Summary(pl.UTF-8):      Biblioteka do programowania gier - biblioteki statyczne
127 Group:          Development/Libraries
128 Requires:       %{name}-devel = %{version}-%{release}
129 Requires:       xorg-lib-libX11-devel
130 Requires:       xorg-lib-libXcursor-devel
131 Requires:       xorg-lib-libXext-devel
132 Requires:       xorg-lib-libXpm-devel
133 Requires:       xorg-lib-libXxf86vm-devel
134
135 %description static
136 Allegro is a cross-platform library intended for use in computer games
137 and other types of multimedia programming.
138
139 This package contains static libraries for linking with allegro
140 applications.
141
142 %description static -l pl.UTF-8
143 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
144 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
145
146 Ten pakiet zawiera biblioteki statyczne do konsolidacji z aplikacjami
147 wykorzystującymi allegro.
148
149 %package debug
150 Summary:        liballd - debug version of shared allegro library
151 Summary(pl.UTF-8):      liballd - wersja debug dzielonej biblioteki allegro
152 Group:          Development/Libraries
153 Requires:       %{name}-devel = %{version}-%{release}
154
155 %description debug
156 liballd - debug version of shared allegro library (contains debugging
157 symbols and other information).
158
159 %description debug -l pl.UTF-8
160 liballd - wersja debug dzielonej biblioteki allegro (zawierająca
161 symbole i inne informacje potrzebne przy odpluskwianiu).
162
163 %package debug-static
164 Summary:        liballd - debug version of static allegro library
165 Summary(pl.UTF-8):      liballd - wersja debug statycznej biblioteki allegro
166 Group:          Development/Libraries
167 Requires:       %{name}-devel = %{version}-%{release}
168
169 %description debug-static
170 liballd - debug version of static allegro library (contains debugging
171 symbols and other information).
172
173 %description debug-static -l pl.UTF-8
174 liballd - wersja debug statycznej biblioteki allegro (zawierająca
175 symbole i inne informacje potrzebne przy odpluskwianiu).
176
177 %package profile
178 Summary:        liballp - profiling version of shared allegro library
179 Summary(pl.UTF-8):      liballp - wersja dzielonej biblioteki allegro służąca do profilowania
180 Group:          Development/Libraries
181 Requires:       %{name}-devel = %{version}-%{release}
182
183 %description profile
184 liballp - profiling version of shared allegro library.
185
186 %description profile -l pl.UTF-8
187 liballp - wersja dzielonej biblioteki allegro służąca do profilowania.
188
189 %package profile-static
190 Summary:        liballp - profiling version of static allegro library
191 Summary(pl.UTF-8):      liballp - wersja statycznej biblioteki allegro służąca do profilowania
192 Group:          Development/Libraries
193 Requires:       %{name}-devel = %{version}-%{release}
194
195 %description profile-static
196 liballp - profiling version of static allegro library.
197
198 %description profile-static -l pl.UTF-8
199 liballp - wersja statycznej biblioteki allegro służąca do
200 profilowania.
201
202 %package svgalib
203 Summary:        A game programming library - svgalib module
204 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla svgalib
205 Group:          Libraries
206 Requires:       %{name} = %{version}-%{release}
207
208 %description svgalib
209 Allegro is a cross-platform library intended for use in computer games
210 and other types of multimedia programming.
211
212 This package contains module for use with allegro and svgalib.
213
214 %description svgalib -l pl.UTF-8
215 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
216 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
217
218 Ten pakiet zawiera moduł do wykorzystania allegro z svgalibem.
219
220 %package dga2
221 Summary:        A game programming library - DGA2 module
222 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla DGA2
223 Group:          Libraries
224 Requires:       %{name} = %{version}-%{release}
225
226 %description dga2
227 Allegro is a cross-platform library intended for use in computer games
228 and other types of multimedia programming.
229
230 This package contains module for use with DGA.
231
232 %description dga2 -l pl.UTF-8
233 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
234 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
235
236 Ten pakiet zawiera moduł do wykorzystania z DGA.
237
238 %package esd
239 Summary:        A game programming library - esound module
240 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla esound
241 Group:          Libraries
242 Requires:       %{name} = %{version}-%{release}
243
244 %description esd
245 Allegro is a cross-platform library intended for use in computer games
246 and other types of multimedia programming.
247
248 This package contains a esound module for use with ESound daemon.
249
250 %description esd -l pl.UTF-8
251 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
252 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
253
254 Ten pakiet zawiera moduł do wykorzystania z demonem ESound.
255
256 %package arts
257 Summary:        A game programming library - aRts module
258 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla aRts
259 Group:          Libraries
260 Requires:       %{name} = %{version}-%{release}
261
262 %description arts
263 Allegro is a cross-platform library intended for use in computer games
264 and other types of multimedia programming.
265
266 This package contains a esound module for use with aRts.
267
268 %description arts -l pl.UTF-8
269 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
270 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
271
272 Ten pakiet zawiera moduł do wykorzystania z aRts.
273
274 %package fbcon
275 Summary:        A game programming library - framebuffer module
276 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla framebuffera
277 Group:          Libraries
278 Requires:       %{name} = %{version}-%{release}
279
280 %description fbcon
281 Allegro is a cross-platform library intended for use in computer games
282 and other types of multimedia programming.
283
284 This package contains a esound module for use with framebuffer.
285
286 %description fbcon -l pl.UTF-8
287 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
288 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
289
290 Ten pakiet zawiera moduł do wykorzystania z framebufferem.
291
292 %package vga
293 Summary:        A game programming library - vga module
294 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla vga
295 Group:          Libraries
296 Requires:       %{name} = %{version}-%{release}
297
298 %description vga
299 Allegro is a cross-platform library intended for use in computer games
300 and other types of multimedia programming.
301
302 This package contains a esound module for use with vga.
303
304 %description vga -l pl.UTF-8
305 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
306 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
307
308 Ten pakiet zawiera moduł do wykorzystania z vga.
309
310 %package alsa
311 Summary:        A game programming library - ALSA modules
312 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduły dla ALSA
313 Group:          Libraries
314 Requires:       %{name} = %{version}-%{release}
315 Obsoletes:      allegro-alsa9
316
317 %description alsa
318 Allegro is a cross-platform library intended for use in computer games
319 and other types of multimedia programming.
320
321 This package contains modules for use with ALSA sound library.
322
323 %description alsa -l pl.UTF-8
324 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
325 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
326
327 Ten pakiet zawiera moduły do wykorzystania z biblioteką dźwiękową
328 ALSA.
329
330 %package jack
331 Summary:        A game programming library - JACK module
332 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla JACK-a
333 Group:          Libraries
334 Requires:       %{name} = %{version}-%{release}
335
336 %description jack
337 Allegro is a cross-platform library intended for use in computer games
338 and other types of multimedia programming.
339
340 This package contains module for use with JACK sound library.
341
342 %description jack -l pl.UTF-8
343 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
344 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
345
346 Ten pakiet zawiera moduł do wykorzystania z biblioteką dźwiękową JACK.
347
348 %package tools
349 Summary:        A game programming library - tools
350 Summary(de.UTF-8):      Zusätzliche Hilfprogramme für die Allegro Bibliothek
351 Summary(es.UTF-8):      Herramientas adicionales para la librería de programación Allegro
352 Summary(fr.UTF-8):      Outils supplémentaires pour la librairie de programmation Allegro
353 Summary(it.UTF-8):      Programmi di utilità aggiuntivi per la libreria Allegro
354 Summary(pl.UTF-8):      Biblioteka do programowania gier - narzędzia
355 Group:          Libraries
356 Requires:       %{name} = %{version}-%{release}
357
358 %description tools
359 Allegro is a cross-platform library intended for use in computer games
360 and other types of multimedia programming.
361
362 This package contains tools.
363
364 %description tools -l de.UTF-8
365 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
366 Computerspielen und anderen Formen von Multinediaprogrammierung.
367 Dieses Paket enthält Programme, die für die Entwicklung von Allegro
368 Programmen hilfreich sind.
369
370 %description tools -l es.UTF-8
371 Allegro es una librería multi-plataforma creada para ser usada en la
372 programación de juegos u otro tipo de programación multimedia. Este
373 paquete contiene herramientas adicionales que son útiles para
374 desarrollar programas que usen Allegro.
375
376 %description tools -l fr.UTF-8
377 Allegro est une librairie multi-plateforme destinée à être utilisée
378 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
379 package contient des outils supplémentaires qui sont utiles pour le
380 développement de programmes avec Allegro.
381
382 %description tools -l it.UTF-8
383 Allegro è una libreria multipiattaforma dedicata all'uso nei
384 videogiochi ed in altri tipi di programmazione multimediale. Questo
385 pacchetto contiene programmi di utilità aggiuntivi utili allo sviluppo
386 di programmi con Allegro.
387
388 %description tools -l pl.UTF-8
389 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
390 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
391
392 Ten pakiet zawiera narzędzia.
393
394 %package tests
395 Summary:        A game programming library - test programs
396 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy testujące
397 Group:          Development/Libraries
398 Requires:       %{name} = %{version}-%{release}
399
400 %description tests
401 This package contains programs for testing allegro library.
402
403 %description tests -l pl.UTF-8
404 Pakiet zawiera programy testujące bibliotekę allegro.
405
406 %package examples
407 Summary:        A game programming library - examples
408 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy przykładowe
409 Group:          Development/Libraries
410 Requires:       %{name} = %{version}-%{release}
411
412 %description examples
413 This package contains example programs which demonstrate allegro
414 features.
415
416 %description examples -l pl.UTF-8
417 Pakiet zawiera programy przykładowe demonstrujące możliwości
418 biblioteki allegro.
419
420 %prep
421 %setup -q
422 #%%patch0 -p1
423 #%%patch1 -p1
424 #%%patch2 -p1
425 %patch3 -p1
426 #%%patch4 -p1
427 #%%patch5 -p1
428 #%%patch6 -p1
429
430 #find include/allegro5 -name '*.h' -print0 | xargs -0 %{__sed} -i -e 's@allegro5/@%{_headers_dir}/include/allegro5@'
431 #%%{__sed} -i -e 's@allegro5/@../@' include/allegro5/internal/alconfig.h
432
433 %build
434 #TARGET_ARCH="%{rpmcflags}" export TARGET_ARCH
435 # dbglib & proflib are compiled besides normlib, so it's ok to have them here
436 #%%configure \
437 #%      %{?with_static:--enable-static} \
438 #%      %{?with_dbglib:--enable-dbglib} \
439 #%      %{?with_proflib:--enable-proflib} \
440 #%%if !%{with alsa}
441 #       --disable-alsadigi \
442 #       --disable-alsamidi \
443 #%%endif
444 #%      %{!?with_arts:--disable-artsdigi} \
445 #%      %{!?with_dga2:--disable-xwin-dga2} \
446 #%      %{!?with_esd:--disable-esddigi} \
447 #%      %{!?with_fbcon:--disable-fbcon} \
448 #%      %{!?with_jack:--disable-jackdigi} \
449 #%      %{!?with_svga:--disable-svgalib} \
450 #%      %{!?with_vga:--disable-vga} \
451 #%%if !%{with sse}
452 #       --disable-sse \
453 #       --disable-asm \
454 #%%endif
455 #%%ifnarch %{ix86}
456 #       --disable-asm \
457 #       --disable-mmx \
458 #       --disable-sse
459 #%%endif
460 mkdir Build
461 cd Build
462 %cmake ..
463
464 %{__make}
465 #%%{__make} \
466 #       MAKEINFO=makeinfo
467
468 %install
469 rm -rf $RPM_BUILD_ROOT
470
471 #%%{__make} install install-man install-info install-lib \
472 #       DESTDIR=$RPM_BUILD_ROOT
473 %{__make} install -C Build \
474         DESTDIR=$RPM_BUILD_ROOT
475
476 #install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/%{version}
477
478 #mv $RPM_BUILD_ROOT%{_bindir}/demo{,-allegro}
479 #mv $RPM_BUILD_ROOT%{_bindir}/play{,-allegro}
480 #mv $RPM_BUILD_ROOT%{_bindir}/setup{,-allegro}
481 #mv $RPM_BUILD_ROOT%{_bindir}/test{,-allegro}
482
483 # help rpm to find reqs for ELF objects
484 #chmod 755 $RPM_BUILD_ROOT%{_libdir}/{*.so,allegro/*/*.so}
485
486 %clean
487 rm -rf $RPM_BUILD_ROOT
488
489 #%%post -p /sbin/ldconfig
490 #%%postun       -p /sbin/ldconfig
491
492 #%%post devel   -p      /sbin/postshell
493 #-/usr/sbin/fix-info-dir -c %{_infodir}
494
495 #%%postun devel -p      /sbin/postshell
496 #-/usr/sbin/fix-info-dir -c %{_infodir}
497
498 %files
499 %defattr(644,root,root,755)
500 #%%doc AUTHORS CHANGES THANKS readme.txt
501 #%%attr(755,root,root) %{_libdir}/liballeg-%{version}.so
502 #%%dir %{_libdir}/allegro
503 #%%dir %{_libdir}/allegro/%{version}
504 #%%{_libdir}/allegro/%{version}/modules.lst
505
506 #%%files devel
507 #%%defattr(644,root,root,755)
508 #%%attr(755,root,root) %{_bindir}/allegro-config
509 #%%{_libdir}/liballeg_unsharable.a
510 #%%{_includedir}/*
511 #%%{_aclocaldir}/allegro.m4
512 #%%{_mandir}/man3/*
513 #%%{_infodir}/*.info*
514
515 #%%if %{with static}
516 #%%files static
517 #%%defattr(644,root,root,755)
518 #%%{_libdir}/liballeg.a
519 #%%endif
520
521 #%%if %{with dbglib}
522 #%%files debug
523 #%%defattr(644,root,root,755)
524 #%%attr(755,root,root) %{_libdir}/liballd-%{version}.so
525 #%%{_libdir}/liballd_unsharable.a
526
527 #%%if %{with static}
528 #%%files debug-static
529 #%%defattr(644,root,root,755)
530 #%%{_libdir}/liballd.a
531 #%%endif
532 #%%endif
533
534 #%%if %{with proflib}
535 #%%files profile
536 #%%defattr(644,root,root,755)
537 #%%attr(755,root,root) %{_libdir}/liballp-%{version}.so
538 #%%{_libdir}/liballp_unsharable.a
539
540 #%%if %{with static}
541 #%%files profile-static
542 #%%defattr(644,root,root,755)
543 #%%{_libdir}/liballp.a
544 #%%endif
545 #%%endif
546
547 #%%if %{with svga}
548 #%%files svgalib
549 #%%defattr(644,root,root,755)
550 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-svgalib.so
551 #%%endif
552
553 #%%if %{with dga2}
554 #%%files dga2
555 #%%defattr(644,root,root,755)
556 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-dga2.so
557 #%%endif
558
559 #%%if %{with esd}
560 #%%files esd
561 #%%defattr(644,root,root,755)
562 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-esddigi.so
563 #%%endif
564
565 #%%if %{with arts}
566 #%%files arts
567 #%%defattr(644,root,root,755)
568 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-artsdigi.so
569 #%%endif
570
571 #%%if %{with fbcon}
572 #%%files fbcon
573 #%%defattr(644,root,root,755)
574 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-fbcon.so
575 #%%endif
576
577 #%%ifarch %{ix86}
578 #%%if %{with vga}
579 #%%files vga
580 #%%defattr(644,root,root,755)
581 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-vga.so
582 #%%endif
583 #%%endif
584
585 #%%if %{with alsa}
586 #%%files alsa
587 #%%defattr(644,root,root,755)
588 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsadigi.so
589 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsamidi.so
590 #%%endif
591
592 #%%if %{with jack}
593 #%%files jack
594 #%%defattr(644,root,root,755)
595 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-jackdigi.so
596 #%%endif
597
598 #%%files tools
599 #%%defattr(644,root,root,755)
600 #%%attr(755,root,root) %{_bindir}/colormap
601 #%%attr(755,root,root) %{_bindir}/exedat
602 #%%attr(755,root,root) %{_bindir}/pack
603 #%%attr(755,root,root) %{_bindir}/rgbmap
604 #%%attr(755,root,root) %{_bindir}/textconv
605 #%attr(755,root,root) %{_bindir}/xkeymap
606 #%%attr(755,root,root) %{_bindir}/xf2pcx
607 #%%attr(755,root,root) %{_bindir}/dat
608 #%%attr(755,root,root) %{_bindir}/dat2c
609 #%%attr(755,root,root) %{_bindir}/dat2s
610 #%%attr(755,root,root) %{_bindir}/grabber
611 #%%attr(755,root,root) %{_bindir}/pat2dat
612 #%attr(755,root,root) %{_bindir}/setup-allegro
613
614 #%%files tests
615 #%%defattr(644,root,root,755)
616 #%%attr(755,root,root) %{_bindir}/afinfo
617 #%%attr(755,root,root) %{_bindir}/akaitest
618 #%%attr(755,root,root) %{_bindir}/cpptest
619 #%%attr(755,root,root) %{_bindir}/demo-allegro
620 #%%attr(755,root,root) %{_bindir}/digitest
621 #%%attr(755,root,root) %{_bindir}/filetest
622 #%%attr(755,root,root) %{_bindir}/gfxinfo
623 #%%attr(755,root,root) %{_bindir}/mathtest
624 #%%attr(755,root,root) %{_bindir}/miditest
625 #%%attr(755,root,root) %{_bindir}/play-allegro
626 #%%attr(755,root,root) %{_bindir}/playfli
627 #%%attr(755,root,root) %{_bindir}/test-allegro
628 #%%attr(755,root,root) %{_bindir}/vesainfo
629
630 #%%files examples
631 #%%defattr(644,root,root,755)
632 #%%attr(755,root,root) %{_bindir}/ex12bit
633 #%%attr(755,root,root) %{_bindir}/ex3buf
634 #%%attr(755,root,root) %{_bindir}/ex3d
635 #%%attr(755,root,root) %{_bindir}/exaccel
636 #%%attr(755,root,root) %{_bindir}/exalpha
637 #%%attr(755,root,root) %{_bindir}/exbitmap
638 #%%attr(755,root,root) %{_bindir}/exblend
639 #%%attr(755,root,root) %{_bindir}/excamera
640 #%%attr(755,root,root) %{_bindir}/excolmap
641 #%%attr(755,root,root) %{_bindir}/exconfig
642 #%%attr(755,root,root) %{_bindir}/excustom
643 #%%attr(755,root,root) %{_bindir}/exdata
644 #%%attr(755,root,root) %{_bindir}/exdbuf
645 #%%attr(755,root,root) %{_bindir}/exexedat
646 #%%attr(755,root,root) %{_bindir}/exfixed
647 #%%attr(755,root,root) %{_bindir}/exflame
648 #%%attr(755,root,root) %{_bindir}/exflip
649 #%%attr(755,root,root) %{_bindir}/exfont
650 #%%attr(755,root,root) %{_bindir}/exgui
651 #%%attr(755,root,root) %{_bindir}/exhello
652 #%%attr(755,root,root) %{_bindir}/exjoy
653 #%%attr(755,root,root) %{_bindir}/exkeys
654 #%%attr(755,root,root) %{_bindir}/exlights
655 #%%attr(755,root,root) %{_bindir}/exmem
656 #%%attr(755,root,root) %{_bindir}/exmidi
657 #%%attr(755,root,root) %{_bindir}/exmouse
658 #%%attr(755,root,root) %{_bindir}/expackf
659 #%%attr(755,root,root) %{_bindir}/expal
660 #%%attr(755,root,root) %{_bindir}/expat
661 #%%attr(755,root,root) %{_bindir}/exquat
662 #%%attr(755,root,root) %{_bindir}/exrgbhsv
663 #%%attr(755,root,root) %{_bindir}/exsample
664 #%%attr(755,root,root) %{_bindir}/exsyscur
665 #%%attr(755,root,root) %{_bindir}/exscale
666 #%%attr(755,root,root) %{_bindir}/exscn3d
667 #%%attr(755,root,root) %{_bindir}/exscroll
668 #%%attr(755,root,root) %{_bindir}/exshade
669 #%%attr(755,root,root) %{_bindir}/exspline
670 #%%attr(755,root,root) %{_bindir}/exsprite
671 #%%attr(755,root,root) %{_bindir}/exstars
672 #%%attr(755,root,root) %{_bindir}/exstream
673 #%%attr(755,root,root) %{_bindir}/exswitch
674 #%%attr(755,root,root) %{_bindir}/extimer
675 #%%attr(755,root,root) %{_bindir}/extrans
676 #%%attr(755,root,root) %{_bindir}/extruec
677 #%%attr(755,root,root) %{_bindir}/exunicod
678 #%%attr(755,root,root) %{_bindir}/exupdate
679 #%%attr(755,root,root) %{_bindir}/exxfade
680 #%%attr(755,root,root) %{_bindir}/exzbuf
681 #%%attr(755,root,root) %{_bindir}/exnew_events
This page took 0.081785 seconds and 3 git commands to generate.