]> git.pld-linux.org Git - packages/allegro.git/blob - allegro.spec
- adapter
[packages/allegro.git] / allegro.spec
1 #
2 # TODO: - Handle situations when there are no modules (most bconds turned off)
3 #       - make bconds work again or remove
4 #
5 # Conditional build:
6 %bcond_without  alsa    # without ALSA modules
7 #%%bcond_without        arts    # without aRts module
8 #%%bcond_without        dga2    # without DGA2 module
9 #%%bcond_without        dbglib  # don't build debug versions of library
10 #%%bcond_without        esd     # without esound module
11 #%%bcond_without        fbcon   # without framebuffer module
12 #%%bcond_without        jack    # without JACK module
13 #%%bcond_without        proflib # don't debug profiling versions of library
14 #%%bcond_without        sse     # build without sse
15 %bcond_without  static  # don't build static versions of library
16 #%%bcond_without        svga    # without svgalib module
17 #%%bcond_without        vga     # without vga module
18 #
19 Summary:        A game programming library
20 Summary(de.UTF-8):      Eine Bibliothek zur Programmierung von Spielen
21 Summary(es.UTF-8):      Una biblioteca de programación de juegos
22 Summary(fr.UTF-8):      Une librairie de programmation de jeux
23 Summary(it.UTF-8):      Una libreria per la programmazione di videogiochi
24 Summary(pl.UTF-8):      Biblioteka do programowania gier
25 Name:           allegro
26 Version:        4.9.16
27 Release:        0.1
28 License:        Giftware
29 Group:          Libraries
30 Source0:        http://downloads.sourceforge.net/alleg/%{name}-%{version}.tar.gz
31 # Source0-md5:  c51796f4035cf9707a3d708f7d9608b4
32 Patch0:         %{name}-info.patch
33 Patch1:         %{name}-examples.patch
34 Patch2:         %{name}-opt.patch
35 Patch3:         %{name}-frame-pointer.patch
36 Patch4:         %{name}-config.patch
37 URL:            http://alleg.sourceforge.net/
38 BuildRequires:  OpenGL-GLU-devel
39 %{?with_alsa:BuildRequires:     alsa-lib-devel}
40 #%%{?with_arts:BuildRequires:   artsc-devel}
41 BuildRequires:  cmake >= 2.6
42 BuildRequires:  curl-devel
43 #%%{?with_esd:BuildRequires:    esound-devel}
44 #%%if %{with jack}
45 #BuildRequires: jack-audio-connection-kit-devel
46 BuildRequires:  physfs-devel
47 #BuildRequires: pkgconfig
48 #%%endif
49 #BuildRequires: sed >= 4.0
50 #%%{?with_svga:BuildRequires:   svgalib-devel}
51 #BuildRequires: texinfo
52 BuildRequires:  xorg-lib-libX11-devel
53 BuildRequires:  xorg-lib-libXcursor-devel
54 BuildRequires:  xorg-lib-libXext-devel
55 BuildRequires:  xorg-lib-libXpm-devel
56 #BuildRequires: xorg-lib-libXxf86dga-devel
57 BuildRequires:  xorg-lib-libXxf86vm-devel
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 Allegro is a cross-platform library intended for use in computer games
62 and other types of multimedia programming.
63
64 %description -l de.UTF-8
65 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
66 Computerspielen und anderen Formen von Multinediaprogrammierung.
67
68 %description -l es.UTF-8
69 Allegro es una librería multi-plataforma creada para ser usada en la
70 programación de juegos u otro tipo de programación multimedia.
71
72 %description -l fr.UTF-8
73 Allegro est une librairie multi-plateforme destinée à être utilisée
74 dans les jeux vidéo ou d'autres types de programmation multimédia.
75
76 %description -l it.UTF-8
77 Allegro è una libreria multipiattaforma dedicata all'uso nei
78 videogiochi ed in altri tipi di programmazione multimediale.
79
80 %description -l pl.UTF-8
81 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
82 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
83
84 %package devel
85 Summary:        A game programming library - header files
86 Summary(es.UTF-8):      Archivos de inclusión
87 Summary(pl.UTF-8):      Biblioteka do programowania gier - pliki nagłówkowe
88 Group:          Development/Libraries
89 Requires:       %{name} = %{version}-%{release}
90
91 %description devel
92 Allegro is a cross-platform library intended for use in computer games
93 and other types of multimedia programming.
94
95 This package contains header files neccessary for compiling
96 applications using allegro library.
97
98 %description devel -l de.UTF-8
99 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
100 Computerspielen und anderen Formen von Multinediaprogrammierung.
101 Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
102 verwenden.
103
104 %description devel -l es.UTF-8
105 Allegro es una librería multi-plataforma creada para ser usada en la
106 programación de juegos u otro tipo de programación multimedia. Este
107 paquete es necesario para compilar los programas que usen Allegro.
108
109 %description devel -l fr.UTF-8
110 Allegro est une librairie multi-plateforme destinée à être utilisée
111 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
112 package est nécessaire pour compiler les programmes utilisant Allegro.
113
114 %description devel -l it.UTF-8
115 Allegro è una libreria multipiattaforma dedicata all'uso nei
116 videogiochi ed in altri tipi di programmazione multimediale. Questo
117 pacchetto è necessario per compilare programmi scritti con Allegro.
118
119 %description devel -l pl.UTF-8
120 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
121 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
122
123 Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
124 aplikacji wykorzystujących bibliotekę allegro.
125
126 %package static
127 Summary:        A game programming library - static libraries
128 Summary(pl.UTF-8):      Biblioteka do programowania gier - biblioteki statyczne
129 Group:          Development/Libraries
130 Requires:       %{name}-devel = %{version}-%{release}
131 Requires:       xorg-lib-libX11-devel
132 Requires:       xorg-lib-libXcursor-devel
133 Requires:       xorg-lib-libXext-devel
134 Requires:       xorg-lib-libXpm-devel
135 Requires:       xorg-lib-libXxf86vm-devel
136
137 %description static
138 Allegro is a cross-platform library intended for use in computer games
139 and other types of multimedia programming.
140
141 This package contains static libraries for linking with allegro
142 applications.
143
144 %description static -l pl.UTF-8
145 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
146 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
147
148 Ten pakiet zawiera biblioteki statyczne do konsolidacji z aplikacjami
149 wykorzystującymi allegro.
150
151 %package debug
152 Summary:        liballd - debug version of shared allegro library
153 Summary(pl.UTF-8):      liballd - wersja debug dzielonej biblioteki allegro
154 Group:          Development/Libraries
155 Requires:       %{name}-devel = %{version}-%{release}
156
157 %description debug
158 liballd - debug version of shared allegro library (contains debugging
159 symbols and other information).
160
161 %description debug -l pl.UTF-8
162 liballd - wersja debug dzielonej biblioteki allegro (zawierająca
163 symbole i inne informacje potrzebne przy odpluskwianiu).
164
165 %package debug-static
166 Summary:        liballd - debug version of static allegro library
167 Summary(pl.UTF-8):      liballd - wersja debug statycznej biblioteki allegro
168 Group:          Development/Libraries
169 Requires:       %{name}-devel = %{version}-%{release}
170
171 %description debug-static
172 liballd - debug version of static allegro library (contains debugging
173 symbols and other information).
174
175 %description debug-static -l pl.UTF-8
176 liballd - wersja debug statycznej biblioteki allegro (zawierająca
177 symbole i inne informacje potrzebne przy odpluskwianiu).
178
179 %package profile
180 Summary:        liballp - profiling version of shared allegro library
181 Summary(pl.UTF-8):      liballp - wersja dzielonej biblioteki allegro służąca do profilowania
182 Group:          Development/Libraries
183 Requires:       %{name}-devel = %{version}-%{release}
184
185 %description profile
186 liballp - profiling version of shared allegro library.
187
188 %description profile -l pl.UTF-8
189 liballp - wersja dzielonej biblioteki allegro służąca do profilowania.
190
191 %package profile-static
192 Summary:        liballp - profiling version of static allegro library
193 Summary(pl.UTF-8):      liballp - wersja statycznej biblioteki allegro służąca do profilowania
194 Group:          Development/Libraries
195 Requires:       %{name}-devel = %{version}-%{release}
196
197 %description profile-static
198 liballp - profiling version of static allegro library.
199
200 %description profile-static -l pl.UTF-8
201 liballp - wersja statycznej biblioteki allegro służąca do
202 profilowania.
203
204 %package svgalib
205 Summary:        A game programming library - svgalib module
206 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla svgalib
207 Group:          Libraries
208 Requires:       %{name} = %{version}-%{release}
209
210 %description svgalib
211 Allegro is a cross-platform library intended for use in computer games
212 and other types of multimedia programming.
213
214 This package contains module for use with allegro and svgalib.
215
216 %description svgalib -l pl.UTF-8
217 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
218 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
219
220 Ten pakiet zawiera moduł do wykorzystania allegro z svgalibem.
221
222 %package dga2
223 Summary:        A game programming library - DGA2 module
224 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla DGA2
225 Group:          Libraries
226 Requires:       %{name} = %{version}-%{release}
227
228 %description dga2
229 Allegro is a cross-platform library intended for use in computer games
230 and other types of multimedia programming.
231
232 This package contains module for use with DGA.
233
234 %description dga2 -l pl.UTF-8
235 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
236 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
237
238 Ten pakiet zawiera moduł do wykorzystania z DGA.
239
240 %package esd
241 Summary:        A game programming library - esound module
242 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla esound
243 Group:          Libraries
244 Requires:       %{name} = %{version}-%{release}
245
246 %description esd
247 Allegro is a cross-platform library intended for use in computer games
248 and other types of multimedia programming.
249
250 This package contains a esound module for use with ESound daemon.
251
252 %description esd -l pl.UTF-8
253 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
254 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
255
256 Ten pakiet zawiera moduł do wykorzystania z demonem ESound.
257
258 %package arts
259 Summary:        A game programming library - aRts module
260 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla aRts
261 Group:          Libraries
262 Requires:       %{name} = %{version}-%{release}
263
264 %description arts
265 Allegro is a cross-platform library intended for use in computer games
266 and other types of multimedia programming.
267
268 This package contains a esound module for use with aRts.
269
270 %description arts -l pl.UTF-8
271 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
272 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
273
274 Ten pakiet zawiera moduł do wykorzystania z aRts.
275
276 %package fbcon
277 Summary:        A game programming library - framebuffer module
278 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla framebuffera
279 Group:          Libraries
280 Requires:       %{name} = %{version}-%{release}
281
282 %description fbcon
283 Allegro is a cross-platform library intended for use in computer games
284 and other types of multimedia programming.
285
286 This package contains a esound module for use with framebuffer.
287
288 %description fbcon -l pl.UTF-8
289 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
290 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
291
292 Ten pakiet zawiera moduł do wykorzystania z framebufferem.
293
294 %package vga
295 Summary:        A game programming library - vga module
296 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla vga
297 Group:          Libraries
298 Requires:       %{name} = %{version}-%{release}
299
300 %description vga
301 Allegro is a cross-platform library intended for use in computer games
302 and other types of multimedia programming.
303
304 This package contains a esound module for use with vga.
305
306 %description vga -l pl.UTF-8
307 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
308 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
309
310 Ten pakiet zawiera moduł do wykorzystania z vga.
311
312 %package alsa
313 Summary:        A game programming library - ALSA modules
314 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduły dla ALSA
315 Group:          Libraries
316 Requires:       %{name} = %{version}-%{release}
317 Obsoletes:      allegro-alsa9
318
319 %description alsa
320 Allegro is a cross-platform library intended for use in computer games
321 and other types of multimedia programming.
322
323 This package contains modules for use with ALSA sound library.
324
325 %description alsa -l pl.UTF-8
326 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
327 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
328
329 Ten pakiet zawiera moduły do wykorzystania z biblioteką dźwiękową
330 ALSA.
331
332 %package jack
333 Summary:        A game programming library - JACK module
334 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla JACK-a
335 Group:          Libraries
336 Requires:       %{name} = %{version}-%{release}
337
338 %description jack
339 Allegro is a cross-platform library intended for use in computer games
340 and other types of multimedia programming.
341
342 This package contains module for use with JACK sound library.
343
344 %description jack -l pl.UTF-8
345 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
346 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
347
348 Ten pakiet zawiera moduł do wykorzystania z biblioteką dźwiękową JACK.
349
350 %package tools
351 Summary:        A game programming library - tools
352 Summary(de.UTF-8):      Zusätzliche Hilfprogramme für die Allegro Bibliothek
353 Summary(es.UTF-8):      Herramientas adicionales para la librería de programación Allegro
354 Summary(fr.UTF-8):      Outils supplémentaires pour la librairie de programmation Allegro
355 Summary(it.UTF-8):      Programmi di utilità aggiuntivi per la libreria Allegro
356 Summary(pl.UTF-8):      Biblioteka do programowania gier - narzędzia
357 Group:          Libraries
358 Requires:       %{name} = %{version}-%{release}
359
360 %description tools
361 Allegro is a cross-platform library intended for use in computer games
362 and other types of multimedia programming.
363
364 This package contains tools.
365
366 %description tools -l de.UTF-8
367 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
368 Computerspielen und anderen Formen von Multinediaprogrammierung.
369 Dieses Paket enthält Programme, die für die Entwicklung von Allegro
370 Programmen hilfreich sind.
371
372 %description tools -l es.UTF-8
373 Allegro es una librería multi-plataforma creada para ser usada en la
374 programación de juegos u otro tipo de programación multimedia. Este
375 paquete contiene herramientas adicionales que son útiles para
376 desarrollar programas que usen Allegro.
377
378 %description tools -l fr.UTF-8
379 Allegro est une librairie multi-plateforme destinée à être utilisée
380 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
381 package contient des outils supplémentaires qui sont utiles pour le
382 développement de programmes avec Allegro.
383
384 %description tools -l it.UTF-8
385 Allegro è una libreria multipiattaforma dedicata all'uso nei
386 videogiochi ed in altri tipi di programmazione multimediale. Questo
387 pacchetto contiene programmi di utilità aggiuntivi utili allo sviluppo
388 di programmi con Allegro.
389
390 %description tools -l pl.UTF-8
391 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
392 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
393
394 Ten pakiet zawiera narzędzia.
395
396 %package tests
397 Summary:        A game programming library - test programs
398 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy testujące
399 Group:          Development/Libraries
400 Requires:       %{name} = %{version}-%{release}
401
402 %description tests
403 This package contains programs for testing allegro library.
404
405 %description tests -l pl.UTF-8
406 Pakiet zawiera programy testujące bibliotekę allegro.
407
408 %package examples
409 Summary:        A game programming library - examples
410 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy przykładowe
411 Group:          Development/Libraries
412 Requires:       %{name} = %{version}-%{release}
413
414 %description examples
415 This package contains example programs which demonstrate allegro
416 features.
417
418 %description examples -l pl.UTF-8
419 Pakiet zawiera programy przykładowe demonstrujące możliwości
420 biblioteki allegro.
421
422 %prep
423 %setup -q
424 #%%patch0 -p1
425 #%%patch1 -p1
426 #%%patch2 -p1
427 #%%patch3 -p1
428 #%%patch4 -p1
429
430 #find include/allegro5 -name '*.h' -print0 | xargs -0 %{__sed} -i -e 's@allegro5/@%{_headers_dir}/include/allegro5@'
431 #%%{__sed} -i -e 's@allegro5/@../@' include/allegro5/internal/alconfig.h
432
433 %build
434 #TARGET_ARCH="%{rpmcflags}" export TARGET_ARCH
435 # dbglib & proflib are compiled besides normlib, so it's ok to have them here
436 #%%configure \
437 #%      %{?with_dbglib:--enable-dbglib} \
438 #%      %{?with_proflib:--enable-proflib} \
439 #%%endif
440 #%      %{!?with_arts:--disable-artsdigi} \
441 #%      %{!?with_dga2:--disable-xwin-dga2} \
442 #%      %{!?with_esd:--disable-esddigi} \
443 #%      %{!?with_fbcon:--disable-fbcon} \
444 #%      %{!?with_jack:--disable-jackdigi} \
445 #%      %{!?with_svga:--disable-svgalib} \
446 #%      %{!?with_vga:--disable-vga} \
447 #%%if !%{with sse}
448 #       --disable-sse \
449 #       --disable-asm \
450 #%%endif
451 #%%ifnarch %{ix86}
452 #       --disable-asm \
453 #       --disable-mmx \
454 #       --disable-sse
455 #%%endif
456 mkdir Build
457 cd Build
458 %cmake .. \
459         -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
460         %{?with_static:-DSHARED="off"} \
461         %{!?with_alsa:-DWANT_ALSA="off"}
462
463 %{__make}
464 #%%{__make} \
465 #       MAKEINFO=makeinfo
466
467 %install
468 rm -rf $RPM_BUILD_ROOT
469
470 #%%{__make} install install-man install-info install-lib \
471 #       DESTDIR=$RPM_BUILD_ROOT
472 %{__make} install -C Build \
473         DESTDIR=$RPM_BUILD_ROOT
474
475 #install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/%{version}
476
477 #mv $RPM_BUILD_ROOT%{_bindir}/demo{,-allegro}
478 #mv $RPM_BUILD_ROOT%{_bindir}/play{,-allegro}
479 #mv $RPM_BUILD_ROOT%{_bindir}/setup{,-allegro}
480 #mv $RPM_BUILD_ROOT%{_bindir}/test{,-allegro}
481
482 # help rpm to find reqs for ELF objects
483 #chmod 755 $RPM_BUILD_ROOT%{_libdir}/{*.so,allegro/*/*.so}
484
485 %clean
486 rm -rf $RPM_BUILD_ROOT
487
488 #%%post -p /sbin/ldconfig
489 #%%postun       -p /sbin/ldconfig
490
491 #%%post devel   -p      /sbin/postshell
492 #-/usr/sbin/fix-info-dir -c %{_infodir}
493
494 #%%postun devel -p      /sbin/postshell
495 #-/usr/sbin/fix-info-dir -c %{_infodir}
496
497 %files
498 %defattr(644,root,root,755)
499 %doc docs/html/refman readme_a5.txt
500 #%%attr(755,root,root) %{_libdir}/liballeg-%{version}.so
501 #%%dir %{_libdir}/allegro
502 #%%dir %{_libdir}/allegro/%{version}
503 #%%{_libdir}/allegro/%{version}/modules.lst
504
505 %files devel
506 %defattr(644,root,root,755)
507 #%%attr(755,root,root) %{_bindir}/allegro5-config
508 #%%{_libdir}/liballeg_unsharable.a
509 %{_includedir}/*
510 #%%{_aclocaldir}/allegro.m4
511 #%%{_mandir}/man3/*
512 #%%{_infodir}/*.info*
513
514 #%%if %{with static}
515 #%%files static
516 #%%defattr(644,root,root,755)
517 #%%{_libdir}/liballeg.a
518 #%%endif
519
520 #%%if %{with dbglib}
521 #%%files debug
522 #%%defattr(644,root,root,755)
523 #%%attr(755,root,root) %{_libdir}/liballd-%{version}.so
524 #%%{_libdir}/liballd_unsharable.a
525
526 #%%if %{with static}
527 #%%files debug-static
528 #%%defattr(644,root,root,755)
529 #%%{_libdir}/liballd.a
530 #%%endif
531 #%%endif
532
533 #%%if %{with proflib}
534 #%%files profile
535 #%%defattr(644,root,root,755)
536 #%%attr(755,root,root) %{_libdir}/liballp-%{version}.so
537 #%%{_libdir}/liballp_unsharable.a
538
539 #%%if %{with static}
540 #%%files profile-static
541 #%%defattr(644,root,root,755)
542 #%%{_libdir}/liballp.a
543 #%%endif
544 #%%endif
545
546 #%%if %{with svga}
547 #%%files svgalib
548 #%%defattr(644,root,root,755)
549 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-svgalib.so
550 #%%endif
551
552 #%%if %{with dga2}
553 #%%files dga2
554 #%%defattr(644,root,root,755)
555 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-dga2.so
556 #%%endif
557
558 #%%if %{with esd}
559 #%%files esd
560 #%%defattr(644,root,root,755)
561 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-esddigi.so
562 #%%endif
563
564 #%%if %{with arts}
565 #%%files arts
566 #%%defattr(644,root,root,755)
567 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-artsdigi.so
568 #%%endif
569
570 #%%if %{with fbcon}
571 #%%files fbcon
572 #%%defattr(644,root,root,755)
573 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-fbcon.so
574 #%%endif
575
576 #%%ifarch %{ix86}
577 #%%if %{with vga}
578 #%%files vga
579 #%%defattr(644,root,root,755)
580 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-vga.so
581 #%%endif
582 #%%endif
583
584 #%%if %{with alsa}
585 #%%files alsa
586 #%%defattr(644,root,root,755)
587 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsadigi.so
588 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsamidi.so
589 #%%endif
590
591 #%%if %{with jack}
592 #%%files jack
593 #%%defattr(644,root,root,755)
594 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-jackdigi.so
595 #%%endif
596
597 #%%files tools
598 #%%defattr(644,root,root,755)
599 #%%attr(755,root,root) %{_bindir}/colormap
600 #%%attr(755,root,root) %{_bindir}/exedat
601 #%%attr(755,root,root) %{_bindir}/pack
602 #%%attr(755,root,root) %{_bindir}/rgbmap
603 #%%attr(755,root,root) %{_bindir}/textconv
604 #%attr(755,root,root) %{_bindir}/xkeymap
605 #%%attr(755,root,root) %{_bindir}/xf2pcx
606 #%%attr(755,root,root) %{_bindir}/dat
607 #%%attr(755,root,root) %{_bindir}/dat2c
608 #%%attr(755,root,root) %{_bindir}/dat2s
609 #%%attr(755,root,root) %{_bindir}/grabber
610 #%%attr(755,root,root) %{_bindir}/pat2dat
611 #%attr(755,root,root) %{_bindir}/setup-allegro
612
613 #%%files tests
614 #%%defattr(644,root,root,755)
615 #%%attr(755,root,root) %{_bindir}/afinfo
616 #%%attr(755,root,root) %{_bindir}/akaitest
617 #%%attr(755,root,root) %{_bindir}/cpptest
618 #%%attr(755,root,root) %{_bindir}/demo-allegro
619 #%%attr(755,root,root) %{_bindir}/digitest
620 #%%attr(755,root,root) %{_bindir}/filetest
621 #%%attr(755,root,root) %{_bindir}/gfxinfo
622 #%%attr(755,root,root) %{_bindir}/mathtest
623 #%%attr(755,root,root) %{_bindir}/miditest
624 #%%attr(755,root,root) %{_bindir}/play-allegro
625 #%%attr(755,root,root) %{_bindir}/playfli
626 #%%attr(755,root,root) %{_bindir}/test-allegro
627 #%%attr(755,root,root) %{_bindir}/vesainfo
628
629 #%%files examples
630 #%%defattr(644,root,root,755)
631 #%%attr(755,root,root) %{_bindir}/ex12bit
632 #%%attr(755,root,root) %{_bindir}/ex3buf
633 #%%attr(755,root,root) %{_bindir}/ex3d
634 #%%attr(755,root,root) %{_bindir}/exaccel
635 #%%attr(755,root,root) %{_bindir}/exalpha
636 #%%attr(755,root,root) %{_bindir}/exbitmap
637 #%%attr(755,root,root) %{_bindir}/exblend
638 #%%attr(755,root,root) %{_bindir}/excamera
639 #%%attr(755,root,root) %{_bindir}/excolmap
640 #%%attr(755,root,root) %{_bindir}/exconfig
641 #%%attr(755,root,root) %{_bindir}/excustom
642 #%%attr(755,root,root) %{_bindir}/exdata
643 #%%attr(755,root,root) %{_bindir}/exdbuf
644 #%%attr(755,root,root) %{_bindir}/exexedat
645 #%%attr(755,root,root) %{_bindir}/exfixed
646 #%%attr(755,root,root) %{_bindir}/exflame
647 #%%attr(755,root,root) %{_bindir}/exflip
648 #%%attr(755,root,root) %{_bindir}/exfont
649 #%%attr(755,root,root) %{_bindir}/exgui
650 #%%attr(755,root,root) %{_bindir}/exhello
651 #%%attr(755,root,root) %{_bindir}/exjoy
652 #%%attr(755,root,root) %{_bindir}/exkeys
653 #%%attr(755,root,root) %{_bindir}/exlights
654 #%%attr(755,root,root) %{_bindir}/exmem
655 #%%attr(755,root,root) %{_bindir}/exmidi
656 #%%attr(755,root,root) %{_bindir}/exmouse
657 #%%attr(755,root,root) %{_bindir}/expackf
658 #%%attr(755,root,root) %{_bindir}/expal
659 #%%attr(755,root,root) %{_bindir}/expat
660 #%%attr(755,root,root) %{_bindir}/exquat
661 #%%attr(755,root,root) %{_bindir}/exrgbhsv
662 #%%attr(755,root,root) %{_bindir}/exsample
663 #%%attr(755,root,root) %{_bindir}/exsyscur
664 #%%attr(755,root,root) %{_bindir}/exscale
665 #%%attr(755,root,root) %{_bindir}/exscn3d
666 #%%attr(755,root,root) %{_bindir}/exscroll
667 #%%attr(755,root,root) %{_bindir}/exshade
668 #%%attr(755,root,root) %{_bindir}/exspline
669 #%%attr(755,root,root) %{_bindir}/exsprite
670 #%%attr(755,root,root) %{_bindir}/exstars
671 #%%attr(755,root,root) %{_bindir}/exstream
672 #%%attr(755,root,root) %{_bindir}/exswitch
673 #%%attr(755,root,root) %{_bindir}/extimer
674 #%%attr(755,root,root) %{_bindir}/extrans
675 #%%attr(755,root,root) %{_bindir}/extruec
676 #%%attr(755,root,root) %{_bindir}/exunicod
677 #%%attr(755,root,root) %{_bindir}/exupdate
678 #%%attr(755,root,root) %{_bindir}/exxfade
679 #%%attr(755,root,root) %{_bindir}/exzbuf
680 #%%attr(755,root,root) %{_bindir}/exnew_events
This page took 0.126991 seconds and 3 git commands to generate.