]> git.pld-linux.org Git - packages/alienarena2007.git/blob - alienarena2007.spec
- add BR: dos2unix
[packages/alienarena2007.git] / alienarena2007.spec
1 %define         relyear         2007
2 %define         dateversion     20070613
3 #
4 Summary:        Alien Arena - freeware online deathmatch FPS game
5 Summary(pl.UTF-8):Alien Arena
6 Name:           alienarena%{relyear}
7 Version:        6.05
8 Release:        0.1
9 License:        GPL
10 Group:          X11/Applications/Games
11 Source0:        http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/%{name}-%{dateversion}-linux.zip
12 # Source0-md5:  08c20b29d0ed529769cab4952e8cfe94
13 URL:            http://red.planetarena.org/
14 BuildRequires:  Mesa-libGLU-devel
15 BuildRequires:  dos2unix
16 BuildRequires:  libjpeg-devel
17 BuildRequires:  SDL-devel
18 BuildRequires:  rpmbuild(macros) >= 1.228
19 BuildRequires:  xorg-lib-libX11-devel
20 BuildRequires:  xorg-lib-libXext-devel
21 Requires(post,preun):   /sbin/chkconfig
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 ALIEN ARENA is a standalone 3D first person online deathmatch shooter
26 crafted from the original source code of Quake II and Quake III,
27 released by id Software under the GPL license. With features including
28 32 bit graphics, new particle engine and effects, light blooms,
29 reflective water, hi resolution textures and skins, hi poly models,
30 stain maps, ALIEN ARENA pushes the envelope of graphical beauty
31 rivaling today's top games.
32
33 The game features 37 levels, which can be played online against other
34 players, or against the built in CodeRED bots.
35
36 Alien Arena offers CTF, AOA(All Out Assault) mode, in which players
37 can climb into vehicles to do battle, Deathball, and Team Core
38 Assault. Simply go into the multiplayer menu to start a server, change
39 the game rules, and choose a map to play on. You can also select from
40 five different mutators(instagib, rocket arena, excessive, low grav,
41 regen, and vampire) to further customize your game experience.
42
43 %package server
44 Summary:        Alien Arena - server
45 Summary(pl.UTF-8):Alien Arena - serwer
46 Group:          X11/Applications/Games
47
48 %description server
49 The dedicated server for Alien Arena.
50
51 %package data
52 Summary:        Alien Arena - the data, botinfo, and arena files
53 Group:          X11/Applications/Games
54
55 %description data
56 This package installs the data, botinfo, and arena files needed to run
57 Alien Arena.
58
59 %prep
60 %setup -q -n %{name}
61 rm -f ../GH3D.txt ../GamersHell.url
62
63 for file in lst cfg txt html lng h c ; do
64         find ./ -noleaf -type f -name \*.$file -exec dos2unix '{}' \;
65 done
66
67 %build
68 %{__make} \
69         CFLAGS="%{rpmcflags} -ldl" \
70         LDFLAGS="%{rpmldflags}"
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post server
82 /sbin/chkconfig --add %{name}
83 %service %{name} restart
84
85 %preun server
86 if [ "$1" = "0" ]; then
87         %service -q %{name} stop
88         /sbin/chkconfig --del %{name}
89 fi
90
91 %files
92 %defattr(644,root,root,755)
93 %doc changelog README
94 %lang(du) %doc docs/AA Dutch.txt
95 %lang(fr) %doc docs/AA French.txt
96 %lang(de) %doc docs/AA German.txt
97 %lang(gr) %doc docs/AA Greek.txt
98 %lang(hu) %doc docs/AA Hungarian.txt
99 %lang(it) %doc docs/AA Italian.txt
100 %lang(pl) %doc docs/AA Polish.txt
101 %lang(po) %doc docs/AA Portuguese.txt
102 %lang(ru) %doc docs/AA Russian.txt
103 %lang(es) %doc docs/AA_ES.txt
104 %attr(755,root,root) %{_bindir}/alien-arena
105 %{_desktopdir}/alien-arena.desktop
106 %{_pixmapsdir}/alien-arena.xpm
107
108 %files data
109 %defattr(644,root,root,755)
110
111 %files server
112 %defattr(644,root,root,755)
113 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
114 %attr(754,root,root) /etc/rc.d/init.d/%{name}
115 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
116 %attr(755,root,root) %{_bindir}/alien-arena-server
117 alien-arena/crded
118 alien-arena/kill-runaway-crded
119 alien-arena/launch-server
120 alien-arena/rcon
121 alien-arena/svstat
122 %{_mandir}/man6/alien-arena-server.6.*
This page took 0.060135 seconds and 3 git commands to generate.