]> git.pld-linux.org Git - packages/agg.git/blob - agg.spec
- rel 1; xorg reqs
[packages/agg.git] / agg.spec
1 Summary:        A High Quality Rendering Engine for C++
2 Summary(pl.UTF-8):      Silnik renderujący wysokiej jakości dla C++
3 Name:           agg
4 Version:        2.5
5 Release:        1
6 License:        GPL v2+
7 Group:          Libraries
8 Source0:        http://www.antigrain.com/%{name}-%{version}.tar.gz
9 # Source0-md5:  ddc67cbdc7d51e1ec984c2ac2724c08a
10 Patch0:         %{name}-depends.patch
11 URL:            http://www.antigrain.com/
12 BuildRequires:  SDL-devel
13 BuildRequires:  xorg-lib-libX11-devel
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  freetype-devel
17 BuildRequires:  libtool
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Anti-Grain Geometry (AGG) is a general purpose graphical toolkit
22 written completely in standard and platform independent C++. It can be
23 used in many areas of computer programming where high quality 2D
24 graphics is an essential part of the project.
25
26 AGG uses only C++ and standard C runtime functions, such as memcpy,
27 sin, cos, sqrt, etc. The basic algorithms don't even use C++ Standard
28 Template Library. Thus, AGG can be used in a very large number of
29 applications, including embedded systems.
30
31 %description -l pl.UTF-8
32 Anti-Grain Geometry (AGG) to toolkit graficzny ogólnego przeznaczenia
33 napisany całkowicie w standardowym i niezależnym od platformy C++.
34 Może być używany w wielu zastosowaniach z zakresu programowania gdzie
35 zasadniczą częścią projektu jest wysokiej jakości grafika 2D.
36
37 AGG używa tylko C++ i standardowych funkcji C, takich jak memcpy, sin,
38 cos, sqrt itp. Podstawowe algorytmy nie używają nawet standardowej
39 biblioteki C++. W ten sposób AGG może być używany w bardzo wielu
40 zastosowaniach, także na systemach wbudowanych.
41
42 %package devel
43 Summary:        Support files necessary to compile applications with agg
44 Summary(pl.UTF-8):      Pliki potrzebne do kompilowania aplikacji z użyciem agg
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 Header and support files necessary to compile applications using agg.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe i pomocnicze potrzebne do kompilowania aplikacji z
53 użyciem agg.
54
55 %package static
56 Summary:        Static agg library
57 Summary(pl.UTF-8):      Statyczna biblioteka agg
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static agg library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka agg.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70
71 %build
72 %{__aclocal}
73 %{__autoheader}
74 %{__autoconf}
75 %{__libtoolize}
76 %{__automake}
77 %configure \
78         --disable-gpc
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc authors copying readme
96 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
97
98 %files devel
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_libdir}/lib*.so
101 %{_libdir}/*.la
102 %{_includedir}/agg2
103 %{_pkgconfigdir}/libagg.pc
104 %{_aclocaldir}/libagg.m4
105
106 %files static
107 %defattr(644,root,root,755)
108 %{_libdir}/*.a
This page took 0.071971 seconds and 4 git commands to generate.