]> git.pld-linux.org Git - packages/adobe-flash.git/blob - adobe-flash.spec
ad6b0c6a3d75a81bcd98d94eb69499ee856b718f
[packages/adobe-flash.git] / adobe-flash.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4
5 %ifarch %{ix86}
6 %define         ver             10.2.153.1
7 %define         libmark %{nil}
8 %endif
9 %ifarch %{x8664}
10 %define         ver             10.3.162.29
11 %define         libmark ()(64bit)
12 %endif
13
14 %define         base_name       adobe-flash
15 %define         rel 1
16 Summary:        Flash plugin for Netscape-compatible WWW browsers
17 Summary(pl.UTF-8):      Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
18 %if %{with license_agreement}
19 Name:           %{base_name}
20 %else
21 Name:           %{base_name}-installer
22 %endif
23 Version:        %{ver}
24 Release:        %{rel}%{?with_license_agreement:wla}
25 Epoch:          1
26 License:        Free to use, non-distributable
27 Group:          X11/Applications/Multimedia
28 %if %{with license_agreement}
29 #Source0:       http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p2_32bit_linux_111710.tar.gz
30 #Source0:       http://fpdownload.macromedia.com/get/flashplayer/current/flash-plugin-%{version}-release.i386.rpm
31 Source0:        http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
32 # NoSource0-md5:        d9765217326bdca56d6a5b9030e8c574
33 NoSource:       0
34 ##Source1:      http://download.macromedia.com/pub/labs/flashplayer10/libflashplayer-%{version}.linux-x86_64.so.tar.gz
35 Source1:        http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p3_64bit_linux_111710.tar.gz
36 # NoSource1-md5:        49b55c7eb8044453e5f6f2e4b3cb4084
37 NoSource:       1
38 Source2:        mms.cfg
39 %else
40 Source3:        http://svn.pld-linux.org/svn/license-installer/license-installer.sh
41 # Source3-md5:  329c25f457fea66ec502b7ef70cb9ede
42 %endif
43 Source4:        memcpy-to-memmove.sh
44 URL:            http://www.adobe.com/products/flashplayer/
45 %if %{with license_agreement}
46 BuildRequires:  rpmbuild(macros) >= 1.357
47 BuildRequires:  sed >= 4.0
48 Requires:       browser-plugins >= 2.0
49 # dlopened by player
50 Requires:       libasound.so.2%{libmark}
51 Requires:       libcurl.so.4%{libmark}
52 %else
53 Requires:       rpm-build-tools >= 4.4.37
54 Requires:       rpmbuild(macros) >= 1.544
55 %endif
56 Provides:       browser(flash)
57 Provides:       macromedia-flash
58 Obsoletes:      flash-plugin
59 Obsoletes:      konqueror-plugin-macromedia-flash
60 Obsoletes:      macromedia-flash
61 Obsoletes:      mozilla-firefox-plugin-macromedia-flash
62 Obsoletes:      mozilla-plugin-macromedia-flash
63 ExclusiveArch:  %{ix86} %{x8664}
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %define         _sysconfdir     /etc/adobe
67
68 # So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
69 %define         _noautoreqdep   libstdc++.so.6
70
71 # No debuginfo to be stored
72 %define         _enable_debug_packages  0
73
74 %description
75 Adobe(R) Flash(R) Player for Linux - the next-generation client
76 runtime for engaging with Flash content and applications on Linux.
77
78 %description -l pl.UTF-8
79 Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
80 treści i aplikacji we Flashu pod Linuksem.
81
82 %prep
83 %if %{with license_agreement}
84 %ifarch %{x8664}
85 %setup -q -T -c -b 1
86 %else
87 %setup -q -T -c -b 0
88 %endif
89
90 %build
91 s=$(echo 'LNX %{version}' | tr . ,)
92 v=$(strings libflashplayer.so | grep '^LNX ')
93 if [ "$v" != "$s" ]; then
94         : wrong version
95         exit 1
96 fi
97
98 %ifarch %{x8664}
99 # Bug #354073: Patch binary to use memmove instead of memcpy from
100 # Redhat's bug https://bugzilla.redhat.com/show_bug.cgi?id=638477#c94
101 cp libflashplayer.so libflashplayer.so.orig
102 /bin/bash %{SOURCE4} libflashplayer.so \
103 || (echo "memcpy-to-memmove.sh failed" && exit 1)
104 %endif
105 %endif
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 %if %{without license_agreement}
110 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
111
112 sed -e '
113         s/@BASE_NAME@/%{base_name}/g
114         s/@TARGET_CPU@/%{_target_cpu}/g
115         s-@VERSION@-%{version}-g
116         s-@RELEASE@-%{release}-g
117         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
118         s,@DATADIR@,%{_datadir}/%{base_name},g
119 ' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
120
121 cp -p %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
122
123 %else
124
125 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
126 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
127 install -p *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
128 %endif
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %if %{without license_agreement}
134 %post
135 %{_bindir}/%{base_name}.install
136 %else
137 %post
138 %update_browser_plugins
139
140 %postun
141 if [ "$1" = 0 ]; then
142         %update_browser_plugins
143 fi
144 %endif
145
146 %files
147 %defattr(644,root,root,755)
148 %if %{without license_agreement}
149 %attr(755,root,root) %{_bindir}/%{base_name}.install
150 %{_datadir}/%{base_name}
151 %else
152 %dir %{_sysconfdir}
153 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
154 %attr(755,root,root) %{_browserpluginsdir}/*.so
155 %endif
This page took 0.060727 seconds and 3 git commands to generate.