]> git.pld-linux.org Git - packages/Zope.git/blob - Zope.spec
- fixed Source0
[packages/Zope.git] / Zope.spec
1 Summary:        An application server and portal toolkit for building Web sites
2 Summary(es):    Un servidor de aplicaciones y un conjunto de herramientas para la construcción de sitios Web
3 Summary(pl):    Serwer aplikacji i toolkit portalowy do tworzenia serwisów WWW
4 Summary(pt_BR): Um servidor de aplicações e um conjunto de ferramentas para construção de sites Web
5 Name:           Zope
6 Version:        2.6.2b5
7 Release:        1
8 License:        Zope Public License (ZPL)
9 Group:          Networking/Daemons
10 Source0:        http://www.zope.org/Products/%{name}/%{version}/%{version}/%{name}-%{version}-src.tgz
11 # Source0-md5:  60ddbd685febb73e10ecdb5da6eda895
12 Source1:        %{name}.init
13 Source2:        %{name}.logrotate
14 Source3:        %{name}.sysconfig
15 Source4:        %{name}-start.sh
16 Source5:        http://zope.org/Documentation/Guides/ZCMG/Tarred%20HTML%202.1.1/ZCMG.html.tgz
17 # Source5-md5:  4c52eebc2e874a0590ac9c04e222e9f1
18 Source6:        http://www.zope.org/Documentation/Guides/DTML/Compressed%20html%202.1.1/DTML.html.tgz
19 # Source6-md5:  10f363dd061a1af8d472c51c32fa0a0e
20 Source7:        http://www.zope.org/Documentation/Guides/ZSQL/2.1.1/ZSQL.html.tgz
21 # Source7-md5:  0cddb5688fc0f886db468da08251fb81
22 Source8:        http://www.zope.org/Documentation/Guides/ZDG/HTML%201.2/ZDG.html.tgz
23 # Source8-md5:  0344ca88acb8a71688d2925975a55443
24 Source9:        http://www.zope.org/Documentation/Guides/ZAG/HTML%201.0/ZAG.html.tgz
25 # Source9-md5:  b28bfc4ba4bee880767fcf89d79532d2
26 Source10:       http://openbsd.secsup.org/distfiles/zopebook-2.5/ZopeBook.tgz
27 # Source10-md5: 268c38a4c7d9f7334cdc98b0a152f8da
28 Patch0:         %{name}-http-virtual-cache.patch
29 URL:            http://www.zope.org/
30 BuildRequires:  python-devel >= 2.3
31 BuildRequires:  perl
32 PreReq:         rc-scripts
33 Requires(pre): /usr/bin/getgid
34 Requires(pre): /bin/id
35 Requires(pre): /usr/sbin/groupadd
36 Requires(pre): /usr/sbin/useradd
37 Requires(postun):      /usr/sbin/userdel
38 Requires(postun):      /usr/sbin/groupdel
39 Requires(post,preun):   /sbin/chkconfig
40 Requires:       logrotate
41 Requires:       python >= 2.3
42 Requires:       python-modules >= 2.3
43 Requires:       python-libs >= 2.3
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         python_prefix           %(echo `python -c "import sys; print sys.prefix"`)
47 %define         python_version          %(echo `python -c "import sys; print sys.version[:3]"`)
48 %define         python_libdir           %{python_prefix}/lib/python%{python_version}
49 %define         python_includedir       %{python_prefix}/include/python%{python_version}
50 %define         python_sitedir          %{python_libdir}/site-packages
51 %define         python_configdir        %{python_libdir}/config
52
53 %define         python_compile          python -c "import compileall; compileall.compile_dir('.')"
54 %define         python_compile_opt      python -O -c "import compileall; compileall.compile_dir('.')"
55
56 %description
57 The Z Object Programming Environment (Zope) is a free, Open Source
58 Python-based application server for building high-performance, dynamic
59 web sites, using a powerful and simple scripting object model and
60 high-performance, integrated object database.
61
62 %description -l es
63 Zope es una aplicación basada en Python, Open Source[tm], para la
64 construcción de sitios dinámicos, usa un modelo de escritura de
65 guiones poderoso y sencillo. Para instalar la aplicación Zope, instale
66 ese paquete y después, Zope-server, para un servidor HTTP integrado
67 simple, Zope-pcgi, para uso con el servidor Apache. Si desea instalar
68 solamente algunas partes de la aplicación Zope, están diponibles otros
69 subpaquetes, usted debe instalar éstos en vez de ese RPM.
70
71 %description -l pl
72 Zope (Z Object Programming Environment - Obiektowe ¦rodowisko
73 Programistyczne Z) jest opartym o Pythona serwerem aplikacji do
74 tworzenia wysoko wydajnych, dynamicznych serwisów WWW, przy u¿yciu
75 u¿ytecznego i prostego modelu obiektowego skryptów oraz wysoko
76 wydajnej zintegrowanej obiektowej bazy danych.
77
78 %description -l pt_BR
79 Zope é uma aplicação baseada em Python, Open Source[tm], para
80 construção de sites dinâmicos, usando um modelo de scripting poderoso
81 e simples Para instalar o Zope, instale esse pacote e depois, ou o
82 Zope-server, para um servidor HTTP integrado simples, ou Zope-pcgi,
83 para uso com o Apache. Se você quiser instalar apenas algumas partes
84 do Zope, outros sub-pacotes estão disponíveis, e você deveria instalar
85 eles ao invés desse RPM.
86
87 %prep
88 %setup -q -n %{name}-%{version}-src -a5
89 %patch0 -p1
90 mkdir ZopeContentManagersGuide GuideToDTML GuideToZSQL ZopeDevelopersGuide 
91 mkdir ZopeAdminGuide ZopeBook
92 tar xzf %{SOURCE5} -C ZopeContentManagersGuide
93 tar xzf %{SOURCE6} -C GuideToDTML
94 tar xzf %{SOURCE7} -C GuideToZSQL
95 tar xzf %{SOURCE8} -C ZopeDevelopersGuide
96 tar xzf %{SOURCE9} -C ZopeAdminGuide
97 tar xzf %{SOURCE10} -C ZopeBook
98
99 %build
100 perl -pi -e "s|data_dir\s+=\s+.*?join\(INSTANCE_HOME, 'var'\)|data_dir=INSTANCE_HOME|" lib/python/Globals.py
101 python wo_pcgi.py
102
103 find lib/python -type f -and \( -name 'Setup' -or -name '.cvsignore' \) -exec rm -f \{\} \;
104 find -type f -and \( -name '*.c' -or -name '*.h' -or -name 'Makefile*' \) -exec rm -f \{\} \;
105 rm -f ZServer/medusa/monitor_client_win32.py
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/zope} \
110         $RPM_BUILD_ROOT{/etc/{rc.d/init.d,logrotate.d,sysconfig}} \
111         $RPM_BUILD_ROOT{/var/log/zope,/var/lib/zope/main}
112
113 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/zope
114 install %{SOURCE2} $RPM_BUILD_ROOT/etc/logrotate.d/zope
115 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/zope
116 install %{SOURCE4} $RPM_BUILD_ROOT%{_sbindir}/zope-start
117
118 cp -a lib/python/* $RPM_BUILD_ROOT%{_libdir}/zope
119 cp -a ZServer/ utilities/ import/ $RPM_BUILD_ROOT%{_libdir}/zope
120 find $RPM_BUILD_ROOT%{_libdir}/zope -type f -name '*.py' -or -name '*.txt' | xargs -r rm -f
121 cp -a ZServer/medusa/test/* $RPM_BUILD_ROOT%{_libdir}/zope/ZServer/medusa/test/
122
123 install zpasswd.py $RPM_BUILD_ROOT%{_bindir}/zpasswd
124 install z2.py $RPM_BUILD_ROOT%{_libdir}/zope
125 install var/Data.fs $RPM_BUILD_ROOT/var/lib/zope/main/Data.fs
126
127 python $RPM_BUILD_ROOT%{_bindir}/zpasswd -u zope -p zope -d localhost \
128         $RPM_BUILD_ROOT/var/lib/zope/main/access
129
130 touch $RPM_BUILD_ROOT/var/log/zope/main.log
131 touch $RPM_BUILD_ROOT/var/log/zope/main-detailed.log
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %pre
137 if [ -z "`getgid zope`" ]; then
138        echo "Making group zope"
139        /usr/sbin/groupadd -r -f zope
140 fi
141 if [ -z "`id -u zope 2>/dev/null`" ]; then
142        echo "Making user zope"
143        /usr/sbin/useradd -r -d /var/lib/zope/main -s /bin/false -c "Zope User" -g zope zope
144 fi
145
146 %post
147 /sbin/chkconfig --add zope
148 if [ -f /var/lock/subsys/zope ]; then
149         /etc/rc.d/init.d/zope restart >&2
150 else
151         echo "Create inituser using \"zpasswd inituser\" in directory \"/var/lib/zope/main\"" >&2
152         echo "Run then \"/etc/rc.d/init.d/zope start\" to start Zope." >&2
153 fi
154
155 %preun
156 if [ "$1" = "0" ]; then
157         if [ -f /var/lock/subsys/zope ]; then
158                 /etc/rc.d/init.d/zope stop
159         fi
160         /sbin/chkconfig --del zope
161 fi
162
163 %postun
164 if [ "$1" = "0" ] ; then
165        echo "Removing user zope"
166        /usr/sbin/userdel zope >/dev/null 2>&1 || :
167        echo "Removing group zope"
168        /usr/sbin/groupdel zope >/dev/null 2>&1 || :    
169 fi
170
171 %files
172 %defattr(644,root,root,755)
173 %doc doc/*.txt *.txt ZopeContentManagersGuide GuideToZSQL ZopeDevelopersGuide ZopeAdminGuide ZopeBook
174 %attr(755,root,root) /etc/rc.d/init.d/zope
175 %attr(755,root,root) %{_bindir}/*
176 %attr(755,root,root) %{_sbindir}/*
177 %{_libdir}/zope
178 %attr(640,root,root) %dir /var/lib/zope
179 %attr(1771,root,zope) %dir /var/lib/zope/main
180 %attr(660,root,zope) %config(noreplace) %verify(not md5 size mtime) /var/lib/zope/main/*
181 %attr(640,root,root) /etc/logrotate.d/zope
182 %attr(640,root,root) /etc/sysconfig/zope
183 %ghost /var/log/zope/main.log
184 %ghost /var/log/zope/main-detailed.log
This page took 0.094603 seconds and 4 git commands to generate.