]> git.pld-linux.org Git - packages/Zope.git/blob - Zope.spec
82f7c4f63460d496c3d953e5a4dd5b76eaf643e4
[packages/Zope.git] / Zope.spec
1 Summary:        An application server and portal toolkit for building Web sites
2 Summary(es):    Un servidor de aplicaciones y un conjunto de herramientas para la construcción de sitios Web
3 Summary(pl):    Serwer aplikacji i toolkit portalowy do tworzenia serwisów WWW
4 Summary(pt_BR): Um servidor de aplicações e um conjunto de ferramentas para construção de sites Web
5 Name:           Zope
6 Version:        2.6.0
7 Release:        3
8 License:        Zope Public License (ZPL)
9 Group:          Networking/Daemons
10 Source0:        http://www.zope.org/Products/%{name}/%{version}/%{name}-%{version}-src.tgz
11 Source1:        http://www.zope.org/Documentation/Guides/ZCMG/ZCMG.html.tgz
12 Source2:        http://www.zope.org/Documentation/Guides/DTML/DTML.html.tgz
13 Source3:        http://www.zope.org/Documentation/Guides/ZSQL/ZSQL.html.tgz
14 Source4:        http://www.zope.org/Documentation/Guides/%{name}-ProductTutorial.tar.gz
15 Source5:        http://www.zope.org/Documentation/Guides/ZDG/ZDG.html.tgz
16 Source6:        http://www.zope.org/Documentation/Guides/ZAG/ZAG.html.tgz
17 # note: above documentation is deprecated, zope.org suggests using ZopeBook:
18 #Source1:       http://www.zope.org/Members/michel/ZB/ZopeBook.tgz
19 Source7:        %{name}.init
20 Source8:        %{name}-zserver.sh
21 URL:            http://www.zope.org/
22 Prereq:         rc-scripts
23 Prereq:         /sbin/chkconfig
24 Prereq:         /usr/sbin/useradd
25 Requires:       python >= 2.2
26 Requires:       python-modules >= 2.2
27 BuildRequires:  python-devel >= 2.2
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define python_prefix      %(echo `python -c "import sys; print sys.prefix"`)
31 %define python_version     %(echo `python -c "import sys; print sys.version[:3]"`)
32 %define python_libdir      %{python_prefix}/lib/python%{python_version}
33 %define python_includedir  %{python_prefix}/include/python%{python_version}
34 %define python_sitedir     %{python_libdir}/site-packages
35 %define python_configdir   %{python_libdir}/config
36
37 %define python_compile     python -c "import compileall; compileall.compile_dir('.')"
38 %define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
39
40 %description
41 The Z Object Programming Environment (Zope) is a free, Open Source
42 Python-based application server for building high-performance, dynamic
43 web sites, using a powerful and simple scripting object model and
44 high-performance, integrated object database.
45
46 %description -l es
47 Zope es una aplicación basada en Python, Open Source[tm], para la
48 construcción de sitios dinámicos, usa un modelo de escritura de
49 guiones poderoso y sencillo. Para instalar la aplicación Zope, instale
50 ese paquete y después, Zope-server, para un servidor HTTP integrado
51 simple, Zope-pcgi, para uso con el servidor Apache. Si desea instalar
52 solamente algunas partes de la aplicación Zope, están diponibles otros
53 subpaquetes, usted debe instalar éstos en vez de ese RPM.
54
55 %description -l pl
56 Zope (Z Object Programming Environment - Obiektowe ¦rodowisko
57 Programistyczne Z) jest opartym o Pythona serwerem aplikacji do
58 tworzenia wysoko wydajnych, dynamicznych serwisów WWW, przy u¿yciu
59 u¿ytecznego i prostego modelu obiektowego skryptów oraz wysoko
60 wydajnej zintegrowanej obiektowej bazy danych.
61
62 %description -l pt_BR
63 Zope é uma aplicação baseada em Python, Open Source[tm], para
64 construção de sites dinâmicos, usando um modelo de scripting poderoso
65 e simples Para instalar o Zope, instale esse pacote e depois, ou o
66 Zope-server, para um servidor HTTP integrado simples, ou Zope-pcgi,
67 para uso com o Apache. Se você quiser instalar apenas algumas partes
68 do Zope, outros sub-pacotes estão disponíveis, e você deveria instalar
69 eles ao invés desse RPM.
70
71 %prep
72 %setup -q -n %{name}-%{version}-src -a4
73 mkdir ZopeContentManagersGuide GuideToDTML GuideToZSQL ZopeDevelopersGuide ZopeAdminGuide
74 tar xzf %{SOURCE1} -C ZopeContentManagersGuide
75 tar xzf %{SOURCE2} -C GuideToDTML
76 tar xzf %{SOURCE3} -C GuideToZSQL
77 tar xzf %{SOURCE5} -C ZopeDevelopersGuide
78 tar xzf %{SOURCE6} -C ZopeAdminGuide
79
80 %build
81 perl -pi -e "s|data_dir\s+=\s+.*?join\(INSTANCE_HOME, 'var'\)|data_dir=INSTANCE_HOME|" lib/python/Globals.py
82 python wo_pcgi.py
83
84 find lib/python -type f -and \( -name 'Setup' -or -name '.cvsignore' \) -exec rm -f \{\} \;
85 find -type f -and \( -name '*.c' -or -name '*.h' -or -name 'Makefile*' \) -exec rm -f \{\} \;
86 rm -f ZServer/medusa/monitor_client_win32.py
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/zope} \
91             $RPM_BUILD_ROOT{/etc/rc.d/init.d,/var/log,/var/lib/zope}
92
93 cp -a lib/python/* $RPM_BUILD_ROOT%{_libdir}/zope
94 cp -a ZServer/ utilities/ import/ $RPM_BUILD_ROOT%{_libdir}/zope
95 find $RPM_BUILD_ROOT%{_libdir}/zope -type f -name '*.py' -or -name '*.txt' | xargs -r rm -f
96 cp -a ZServer/medusa/test/* $RPM_BUILD_ROOT%{_libdir}/zope/ZServer/medusa/test/
97
98 install zpasswd.py $RPM_BUILD_ROOT%{_bindir}/zpasswd
99 install z2.py $RPM_BUILD_ROOT%{_libdir}/zope
100 install %{SOURCE8} $RPM_BUILD_ROOT%{_sbindir}/zope-zserver
101 install %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/zope
102 install var/Data.fs $RPM_BUILD_ROOT/var/lib/zope/Data.fs
103
104 touch $RPM_BUILD_ROOT/var/log/zope
105
106 python $RPM_BUILD_ROOT%{_bindir}/zpasswd -u zope -p zope -d localhost $RPM_BUILD_ROOT/var/lib/zope/access
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %pre
112 if [ -z "`getgid zope`" ]; then
113         echo "Making group zope"
114         /usr/sbin/groupadd -r -f zope
115 fi
116
117 if [ -z "`id -u zope 2>/dev/null`" ]; then
118         echo "Making user zope"
119         /usr/sbin/useradd -r -d /var/lib/zope -s /bin/false -c "Zope User" -g zope zope
120 fi
121
122 %post
123 /sbin/chkconfig --add zope
124 if [ -f /var/lock/subsys/zope ]; then
125         /etc/rc.d/init.d/zope restart >&2
126 else
127         echo "Run \"/etc/rc.d/init.d/zope start\" to start Zope." >&2
128 fi
129
130 %preun
131 if [ "$1" = "0" ]; then
132         if [ -f /var/lock/subsys/zope ]; then
133                 /etc/rc.d/init.d/zope stop
134         fi
135         /sbin/chkconfig --del zope
136 fi
137
138 %postun
139 if [ "$1" = "0" ] ; then
140         echo "Removing user zope"
141         /usr/sbin/userdel zope >/dev/null 2>&1 || :
142         echo "Removing group zope"
143         /usr/sbin/groupdel zope >/dev/null 2>&1 || :    
144 fi
145
146 %files
147 %defattr(644,root,root,755)
148 %attr(755,root,root) /etc/rc.d/init.d/zope
149 %attr(755,root,root) %{_bindir}/*
150 %attr(755,root,root) %{_sbindir}/*
151 %{_libdir}/zope
152 %attr(1771,root,zope) %dir /var/lib/zope
153 %attr(660,root,zope) %config(noreplace) %verify(not md5 size mtime) /var/lib/zope/*
154 %doc *.txt doc/*.txt ZopeContentManagersGuide GuideToZSQL Tutorial ZopeDevelopersGuide ZopeAdminGuide
This page took 0.095313 seconds and 3 git commands to generate.