]> git.pld-linux.org Git - packages/Zope-TranslationService.git/blob - Zope-TranslationService.spec
- initial release
[packages/Zope-TranslationService.git] / Zope-TranslationService.spec
1 %include        /usr/lib/rpm/macros.python
2
3 %define         zope_subname    TranslationService
4
5 Summary:        TranslationService is a placeful translation service for Zope
6 Summary(pl):    TranslationService jest ¶rodowiskiem dla translacji jêzykowych dla Zope
7 Name:           Zope-%{zope_subname}
8 Version:        0.4
9 Release:        1
10 License:        GNU
11 Group:          Development/Tools
12 Source0:        http://www.zope.org/Members/efge/%{zope_subname}/%{zope_subname}-%{version}.tgz
13 # Source0-md5:  b1399f80dc71ea8a54f4c6dc179c12dd
14 URL:            http://www.zope.org/Members/efge/TranslationService
15 %pyrequires_eq  python-modules
16 Requires:       Zope
17 Requires:       Zope-Localizer
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         product_dir     /usr/lib/zope/Products
22
23 %description
24 TranslationService is a placeful translation service for Zope
25
26 %description -l pl
27 TranslationService jest ¶rodowiskiem dla translacji jêzykowych dla
28 Zope
29
30 %prep
31 %setup -q -c %{zope_subname}-%{version}
32
33 %build
34 cd %{zope_subname}
35 mkdir docs
36 mv -f HISTORY.txt docs/
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT%{product_dir}
41 cp -af * $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
42
43 %py_comp $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
44 %py_ocomp $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
45
46 find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
47 rm -rf $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}/docs
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post
53 if [ -f /var/lock/subsys/zope ]; then
54         /etc/rc.d/init.d/zope restart >&2
55 fi
56
57 %preun
58
59 %postun
60 if [ -f /var/lock/subsys/zope ]; then
61         /etc/rc.d/init.d/zope restart >&2
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc %{zope_subname}/docs/*
67 %{product_dir}/%{zope_subname}
This page took 0.08348 seconds and 3 git commands to generate.