]> git.pld-linux.org Git - packages/Zope-CMFPlone.git/blob - Zope-CMFPlone.spec
2400041f9910f9310904bb2c98fbe381231f42e2
[packages/Zope-CMFPlone.git] / Zope-CMFPlone.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    CMFPlone
3 Summary:        Free and open source Content Management System based on Zope and CMF
4 Summary:        Darmowy i otwarty system zarz±dzania tre¶ci± oparty na Zope i CMF
5 Name:           Zope-%{zope_subname}
6 Version:        2.0
7 %define         sub_ver beta3
8 Release:        4.%{sub_ver}
9 License:        Zope Public License (ZPL), GPL
10 Group:          Networking/Daemons
11 Source0:        http://dl.sourceforge.net/plone/%{zope_subname}%{version}-%{sub_ver}.tar.gz
12 # Source0-md5:  ae47b12f56eb6e4f86ec7b0650e35552
13 URL:            http://www.plone.org/
14 %pyrequires_eq  python-modules
15 Requires:       Zope-CMF >= 1.4
16 Requires:       Zope >= 2.6.2
17 Requires:       Zope-BTreeFolder2
18 Requires:       Zope-CMFQuickInstallerTool
19 Requires:       Zope-ExternalEditor
20 Requires:       Zope-Formulator
21 Requires:       Zope-GroupUserFolder
22 Requires:       /usr/sbin/installzopeproduct
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25 Obsoletes:      Plone
26
27 %description
28 Plone is a free, open source Content Management System. The focus of
29 Plone is to provide value at every level of an organization. It comes
30 with a workflow engine, pre-configured security and roles, a set of
31 content types and multi-lingual support. There are many developers,
32 writers and testers from all over the world, contributing to Plone
33 everyday. Plone is based on the Content Management Framework.
34
35 %description -l pl
36 Plone jest darmowym systemem zarz±dzania informacj± z otwartym kodem
37 ¼ród³owym. G³ównym celem Plone jest mo¿liwo¶æ dzielenia siê informacj±
38 na ka¿dym poziomie dostêpu. Jest to "silnik" serwisu umo¿liwiaj±cy
39 pracê z wieloma jêzykami, z wstêpn± konfiguracj± uwzglêdniaj±c±
40 zabezpieczenia serwisu. Plone dzia³a w zestawie z CMF, Zope i
41 Pythonem.
42
43 %prep
44 %setup -q -n %{zope_subname}-%{version}-%{sub_ver}
45
46 %build
47 # remove dirs - additional packages!
48 rm -rf {BTreeFolder2,CMFQuickInstallerTool,ExternalEditor,GroupUserFolder,Formulator}
49
50 mkdir docs docs/CMFPlone docs/CMFFormController docs/i18n
51 rm -rf `find . type f -name .cvsignore`
52 mv -f CMFPlone/{CREDITS.txt,ChangeLog,HISTORY.txt,INSTALL.txt,README.txt} docs/CMFPlone
53 mv -f CMFPlone/docs/* docs/CMFPlone
54 mv -f CMFPlone/i18n/ChangeLog docs/i18n
55 rm -rf CMFPlone/i18n/{build.bat,msgfmt.exe}
56 mv -f CMFFormController/{AUTHORS,ChangeLog,README.txt} docs/CMFFormController
57 rm -rf CMFPlone/docs
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
62 cp -af * $RPM_BUILD_ROOT%{_datadir}/%{name}
63
64 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
65 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
66
67 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 for p in CMFPlone CMFActionIcons CMFFormController; do
74         /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
75 done
76 if [ -f /var/lock/subsys/zope ]; then
77         /etc/rc.d/init.d/zope restart >&2
78 fi
79 echo "From /manage interface there should be a 'Select Type to Add' and says Plone Site" >&2
80
81 %postun
82 if [ "$1" = "0" ]; then
83         for p in CMFPlone CMFActionIcons CMFFormController; do
84                 /usr/sbin/installzopeproduct -d $p
85         done
86         if [ -f /var/lock/subsys/zope ]; then
87                 /etc/rc.d/init.d/zope restart >&2
88         fi
89 fi
90
91 %files
92 %defattr(644,root,root,755)
93 %doc docs/*
94 %{_datadir}/%{name}
This page took 0.054566 seconds and 3 git commands to generate.