]> git.pld-linux.org Git - packages/Zope-CMFPhoto.git/blob - Zope-CMFPhoto.spec
- cleanups
[packages/Zope-CMFPhoto.git] / Zope-CMFPhoto.spec
1 %include        /usr/lib/rpm/macros.python
2 %define         zope_subname    CMFPhoto
3 Summary:        CMFPhoto - a Zope product with wrapper objects and a Plone skin for the Photo product
4 Summary(pl):    CMFPhoto - dodatek dla Zope umo¿liwiaj±cy operacje na obiektach i skórach w Plone
5 Name:           Zope-%{zope_subname}
6 Version:        0.2
7 Release:        1
8 License:        GNU
9 Group:          Development/Tools
10 Source0:        http://dl.sourceforge.net/collective/%{zope_subname}-%{version}.tar.gz
11 # Source0-md5:  56f8fe2d79dbeae6d518a1bc1d55db30
12 URL:            http://sourceforge.net/projects/collective/
13 %pyrequires_eq  python-modules
14 Requires:       CMF
15 Requires:       ImageMagick
16 Requires:       Plone
17 Requires:       Zope
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         product_dir     /usr/lib/zope/Products
22
23 %description
24 CMFPhoto is a Zope product with wrapper objects and a Plone skin for
25 the Photo product.
26
27 %description -l pl
28 CMFPhoto jest dodatkiem dla Zope umo¿liwiaj±cym operacje na obiektach
29 i skórach w Plone.
30
31 %prep
32 %setup -q -c %{zope_subname}-%{version}
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 install -d $RPM_BUILD_ROOT%{product_dir}
37
38 cp -af * $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
39
40 %py_comp $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
41 %py_ocomp $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}
42
43 rm -rf $RPM_BUILD_ROOT%{product_dir}/%{zope_subname}/*.txt
44 find $RPM_BUILD_ROOT -type f -name "*.py" -exec rm -rf {} \;;
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %post
50 if [ -f /var/lock/subsys/zope ]; then
51         /etc/rc.d/init.d/zope restart >&2
52 fi
53
54 %postun
55 if [ -f /var/lock/subsys/zope ]; then
56         /etc/rc.d/init.d/zope restart >&2
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %doc %{zope_subname}/*.txt
62 %{product_dir}/%{zope_subname}
This page took 0.053094 seconds and 4 git commands to generate.