]> git.pld-linux.org Git - packages/XdeFactor-ng.git/blob - XdeFactor-ng.spec
- Release: 2
[packages/XdeFactor-ng.git] / XdeFactor-ng.spec
1 #
2 # TODO:
3 # - do defactor-ng_sql.spec with automagical script which
4 #   configure our databases to work with XdeFactor-ng or phpDeFactor-ng
5 # - add user ksiegowy (accounter) to whole distribution ?
6 #
7 %define         _snap   20030212
8 %define         _modules login logout about clients goods invoices means_of_transport stores archive_invoices
9 Summary:        XdeFactor - New Generation of program to make invoices
10 Summary(pl):    XdeFactor - Nowa Generacja programu do fakturowania
11 Name:           XdeFactor-ng
12 Version:        %{_snap}
13 Release:        2
14 License:        GPL
15 Group:          Applications
16 BuildRequires:  glib2-devel
17 BuildRequires:  postgresql-devel
18 BuildRequires:  gtk+2-devel
19 BuildRequires:  pango-devel
20 BuildRequires:  pkgconfig
21 BuildRequires:  freetype-devel
22 Prereq:         /sbin/ldconfig
23 Source0:        http://defactor-ng.gnu.pl/XdeFactor-ng_snapshots/%{name}_%{version}.tar.gz
24 Source1:        %{name}.conf
25 Source2:        %{name}-modules.conf
26 Patch0:         %{name}-includes.patch
27 Patch1:         %{name}-modules-includes.patch
28 Patch2:         %{name}-sharedir.patch
29 URL:            http://defactor-ng.gnu.pl/
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This is nice program to makeing invoices, service clients, service
34 stores, service goods, service means of transport, service archive
35 invoices. It's based on GTK+2 library.
36
37 %description -l pl
38 Ca³kiem przyjemny program do fakturowania, obs³ugi klientów, obs³ugi
39 magazynów, zarz±dzania us³ugami/towarami, zarz±dzania ¶rodkami transportu,
40 zarz±dzania fakturami archiwalnymi. Jest on oparty o bibliotekê GTK+2.
41
42 %prep
43 %setup -q -n xdefactor-ng
44 %patch0 -p1
45 %patch1 -p1
46 %patch2 -p1
47
48 %build
49 cd src
50 %{__make} CC="gcc %{rpmcflags}"
51
52 cd modules
53
54 for i in %{_modules}; do
55  cd $i
56  %{__make} CC="gcc %{rpmcflags}"
57  cd ..
58 done
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/defactor-ng/x/modules/,%{_bindir},%{_datadir}/%{name}/images,%{_libdir}}
63
64 install src/xdefactor-ng $RPM_BUILD_ROOT/%{_bindir}/
65 install conf/logo.jpg $RPM_BUILD_ROOT/%{_datadir}/%{name}/images/
66 #install conf/modules.conf.example $RPM_BUILD_ROOT/%{_datadir}/%{name}/
67 install conf/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/defactor-ng/x/
68 install conf/host.name $RPM_BUILD_ROOT%{_sysconfdir}/defactor-ng/x/
69 cat %{SOURCE1} >> $RPM_BUILD_ROOT%{_sysconfdir}/defactor-ng/x/xdefactor-ng.conf
70 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/defactor-ng/x/modules.conf
71
72
73 cd src/modules
74          
75 for i in %{_modules}; do
76  cd $i
77 for j in *.so; do
78   install $j $RPM_BUILD_ROOT%{_libdir}/
79  done
80  install *.conf $RPM_BUILD_ROOT%{_sysconfdir}/defactor-ng/x/modules/
81  cd ..
82 done
83
84 %post -p /sbin/ldconfig
85
86 %postun -p /sbin/ldconfig
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS README conf/modules.conf.example
94 %attr(755,root,root) %{_bindir}/xdefactor-ng
95 %{_datadir}/%{name}/images/logo.jpg
96 %{_sysconfdir}/defactor-ng/x/*.conf
97 %{_sysconfdir}/defactor-ng/x/host.name
98 %{_sysconfdir}/defactor-ng/x/modules/*.conf
99 %{_libdir}/libxdef_*.so
This page took 0.029728 seconds and 4 git commands to generate.