]> git.pld-linux.org Git - packages/XaoS.git/blob - XaoS.spec
- updated to 3.1pre5, fixed svga and ggi drivers, moved to /usr, cleanups
[packages/XaoS.git] / XaoS.spec
1 #
2 # Conditional build:
3 #
4 # _without_aa           - without aalib output support
5 # _without_ggi          - without ggi output support
6 # _without_ncurses      - without ncurses output support
7 # _without_svga         - without svga output support
8 #
9 %ifnarch %{ix86} alpha
10 %define _without_svgalib 1
11 %endif
12 Summary:        A fast, portable real-time interactive fractal zoomer
13 Summary(pl):    Szybki, przeno¶ny i interaktywny explorator fraktali
14 Name:           XaoS
15 Version:        3.1
16 %define pre     pre5
17 Release:        0.%{pre}.1
18 License:        GPL
19 Group:          X11/Applications
20 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/xaos/%{name}-%{version}%{pre}.tar.gz
21 Source1:        %{name}.desktop
22 Source2:        %{name}.png
23 Patch0:         %{name}-nosuid.patch
24 Patch1:         %{name}-brokenasm.patch
25 Patch2:         %{name}-ggi-fix.patch
26 Patch3:         %{name}-svga-fix.patch
27 URL:            http://xaos.theory.org/
28 BuildRequires:  XFree86-devel
29 %{!?_without_aa:BuildRequires:          aalib-devel}
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 %{!?_without_ggi:BuildRequires:         libggi-devel}
33 BuildRequires:  libpng-devel
34 %{!?_without_ncurses:BuildRequires:     ncurses-devel}
35 %{!?_without_svga:BuildRequires:        svgalib-devel}
36 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 XaoS is a fast portable real-time interactive fractal zoomer. It
40 supports outputs such as X11, aalib, ncurses and SVGAlib. It displays
41 the Mandelbrot set (among other escape time fractals) and allows you
42 zoom smoothly into the fractal. Various coloring modes are provided
43 for both the points inside and outside the selected set. In addition,
44 switching between Julia and Mandelbrot fractal types is provided. The
45 first version was a poorly written Mandelbrot view by Thomas later
46 modified by Jan to support high frame-rate zooming. Other additions
47 were later made including autopilot (for those of you without drivers
48 licenses), palette changing, PNG saving, and fractal inversion.
49
50 %description -l pl
51 XaoS jest szybkim, przeno¶nym i interaktywnym exploratorem fraktali.
52 Efekty jego dzia³ania mo¿na ogl±daæ z u¿yciem drajwerów X11, aalib,
53 ncurses oraz SVGAlib. XaoS wy¶wietla zbiór Mandelbrota (i nie tylko) i
54 pozwala na p³ynne powiêkszanie/pomniejszanie widocznego zakresu.
55 Dostêpne s± ró¿ne rodzaje kolorowania dla punktów w wybranym zbiorze,
56 jak i poza nim. Dodatkowo, mo¿liwe jest prze³±czanie miêdzy fraktalem
57 Mandelbrota, a odpowiadaj±cym mu fraktalem Julii (i w drug± stronê).
58 Pierwsza wersja (Tomasa) by³a kiepsko napisanym wy¶wietlaczem zbioru
59 Mandelbrota. Zosta³a zmodyfikowana przez Jana aby umo¿liwiaæ szybkie
60 powiêkszanie. Inne zmiany, zrobione pó¼niej to autopilot, zmiana
61 palety, zapisywanie PNG i inwersja fraktali.
62
63 %prep
64 %setup -q -n %{name}-%{version}%{pre}
65 %patch0 -p1
66 %patch1 -p1
67 %patch2 -p1
68 %patch3 -p1
69
70 %build
71 cp -f /usr/share/automake/config.* .
72 %{__autoconf}
73 %configure \
74         --with-x \
75         --with-x11-driver=yes \
76         %{?_without_aa:         --with-aa-driver=no} \
77         %{?_without_ggi:        --with-ggi-driver=no} \
78         %{?_without_ncurses:    --with-curses-driver=no} \
79         %{?_without_svga:       --with-svga-driver=no}
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT{%{_infodir},%{_applnkdir},%{_pixmapsdir}} \
86         $RPM_BUILD_ROOT%{_datadir}/locale/{hu,es,fr,cs,de}/LC_MESSAGES
87
88 %{__make} install \
89         datadir=$RPM_BUILD_ROOT%{_datadir} \
90         bindir=$RPM_BUILD_ROOT%{_bindir} \
91         mandir=$RPM_BUILD_ROOT%{_mandir} \
92         infodir=$RPM_BUILD_ROOT%{_infodir} \
93         LOCALEDIR=$RPM_BUILD_ROOT%{_datadir}/locale
94
95 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}
96 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
97
98 %find_lang xaos
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post
104 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
105
106 %postun
107 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
108
109 %files -f xaos.lang
110 %defattr(644,root,root,755)
111 %doc TODO doc/{ANNOUNCE,AUTHORS,PROBLEMS,README{,.bugs,.ggi},SPONSORS}
112 %attr(755,root,root) %{_bindir}/xaos
113 %dir %{_datadir}/XaoS
114 %dir %{_datadir}/XaoS/catalogs
115 %lang(cs) %{_datadir}/XaoS/catalogs/cesky.cat
116 %lang(de) %{_datadir}/XaoS/catalogs/deutsch.cat
117 %{_datadir}/XaoS/catalogs/english.cat
118 %lang(es) %{_datadir}/XaoS/catalogs/espanhol.cat
119 %lang(fr) %{_datadir}/XaoS/catalogs/francais.cat
120 %lang(hu) %{_datadir}/XaoS/catalogs/magyar.cat
121 %{_datadir}/XaoS/examples
122 %{_datadir}/XaoS/help
123 %{_datadir}/XaoS/tutorial
124 %{_mandir}/man6/*
125 %{_infodir}/*.info*
126 %{_pixmapsdir}/XaoS.png
127 %{_applnkdir}/XaoS.desktop
This page took 0.075224 seconds and 4 git commands to generate.