]> git.pld-linux.org Git - packages/X11-driver-firegl.git/blob - X11-driver-firegl.spec
- missing BuildRequires
[packages/X11-driver-firegl.git] / X11-driver-firegl.spec
1 #
2 # Conditional build:
3 # _without_dist_kernel
4 #
5
6 %define         _min_xfree      4.3.0
7 %define         _gcc_ver        %(gcc -dumpversion)
8
9 Summary:        Linux Drivers for ATI graphics accelerators
10 Summary(pl):    Sterowniki do akceleratorów graficznych ATI
11 Name:           XFree86-driver-firegl
12 Version:        3.7.0
13 Release:        1
14 License:        ATI Binary (parts are GPL)
15 Vendor:         ATI
16 Group:          X11/XFree86
17 Source0:        http://www2.ati.com/drivers/linux/fglrx-glc22-%{_min_xfree}-%{version}.i386.rpm
18 # Source0-md5:  7dd12340a2b8525b3a9fa1f310e06141
19 Patch0:         firegl-panel.patch
20 Patch1:         XFree86-driver-firegl-kh.patch  
21 URL:            http://www.ati.com/support/drivers/linux/radeon-linux.html
22 BuildRequires:  cpio
23 %{!?_without_dist_kernel:BuildRequires:         kernel-headers >= 2.2.0 }
24 BuildRequires: rpm-utils
25 BuildRequires: qt-devel
26 BuildRequires: kernel-sources
27 BuildRequires: XFree86-OpenGL-devel
28 BuildRequires: xrender-devel
29 BuildRequires: xft-devel
30 Requires:       XFree86-Xserver
31 Requires:       XFree86-libs >= %{_min_xfree}
32 Requires:       XFree86-modules >= %{_min_xfree}
33 %{!?_without_dist_kernel:Requires:      kernel-video-firegl = %{version} }
34 Provides:       XFree86-OpenGL-core = %{_min_xfree}
35 Obsoletes:      Mesa
36 Obsoletes:      XFree86-OpenGL-libGL
37 Provides:       XFree86-OpenGL-libGL
38 ExclusiveArch:  i586 i686 athlon
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _noautoreqdep   libGL.so.1.2
42
43 %define         _prefix         /usr/X11R6
44 %define         _mandir         %{_prefix}/man
45
46 %description
47 Display driver files for the ATI Radeon 8500, 9700, Mobility M9 and
48 the FireGL 8700/8800, E1, Z1/X1 graphics accelerators. This package
49 provides 2D display drivers and hardware accelerated OpenGL.
50
51 %description -l pl
52 Sterowniki do kart graficznych ATI Radeon 8500, 9700, Mobility M9 oraz
53 graficznych akceleratorów FireGL 8700/8800, E1, Z1/X1. Pakiet
54 dostarcza sterowniki obs³uguj±ce wy¶wietlanie 2D oraz sprzêtowo
55 akcelerowany OpenGL.
56
57 %package -n kernel-video-firegl
58 Summary:        ATI kernel module for FireGL support
59 Summary(pl):    Modu³ j±dra oferuj±cy wsparcie dla ATI FireGL
60 Release:        %{release}@%{_kernel_ver_str}
61 License:        ATI
62 Vendor:         ATI
63 Group:          Base/Kernel
64 %{!?_without_dist_kernel:%requires_releq_kernel_up}
65 PreReq:         modutils >= 2.3.18-2
66 Requires(post,postun):  /sbin/depmod
67
68 %description -n kernel-video-firegl
69 ATI kernel module for FireGL support.
70
71 %description -n kernel-video-firegl -l pl
72 Modu³ j±dra oferuj±cy wsparcie dla ATI FireGL.
73
74 %package -n kernel-smp-video-firegl
75 Summary:        ATI kernel module for FireGL support
76 Summary(pl):    Modu³ j±dra oferuj±cy wsparcie dla ATI FireGL
77 Release:        %{release}@%{_kernel_ver_str}
78 License:        ATI
79 Vendor:         ATI
80 Group:          Base/Kernel
81 %{!?_without_dist_kernel:%requires_releq_kernel_smp}
82 PreReq:         modutils >= 2.3.18-2
83 Requires(post,postun):  /sbin/depmod
84
85 %description -n kernel-smp-video-firegl
86 ATI kernel module for FireGL support.
87
88 %description -n kernel-smp-video-firegl -l pl
89 Modu³ j±dra oferuj±cy wsparcie dla ATI FireGL.
90
91 %prep
92 %setup -q -c -T
93 rpm2cpio %{SOURCE0} | cpio -i -d
94 bzip2 -d -v usr/X11R6/bin/*.bz2
95 mkdir panel_src
96 tar -xzf usr/src/ATI/fglrx_panel_sources.tgz -C panel_src
97 %patch0 -p1
98 %{!?_without_dist_kernel:%patch1 -p1}
99
100 %build
101 cd lib/modules/fglrx/build_mod/
102 cp make.sh make.sh.org && rm -f make.sh
103 sed -e 's#gcc#%{kgcc}#g' -e 's#`id -u` -ne 0#`id -u` -ne `id -u`#g' make.sh.org > make.sh
104 chmod 755 make.sh
105 ./make.sh \
106         SMP=1
107 mv fglrx.ko fglrx-smp.ko
108 ./make.sh clean
109 ./make.sh
110 cd ../../../../panel_src
111
112 #%{__make} \
113 #       MK_QTDIR=/usr \
114 #       LIBQT_DYN=qt-mt
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/X11/extensions} \
119         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc/
120
121 install lib/modules/fglrx/build_mod/fglrx.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc
122 install lib/modules/fglrx/build_mod/fglrx-smp.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc
123
124 install usr/X11R6/bin/{fgl_glxgears,fglrxconfig,fglrxinfo} $RPM_BUILD_ROOT%{_bindir}
125 #install panel_src/{fireglcontrol.qt3.gcc%{_gcc_ver},fireglcontrol} $RPM_BUILD_ROOT%{_bindir}
126 cp -r usr/X11R6/lib/* $RPM_BUILD_ROOT%{_libdir}/
127
128 cd $RPM_BUILD_ROOT%{_libdir}
129 ln -s libGL.so.* libGL.so
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %post   -n kernel-video-firegl
138 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver} }%{_kernel_ver}
139
140 %postun -n kernel-video-firegl
141 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver} }%{_kernel_ver}
142
143 %post   -n kernel-smp-video-firegl
144 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver}smp }%{_kernel_ver}smp
145
146 %postun -n kernel-smp-video-firegl
147 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver}smp }%{_kernel_ver}smp
148
149 %files
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/*
152 %attr(755,root,root) %{_libdir}/lib*.so*
153 %attr(755,root,root) %{_libdir}/modules/*/*.so
154 %attr(755,root,root) %{_libdir}/modules/*/*.o
155 %attr(644,root,root) %{_libdir}/modules/*/*.a
156 %attr(755,root,root) /usr/X11R6/lib/libfglrx_gamma.a
157
158 %files -n kernel-video-firegl
159 %defattr(644,root,root,755)
160 /lib/modules/%{_kernel_ver}/misc/*.ko*
161
162 %files -n kernel-smp-video-firegl
163 %defattr(644,root,root,755)
164 /lib/modules/%{_kernel_ver}smp/misc/*.ko*
This page took 0.050319 seconds and 4 git commands to generate.