]> git.pld-linux.org Git - packages/X11-driver-firegl.git/blob - X11-driver-firegl.spec
9312480d8c303d3925d06e790a81b44e88d5be5c
[packages/X11-driver-firegl.git] / X11-driver-firegl.spec
1 #
2 # Conditional build:
3 # _without_dist_kernel
4 #
5 # TODO:
6 # - kernel modules (SMP)
7
8 Summary:        Linux Drivers for ATI graphics accelerators
9 Summary(pl):    Sterowniki do akceleratorów graficznych ATI
10 Name:           XFree86-driver-firegl
11 Version:        3.2.8
12 Release:        1
13 License:        ATI Binary
14 Vendor:         ATI
15 Group:          X11/XFree86
16 URL:            http://www.ati.com/support/drivers/linux/radeon-linux.html
17 Source0:        http://www2.ati.com/drivers/firegl/fglrx-glc22-4.3.0-%{version}.i586.rpm
18 # Source0-md5:  824aaaafd4b4867c2456860ea5eff5ec
19 Patch0:         firegl-panel.patch
20 Patch1:         XFree86-driver-firegl-kh.patch  
21 BuildRequires:  cpio
22 %{!?_without_dist_kernel:BuildRequires:         kernel-headers >= 2.2.0 }
23 BuildRequires:  rpm-utils
24 Requires:       XFree86-Xserver
25 Requires:       XFree86-libs >= 4.3.0
26 Requires:       XFree86-modules >= 4.3.0
27 Requires:       kernel-video-firegl = %{version}
28 Provides:       XFree86-OpenGL-core
29 Obsoletes:      Mesa
30 Obsoletes:      XFree86-OpenGL-libGL
31 Provides:       XFree86-OpenGL-libGL
32 ExclusiveArch:  i586 i686 athlon
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _noautoreqdep   libGL.so.1.2
36
37 %define         _prefix         /usr/X11R6
38 %define         _mandir         %{_prefix}/man
39
40 %description
41 Display driver files for the ATI Radeon 8500, 9700, Mobility M9 and
42 the FireGL 8700/8800, E1, Z1/X1 graphics accelerators. This package
43 provides 2D display drivers and hardware accelerated OpenGL.
44
45 %description -l pl
46 Sterowniki do kart graficznych ATI Radeon 8500, 9700, Mobility M9 oraz
47 graficznych akceleratorów FireGL 8700/8800, E1, Z1/X1. Pakiet
48 dostarcza sterowniki obs³uguj±ce wy¶wietlanie 2D oraz sprzêtowo
49 akcelerowany OpenGL.
50
51 %package -n kernel-video-firegl
52 Summary:        ATI kernel module for FireGL support
53 Summary(pl):    Modu³ j±dra oferuj±cy wsparcie dla ATI FireGL
54 Release:        %{release}@%{_kernel_ver_str}
55 License:        ATI
56 Vendor:         ATI
57 Group:          Base/Kernel
58 %{!?_without_dist_kernel:%requires_releq_kernel_up}
59 PreReq:         modutils >= 2.3.18-2
60 Requires(post,postun):  /sbin/depmod
61
62 %description -n kernel-video-firegl
63 ATI kernel module for FireGL support.
64
65 %description -n kernel-video-firegl -l pl
66 Modu³ j±dra oferuj±cy wsparcie dla ATI FireGL.
67
68 %prep
69 %setup -q -c -T
70 rpm2cpio %{SOURCE0} | cpio -i -d
71 bzip2 -d -v usr/X11R6/bin/*.bz2
72 mkdir panel_src
73 tar -xzf usr/src/ATI/fglrx_panel_sources.tgz -C panel_src
74 %patch0 -p1
75 %{!?_without_dist_kernel:%patch1 -p1}
76
77 %build
78 cd lib/modules/fglrx/build_mod/
79 cp make.sh make.sh.org && rm -f make.sh
80 sed -e 's#gcc#%{kgcc}#g' -e 's#`id -u` -ne 0#`id -u` -ne `id -u`#g' make.sh.org > make.sh
81 chmod 755 make.sh
82 ./make.sh
83 cd ../../../../panel_src
84 %{__make} MK_QTDIR=/usr \
85         LIBQT_DYN=qt-mt
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/X11/extensions}
90 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/
91
92 install lib/modules/fglrx/build_mod/fglrx.o             $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/
93
94 install usr/X11R6/bin/{fgl_glxgears,fglrxconfig,fglrxinfo} $RPM_BUILD_ROOT%{_bindir}
95 install panel_src/{fireglcontrol.qt3.gcc3.3.1,fireglcontrol} $RPM_BUILD_ROOT%{_bindir}
96 cp -r usr/X11R6/lib/* $RPM_BUILD_ROOT%{_libdir}/
97
98 cd $RPM_BUILD_ROOT%{_libdir}
99 ln -s libGL.so.* libGL.so
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %post   -n kernel-video-firegl
108 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver} }%{_kernel_ver}
109
110 %postun -n kernel-video-firegl
111 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver} }%{_kernel_ver}
112
113 %files
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_bindir}/*
116 %attr(755,root,root) %{_libdir}/lib*.so*
117 %attr(755,root,root) %{_libdir}/modules/*/*.so
118 %attr(755,root,root) %{_libdir}/modules/*/*.o
119 %attr(644,root,root) %{_libdir}/modules/*/*.a
120 %attr(755,root,root) /usr/X11R6/lib/libfglrx_gamma.a
121
122 %files -n kernel-video-firegl
123 %defattr(644,root,root,755)
124 /lib/modules/%{_kernel_ver}/misc/*.o*
This page took 0.049091 seconds and 3 git commands to generate.