]> git.pld-linux.org Git - packages/X11-driver-firegl.git/blob - X11-driver-firegl.spec
- 3.7.0
[packages/X11-driver-firegl.git] / X11-driver-firegl.spec
1 #
2 # Conditional build:
3 # _without_dist_kernel
4 #
5
6 %define         _min_xfree      4.3.0
7 %define         _gcc_ver        %(gcc -dumpversion)
8
9 Summary:        Linux Drivers for ATI graphics accelerators
10 Summary(pl):    Sterowniki do akceleratorów graficznych ATI
11 Name:           XFree86-driver-firegl
12 Version:        3.7.0
13 Release:        1
14 License:        ATI Binary (parts are GPL)
15 Vendor:         ATI
16 Group:          X11/XFree86
17 Source0:        http://www2.ati.com/drivers/linux/fglrx-glc22-%{_min_xfree}-%{version}.i386.rpm
18 # Source0-md5:  7dd12340a2b8525b3a9fa1f310e06141
19 Patch0:         firegl-panel.patch
20 Patch1:         XFree86-driver-firegl-kh.patch  
21 URL:            http://www.ati.com/support/drivers/linux/radeon-linux.html
22 BuildRequires:  cpio
23 %{!?_without_dist_kernel:BuildRequires:         kernel-headers >= 2.2.0 }
24 BuildRequires:  rpm-utils
25 Requires:       XFree86-Xserver
26 Requires:       XFree86-libs >= %{_min_xfree}
27 Requires:       XFree86-modules >= %{_min_xfree}
28 %{!?_without_dist_kernel:Requires:      kernel-video-firegl = %{version} }
29 Provides:       XFree86-OpenGL-core = %{_min_xfree}
30 Obsoletes:      Mesa
31 Obsoletes:      XFree86-OpenGL-libGL
32 Provides:       XFree86-OpenGL-libGL
33 ExclusiveArch:  i586 i686 athlon
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _noautoreqdep   libGL.so.1.2
37
38 %define         _prefix         /usr/X11R6
39 %define         _mandir         %{_prefix}/man
40
41 %description
42 Display driver files for the ATI Radeon 8500, 9700, Mobility M9 and
43 the FireGL 8700/8800, E1, Z1/X1 graphics accelerators. This package
44 provides 2D display drivers and hardware accelerated OpenGL.
45
46 %description -l pl
47 Sterowniki do kart graficznych ATI Radeon 8500, 9700, Mobility M9 oraz
48 graficznych akceleratorów FireGL 8700/8800, E1, Z1/X1. Pakiet
49 dostarcza sterowniki obs³uguj±ce wy¶wietlanie 2D oraz sprzêtowo
50 akcelerowany OpenGL.
51
52 %package -n kernel-video-firegl
53 Summary:        ATI kernel module for FireGL support
54 Summary(pl):    Modu³ j±dra oferuj±cy wsparcie dla ATI FireGL
55 Release:        %{release}@%{_kernel_ver_str}
56 License:        ATI
57 Vendor:         ATI
58 Group:          Base/Kernel
59 %{!?_without_dist_kernel:%requires_releq_kernel_up}
60 PreReq:         modutils >= 2.3.18-2
61 Requires(post,postun):  /sbin/depmod
62
63 %description -n kernel-video-firegl
64 ATI kernel module for FireGL support.
65
66 %description -n kernel-video-firegl -l pl
67 Modu³ j±dra oferuj±cy wsparcie dla ATI FireGL.
68
69 %package -n kernel-smp-video-firegl
70 Summary:        ATI kernel module for FireGL support
71 Summary(pl):    Modu³ j±dra oferuj±cy wsparcie dla ATI FireGL
72 Release:        %{release}@%{_kernel_ver_str}
73 License:        ATI
74 Vendor:         ATI
75 Group:          Base/Kernel
76 %{!?_without_dist_kernel:%requires_releq_kernel_smp}
77 PreReq:         modutils >= 2.3.18-2
78 Requires(post,postun):  /sbin/depmod
79
80 %description -n kernel-smp-video-firegl
81 ATI kernel module for FireGL support.
82
83 %description -n kernel-smp-video-firegl -l pl
84 Modu³ j±dra oferuj±cy wsparcie dla ATI FireGL.
85
86 %prep
87 %setup -q -c -T
88 rpm2cpio %{SOURCE0} | cpio -i -d
89 bzip2 -d -v usr/X11R6/bin/*.bz2
90 mkdir panel_src
91 tar -xzf usr/src/ATI/fglrx_panel_sources.tgz -C panel_src
92 %patch0 -p1
93 %{!?_without_dist_kernel:%patch1 -p1}
94
95 %build
96 cd lib/modules/fglrx/build_mod/
97 cp make.sh make.sh.org && rm -f make.sh
98 sed -e 's#gcc#%{kgcc}#g' -e 's#`id -u` -ne 0#`id -u` -ne `id -u`#g' make.sh.org > make.sh
99 chmod 755 make.sh
100 ./make.sh \
101         SMP=1
102 mv fglrx.ko fglrx-smp.ko
103 ./make.sh clean
104 ./make.sh
105 cd ../../../../panel_src
106
107 #%{__make} \
108 #       MK_QTDIR=/usr \
109 #       LIBQT_DYN=qt-mt
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir}/X11/extensions} \
114         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc/
115
116 install lib/modules/fglrx/build_mod/fglrx.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc
117 install lib/modules/fglrx/build_mod/fglrx-smp.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc
118
119 install usr/X11R6/bin/{fgl_glxgears,fglrxconfig,fglrxinfo} $RPM_BUILD_ROOT%{_bindir}
120 #install panel_src/{fireglcontrol.qt3.gcc%{_gcc_ver},fireglcontrol} $RPM_BUILD_ROOT%{_bindir}
121 cp -r usr/X11R6/lib/* $RPM_BUILD_ROOT%{_libdir}/
122
123 cd $RPM_BUILD_ROOT%{_libdir}
124 ln -s libGL.so.* libGL.so
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %post   -n kernel-video-firegl
133 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver} }%{_kernel_ver}
134
135 %postun -n kernel-video-firegl
136 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver} }%{_kernel_ver}
137
138 %post   -n kernel-smp-video-firegl
139 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver}smp }%{_kernel_ver}smp
140
141 %postun -n kernel-smp-video-firegl
142 /sbin/depmod -a %{!?_without_dist_kernel:-F /boot/System.map-%{_kernel_ver}smp }%{_kernel_ver}smp
143
144 %files
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_bindir}/*
147 %attr(755,root,root) %{_libdir}/lib*.so*
148 %attr(755,root,root) %{_libdir}/modules/*/*.so
149 %attr(755,root,root) %{_libdir}/modules/*/*.o
150 %attr(644,root,root) %{_libdir}/modules/*/*.a
151 %attr(755,root,root) /usr/X11R6/lib/libfglrx_gamma.a
152
153 %files -n kernel-video-firegl
154 %defattr(644,root,root,755)
155 /lib/modules/%{_kernel_ver}/misc/*.ko*
156
157 %files -n kernel-smp-video-firegl
158 %defattr(644,root,root,755)
159 /lib/modules/%{_kernel_ver}smp/misc/*.ko*
This page took 0.192833 seconds and 3 git commands to generate.