]> git.pld-linux.org Git - packages/WindowMaker.git/blob - WindowMaker.spec
- added singleclick patch
[packages/WindowMaker.git] / WindowMaker.spec
1 %define         extraver        0.1
2
3 Summary:        NeXT-alike window manager
4 Summary(fr):    Gestionnaire de fenêtres avec le look NeXT
5 Summary(pl):    Mened¿er okien w stylu NeXT
6 Name:           WindowMaker
7 Version:        0.60.0
8 Release:        2
9 Group:          X11/Window Managers
10 Group(pl):      X11/Zarz±dcy Okien
11 Copyright:      GPL
12 Source0:        ftp://ftp.windowmaker.org/pub/beta/srcs/%{name}-%{version}.tar.bz2
13 Source1:        ftp://windowmaker.org/pub/WindowMaker-data.tar.gz
14 Source2:        ftp://ftp.windowmaker.org/pub/beta/srcs/%{name}-extra-%{extraver}.tar.gz
15 Patch0:         WindowMaker-CFLAGS.patch
16 Patch1:         WindowMaker-wmconfig.patch
17 Patch2:         WindowMaker-a_macro.patch
18 Patch3:         WindowMaker-pixmaps.patch
19 Patch4:         WindowMaker-shared.patch
20 Patch5:         WindowMaker-areas.patch
21 Patch6:         WindowMaker-runinst.patch
22 Patch7:         WindowMaker-ru.po.patch
23 Patch8:         Windowmaker-WINGs.h.patch
24 Patch9:         Windowmaker-singleclick.patch
25 URL:            http://www.windowmaker.org/
26 BuildPrereq:    libPropList-devel >= 0.8.3
27 BuildPrereq:    xpm-devel
28 BuildPrereq:    libpng-devel
29 BuildPrereq:    libjpeg-devel >= 6b
30 BuildPrereq:    libtiff-devel
31 BuildPrereq:    libungif-devel
32 BuildPrereq:    gettext
33 Requires:       wmconfig
34 Requires:       /lib/cpp
35 Requires:       %{name}-libs = %{version}
36 BuildRoot:      /tmp/%{name}-%{version}-root
37
38 %define         _prefix         /usr/X11R6
39 %define         _mandir         %{_prefix}/man
40 %define         _sysconfdir     /etc/X11
41
42 %description
43 WindowMaker is a window manager designed to emulate the look and feel of
44 part of the NEXTSTEP(tm) GUI. It's supposed to be fast, relatively small,
45 feature rich and easy to configure, with a simple and elegant appearance
46 borrowed from NEXTSTEP(tm).
47
48 %description -l fr
49 WindowMaker est un "Window Manager" conçu pour émuler l'apparence et la
50 sensation de l'interface graphique NeXTSTEP(tm). Il est suposé être rapide,
51 relativement petit, facile a configurer, extremement complet et avec
52 l'apparence simple et élégante empruntée a NeXTSTEP(tm).
53
54 %description -l pl
55 WindowMaker jest mened¿erem okien przypominaj±cy wygl±dem i wygod± obs³ugi
56 interfejs systemu NeXTSTEP(tm). Jest szybki, stosunkowo ma³y, o du¿ych
57 mo¿liwo¶ciach i ³atwy w konfiguracji. Konfiguruje siê go myszk±, za pomoc±
58 programu WPrefs wchodz±cego w sk³ad tego pakietu.
59
60 %package libs
61 Summary:        WindowMaker shared libraries
62 Summary(pl):    Biblioteki wspó³dzielone WindowMakera
63 Group:          Libraries
64 Group(pl):      Biblioteki
65
66 %description libs
67 This package contains shared libraries for run WindowMaker.
68
69 %description libs -l pl
70 Ten pakiet zawiera biblioteki wspó³dzielone niezbêdne do pracy
71 mened¿era okien WindowMaker.
72
73 %package devel
74 Summary:        WindowMaker libraries
75 Summary(fr):    Librairies de WindowMaker
76 Summary(pl):    Biblioteki WindowMakera
77 Group:          Development/Libraries
78 Group(pl):      Programowanie/Biblioteki
79 Requires:       %{name}-libs = %{version}
80
81 %description devel
82 This package contains libraries for building WindowMaker-enhanced
83 applications.
84
85 %description devel -l fr
86 Ce paquet contient des librairies pour faire des applications mise en valeur
87 par WindowMaker.
88
89 %description devel -l pl
90 Ten pakiet zawiera pliki nag³ówkowe i biblioteki niezbêdne do tworzenia
91 aplikacji wykorzystuj±cych mo¿liwo¶ci mened¿era okien WindowMaker.
92
93 %package static
94 Summary:        WindowMaker static libraries
95 Summary(pl):    Biblioteki statyczne WindowMakera
96 Group:          Development/Libraries
97 Group(pl):      Programowanie/Biblioteki
98 Requires:       %{name}-devel = %{version}
99
100 %description static
101 This package contains static libraries for building WindowMaker-enhanced
102 applications.
103
104 %description static -l pl
105 Ten pakiet zawiera statyczne biblioteki niezbêdne do tworzenia
106 aplikacji wykorzystuj±cych mo¿liwo¶ci mened¿era okien WindowMaker.
107
108 %prep
109 %setup -q -a 1 -a 2
110
111 %patch0 -p1
112 %patch1 -p0
113 %patch2 -p0
114 %patch3 -p1
115 %patch4 -p1
116 %patch5 -p1
117 %patch6 -p1
118 %patch7 -p0
119 %patch8 -p1
120 %patch9 -p1
121
122 %build
123 autoconf
124 LINGUAS="cs de el es fi fr gl hr it ja ko nl no pl pt ro ru  \
125          se sk tr zh_CN zh_TW.Big5" ; export LINGUAS
126 CPP_PATH="/lib/cpp" ; export CPP_PATH
127
128 %configure \
129         --sysconfdir=%{_sysconfdir} \
130         --with-nlsdir=%{_datadir}/locale \
131         --enable-kanji \
132         --enable-sound \
133         --enable-gnome \
134         --disable-debug \
135         --enable-superfluous \
136         --enable-newstyle \
137         --enable-kde \
138         --enable-shared \
139         --enable-static \
140         --enable-usermenu
141
142 touch WindowMaker/Defaults/W*.in
143
144 make \
145         LINGUAS="cs de el es fi fr gl hr it ja ko nl no pl pt ro ru  \
146                 se sk tr zh_CN zh_TW.Big5" \
147         CFLAGS="$RPM_OPT_FLAGS" \
148         LDFLAGS="-s" 
149
150 autoconf
151 cd %{name}-extra-%{extraver}
152 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
153 ./configure %{_target_platform} \
154         --prefix=%{_prefix} \
155         --mandir=%{_mandir} \
156         --with-nlsdir=%{_datadir}/locale \
157         --with-iconsdir=%{_datadir}/pixmaps
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161 install -d $RPM_BUILD_ROOT%{_datadir}/pixmaps
162
163 make install \
164         LINGUAS="cs de el es fi fr gl hr it ja ko nl no pl pt ro ru  \
165                 se sk tr zh_CN zh_TW.Big5" \
166         DESTDIR=$RPM_BUILD_ROOT 
167
168 install util/bughint $RPM_BUILD_ROOT%{_bindir}
169
170 install WindowMaker-data/pixmaps/* $RPM_BUILD_ROOT%{_datadir}/pixmaps
171
172 (cd %{name}-extra-%{extraver};
173 make DESTDIR=$RPM_BUILD_ROOT install )
174
175 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*so.*.*
176
177 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
178         AUTHORS BUGFORM BUGS ChangeLog FAQ NEWS README
179
180 %find_lang %{name}
181 %find_lang WPrefs
182 cat WPrefs.lang >> %{name}.lang
183
184 %post   -p /sbin/ldconfig
185 %postun -p /sbin/ldconfig
186
187 %clean
188 rm -r $RPM_BUILD_ROOT
189
190 %files -f %{name}.lang
191 %defattr(644,root,root,755)
192 %doc AUTHORS.gz BUGFORM.gz BUGS.gz 
193 %doc ChangeLog.gz FAQ.gz NEWS.gz README.gz
194
195 %dir /etc/X11/WindowMaker
196 %config %verify(not size mtime md5) %{_sysconfdir}/WindowMaker/*
197
198 %{_mandir}/man1/*
199
200 %{_datadir}/pixmaps/*
201
202 %attr(755,root,root) %{_bindir}/geticonset
203 %attr(755,root,root) %{_bindir}/getstyle
204 %attr(755,root,root) %{_bindir}/seticons
205 %attr(755,root,root) %{_bindir}/setstyle
206 %attr(755,root,root) %{_bindir}/wdwrite
207 %attr(755,root,root) %{_bindir}/wkdemenu.pl
208 %attr(755,root,root) %{_bindir}/wm-oldmenu2new
209 %attr(755,root,root) %{_bindir}/wmaker
210 %attr(755,root,root) %{_bindir}/wmaker.inst
211 %attr(755,root,root) %{_bindir}/wmsetbg
212 %attr(755,root,root) %{_bindir}/wsetfont
213 %attr(755,root,root) %{_bindir}/wxcopy
214 %attr(755,root,root) %{_bindir}/wxpaste
215
216 %{_datadir}/WindowMaker
217
218 %dir %{_prefix}/GNUstep
219 %dir %{_prefix}/GNUstep/Apps
220 %dir %{_prefix}/GNUstep/Apps/WPrefs.app
221
222 %attr(755,root,root) %{_prefix}/GNUstep/Apps/WPrefs.app/WPrefs
223
224 %{_prefix}/GNUstep/Apps/WPrefs.app/tiff
225 %{_prefix}/GNUstep/Apps/WPrefs.app/xpm
226 %{_prefix}/GNUstep/Apps/WPrefs.app/WPrefs.tiff
227 %{_prefix}/GNUstep/Apps/WPrefs.app/WPrefs.xpm
228
229 %files libs
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_libdir}/lib*.so.*.*
232 %{_datadir}/WINGs
233
234 %files devel
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_libdir}/lib*.so
237 %attr(755,root,root) %{_bindir}/get-wraster-flags
238 %{_includedir}/*.h
239 %{_libdir}/lib*.la
240
241 %files static
242 %defattr(644,root,root,755)
243 %{_libdir}/lib*.a
244
245 %changelog
246 * Sat Jul 10 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
247   [0.60.0-2]
248 - aadde Windowmaker-WINGs.h.patch which fix probems compiling WM on system
249   without installed WindowMaker-devel,
250 - fix: include WPrefs .mo files.
251
252 * Fri Jun 25 1999 Piotr Czerwiñski <pius@pld.org.pl> 
253   [0.60.0-1]
254 - updated to 0.60.0,
255 - added using more rpm macros,
256 - added %{name}-ru.po.patch,
257 - added --enable-usermenu to ./configure options.
258
259 * Mon Jun 07 1999 Jan Rêkorajski <baggins@pld.org.pl>
260   [0.53.0-4]
261 - fixed --prefix
262 - added find_lang macro
263
264 * Sun May  9 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
265   [0.53.0-3]
266 - now package is FHS 2.0 compliant.
267
268 * Wed Apr 28 1999 Artur Frysiak <wiget@pld.org.pl>
269   [0.53.0-2]
270 - added WindowMaker-extra (more themes)
271 - added areas and runinst patches from RH 6.0
272
273 * Mon Apr 19 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
274   [0.52.0-1]
275 - recompiles on new rpm,
276 - more BuildPrereq (libjpg-deve, xpm-devel, libpng-devel, libtiff-devel).
277
278 * Fri Mar 12 1999 Artur Frysiak <wiget@pld.org.pl>
279   [0.51.2-1]
280 - added more locale (dk and zh_TW.Big5)
281 - removed WindowMaker-po.install.patch
282 - upgraded WindowMaker-pl.po.patch (sync with i18n CVS)
283 - added WindowMaker-pixmaps.patch (add /usr/X11/share/pixmaps to default 
284   icons/pixmaps path)
285 - added --sysconfdir=/etc/X11 to ./configure
286 - added /etc/X11/WindowMaker to %%files section
287
288 * Wed Mar  3 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
289   [0.51.0-2]
290 - removed man group from man pages.
291
292 * Tue Feb  9 1999 Micha³ Kuratczyk <kurkens@polbox.com>
293 - gzipping instead bzipping
294 - simplification in %files
295 - cosmetic changes
296
297 * Wed Feb  3 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
298   [0.50.2-1d]
299 - added stripping shared libraries,
300 - removed SONAME symlinks from main package.
301
302 * Fri Jan 15 1999 Artur Frysiak <wiget@usa.net>
303 - upgraded to 0.50.2
304 - rewrite %{name}-po.patch
305 - added icons (WindowMaker-data.tar.gz) 
306   by Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
307 - added --enable-superfluous and --enable-newstyle configure options 
308   by Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
309 - added --enable-kde configure options
310 - added more Requires
311 - added wmconfig support
312
313 * Sat Sep 26 1998 Pawe³ Gajda <pagaj@shadow.eu.org>
314   [0.20.0-1d]
315 - added --disable-shm option to configure script
316 - added patches to fix I18N stuff
317 - moved bughint script to /usr/X11R6/bin
318 - WPrefs is now back in /usr/X11R6/GNUstep
319 - built against Tornado,
320 - build from non root's account.
321
322 * Mon Sep 21 1998 Pawe³ Gajda <pagaj@shadow.eu.org>
323   [0.19.3-2]
324 - fixed problems with paths to icons, styles and WPrefs
325 - removed all patches
326 - moved WPrefs stuff to /usr/X11R6/share/GNUstep
327 - fixed I18N
328 - added Polish summary and description
329
330 * Thu Sep  8 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
331   [0.19.3-1]
332 - added -q %setup parameter,
333 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
334 - added using %%{name} and %%{version} in Source,
335 - changeded dependences to "Requires: %%{name} = %%{version}" in devel
336   subpackage,
337 - removed "rm -r %%{builddir}" - it's automatically removed if rpm is runed
338   on building with --clean,
339 - removed COPYING and INSTALL from %doc (copyright statment is in Copyright
340   field),
341 - WindowMaker is now builded from bz2 source tar,
342 - removed Packager field (this must be placed in persolan ~/.rpmrc),
343 - nls stuff moved to %{_datadir}/locale,
344 - added --disable-debug for configure,
345 - adde %lang macros for %{_datadir}/locale/*/LC_MESSAGES/* files,
346 - added WindowMaker-fix_po.patch wit fixing .po files,
347 - simplification in %files and added using %defattr macro also.
348
349 * Tue Jul 21 1998 W. Reilly Cooley <wcooley@nakedape.ml.org>
350 - updated from 16.1 to 17.2; made it use RPM_OPT_FLAGS
This page took 0.132082 seconds and 4 git commands to generate.