]> git.pld-linux.org Git - packages/VOCP.git/blob - VOCP.spec
initial release, build, but not everythink work fine
[packages/VOCP.git] / VOCP.spec
1
2 # TODO:
3 # -move vocpweb.cgi to cgi-bin directory or adding
4 #   <Directory %{_vocpwebdir}>
5 #       Options ExecCGI
6 #   </Directory>
7 #   to httpd.conf, what with diff in locaton confs between apatche 1.x and 2.x ?,
8 # -make to work pass checking in xvocp.pl, luzik is to lame in perl,
9 # -add .desktop files and icons, min. for callcenter & boxconf,
10 # -full test package,
11 # -translate description,
12 # -play with secure stuff, attr for examle, luzik is to lame in sec,
13 # -fix BR, for each package
14
15 %include        /usr/lib/rpm/macros.perl
16
17 %define         _vocpwebdir     /home/services/httpd/html/vocp
18
19 Summary:        VOCP is a complete messaging solution for voice modems
20 Summary(pl):    VOCP jest a complete messaging solution dla voice modems
21 Name:           vocp
22 Version:        0.9.3
23 Release:        0.1
24 License:        GPL
25 Group:          Applications/Communications
26 Source0:        http://prdownloads.sourceforge.net/vocp/VOCP-%{version}.tar.bz2
27 Source1:        %{name}.logrotate
28 Patch0:         %{name}-vars.patch
29 Patch1:         %{name}-bin.patch
30 Patch2:         %{name}-%{name}web.patch
31 Patch3:         %{name}-doc.patch
32 URL:            http://www.vocpsystem.com
33 Requires:       perl-Modem-Vgetty
34 Requires:       festival
35 Requires:       perl-Audio-DSP
36 Requires:       perl-XML-Mini
37 Requires:       perl-Tk-JPEG
38 Requires:       perl-Crypt-CBC
39 Requires:       perl-Crypt-Blowfish
40 Requires:       perl-MIME-tools
41 Requires:       logrotate
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Much more than an answering machine, VOCP transforms your computer
46 into a full-featured call answering and voice messaging system.
47
48 %description -l pl
49 Du¿o wiêcej ni¿ automatyczna sekretarka, VOCP zmieni twój komputer w
50 pe³ni funkcjonalny setem do voice messaging
51 system!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
52
53 %package perl-modules
54 Summary:        Perl modules for VOCP
55 Summary(pl):    Modlu³y perla dla VOCP
56 Group:          Applications/Communications
57 Requires:       perl >= 5.8.0
58
59 %description perl-modules
60 Perl modules for VOCP
61
62 %description perl-modules -l pl
63 Modlu³y perla dla VOCP
64
65
66 %package vocpweb
67 Summary:        Web GUI for VOCP
68 Summary(pl):    Web GUI for VOCP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
69 Group:          Applications/Communications
70 Requires:       %{name}-modules
71
72 %description vocpweb
73 Web GUI for VOCP
74
75 %description vocpweb -l pl
76 Web GUI for VOCP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
77
78
79
80 %prep
81 %setup -q
82
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p1
86 %patch3 -p1
87
88 %build
89 cd prog/bin
90 gcc -o pwcheck pwcheck.c
91 gcc -o xfer_to_vocp xfer_to_vocp.c
92
93 cd ../VOCP
94 %{__perl} Makefile.PL INSTALLDIRS=vendor
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 install -d $RPM_BUILD_ROOT%{_sysconfdir}/vocp \
101         $RPM_BUILD_ROOT%{_datadir}/vocp/{images,messages,run,sounds,lib} \
102         $RPM_BUILD_ROOT%{_var}/spool/voice/{commands,incoming/cache,messages} \
103         $RPM_BUILD_ROOT%{_bindir} \
104         $RPM_BUILD_ROOT%{_vocpwebdir}/{img,sounds,tpl} \
105         $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d \
106         $RPM_BUILD_ROOT/var/log
107
108 cp -R images $RPM_BUILD_ROOT%{_datadir}/vocp
109 cp -R sounds $RPM_BUILD_ROOT%{_datadir}/vocp
110 cp -R messages $RPM_BUILD_ROOT%{_datadir}/vocp
111 cp -R prog/lib $RPM_BUILD_ROOT%{_datadir}/vocp
112 cp prog/bin/README prog/bin/README-bin
113 cp -R commands $RPM_BUILD_ROOT%{_var}/spool/voice
114 cp -R messages/*.rmd $RPM_BUILD_ROOT%{_var}/spool/voice/messages
115 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/%{name}
116 install vocpweb/*.html $RPM_BUILD_ROOT%{_vocpwebdir}
117 install vocpweb/styles.css $RPM_BUILD_ROOT%{_vocpwebdir}
118 install vocpweb/img/*.gif $RPM_BUILD_ROOT%{_vocpwebdir}/img
119 install vocpweb/sounds/*.html $RPM_BUILD_ROOT%{_vocpwebdir}/sounds
120 install vocpweb/tpl/*.html $RPM_BUILD_ROOT%{_vocpwebdir}/tpl
121 install vocpweb/vocpweb.cgi $RPM_BUILD_ROOT%{_vocpwebdir}
122 touch $RPM_BUILD_ROOT/var/log/{vocp-calls.log,vocp.log,voicelog}
123 for i in boxconf.pl convert_boxconf.pl pvftomp3 pwcheck \
124 toggleEmail2Vm.pl vocphax.pl xfer_to_vocp xvocp.pl \
125 callcenter.pl convert_fax.sh email2vm.pl pvftoogg \
126 pwcheck.pl txttopvf vocplocal.pl xfer_to_vocp \
127 cnd-logger.pl cryptpass.pl messages.pl pwcheck \
128 view_fax.sh wav2rmd.pl xfer_to_vocp.pl ../vocp.pl; do
129         install prog/bin/$i $RPM_BUILD_ROOT%{_bindir}
130 done
131 for i in boxes.conf boxes.conf.sample boxes.conf.shadow cid-filter.conf vocp.conf; do
132         install prog/$i $RPM_BUILD_ROOT%{_sysconfdir}/vocp
133 done
134
135 cd prog/VOCP
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138 cd ../..
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %files
144 %defattr(644,root,root,755)
145 %doc README INSTALL LICENSE CHANGELOG prog/bin/README-bin doc
146 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/vocp/*
147 %attr(755,root,root) %{_bindir}/*
148 %{_datadir}/%{name}/*
149 %attr(1777,root,root) %dir /var/spool/voice/incoming/cache
150 %attr(755,root,root) /var/spool/voice/commands/*
151 %{_var}/spool/voice/messages/*
152 %attr(640,root,root) %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
153 %attr(640,root,root) /var/log/*log
154
155 %files perl-modules
156 %defattr(644,root,root,755)
157 %{perl_vendorlib}/VOCP.pm
158 %{perl_vendorlib}/VOCP/*
159 %{perl_vendorlib}/auto/VOCP/autosplit.ix
160 %{_mandir}/man3/*
161
162
163 %files vocpweb
164 %defattr(644,root,root,755)
165 %doc vocpweb/INSTALL vocpweb/README vocpweb/SECURITY
166 %dir %{_vocpwebdir}
167 %attr(1777,root,root) %dir %{_vocpwebdir}/sounds
168 %{_vocpwebdir}/index.html
169 %{_vocpwebdir}/styles.css
170 %{_vocpwebdir}/vocpwebhelp.html
171 %{_vocpwebdir}/img/*.gif
172 %{_vocpwebdir}/sounds/index.html
173 %{_vocpwebdir}/tpl/*.html
174 %attr(4755,root,root) %{_vocpwebdir}/vocpweb.cgi
This page took 0.073534 seconds and 4 git commands to generate.