]> git.pld-linux.org Git - packages/SysVinit.git/blob - SysVinit.spec
- changed all BuildRoot definitons
[packages/SysVinit.git] / SysVinit.spec
1 Summary:        System V initialization program
2 Summary(de):    System V-Intialisierungsprogramm
3 Summary(fr):    Programme d'initialisation Sys V.
4 Summary(pl):    Program inicjalizuj±cy w Systemie V 
5 Summary(tr):    System V baþlatma programý
6 Name:           SysVinit
7 Version:        2.78
8 Release:        5
9 License:        GPL
10 Group:          Base
11 Group(pl):      Podstawowe
12 Source0:        ftp://ftp.cistron.nl/pub/people/miquels/software/sysvinit-%{version}.tar.gz
13 Source1:        sysvinit.logrotate
14 Patch0:         sysvinit-paths.patch
15 Patch1:         sysvinit-bequiet.patch
16 Patch2:         sysvinit-md5-bigendian.patch
17 Patch3:         sysvinit-wtmpx.patch
18 Prereq:         fileutils
19 Prereq:         utempter
20 Requires:       logrotate
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _sbindir        /sbin
24
25 %description
26 The SysVinit package contains a group of processes that control the very
27 basic functions of your system. SysVinit includes the init program, the
28 first program started by the Linux kernel when the system boots. Init then
29 controls the startup, running and shutdown of all other programs.
30
31 %description -l de
32 SysVinit ist das erste Programm, das beim Systemstart vom Linux-Kernel
33 gestartet wird. Es steuert das Starten, Ausführen und Beenden aller anderen
34 Programme.
35
36 %description -l fr
37 SysVinit est le premier programme exécuté par le noyau de Linux lorsque le
38 système démarre, il contrôle le lancement, l'exécution et l'arrêt de tous
39 les autres programmes.
40
41 %description -l pl
42 SysVinit jest pierwszym programem uruchamianym przez j±dro, podczas  startu
43 systemu. Kontroluje start, pracê oraz zamykanie wszystkich innych
44 programów.
45
46 %description -l tr
47 SysVinit, sistem açýlýrken Linux çekirdeði tarafýndan çalýþtýrýlan ilk
48 programdýr. Diðer programlarýn baþlamalarýný, çalýþmalarýný ve
49 sonlanmalarýný saðlar/denetler.
50
51 %prep
52 %setup -q -n sysvinit-%{version}
53 %patch0 -p1
54 %patch1 -p1
55 %patch2 -p1
56 %patch3 -p1
57
58 %build
59 make -C src OPTIMIZE="$RPM_OPT_FLAGS"
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man{1,5,8}} \
65         $RPM_BUILD_ROOT/{etc/{logrotate.d,sysconfig},var/log}
66
67 make install -C src \
68         ROOT=$RPM_BUILD_ROOT \
69         BIN_OWNER=`id -u` \
70         BIN_GROUP=`id -g`
71
72 install %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/sysvinit
73
74 ln -sf ../var/run/initrunlvl $RPM_BUILD_ROOT/etc
75 ln -sf killall5 $RPM_BUILD_ROOT%{_sbindir}/pidof
76
77 touch $RPM_BUILD_ROOT/var/log/{lastlog,wtmpx,btmpx}
78
79 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/poweroff.8
80 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/telinit.8
81 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/reboot.8
82
83 echo .so halt.8 > $RPM_BUILD_ROOT%{_mandir}/man8/reboot.8
84 echo .so halt.8 > $RPM_BUILD_ROOT%{_mandir}/man8/telinit.8
85 echo .so halt.8 > $RPM_BUILD_ROOT%{_mandir}/man8/poweroff.8
86 echo .so last.1 > $RPM_BUILD_ROOT%{_mandir}/man1/lastb.1
87
88 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
89         doc/Propaganda debian/changelog doc/sysvinit-%{version}.lsm  
90
91 %post
92 if [ -f /var/log/wtmp ]; then
93         mv -f /var/log/wtmp /var/log/wtmp.rpmsave
94 fi
95 touch /var/log/{lastlog,wtmpx,btmpx}
96 chmod 0644 /var/log/lastlog /var/log/wtmpx
97 chmod 0640 /var/log/btmpx
98 chgrp utmp /var/log/wtmpx
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %doc doc/Propaganda.gz debian/changelog.gz doc/sysvinit-%{version}.lsm.gz
106
107 %attr(755,root,root) %{_sbindir}/*
108 %attr(755,root,root) %{_bindir}/last
109 %attr(755,root,root) %{_bindir}/lastb
110 %attr(755,root,root) %{_bindir}/mesg
111 %attr(755,root,root) %{_bindir}/utmpx-dump
112 %attr(2555,root,tty) %{_bindir}/wall
113
114 %attr(640,root,root) /etc/logrotate.d/*
115 %ghost /etc/initrunlvl
116 %ghost /var/log/lastlog
117 %attr(660,root,utmp) %ghost /var/log/wtmpx
118 %attr(640,root,root) %ghost /var/log/btmpx
119
120 %{_mandir}/man*/*
This page took 0.034803 seconds and 4 git commands to generate.