]> git.pld-linux.org Git - packages/SysVinit.git/blob - SysVinit.spec
- Requires: mingetty
[packages/SysVinit.git] / SysVinit.spec
1 Summary:        System V initialization program
2 Summary(de):    System V-Intialisierungsprogramm
3 Summary(fr):    Programme d'initialisation Sys V.
4 Summary(pl):    Program inicjalizuj±cy w Systemie V 
5 Summary(tr):    System V baþlatma programý
6 Name:           SysVinit
7 Version:        2.78
8 Release:        5
9 License:        GPL
10 Group:          Base
11 Group(pl):      Podstawowe
12 Source0:        ftp://ftp.cistron.nl/pub/people/miquels/software/sysvinit-%{version}.tar.gz
13 Source1:        sysvinit.logrotate
14 Patch0:         sysvinit-paths.patch
15 Patch1:         sysvinit-bequiet.patch
16 Patch2:         sysvinit-md5-bigendian.patch
17 Patch3:         sysvinit-wtmpx.patch
18 Prereq:         fileutils
19 Prereq:         utempter
20 Requires:       logrotate
21 Requires:       mingetty
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _sbindir        /sbin
25
26 %description
27 The SysVinit package contains a group of processes that control the very
28 basic functions of your system. SysVinit includes the init program, the
29 first program started by the Linux kernel when the system boots. Init then
30 controls the startup, running and shutdown of all other programs.
31
32 %description -l de
33 SysVinit ist das erste Programm, das beim Systemstart vom Linux-Kernel
34 gestartet wird. Es steuert das Starten, Ausführen und Beenden aller anderen
35 Programme.
36
37 %description -l fr
38 SysVinit est le premier programme exécuté par le noyau de Linux lorsque le
39 système démarre, il contrôle le lancement, l'exécution et l'arrêt de tous
40 les autres programmes.
41
42 %description -l pl
43 SysVinit jest pierwszym programem uruchamianym przez j±dro, podczas  startu
44 systemu. Kontroluje start, pracê oraz zamykanie wszystkich innych
45 programów.
46
47 %description -l tr
48 SysVinit, sistem açýlýrken Linux çekirdeði tarafýndan çalýþtýrýlan ilk
49 programdýr. Diðer programlarýn baþlamalarýný, çalýþmalarýný ve
50 sonlanmalarýný saðlar/denetler.
51
52 %prep
53 %setup -q -n sysvinit-%{version}
54 %patch0 -p1
55 %patch1 -p1
56 %patch2 -p1
57 %patch3 -p1
58
59 %build
60 make -C src OPTIMIZE="$RPM_OPT_FLAGS"
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man{1,5,8}} \
66         $RPM_BUILD_ROOT/{etc/{logrotate.d,sysconfig},var/log}
67
68 make install -C src \
69         ROOT=$RPM_BUILD_ROOT \
70         BIN_OWNER=`id -u` \
71         BIN_GROUP=`id -g`
72
73 install %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/sysvinit
74
75 ln -sf ../var/run/initrunlvl $RPM_BUILD_ROOT/etc
76 ln -sf killall5 $RPM_BUILD_ROOT%{_sbindir}/pidof
77
78 touch $RPM_BUILD_ROOT/var/log/{lastlog,wtmpx,btmpx}
79
80 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/poweroff.8
81 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/telinit.8
82 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/reboot.8
83
84 echo .so halt.8 > $RPM_BUILD_ROOT%{_mandir}/man8/reboot.8
85 echo .so halt.8 > $RPM_BUILD_ROOT%{_mandir}/man8/telinit.8
86 echo .so halt.8 > $RPM_BUILD_ROOT%{_mandir}/man8/poweroff.8
87 echo .so last.1 > $RPM_BUILD_ROOT%{_mandir}/man1/lastb.1
88
89 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
90         doc/Propaganda debian/changelog doc/sysvinit-%{version}.lsm  
91
92 %post
93 if [ -f /var/log/wtmp ]; then
94         mv -f /var/log/wtmp /var/log/wtmp.rpmsave
95 fi
96 touch /var/log/{lastlog,wtmpx,btmpx}
97 chmod 0644 /var/log/lastlog /var/log/wtmpx
98 chmod 0640 /var/log/btmpx
99 chgrp utmp /var/log/wtmpx
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files
105 %defattr(644,root,root,755)
106 %doc doc/Propaganda.gz debian/changelog.gz doc/sysvinit-%{version}.lsm.gz
107
108 %attr(755,root,root) %{_sbindir}/*
109 %attr(755,root,root) %{_bindir}/last
110 %attr(755,root,root) %{_bindir}/lastb
111 %attr(755,root,root) %{_bindir}/mesg
112 %attr(755,root,root) %{_bindir}/utmpx-dump
113 %attr(2555,root,tty) %{_bindir}/wall
114
115 %attr(640,root,root) /etc/logrotate.d/*
116 %ghost /etc/initrunlvl
117 %ghost /var/log/lastlog
118 %attr(660,root,utmp) %ghost /var/log/wtmpx
119 %attr(640,root,root) %ghost /var/log/btmpx
120
121 %{_mandir}/man*/*
This page took 0.047068 seconds and 4 git commands to generate.