]> git.pld-linux.org Git - packages/SearchAndRescue.git/blob - SearchAndRescue.spec
- updated to 1.1.0
[packages/SearchAndRescue.git] / SearchAndRescue.spec
1 #
2 # TODO:
3 #       - fix default paths
4 #
5 # Conditional build:
6 %bcond_with     libY    # build with libY
7 %bcond_with     jsw     # uild with joystick support
8 #
9 %define         shortname       searchandrescue
10 %define         data_ver        1.0.0
11 Summary:        Search And Rescue - Linux flight simulator
12 Summary(pl.UTF-8):      Search And Rescue - symulator lotu śmigłowca
13 Name:           SearchAndRescue
14 Version:        1.1.0
15 Release:        0.1
16 License:        GPL v2+
17 Group:          X11/Applications/Games
18 Source0:        http://downloads.sourceforge.net/searchandrescue/Program/%{name}-%{version}.tar.gz
19 # Source0-md5:  f785d5968a8c3f57b021d40953ac4d32
20 Source1:        http://downloads.sourceforge.net/searchandrescue/Data_Files/%{name}-data-%{data_ver}.tar.gz
21 # Source1-md5:  da92f5fa7587cc0a712706d01b2f59f1
22 URL:            http://searchandrescue.sourceforge.net/
23 BuildRequires:  OpenGL-devel
24 %{?with_liby:BuildRequires:     libY-devel}
25 %{?with_jsw:BuildRequires:      libjsw-devel}
26 BuildRequires:  xorg-xserver-server-devel
27 Requires:       OpenGL
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
31
32 %description
33 Linux flight simulator.
34
35 %description -l pl.UTF-8
36 Symulator lotu śmigłowcem.
37
38 %prep
39 %setup -q -n %{shortname}_%{version}
40
41 %build
42 ./configure Linux --prefix=%{_prefix}
43 %{__make} \
44         LDFLAGS="%{rpmldflags}" OPTFLAGS="%{rpmcflags} %{!?debug:-fomit-frame-pointer}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT%{_datadir}/games/%{shortname}
49
50 %{__make} install \
51         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
52         GAMES_DIR=$RPM_BUILD_ROOT%{_bindir} \
53         MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man6 \
54         SHARE_GAMES_DIR=$RPM_BUILD_ROOT%{_datadir} \
55         SHADE_ICONS_DIR=$RPM_BUILD_ROOT%{_pixmapsdir}
56
57 # unpack data files
58 tar xvf %{SOURCE1} -C $RPM_BUILD_ROOT%{_datadir}/games/%{shortname}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc AUTHORS INSTALL README
66 %attr(755,root,root) %{_bindir}/*
67 %{_datadir}/games/%{shortname}
68 %{_pixmapsdir}/SearchAndRescue.xpm
69 %{_mandir}/man6/*
This page took 0.066311 seconds and 4 git commands to generate.